none
Windows 7 - How to keep the size of the preview pane when closing and re-opening Explorer?

    Question

  • Hi to all,
    I'm sure a lot of people are annoyed with the same bug...it apprently happens on all Windows 7 editions.
    When you open explorer, and activate the preview pane using the button on the uper right, you can define the size like any pane by clicking and draging the vertical border line. But when you close explorer and open it again, the size is not kept, and the preview pane is very big, you have to click and drag everytime to resize it.

    It doesn't happen if you double-click on computer, it only happens when you click on explorer icon which opens the libraries location, the default location (i'm not completly sure but i've only seen that in this way).

    It seems that Explorer doesn't read correctly the REG_BINARY of "ReadingPaneSizer " (or maybe the values "PageSpaceControlSizer " or "PreviewPaneSizer ") in the key "HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Modules\GlobalSettings\Sizer " when it opens, but it writes it apparently correctly when you manual resize the pane, and the value isn't change before manual action, even when explorer opens and display preview pane in a different size.

    And the last thing, when you open explorer, activate preview pane, resize preview pane, deactivate it, close explorer, open explorer again, activate preview pane, the size is the good one, preserved from previous explorer window...

    So question is, does someone know a way to fix this *really* annonying bug? I can't activate the preview pane in default profile for my domain users if there is this bug...

    Thanks for your help
    Wednesday, September 02, 2009 12:43 PM

All replies

  • So, no one is concerned with this bug?! That's the worst thing i've seen in Win7 so far...
    Monday, September 07, 2009 9:47 AM
  • I tried to reproduce your complaint be creating a preview pane of a given size in the parent library window. After closing and reopening the window the preview pane was as I had originaly set it. I performed the same experiment with normal explorer windows and also the preview pane was as I set it for the the last window I adjusted it with. The preview pane will be the same size in every window as the window that was initially used to adjust it.

    Monday, September 07, 2009 5:35 PM
  • Thanks for your answer, but i assure you that on every Windows 7 i installed (Ultimate, Home Premium), it's the same problem everytime! I'm really surprised you didn't have this bug, since people are talking about on many pages on the net. Maybe it's because i modify some settings and i use "apply to all folders", who knows? But try again, it happens all the time, and it was already the case in the RC. I tried a lot of things, it's always the same song :(

    Anyway, I found a workaround: i had to change the explorer pinned icon to open the window in "Computer" instead of "Libraries" (it's better for me).

    I had to edit properties of the link "Windows Explorer " in the folder %userprofile%C\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar and modify the target to "%windir%\explorer.exe /e /root,::{20D04FE0-3AEA-1069-A2D8-08002B30309D} ".

    This way, i'm not jumping directly on libraries on new window, and no problem of pane big size.

    I really hope that Microsoft would care about complaints on explorer (like you have to click on the left pane to scroll it with mouse roll, not only move your cursor over it to scroll, look at Firefox bookmark for example), and that this bug will be resolved.

    Bye
    • Proposed as answer by markquinnuk Thursday, June 05, 2014 1:48 PM
    Tuesday, September 08, 2009 2:57 PM
  • The following may be a stupid question, but have you changed folders after opening Explorer?

    Some people start Explorer on a fixed location (I do this).

    If you start Explorer, don't change locations, make your changes, then close Explorer, it will remember those changes as associated with the folder.  Then when you open it on the same folder again it will remember those changes.

    If you change folders after starting it, it will remember them on the folder you were on when you made the changes.  Then when you start it again on a different folder it uses the settings that were saved for that folder.

    Sorry if this is a bit twisted sounding; I had to hurry through it.

    -Noel



    Edit: From reading your later post, it sounds like what I described is involved with your issue.  Glad you found a workaround.

    I'm also glad I'm not the only one who feels the wrong thing seems to scroll when I turn the mouse wheel.  I also have the distinct impression that Explorer tries to move things out from under my mouse cursor just as I'm about to click...  :-/
    Tuesday, September 08, 2009 5:23 PM
  • Thanks for your answer, but i assure you that on every Windows 7 i installed (Ultimate, Home Premium), it's the same problem everytime! I'm really surprised you didn't have this bug, since people are talking about on many pages on the net. Maybe it's because i modify some settings and i use "apply to all folders", who knows? But try again, it happens all the time, and it was already the case in the RC. I tried a lot of things, it's always the same song :(

    Anyway, I found a workaround: i had to change the explorer pinned icon to open the window in "Computer" instead of "Libraries" (it's better for me).

    I had to edit properties of the link "Windows Explorer " in the folder %userprofile%C\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar and modify the target to "%windir%\explorer.exe /e /root,::{20D04FE0-3AEA-1069-A2D8-08002B30309D} ".

    This way, i'm not jumping directly on libraries on new window, and no problem of pane big size.

    I really hope that Microsoft would care about complaints on explorer (like you have to click on the left pane to scroll it with mouse roll, not only move your cursor over it to scroll, look at Firefox bookmark for example), and that this bug will be resolved.

    Bye

    Vincent, if your still there here's an easier way to get computer view with disk drives to open from the task bar.

    Just right click on the desktop and select NEW, and Shortcut. Type "explorer.exe ,0" without the quotes into the text box. Note the space follwed by a comma and 0 after explorer.exe. Drag that to the task bar.
    Tuesday, September 08, 2009 5:55 PM
  • Ah, good one Horshak, it's easier to make this shortcut, thanks :) I was focused on changing the existing pinned one.

    Noel, thanks for your answer. And yes, about the scrolling in Explorer, i told Microsoft during RC and Beta to do something about it, by using the location of the cursor to focus the good pane to scroll, not by clicking to change the focus on the pane. The way it's working is awful, because if you want to scroll the left pane to see folders on the list and keep the current folder on the right pane (for example, to move files by drag and drop, but not only), you have to click on the same folder on the left pane to keep your path and give the focus to be able to scroll (yeah, it's not so easy to describe, sorry). But often, it will understand you want to rename it... Or you can use scroll bar, yes, but please...i have a scrolling mouse!

    So, the main problem is that explorer doesn't understand that scrolling means "you want to scroll in the pane where your cursor is", not where you have clicked before.

    Hope that these explanations aren't too dark...
    Wednesday, September 09, 2009 11:41 AM
  • is there a solution to this bug yet?

    Vincent13 workaround works however if you pin additional folders to the jumplist and open one of them, then again the preview pane size gets messed up. so annoying!!!

    I even reported this bug to microsoft, but they never fixed it :-(
    Wednesday, October 14, 2009 1:27 AM

  • "So, the main problem is that explorer doesn't understand .... "
    For me, the main problem in Windows 7 is Windows Explorer. Period.
    Wednesday, October 14, 2009 4:38 PM
  • I cannot believe after all the versions of windows we've had that this is STILL a problem.  There needs to be some kind of settings panel that you can pop up and check a box that says "stay this size".  I mean really, wouldn't Microsoft's own employees get very sick of this?  Even my mom complained about it the other day and she's not that saavy.  Looks like Microsoft refuses to do usability testing or just dodges the simple obvious fixes that would make our life a LOT easier in windows.  Microsoft keeps putting out commercials about usability in Windows 7 yet we still are forced to deal with these types of shortcomings in 2009 after all these years yet same issue in Windows 7 with keeping windows size!


    C# Web Developer
    Thursday, November 12, 2009 3:39 PM
  • I would love to see this fixed as well. This makes Windows super frustrating to me. I can't imagine it would be hard to fix and it would make life sooo much easier. Microsoft, please give me an enjoyable enduser experience with Windows 7.. So far, you have not.
    Sunday, November 15, 2009 3:50 PM
  • same problem here, it drives me up the walls to have to set the preview-window size again and again, especially since you have to drag that thin line around. try this on a htpc connected to a 47" lcd-tv on 1080p resolution from 4,5 meters distance ... after the 100th time you start to get a 'slight' dislike for whoever programmed that piece of ...
    Friday, December 11, 2009 3:05 PM
  • same problem here, it drives me up the walls to have to set the preview-window size again and again, especially since you have to drag that thin line around. try this on a htpc connected to a 47" lcd-tv on 1080p resolution from 4,5 meters distance ... after the 100th time you start to get a 'slight' dislike for whoever programmed that piece of ...
    This is bascially the same issue in the thread "can we get a real answer " on windows folder size.
    In windows 7, they lobotomized Explorer.  It no longer remembers anything about each folder individually - though it still writes that lame desktop.ini file into every folder.  Instead, Windows can remember ONLY the last folder closed.

    If this, and other interface issues are bothering you as much as they are me, and my peers, well - reach out to Advocate@microsoft.com.  Provide them detailed examples (more detail = better!) of the behavior and how it impacts you, your mom, your work flows, etc.  Please don't just say "it's stupid" - of course you can, if you illustrate HOW/and WHY...

    That email address again = advocate@microsoft.com.  It is crucial to include details.  i.e. how many versions of windows you've used before.  how many pc's are affected by this (or, how many computers you WILL NOT BE UPGRADING due to the broken, dumbed down, lobotomized explorer functionality...) and so on.

    Thanks!
    Perhaps we can get microsoft to listen.  Perhaps they're restore Explorer to the functionality it had in win98, 2000, xp, and even to a degree in Vista...(where the lobotomy began, IMHO)

    John
    • Proposed as answer by bigjohn-s Saturday, December 12, 2009 3:04 AM
    Friday, December 11, 2009 5:13 PM
  • Hi,

    I have the exact same problem. The size of preview pane is not "stored" and reverts back to a big hulky size everytime a folder is reopened. period. I second vincent13 on this. Thanks of starting this thread.

    @Noel Carboni , What vincent13 asked is anything but a " Stupid question". Why do think so many people are pulling this thread out of Google? Are we all dumb?!

    Sunday, January 17, 2010 3:38 AM
  • Sorry for any confusion, I was referring to *my* question, not his.

    -Noel
    Sunday, January 17, 2010 5:42 AM
  • I have this problem too, Windows 7, 64 bit.  I open the folder with my pictures and I open the preview panel then I set the size that I want, but if I close the explorer with the preview panel open and then open the explorer the preview panel size its huge and I hate that.  However, when I set the size of the preview panel, close the preview panel and then close the explorer when I open the explorer and the preview panel again the preview panel retains its size.  So the only thing that I gan think of is that it is a bug, that feature is not working correctly and for what I can see I am not the only one who's upset.  Please Microsoft fix this ASAP.
    Wednesday, January 20, 2010 2:46 AM
  • I found a simple solution. When this bug appears, you have to maximize the size of the explorer window, but not with the appropriate button. You have to enlarge the window manually. Then, you have to resize the preview pane. Then you can close the explorer window.

    Now, when you start again explorer, you can maximize it with the button. And suprise, it keeps the size of the preview pane.
    • Edited by MastahMatt Sunday, January 24, 2010 10:46 PM syntax
    • Proposed as answer by ScottyJN Friday, January 29, 2010 3:39 PM
    Sunday, January 24, 2010 10:46 PM
  • I was having the same headache as you. Every time I opened explorer with the preview window activated it would show the files section compressed and the preview section maximized. Well I found a simple workaround.

    I created a new shortcut on the desktop for explorer from C:\windows\explorer.exe. Once created open the explorer shortcut properties and edit the Target. Make it read "C:\Windows\explorer.exe /select, C:" without the quotation marks and save it. Now you can pin this to the taskbar.

    The switch "/select, C:" will open in the "Computer" view showing all of your drives; you can google other explorer switches. It even remembers the way I left my folders in the folder list pane. For example, my user folder use to open fully expanded and I didn't like that, so I collapsed it as well as some other folders, then I closed explorer it and opened it again. It opened just as I had set it, including the size of the preview pane.

    One caveat, opening explorer with the windows key+E or right clicking on start to open explorer takes you back to your original problem of the preview screen being fully opend but the collapsed folder list is still remembered. So just use your shortcut that you placed on the taskbar to be less annoyed.
    Monday, January 25, 2010 8:52 PM
  • Alright..Here's what I did...

    I had a folder on my desktop named 'Pics'.
    Every time open this folder, the preview pane would reset itself no matter how much I changed it.
    So I opened an Explorer window and reset its pane to my desired size. Then I transferred the folder on my desktop to the C: drive of my already open explorer window. After I did that, I opened the pics folder and the windows pane did not change. After this, I went back to the C: folder and dragged the Pics Folder back on the desktop. I closed my Explorer window and opened the Pics folder from the desktop.

    It worked! The Preview pane remained the same size as it was in the Explorer window.

    Only problem is with Recycle bin! Now if I open the Recycle bin, the preview pane messes up. After that, if I open Explorer, the pane is the same size as it was in Recycle Bin.

    But I dont use the Recycle Bin that much...So yeah..
    Wednesday, January 27, 2010 11:01 PM
  • I've not been in this thread for long time, and i can see that many are affected by this !@*:!$ bug...no matter what is the version of Windows 7, Por, Ultimate, Home, x86 or x64...

    Thanks MastahMatt for your solution, it shows me a more simple way to "fix" this annoying bug: just open the window not maximised, but keep it big enough to resize the preview pane like you wish, then grab the window on the top of the screen to maximise it (new Windows 7 feature), then close it, and it should now open with the correct preview pane size, with the default link on taskbar (libraries location). I tried to resize preview pane, close and re-open, it looks OK (but, like others say, it just keeps the last preview pane size used, not the one for each folders...what a pity...).

    It worked for me right now, but until when?

    I hope this helps, but Microsoft should do something to this kind of bugs!!
    Tuesday, February 02, 2010 2:15 PM
  • I found a simple solution. When this bug appears, you have to maximize the size of the explorer window, but not with the appropriate button. You have to enlarge the window manually. Then, you have to resize the preview pane. Then you can close the explorer window.

    Now, when you start again explorer, you can maximize it with the button. And suprise, it keeps the size of the preview pane.

    Thank you MastahMatt. This has been pestering me for a very long time.
    Thursday, February 18, 2010 3:03 AM
  • I found a simple solution. When this bug appears, you have to maximize the size of the explorer window, but not with the appropriate button. You have to enlarge the window manually. Then, you have to resize the preview pane. Then you can close the explorer window.

    Now, when you start again explorer, you can maximize it with the button. And suprise, it keeps the size of the preview pane.

    Thank you MastahMatt. This has been pestering me for a very long time.

    Sorry its not working for me, step by step idiots guide please.

    Eeek, this is v frustrating...if you open a folder location and maximise it,toggle the preview pane to the on state if its off, then resize it so a smaller size with the preview pane enabled. IT shrinks..

    Then maximise the window and the position it was in at its smaller window size remains skewed far to the left and so the preview pane on the right is too large.

    There needs to be a way to set the position when fully maximised. This is really doing my head in, and the thumbnails dont seem to be previewing properly for .pdf'....another issue though...can someone post steps to sort this out at some point soon before I throw windows 7 ...out the window, this kind bug is just gona suck up time doing needles adjustment in the long run.

    Friday, April 30, 2010 5:29 PM
  • Alright..Here's what I did...

    I had a folder on my desktop named 'Pics'.
    Every time open this folder, the preview pane would reset itself no matter how much I changed it.
    So I opened an Explorer window and reset its pane to my desired size. Then I transferred the folder on my desktop to the C: drive of my already open explorer window. After I did that, I opened the pics folder and the windows pane did not change. After this, I went back to the C: folder and dragged the Pics Folder back on the desktop. I closed my Explorer window and opened the Pics folder from the desktop.

    It worked! The Preview pane remained the same size as it was in the Explorer window.

    Only problem is with Recycle bin! Now if I open the Recycle bin, the preview pane messes up. After that, if I open Explorer, the pane is the same size as it was in Recycle Bin.

    But I dont use the Recycle Bin that much...So yeah..
    Unbelievable that people should resort to methods like this to enable basic UI functionality. Thank you Microsoft for the crippled windows explorer!
    Saturday, May 01, 2010 10:43 PM
  • I too have this issue with both Windows 7 32 & 64 bit. I used the manual resize fix above and it appears to have worked but I do believe this is a bug that MS should fix.

    Thanks to everyone who's proposed solutions!

     

    Wednesday, May 05, 2010 4:56 PM
  •  This is an ingenious solution for a head-Aching problem, Thnks
    Saturday, June 12, 2010 12:00 PM
  • I cannot believe that still have not fix this annoying thing !

    Maybe SP1 will, but I really doubt that microsoft care about this...

    They crippled Explorer so hard :(

    Sunday, July 18, 2010 10:47 PM
  • I have a video of a problem which I think is similar if not the same as yours: http://www.youtube.com/watch?v=Lg7iHk81ugA

    If I open a maximised explorer window from anywhere then close it, the preview pane grows every time I do it. This is the worst thing about Windows 7.. Why can't it be fixed??

    Monday, August 16, 2010 3:48 PM
  • This is a really irritating problem which has just started occurring on my W7 machine - after several months when it did not happen. Obviously the clones at Microsoft don't monitor their forums. There should not need to be work round for this - and none of the ones listed actually work for me.

     

    Oh for the day that Linux grows up into an adult OS.

    Saturday, August 28, 2010 5:25 AM
  • I don't even really post here, but I'm having the same problem. Seriously, it's such an unnecessary hassle. Microsoft, fix your ____!

    You'd think for being such a wealthy company they'd be able to hire people with the proper abilities to be able to perfect their software. Obviously, their devs are way to engrossed with their pay to even bother fixing the 'little' stuff (by their terms). Such a shame... Windows 7 could be such a beast if they just put a little more effort into fixing it's problems.

    Thursday, October 14, 2010 9:39 AM
  • This worked for me, and is real easy:

    Open a window, whatever size you want, but make sure it has another folder within it. Resize the preview pane to the desired size. Then, before closing the window, go into the sub folder. Now you can close the window. The process of navigating into a sub-folder seemed to lock in the memory of the preview pane for me, regardless of how I got to the original folder (via desktop, taskbar, etc.)

    When I opened a window, resized the preview pane, then closed the window - that's when the preview pane always came back large.

    Good luck.

    Saturday, October 23, 2010 12:09 AM
  • Hello,

    I have also been wondering how to overcome this problem, and have found that, if I set the pane size to what I want, and then 'Hide the preview pane' (see top right of screen), the pane size is remembered when I reopen Windows Explorer.

    Unfortunately you have to remember, though, to 'Hide the preview pane' before closing the Window.  That is a real pain - see the pun!

    • Proposed as answer by Hurstpoint Thursday, November 04, 2010 11:13 PM
    Thursday, November 04, 2010 10:53 PM
  • Sorry, I don't have a solution, but I do have the greatest sympathy for everyone here. It happens to me too and I HATE IT!

     

    PLEASE, PLEASE, PLEASE FIX THIS! I love Windows 7 otherwise!

    • Proposed as answer by aniolki Friday, February 11, 2011 6:56 PM
    Saturday, November 20, 2010 4:59 AM
  • See my solution above - Hurstpoint
    Saturday, November 20, 2010 4:36 PM
  • Yes the bug is annoying. It started after I installed Office 2010.
    Tuesday, January 04, 2011 3:10 PM
  • I found a simple solution. When this bug appears, you have to maximize the size of the explorer window, but not with the appropriate button. You have to enlarge the window manually. Then, you have to resize the preview pane. Then you can close the explorer window.

    Now, when you start again explorer, you can maximize it with the button. And suprise, it keeps the size of the preview pane.
    This worked for me, but I wish it wasn't the way it worked!
    Sunday, January 23, 2011 3:12 PM
  • This worked for me :D Thanks!!
    Monday, January 31, 2011 7:54 AM
  • I am not sure if you are talking about the same issue and I don't know about your .pdf problem but if you want to enlarge the preview screen and have it remain that size even after you close IE and then reopen it I will try to explain:

    Open IE.

    If you don't have a preview that takes up your whole computer screen move your cursor to the top edge of the preview pane. When you see the double arrow click and drag the top edge to the top of your computer screen.

    Then move your cursor to the side of the preview pane, when you see the double arrow-click and drag the side edge to the edge of your computer screen.

    Next go to the upper right corner and click the middle square (with the square inside of it). When you hover over it for a few seconds it will say maximize. It won't look like much happened, just a glich, but you should notice that there are now two squares inside of it. That should lock the screen for you. Hope it helps. It worked for me.

    Monday, January 31, 2011 8:13 AM
  • tried all these suggestions (esp creating new shortcuts) and nothing worked. the only solution is DON'T MAXIMIZE the window. set to minimized, set the size of the window manually to fit the screen, then set preview pane size. when i close, then open again, the non-mazimized window preview pane is the same as i set it. this seems to be the only solution that works and stays working.
    Friday, February 11, 2011 7:00 PM
  • Brilliant! Simple & Elegant solution! I had been having a terrible time always trying to grab the line to move it- the double-headed arrow was impossibly difficult to latch onto.
    Monday, February 21, 2011 4:42 AM
  • I cannot believe after all the versions of windows we've had that this is STILL a problem.  There needs to be some kind of settings panel that you can pop up and check a box that says "stay this size".  I mean really, wouldn't Microsoft's own employees get very sick of this?  Even my mom complained about it the other day and she's not that saavy.  Looks like Microsoft refuses to do usability testing or just dodges the simple obvious fixes that would make our life a LOT easier in windows.  Microsoft keeps putting out commercials about usability in Windows 7 yet we still are forced to deal with these types of shortcomings in 2009 after all these years yet same issue in Windows 7 with keeping windows size!


    C# Web Developer

    It's not stil fix on feb 2011
    Sunday, February 27, 2011 12:56 AM
  • I found a simple solution. When this bug appears, you have to maximize the size of the explorer window, but not with the appropriate button. You have to enlarge the window manually. Then, you have to resize the preview pane. Then you can close the explorer window.

    Now, when you start again explorer, you can maximize it with the button. And suprise, it keeps the size of the preview pane.

    Work well ... but it so bizard
    Sunday, February 27, 2011 1:04 AM
  • For me the problem became much worse in Service Pack 1. Before I installed it, it rarely happens, now it keeps on happening.
    Tuesday, March 15, 2011 10:20 AM
  • As of March2011 Windows 7 issue persists, no 'remember folder settings' type ability.. very annoying!
    Even "explore.exe /n" (no navigation pane) doesn't work to shut off the nav pane.

    I wrote script to change explorer registry to shut off navigation pane, launch explorer with path provided, then change registry back to its original pane setting.
    Unfortunately, the explorer screen size registry settings do NOT work at all as per old MS location of HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Streams\0  ---  Windows used to make a 0, 1, 2, 3, etc. for each window size to be remembered, but now it only has 0 and the value there does not change upon explorer window resize.

    Anyways, here's a batch script to launch with navigation pane off and reset back to original settings

    @echo off
    rem --- neumann 16mar2011
    rem --- usage example:   explorerwin7nonavigation.bat "z:\2007 rff"
    rem ----- follow this script name with the directory to open in "quotes"
    rem --- Win7 explorer doesn't remmber folder settings, and explorer /n  doesn't work to launch with navigation pane off
    rem --- so here I reg change to shut off navigation, open explorer, then change registry back to what it had.
    rem --- unfortunately I've not figured out where Win7 stores the window size for explorer, it's not where it was under XP
    rem --- as HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Streams\0 , \1,  \2, etc.

    set REGKEY=HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Modules\GlobalSettings\Sizer
    set REGVAL=PageSpaceControlSizer
    set ONPANE=150100000100000000000000E5010000
    set NOPANE=1501000000000000000000007B020000
    set OLDPANE=.

    rem --- read in existing window pane setting
      for /f "usebackq tokens=3" %%a in (`reg query %REGKEY% /v %REGVAL%^|find /i "%REGVAL%"`) do set OLDPANE=%%a
      if "%OLDPANE"=="." set OLDPANE=ONPANE

    rem --- shut off navigation pane and launch explorer -- i can't set explorer window size yet
      reg add %REGKEY% /v %REGVAL% /t REG_BINARY /d %NOPANE% /f 2>nul >nul
      explorer %1

    rem --- must delay because explorer can launch after reg reset below
      ping -n 2 localhost 2>nul >nul
    rem --- turn back on explorer pane
      reg add %REGKEY% /v %REGVAL% /t REG_BINARY /d %ONPANE% /f 2>nul >nul

     

    Wednesday, March 16, 2011 3:16 PM
  • Same issue here - extremely annoying
    Sunday, April 10, 2011 12:02 AM
  • Hi all,
    I just came around again to see if someone had found something new, but apparently, until MS does something, we'll be very annoyed with this...

    Anyway, in my concern, the best way i found is to fix rights on the good registry key when panes sizes are fixed. Just keep "Read" for each account on the key (to be completly correct, i think you only need to delete full control and keep read for current user):

    "HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Modules\GlobalSettings\Sizer"

    And you're done, it'will keep the size each time you open a new explorer window, except when you use shortcuts to libraries (but if, still with this same window, you navigate to others folders and even came back to the libraries, you'll keep the good sizes). But of course, you won't be able to change the default size (you can change it while navigating) until you revert to "Full Control" for current user...

    Hope it will help... and hope that oneday MS will do something to fix this!

     

    Wednesday, April 13, 2011 9:00 AM
  • I'm also experiencing this very annoying issue. Win 7 Ult x64.

     

    It appears MS has a bit of code similar to this

    prevPaneSize += prevPaneSize;

     

    Instead of using any proper scaling calculation between maximize and minimize for explorer windows, and storing this setting. Hopefully, they'll get as annoyed at it as we are and fix it. Unless all MS coders primarily use *Nix for work.

    Saturday, April 23, 2011 1:59 PM
  • Search for, download, and install a free tool called ShellFolderFix.  It will remember and reposition your Windows Explorer windows where you left them.  Very pleasant to have that ability.

    -Noel


    Saturday, April 23, 2011 3:12 PM
  •  

    Hi, All. Here's the solution, the critical point is that don't resize the pane in maximize windows, resize the pane in a smaller window than the biggest one, then close and open again, you'll find it work well.

    • Proposed as answer by W0lfbane Monday, August 08, 2011 5:03 AM
    Thursday, August 04, 2011 5:06 PM
  • Wow, its almost TWO YEARS since this F&*%ing bug was first reported here,

    and its STILL NOT FIXED

     

    This is why Microsoft is criticised so much.

    WTF Microsoft - fix the annoying bugs. This and the "hide all subfolders off the bottom of the screen when you expand a folder" are SHOW STOPPERS.

    They made me move to "XYplorer" on my pc.

     

    FIX IT you deaf lazies


    If I am all here, does that mean I am not all there?
    Wednesday, August 10, 2011 10:23 AM
  • For me, running "explorer.exe ,0" appears to have permanently fixed the issue regardless of how I open explorer. This was slowly driving me crazy, thank you ZERO Tolerance.
    Saturday, September 03, 2011 3:42 PM
  • its getting on for THREE YEARS and its STILL NOT FIXED.

    wtf microsoft, dont you care that you introduced new bugs were none existed before?

    We are telling you about SERIOUS BUGS that make users curse your products... and your responce? Nada, Zip, Silence!!

    FFS FIX IT

    (yes it pisses me off no end!)


    If I am all here, does that mean I am not all there?
    Monday, October 17, 2011 9:18 AM
  • Dear Ms, are you going to fix this now?

     

     

    Thursday, November 10, 2011 3:57 PM
  • I have a VERY SIMPLE EASY solution : 1- Open your folder, doesn't matter what folder type (pictures, music, documents) 2- Set your windows, pane size, everything you want to see 3- Click the "hide preview pane" icon to OFF, and click again to ON 4- close your folder 5- re-open it and ...
    • Proposed as answer by fanfarenj Sunday, November 20, 2011 5:58 AM
    • Unproposed as answer by fanfarenj Sunday, November 20, 2011 5:58 AM
    • Proposed as answer by joey ramone Saturday, August 11, 2012 4:12 PM
    • Unproposed as answer by joey ramone Saturday, August 11, 2012 4:12 PM
    Saturday, November 19, 2011 5:19 PM

  • Anyway, I found a workaround: i had to change the explorer pinned icon to open the window in "Computer" instead of "Libraries" (it's better for me).

    I had to edit properties of the link "Windows Explorer " in the folder %userprofile%C\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar and modify the target to "%windir%\explorer.exe /e /root,::{20D04FE0-3AEA-1069-A2D8-08002B30309D} ".

    Yeah, this worked for me :)

    Although I didn't have to muck around in the properties, just unpinned 'Libraries' from the task bar, then dragged 'Computer' icon from the desktop to the task bar and pinned it in place.

    Wednesday, November 23, 2011 10:10 PM
  • Hi to all,
    I'm sure a lot of people are annoyed with the same bug...it apprently happens on all Windows 7 editions.
    When you open explorer, and activate the preview pane using the button on the uper right, you can define the size like any pane by clicking and draging the vertical border line. But when you close explorer and open it again, the size is not kept, and the preview pane is very big, you have to click and drag everytime to resize it.

    It doesn't happen if you double-click on computer, it only happens when you click on explorer icon which opens the libraries location, the default location (i'm not completly sure but i've only seen that in this way).

    It seems that Explorer doesn't read correctly the REG_BINARY of "ReadingPaneSizer " (or maybe the values "PageSpaceControlSizer " or "PreviewPaneSizer ") in the key "HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Modules\GlobalSettings\Sizer " when it opens, but it writes it apparently correctly when you manual resize the pane, and the value isn't change before manual action, even when explorer opens and display preview pane in a different size.

    And the last thing, when you open explorer, activate preview pane, resize preview pane, deactivate it, close explorer, open explorer again, activate preview pane, the size is the good one, preserved from previous explorer window...

    So question is, does someone know a way to fix this *really* annonying bug? I can't activate the preview pane in default profile for my domain users if there is this bug...

    Thanks for your help
    I have been having exactly the same problem, really annoying to have to resize a window every time to see what is on the pane........Windows need to sort this out, not even as good as previous older versions if you ask me.
    Thursday, November 24, 2011 10:17 AM
  • I found a simple solution. When this bug appears, you have to maximize the size of the explorer window, but not with the appropriate button. You have to enlarge the window manually. Then, you have to resize the preview pane. Then you can close the explorer window.

    Now, when you start again explorer, you can maximize it with the button. And suprise, it keeps the size of the preview pane.


    Thank you very much MastahMatt.  This works exactly as you elgantly describe.  As long as I don't use the MAX button to resize my Explorer window, MS keeps the width of pane settings I previously used.

     

    Of course, it would be nice if there were a permanent setting available from MS directly on the Control Panel, but since that obviously isn't coming anytime soon, I will be using your solution from now on.

     

    With gratitude,

    ASH

    • Proposed as answer by April Hall Saturday, December 03, 2011 10:13 PM
    Saturday, December 03, 2011 10:11 PM
  • OK, first of all, I've tried all of the "solutions" on this page to a "T", all with no avail.  One thing I'd like to add is that if I make the preview pane larger than the already HUGE "default" size, the setting gets saved.  But, if if I make it smaller than the "default", it reverts back to the "default", which takes up most of the screen.  One interesting thing to note is that this "default" size issue only seems to appear when the window is maximized.

    I find it uncanny that the preview pane is so large that it virtually eliminates white space.  As a power user who is fed up with MS catering to "casual users" (ie. Idiots) to line their pockets, this looks like an obvious move to cater to the Grandma crowd, who would be pleased as punch if the previews of their cat photos were big enough to be seen without reaching for their reading glasses.  Remember, these are the idiots who can't understand something as simple as a folder hierarchy, hence the unnecessary and messy "Libraries".  So, to them, they open "My Computer", click "Pictures", and "Oh!, there's Billy's graduation pictures, isn't he cute?".  That's nice for them, and I like how MS was at least smart enough to leave "Windows+E" alone, in that it brings up your drives and not a bunch of hokey shortcuts.  It just seems that all updates to Windows in the past 10 years center around security and graphics, 2 things I could give a F&#! about.  Their priorities are so skewed, whatever happened to functionality and performance?

    3 years and no fix?  Well, why would they bother?  What other OS are you going to use?  MacOS, which caters even more to the "granny" crowd, or Linux, which is incompatible with the majority of software?  MS has a monopoly on PC UIs with Windows, and they're not inclined to cater to power users for 2 reasons.  1) There's fewer of us, hence less money to be made.  2) We're all nitpicky and would disagree on everything anyway, lol.  The "granny" crowd is easy to please and has lots of cash.

    I just want my PC to be, I dunno, USABLE.  Seriously, this bug (among other things) is really hurting my productivity.  My only consolation is that the older generation that they seem to be catering to will die off eventually, but my better judgment tells me that as long as there are stupid people, companies will do stupid things to get their money.




    • Edited by Nick Todd Tuesday, May 01, 2012 9:34 AM
    Tuesday, May 01, 2012 9:33 AM
  • None of the solutions here did it for me, although i haven't tried the register tweaks which just don't look trustwordy, no offence intended but with phrases such as "maybe" i become unsure.

    What i miss, is a correct representation of how to replicate. Or maybe i have a slightly different bug since solutions that involve manual maximizing/minimizing/closing/repening etc. do NOT help here (fresh install Win7 Pro SP1, 1 week into use). Steps to replicate:

    1-open Windows Explorer. This may be "computer" or any other instance, it does NOT matter.

    2-maximize the window. Again, method does NOT matter.

    3-drag slider to the right. for reference, it put it so that the words "select a file to preview" are still readable.

    4-close the window, re-open, preview panel seems fine. But it ain't.

    5-resize the window till it fills a quarter of the screen or less and/or until "select a file to preview" is not longer visible. You may in fact choose any smaller size, it's just better visible this way.

    6-maximize the window, preview pane seems fine. But it ain't.

    7-repeat #5. Close the window. Repeat #1 and #2.

    See? It ain't.

    The slider does simply not scale with the window if the window gets larger and if the window+slider was closed in a smaller state. And like many threads i have been reading last week, there is not a single real answer from the manufacturer's side. I heard good stuff about Win7, so after a period with hardware issues on Ubuntu i gave the hell of Gates a try again.

    So sorry.


    • Edited by Juno R Saturday, May 12, 2012 7:20 PM
    Saturday, May 12, 2012 7:18 PM
  • FOR THE LOVE OF GOD, FIX THIS BUG

    If I am all here, does that mean I am not all there?

    Friday, June 08, 2012 12:47 PM
  • I cannot believe after all the versions of windows we've had that this is STILL a problem.  There needs to be some kind of settings panel that you can pop up and check a box that says "stay this size".  I mean really, wouldn't Microsoft's own employees get very sick of this?  Even my mom complained about it the other day and she's not that saavy.  Looks like Microsoft refuses to do usability testing or just dodges the simple obvious fixes that would make our life a LOT easier in windows.  Microsoft keeps putting out commercials about usability in Windows 7 yet we still are forced to deal with these types of shortcomings in 2009 after all these years yet same issue in Windows 7 with keeping windows size!


    C# Web Developer

    As a developer I'm getting more and more convinced every day that no-one in Microsoft is using the dummy, bloody software they produce themselves! I wouldn't be surprised to discover that in that company the most of PCs are Macintosh or Linux!!!
    And no surprise that once Bill Gates actually came to a demo display running a presentation on Apple Mac!!!!

    And what to say about Win7? A lot of problems, a lot of unagreable choices (the start menu, the worse and unfriendliest serch tool I've ever seen, the folder sharing and the almost blasphem "home" group, the complications about networking and the masking of the useful information with useless wizards, and a lot of other stuff), a lot of things that were really useful in previous version disappeared and removed in the name of a "reduction of unnecessary skills for the user, not to get him confused" (!!!!!!), a lot of useless complications and redundancies brought to give us pain! Just like they did for the VBNet, in the past you had an average, manageable level of difficulty for doing everithing you liked. Now you have a subnormal level for doing silly things that in most of cases are below your needs, and it's instead much more difficult to get something really useful... The same things that required before a little skill now bring pains to your ass!!!

    I think the last version of the OS should be a case study in schools and universities as a brilliant example for developers of WHAT THEY SHOULD AVOID to produce!!!
    And besides, thay take no care about it! 

    I would have never mover from XP if I could!!! Bad, rough, vicious but after almost 10 yrs of patching, fixing, and so (average time for MS to get something decently working, I'd say!) , finally quite reliable and stable, and enough simple for everybody

    I dream of a worldwide class action against Microsoft to make them payback all the pains they gave us with their fucking OS's talking about "caring about the user" and instead making their fucking choices with no care of users or thinking that the average user is much less than subnormal!!!!!

    Such a revenge would bring me more happiness than winning the lotto!!!! If we were really civilized, that would be possible no matter their fucking EULAs, and we'd have already done it!!!

    Wednesday, June 27, 2012 1:00 PM
  • What should help is NOT to maximize the Explorer window after you did a change to the preview pane.
    So open the Explorer and manually maximise it. Then resize the preview pane to what you like.
    Close Explorer and reopen it.
    I tested on a vanilla Win7SP1 Installation and there it is possible to save a different setting for the preview pane and get it back after closing the Explorer.

    But this Setting is lost immediatly, once maximising the Explorer.

    Resizing the Explorer scales the preview pane different from what i would expect. But it scales.

    By the way, the Problem looks to be solved in Win 8 RP :-)
    I was not able to get this error there.

    Thursday, June 28, 2012 1:08 PM
  • Noel, I realize this is a very old post, but was searching to see if there was ever a fix for this preview pane problem in Win 7 Explorer when I came across your name.  Did you go to high school in Florida??

    R Allen

    Thursday, July 05, 2012 4:17 PM
  • Nice, this worked.

    Thanks

    Wednesday, August 08, 2012 2:07 AM
  • same problem here...incredible...
    Sunday, September 09, 2012 10:02 PM
  • Did you go to high school in Florida??

    Yep, that's me.  I take it you did too?

    Feel free to eMail me if you'd like.  My eMail address is in my profile.

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Monday, September 10, 2012 2:30 AM
  • screw microsoft. they don't give a fuck about the people using this version of windows i guess cause the new ones coming out soon. fuck'm they've had this problem with the preview pane for years. i've waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and waited and FUCK'M
    Thursday, September 13, 2012 11:53 PM
  • You've made the invalid assumption that someone, somewhere in Microsoft cares whether the stuff they release actually works.

    People who want things to work are hard to please.  Thus they will no longer be marketing to you.  They're more interested in powering toys now.

    Welcome to the future.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Friday, September 14, 2012 12:23 AM
  • I am utterly amazed that this issue has existed since 2009. It does it to me as well. Just after a few days, it started again with a new install. Unbelievable.
    Tuesday, September 18, 2012 4:44 AM
  • Hi all,

    I was having this problem:  in Windows 7, when I am on my webmail e.g., hotmail, and when attaching a file, the windows explorer "browse for attachment" window would keep forgetting the position of the navigation pane (it was as short as it could be and was covering most of the folders) and whether I turned on or off the preview pane.

    So what I tried was to simply first click to browse for an attachment, then make sure there is a file which to attach without going into any other folders (because they would reset sizing).  Next please resize the WHOLE explorer "browse for" window at the corner of it, until it is at a comfortable size.  Then turn off (or ON) your preview pane and resize your navigation pane, as you wish.  Then directly click on any file you wish to attach for now, and then "OPEN" to add the attachment.

    You just need a file to click and open once after you set your panes and window size.  Then after your email shows it's attached the file, go back to add another attachment.

    That is where you should see that your window panes & positioning are remembered from the last time.

    DONE!!

    Hope this helps.

    • Proposed as answer by joechello Tuesday, October 16, 2012 1:50 AM
    Monday, October 15, 2012 11:43 PM
  • Wtf are you talking about Davol. That has practically nothing to do with this topic.
    Friday, November 02, 2012 8:50 PM
  • this fixed the problem for me

    I found a simple solution. When this bug appears, you have to maximize the size of the explorer window, but not with the appropriate button. You have to enlarge the window manually. Then, you have to resize the preview pane. Then you can close the explorer window.

    Now, when you start again explorer, you can maximize it with the button. And suprise, it keeps the size of the preview pane.

    Edited by MastahMatt Sunday, January 24, 2010 10:46 PMsyntax
    • Proposed As Answer by ScottyJN Friday, January 29, 2010 3:39 PM
    Tuesday, November 06, 2012 8:36 AM
  • I found this and it worked for me
    Support Engineer


    Were you able to save folder and preview panes' before?

    (A). I would suggest you to run SFC scan and check if that helps.
    To run the System File Checker tool, follow these steps:
    1. Click Start, and then type cmd in the Start Search box.
    2. Right-click cmd in the Programs list, and then click Run as administrator.
    If you are prompted for an administrator password or confirmation, type your password or click Continue
    3. At the command prompt, the following line, and then press ENTER:
      sfc /scannow

    (B). Also try these steps and check.
    Click on Organize>Folder Options, select View tab, scroll down and look for the option 'restore previous folder windows at logon' and place a check mark on it and click on Ok.

    Hope it helps
    Thanks and regards
    Dinesh-Microsoft Support
    Monday, December 03, 2012 3:11 PM
  • I found this and it worked for me

    Support Engineer


    Were you able to save folder and preview panes' before?

    (A). I would suggest you to run SFC scan and check if that helps.
    To run the System File Checker tool, follow these steps:
    1. Click Start, and then type cmd in the Start Search box.
    2. Right-click cmd in the Programs list, and then click Run as administrator.
    If you are prompted for an administrator password or confirmation, type your password or click Continue
    3. At the command prompt, the following line, and then press ENTER:
      sfc /scannow

    (B). Also try these steps and check.
    Click on Organize>Folder Options, select View tab, scroll down and look for the option 'restore previous folder windows at logon' and place a check mark on it and click on Ok.

    Hope it helps
    Thanks and regards
    Dinesh-Microsoft Support

    Monday, December 03, 2012 3:12 PM
  • This problem has been driving me nuts.  I have a computer with windows 8 and have classic shell installed. I have no problems with explorer in 8. I only recently started using windows 7 and found this thread. I'll be sure to let everyone I know about this fix.
    Tuesday, March 26, 2013 11:26 PM
  • I have the same annoying, frustrating, and the sign of OS Development Incompetance on my Windows 7 64bit also!!! The solution is not to resize the Windows in this way or that way!! This should work at all times! Apparently you who are answering with these pitty work arounds are not really a heavy user like Vincent13 or me. At any given time I have several tasks open on my monitors; I cannot fiddel around with these kinds of things on regular basis!! Come on Microsoft engineers get on the ball and fix this!! As stupid and negligible of a problem this seems to be!!

    Alcompco

    Wednesday, April 17, 2013 6:47 PM
  • OK, I actually think there is a working work-around for this, or at least it seems to have stopped resizing the preview pane on my 64bit win7 pro machine (with office 2010 installed), and classic shell on. I read the whole string above, and after trying several ideas it now works, but it may be a combination of of the solutions above, so I'll list what I did step by step.

    1) I followed the advice to change the default folder away from the libraries view. I have it set as a network drive that is my main drive at work. I did this by R-click explorer icon>R-click 'Windows Explorer'>Properties> Then changed the Target to 'N:' (or whatever you want the default to be).

    This worked a couple of times, but then stopped working (seemed to be a issue with how long I left it between trying again?)

    2) So then I followed the instructions to minimise explorer, drag out to nearly full size, re-size the preview pane appropriately. Then I closed explorer, re-opened it, maximised the window, and closed it again.

    Now it seems to work, it opens maximised, and to a better default location. That said, I haven't actually re-started windows yet, so I'll come back and edit this if it fails to work after that. Assume it works if I don't come back to edit...

    ... yep, still OK after a re-start. Phew. Still seems to require me to go through the minimise/adjust/maximise routine to make it remember a change to the size of it though.


    • Edited by nattrill Thursday, June 13, 2013 10:19 AM
    Thursday, June 13, 2013 10:10 AM
  • Hi All,

    I have found the solution to this problem. It is a permission problem in the registry. If you remove (deny) the "SYSTEM" "value setup" permission, the Windows 7 cannot re-write your settings! :)
    Please read it on my blog, I have added some screenshot to my description:

    http://blog.arnoldweb.hu/en/2013/07/solved-windows-7-issue-how-to-keep-the-size-of-the-preview-pane-when-closing-and-re-opening-explorer/

    Sorry for the Hungarian language Windows 7... Every settings in English version on the same place like Hungarian. :)

    I hope my post help for everybody!

    Regards,

    Arnold


    • Edited by Arnold Krausz Wednesday, July 10, 2013 3:06 PM misspelling
    Wednesday, July 10, 2013 3:05 PM
  • You may have posted this last year, but I just had to tell you that you rule. Someone needed to say it for facks sake, and I'm tired as HELL of them placating these moron customers and not giving a crap about anyone else. (also lol to what you said about the granny and her pictures)
    Don't forget that actually, there are a HUGE amount of companies/businesses that use computers as well, and that's a GIGANTIC percentage of their earnings. So it baffles me even more that they refuse to make computers for people who actually KNOW how to use one and want the full functionality, not LESS (don't get me STARTED on Windows 8 and how much I loathe that piece of crap, which doesn't even deserve to be called an OS), and there's an easy way to give us all that, and even keep the idiots happy too (they could also work on a separate version of Windows for them and not just forget about everyone else, as it would be EASY as hell and bare bones most likely).

    When someone installs it, they should get a few options, one that asks if they want full control/functionality, or one that asks them if they are basically a novice or don't want/need to use stuff they wouldn't know anything about, and maybe something in between. There is absolutely NO reason to leave us out of the picture completely. People use computers for everything in business these days, and something as simple as this seemingly small thing we're talking about here shouldn't be an issue WHATSOEVER, being that it would be ridiculously easy to fix and cost them virtually nothing. I'm sick of this crap. I really would love to use Linux, but like you said it, the incompatibilities are just too far and many to be of enough use to us. I hate Apple and all of their fanboy bullsh*t, and I find their interface hideous (as well as windows too, especially 8, but I hate Apple's more.) and I hate everything about macs. Plus I've used Windows since it was DOS and I was about 5. I grew up with Windows and I miss basic functionalities we no longer have, among many other things.  I wish someone new would come into the game and create an OS for people who love and are good with computers, has compatibility with all Windows software, and looks good. *sigh* but people just don't seem to have dreams like that anymore. What happened to Bill? It seems like he's not even involved anymore whatsoever.... that's too bad, considering he's pretty brilliant.

    MICROSOFT: STOP PLACATING THE IDIOTS AND START PAYING ATTENTION TO REAL CUSTOMERS WHO APPRECIATE COMPUTERS! WE WANT FULL FUNCTIONALITY. WE WANT MORE, NOT LESS!
    Thursday, August 08, 2013 6:49 AM
  • Those are pretty obvious and unhelpful "solutions" that do nothing to fix the problem.
    Thursday, August 08, 2013 6:59 AM
  • THIS DUMMY EIGHTY YEAR OLD SAILOR FOUND THAT BY CLOSING THE PREVIEW PANE, ALL WAS NOMAL ON REOPENING A WINDOW.   TRY IT YOU MIGHT LIKE IT!  RAY
    Wednesday, September 04, 2013 4:14 PM
  • Hey Old Timer (I'm just a few years behind you so I can call you an old timer without meaning an insult),

    I see with age, one becomes smarter and wiser.  Great suggestion about just closing the preview pane (Duh!) which I took.  If I want to preview something I can easily just hit the preview pane option at the top of the right corner of a folder.

    You're a genius!!!!

    Thanks a bunch.

    Mandy


    • Edited by Mandy123 Saturday, November 09, 2013 12:38 AM
    Saturday, November 09, 2013 12:36 AM
  • Thank your for taking the time to share...
    That was so simple to solve a problem that has been annoying me for months.

    It works perfectly now.
    I simply followed your instructions by opening Windows Explorer and adjusting the size manually and "Adjusting the width of the Preview Pane" to be the approximate size that I want as default. Then I closed the window. Re-opened the Windows Explorer and then maximized it. Closed it once more and then Re-opened and it was exactly as I wanted. Perfect.

    Thanks again.

    Sunday, April 06, 2014 4:34 PM
  • Thanks Vincint13 this worked a treat.
    Thursday, June 05, 2014 1:49 PM