none
Windows 8.1 connecting to Ad Hoc networks

Answers

  • It turns out that Windows 8.1 doesn't show ad-hoc networks and it's by design. Not sure what on earth made them add this change.

    Anyway, after a lot of digging, I was finally able to force it to connect. I compiled a small howto.

    Note, this is NOT about how to create an ad-hoc network to share your Internet connection with another device! It's about how to connect your Windows 8.1 PC to an existing ad-hoc network created on another device.


    How to connect to an ad-hoc WiFi network in Windows 8.1.

    Because the wireless network picker in Windows 8.1 doesn't show ad-hoc networks, connecting must be done by hand.

    To see all networks in range, including ad-hoc, run this command in command shell (cmd.exe):

    > netsh wlan show networks


    SETUP

    This must be done once per network.

    • go to "Network and Sharing Center"
    • click "Set up a new connection or network"
    • double click "Manually connect to a wireless network"
    • enter the SSID of the ad-hoc network (as shown by "netsh wlan show networks") into the "Network name" field
    • configure security settings accordingly
    • uncheck "Start this connection automatically" (important)
    • click "Next", then "Close"

    Run this command (important):

    > netsh wlan set profileparameter <ssid> connectiontype=ibss

    Replace <ssid> with the SSID of your network.


    CONNECT

    After setting up, run this command whenever you want to connect:

    > netsh wlan connect <ssid>

    Replace <ssid> with the SSID of your network.

    Hovering over WiFi icon in system tray will show the name of the network that you are currently connected to, even if it's an ad-hoc network (the network picker will not show it if it's ad-hoc). The name is also visible in "Network and Sharing Center" window.


    DISCONNECT

    To disconnect from the ad-hoc network: connect to a different network, turn off wifi, or run this command:

    > netsh wlan disconnect


    CLEANUP

    To remove the network profile from Windows, run this command:

    > netsh wlan delete profile <ssid>

    Replace <ssid> with the SSID of your network.

    • Edited by y4k Sunday, November 03, 2013 11:38 PM
    • Proposed as answer by EEStud Monday, December 09, 2013 2:30 AM
    • Marked as answer by David WoltersModerator Friday, March 21, 2014 3:13 PM
    Sunday, November 03, 2013 11:30 PM

All replies

  • Hi,


    Try to update or reinstall the NIC card on your machine for test.


    Leo Huang
    TechNet Community Support

    Friday, July 05, 2013 6:33 AM
  • This solution not work for me. My wireles device is intel centrino N-2230, it is show me a star(* available connections) but, when i click connection list, isnt show me any connection.

    Friday, November 01, 2013 2:13 PM
  • It turns out that Windows 8.1 doesn't show ad-hoc networks and it's by design. Not sure what on earth made them add this change.

    Anyway, after a lot of digging, I was finally able to force it to connect. I compiled a small howto.

    Note, this is NOT about how to create an ad-hoc network to share your Internet connection with another device! It's about how to connect your Windows 8.1 PC to an existing ad-hoc network created on another device.


    How to connect to an ad-hoc WiFi network in Windows 8.1.

    Because the wireless network picker in Windows 8.1 doesn't show ad-hoc networks, connecting must be done by hand.

    To see all networks in range, including ad-hoc, run this command in command shell (cmd.exe):

    > netsh wlan show networks


    SETUP

    This must be done once per network.

    • go to "Network and Sharing Center"
    • click "Set up a new connection or network"
    • double click "Manually connect to a wireless network"
    • enter the SSID of the ad-hoc network (as shown by "netsh wlan show networks") into the "Network name" field
    • configure security settings accordingly
    • uncheck "Start this connection automatically" (important)
    • click "Next", then "Close"

    Run this command (important):

    > netsh wlan set profileparameter <ssid> connectiontype=ibss

    Replace <ssid> with the SSID of your network.


    CONNECT

    After setting up, run this command whenever you want to connect:

    > netsh wlan connect <ssid>

    Replace <ssid> with the SSID of your network.

    Hovering over WiFi icon in system tray will show the name of the network that you are currently connected to, even if it's an ad-hoc network (the network picker will not show it if it's ad-hoc). The name is also visible in "Network and Sharing Center" window.


    DISCONNECT

    To disconnect from the ad-hoc network: connect to a different network, turn off wifi, or run this command:

    > netsh wlan disconnect


    CLEANUP

    To remove the network profile from Windows, run this command:

    > netsh wlan delete profile <ssid>

    Replace <ssid> with the SSID of your network.

    • Edited by y4k Sunday, November 03, 2013 11:38 PM
    • Proposed as answer by EEStud Monday, December 09, 2013 2:30 AM
    • Marked as answer by David WoltersModerator Friday, March 21, 2014 3:13 PM
    Sunday, November 03, 2013 11:30 PM
  • The above given solution of connecting to an ad-hoc network through command prompt is the perfect solution for windows 8.1

    PS Updating your wireless drivers wont do any good.But work out the above given solution.It's 100% working.

    And I request Microsoft to please bring an update in windows 8.1 that would allow to see other ad-hoc network and connect with it.

    Sunday, November 10, 2013 11:50 AM
  • Agreed. 

    However, we work with home automation, and some Global Cache products (which are very popular) require Adhoc for initial configuration.

    So, this "improvement" to Windows is actually going to cost us a lot of money and time wasted on Support. 

    Seeing as the windows stack still supports Adhoc anyway, it might make sense to prevent the creation of Adhoc networks on GUI to encourage people to migrate, but there is no good reason for blocking viewing of adhoc networks by GUI.

    It's particularly rediculous because Microsoft didn't exactly visibly depreciate the use of the protocol, which makes me wonder if there is a serious security flaw with Microsoft's Adhoc implementation (which is the only reason I could think of why they would do this, otherwise, its simply an incredibly stupid mistake)

    Wednesday, November 13, 2013 3:02 AM
  • when i try to set connectiontype =IBSS it brings me help screen with error one or more parameters for the command are not correct or missing . I am using windows surface tablet Gen1 . But if i set nonbroadcast=yes , then i am able to see the ssid in my wireless GUI ,still wont connect though

    I also tried to create profile usind xml file and forcing ConnectionType=IBSS , ut after successful creation still shows Connectiontype as ESS


    • Edited by skumar19 Friday, December 06, 2013 11:11 AM
    Friday, December 06, 2013 11:01 AM
  • Try This App To Join Or Creat Adhock Network On Windows 8.1 

    http://www.sharebeast.com/5ft39mql0ysx

    • Proposed as answer by Aideal Ryder Sunday, December 08, 2013 7:38 AM
    Sunday, December 08, 2013 7:37 AM
  • You are a boss.  After upgrading to windows 8.1 I could no longer print wirelessly because my SSID was not displayed.  In addition, using netsh wouldn't even allow me to connect.  Turns out that the printer profile still existed so during the upgrade it stayed.  Then I tried netsh wlan connect <> interface=<> and it wouldn't connect.  Did exactly what you said and it works!  Thanks.
    Monday, December 09, 2013 2:30 AM
  • I have been a huge supporters of windows and I upgraded to windows 8.1 and cannot connect to ad-hoc networks so therefore I cannot print wirelessly anymore.  You should be ashamed to even think of marking this as an answer Leo.  Seriously, if you half the techie you think you are, you shouldn't have even posted this.  Anyone who is trying to connect to an ad-hoc network knows to update their drivers.  Seriously, take this complaint to your boss because there are so many people with this same issue.  Or, even better, reply to this with the update number that I can run on windows 8.1 to fix this non-sense issue. 
    Monday, December 09, 2013 2:33 AM
  • Less software is better.  Propose a real fix.
    Monday, December 09, 2013 2:35 AM
  • Heh, nice one, Aideal Ryder :).

    You basically made my howto interactive. Even the wording in "steps to setup" is the same.


    Friday, December 13, 2013 1:46 PM
  • I have an asus vivotab me400 tablet running on win 8. It can see ad hoc networks but can not connect to them.

    When I try to connect it says it is verifying but it just timesout. The device that is transmitting the wifi says it's connected but my win 8 tablet does not connect.

    Will I be able to use this tweek to connect with on a win 8? thanks


    • Edited by kcaegis45 Sunday, January 12, 2014 8:56 AM
    Sunday, January 12, 2014 8:55 AM
  • Thanks for this ..I tried a lot of  other things.. took me a while to find your post... was really important to my company .. can't thank you enough. 
    Monday, February 17, 2014 7:35 AM
  • This solution not work for me. My wireles device is intel centrino N-2230, it is show me a star(* available connections) but, when i click connection list, isnt show me any connection.


    me too.  any solution?  I need urgent help as I cannot get my Dell Tab online.
    Tuesday, March 25, 2014 7:58 AM
  • It's not working for me. I dont see the created ad hoc anywhere not even in the "Network and Sharing Center" window. please help me out.
    Tuesday, April 08, 2014 10:01 AM
  • If I follow your steps describing how to connect to an ad-hoc network but choos a SSID that is not already in use it also works and by doing so I seem to have created an ad-hoc network which others can than you.
    Wednesday, April 09, 2014 2:40 PM
  • y4k when i run the command "netsh wlan connect <ssid> i get that the syntax is incorrect and i'm sure that i'm typing it right with the name of the ssid. what should I do?
    Monday, May 19, 2014 7:25 PM
  • Its working for me now.

    Yes this has been a major problem for me as I use my Phone WiFi to use internet and it's a Ad-Hoc Network. Somehow my Wifi Dongle from "D-Link" is able to detect and connect to any Ad-Hoc network. This wnot possible with the in-built wireless lan in the laptop.

    Earlier I had tried the longer route through CMD mentioned in the chains of responses here, but the WiFi network used to drop put very frequently. So I sticked with the WiFi Dongle solution instead.

    Recently, I again tried to connect to the Ad-Hoc network hoping that some recent Windows Patch would have fixed the problem. Alas the same "Exclamation Mark" in the taskbar, saying I have limited connection and no link to Internet. Then I ran Network Diagnostics on the same to see if that brings out something new. The result was a message saying "DHCP not enabled for your <Wireless LAN Name>". I let the Diagnostic Tool do an autofix and "Mama Mia", no exclamation mark!!!!!, I am connected to the Internet now.

    I tried restarting and reconnecting and it works fine now.

    Let me know if this works for everyone.

    Thursday, May 29, 2014 1:00 PM
  • when i enter this command netsh wlan set profileparameter <ssid> connectiontype=ibss says...Failed to modify the profle. Error 0x8000E: not possible to set automatic connection for ad-hoc network
    Sunday, June 29, 2014 3:49 PM
  • Thank you for such a detailed explanation ! I can connect to the ad hoc network I use to spread Internet (sharing the internet connection) as an ordinary Wi-Fi. But unfortunately I can't have Internet. Do you have a suggestion that might help ? Thanks a lot for considering my question !
    Friday, August 22, 2014 5:14 PM
  • I realize this is for 8.1 and my question relates to 8, but I can't find anything that even comes close. I have a Acer running Windows 8 (not pro) and I cannot get the ad-hoc to work. When I run

    > netsh wlan show networks

    the network shows, but when I try to replace it, it states that it does not exist. The SSID also shows in the network list with a triangle along with all the rest on the tablet. The wireless part of my router has died and I have connected my laptops and printer ad-hoc while I am waiting for a new router. The tablet does not want to cooperate.

    Monday, September 01, 2014 8:02 PM