none
IPEnableRouter, ICS, and RRAS

    Question

  • Hi,

    I'm trying to setup a mini work domain at our office. Our building has a single different static IP address assigned to each room, but the IP addresses are on the same subnet. I'm trying to configure two of the rooms to be able to share files and access remote desktop between them, as well as access the internet.

    Each room has a computer that has 2 NICs (1 connected to the internet via the room's static IP address, and 1 connected to a switch so all other computers access the network through that PC). For example, in Room 1, NIC 1 has IP address 10.10.10.10 and NIC 2 has IP address 192.168.10.1. All other computers in Room 1 use 192.168.10.1 as the subnet. I also used "route -p add..." in the command prompt to route between the 2 rooms.

    Here's the problem:

    I set the IPEnableRouter register to 1, and I used Internet Connection Sharing (ICS) to set NIC 1 to share internet access. This allowed all other computers in Room 1 to access the internet. However, when I go to Room 2 to try to ping any of the computers in Room 1 (i.e. 192.168.10.5), it fails.

    On the other hand, if I disable the share internet access from NIC 1 in ICS and keep IPEnableRouter as 1, I am able to ping 192.168.10.5 from Room 2, but the computers in Room 1 can no longer access the internet.

    While browsing other related posts, I noticed some suggested enabling Routing and Remote Access Service (RRAS).

    My question is, which combination of IPEnableRouter, ICS, and RRAS will help me get what I want? So far it seems that IPEnableRouter without ICS is the closest to what I want, but then why can't I get internet access on the other computers?

    Thank you,

    Elton

    Thursday, August 25, 2011 1:18 AM

All replies

  • Totally you need to change in three registry settings & Restart the system

     

    HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ Tcpip \ Parameters  IPEnableRouter as 1

    HKEY_LOCAL_MACHINE \ SYSTEM \ ControlSet001 \ Services \ Tcpip \ Parameters  IPEnableRouter as 1

    HKEY_LOCAL_MACHINE \ SYSTEM \ ControlSet002 \ Services \ Tcpip \ Parameters  IPEnableRouter as 1

     

    Otherwise better use router & create vlans 


    Regards, Kalyan.
    Monday, January 30, 2012 11:19 AM