none
windows 7 devices and printers not showing

    General discussion

  • The ultimate fix was when MS Support advised be to go to services.msc and start Bluetooth services (and set it to automatic) -- I did, rebooted and the Windows 7 Pro Devices and Printers once again showed up!

    Not sure why Bluetooh services would cause my Device and Printers window to open blank (and seemingly keep looking for icons to populate the screen), but I am sure the code fix will be in a fuute windows update.

    There was no other place to put this so, I figured that this possible solution will help other early adopters of Win7
    Tuesday, December 08, 2009 3:59 PM

All replies

  • Thank you Rick.  Your solution worked

     

    Cheers

    Mary

    Monday, October 25, 2010 11:29 PM
  • Great ! Thanks for sharing.

    I actually didn't have to reboot, but merely start the service. Unbelievable..... but it's working . Tkx.

    Wednesday, April 13, 2011 1:40 PM
  • Thanks Rick,

    Piece of cake to resolve the issue and it did work.  Not sure as to why that affects the device and printers as well.

    Sunday, August 14, 2011 2:01 PM
  • Thank you. This has been driving me nuts for weeks and you finally provided the solution. I'm not an early adopter and we are on SP1 - and this still is not resolved correctly. 

     

    The workaround is perfect.

     

    Tim

    Tuesday, September 06, 2011 10:24 PM
  • This also fixed a second issue. I have not been able to click the "Remove Hardware Safely" icon to eject devices from the tray. Thanks again. Two birds with one stone.
    Tuesday, September 06, 2011 10:32 PM
  • The ultimate fix was when MS Support advised be to go to services.msc and start Bluetooth services (and set it to automatic) -- I did, rebooted and the Windows 7 Pro Devices and Printers once again showed up!

    Not sure why Bluetooh services would cause my Device and Printers window to open blank (and seemingly keep looking for icons to populate the screen), but I am sure the code fix will be in a fuute windows update.

    There was no other place to put this so, I figured that this possible solution will help other early adopters of Win7

    Thanks a lot Rick , it solve my problem, fixes my bluetooth problem, i was working on the problem for a couple of days.

    Thanks again !

    Thursday, December 01, 2011 12:02 PM
  • This problem of printers now showing under devices and printers can also be caused by installing then then uninstalling access 97 on windows 7. reinstalling access 97 fixes the problem. don't know why but it's consistent accross devices no matter how many times you install or uninstall.
    Wednesday, December 14, 2011 1:53 AM
  • Try the below KB:

    http://support.microsoft.com/kb/2486635: The Devices and Printers window stops responding (hangs) after you disable the Bluetooth Support service in Windows 7 or in Windows Server 2008 R2

    Wednesday, March 14, 2012 5:16 PM
  • I have the sames problem with my Devices and printers it will not load.  Ive tried all the fixed mentioned here and a few others.  For me, i noticed that when i opened Devices and printers by going through the control panel it loads just fine. But if i try going to Devices and printers from the start menu, it will not load.

    Monday, April 30, 2012 5:00 PM
  • It worked!!!!!!!! Thank you.
    Wednesday, October 17, 2012 4:20 PM
  • This is really good and quick solution. Many many thanks
    Monday, October 22, 2012 1:43 AM
  • Tried this.  I didn't work for me.  Just saying.
    Saturday, November 24, 2012 2:01 PM
  • Thank Rick27607.

    services.msc it really grate solutions. Enter to run, tape services.msc, activate Blutouth and ales!

    Tuesday, December 04, 2012 2:34 PM
  • Hi,

    I tried all things mentioned here and in other forums; nothing helped us to get things done. Printers were still not showing up in Devices and Printers.

    I discovered opening Printers and Devices in a separate process (with a Shift+right click on Printers and Devices) works - All Printers and devices show up in Printers and Devices now.

    Do not know what caused this behaviour, but to avoid any further issues I changed the following:

    Open Windows Explorer, goto Extras, Options, View and Activate the "..run in separate Process" Option.

    That helped us.

    Josi

    Monday, May 20, 2013 8:59 PM