none
Java 7u45 not working on Win 8.1 pro 64 bit

    Question

  • After updating to 8.1, yesterday, I had to reinstall a few things, Like Avast IS. Now that wasn't a problem, but not having Java working is. I have tried uninstalling and reinstalling it. I have used both IE11, and FF24, and Java doesn't even try to run. What can I do to get Java working again?

    Friday, October 18, 2013 12:15 PM

Answers

  • Finally, I corrected the issue. Windows Firewall was blocking java as well and all private incoming connections. Disabling the fire wall doesn't work. You have to get into the Firewall settings and unblock Java in the inbound rules, and then go to the "Windows Firewall Properties" and under the Private tab, click on the inbound connections' drop down, and select Allow, hit Apply and OK.
    • Marked as answer by King_Xerxes1 Friday, October 18, 2013 1:32 PM
    Friday, October 18, 2013 1:32 PM
  • Just Uncheck the box for 'Enable Enhanced Protected Mode' in the advanced tab of the Internet Options. Restart browser and all addons will work as normal.  IE 11's advanced security.
    • Proposed as answer by Frankiefish Tuesday, October 29, 2013 10:43 AM
    • Marked as answer by King_Xerxes1 Tuesday, October 29, 2013 11:13 AM
    Monday, October 28, 2013 8:02 PM

All replies

  • Finally, I corrected the issue. Windows Firewall was blocking java as well and all private incoming connections. Disabling the fire wall doesn't work. You have to get into the Firewall settings and unblock Java in the inbound rules, and then go to the "Windows Firewall Properties" and under the Private tab, click on the inbound connections' drop down, and select Allow, hit Apply and OK.
    • Marked as answer by King_Xerxes1 Friday, October 18, 2013 1:32 PM
    Friday, October 18, 2013 1:32 PM
  • Monday, October 21, 2013 2:04 AM
  • How did you do this? Java is not showing up in Firewall for me? I have uninstalled and reinstalled 4 times now.
    Thursday, October 24, 2013 9:50 PM
  • Go to your Control Panel, find the Windows Firewall, after you open that, you need to click on Advanced settings. Click on Inbound Rules, scroll down until you see Java, it maybe listed several times. Right click on the ones that are blocked and select Properties. On the General tab, you will see a section called Action, you will need to tick the Allow the connection. Apply and then OK, do that for all blocked Java entries.

    EDIT: Sorry I missed where you said that it wasn't showing up. Are you looking in the "Inbound Rules"? If so, did you install the 32bit version? Even on a 64bit OS, you should have the 32bit installed. You can also always add the Java entry into the firewall setting. I will type out how to do that if you need.

    I tried to upload an image for you, but the site won't let me.

    Now if Java was the only thing not connecting, then you should be good to go, if you still have an issue with Java, then follow the steps again, but this time, you will need to open the Advanced tab and under the Profiles section, check the private box, apply and OK.




    Friday, October 25, 2013 5:34 PM
  • This is not correct. Everything works fine on Firefox and Chrome, but not on the new Internet Explorer ver 11. I also use Norton and not the windows firewall. It is not a Norton problem, it is not a firewall problem and it is not a Java problem, there is something up in either Windows 8.1 or IE 11.
    • Proposed as answer by Frankiefish Monday, October 28, 2013 8:00 PM
    • Unproposed as answer by Frankiefish Monday, October 28, 2013 8:00 PM
    Saturday, October 26, 2013 10:47 PM
  • Well, you might have IE11 settings set to secure. It is working just fine for me now.
    Saturday, October 26, 2013 11:46 PM
  • Just Uncheck the box for 'Enable Enhanced Protected Mode' in the advanced tab of the Internet Options. Restart browser and all addons will work as normal.  IE 11's advanced security.
    • Proposed as answer by Frankiefish Tuesday, October 29, 2013 10:43 AM
    • Marked as answer by King_Xerxes1 Tuesday, October 29, 2013 11:13 AM
    Monday, October 28, 2013 8:02 PM
  • Java wasn't showing up on my firewall either. I tried to add every .exe file that is include on the Java folder but I still get the security issue message that don't let the App run.

    I wish I could go back to Windows 8, this 8.1 update is a real pain in the ass. I can't even use the bluetooth anymore.

    Saturday, January 04, 2014 12:19 AM
  • Java wasn't showing up on my firewall either. I tried to add every .exe file that is include on the Java folder but I still get the security issue message that don't let the App run.

    I wish I could go back to Windows 8, this 8.1 update is a real pain in the ass. I can't even use the bluetooth anymore.

    Now I'm getting this:

    "the publisher cannot be verified by a trusted source. Code will be treated as unsigned"

    Where to go???

    Saturday, January 04, 2014 1:46 AM