none
Windows 7 - Change local profile to domain profile instantly

    Question

  • Hi,

    I have just joined a computer to the domain before the computer was in a non-domain environment.

    Instead of re-creating the local user profile named 'userA' to the domain one, I went into the registry and just updated the 'ProfileImagePath' (HKLM\Software\Microsoft\Windows NT\CurrentVersion\ProfileList -> SID -> ProfileImagePath ) from the domain profile 'c:\users\userB' to 'c:\users\userA'. I then assigned the domain user permissions to 'c:\users\userA' folder.

    It works great but there's one culprit. UAC must be disabled. If UAC is enabled, I get this error message 'Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item.' when clicking on eg. My Computer, Control Panel, Documents, etc.

    I have found another way to copy the local user profile to the domain one via 'system properties -> advanced -> user profiles -> copy to' but this way is not as seamless and it is more time consuming. Everything works fine when using the 'copy to' way and I have no problems with UAC enabled.

    I would like to have UAC enabled at default settings. How can I make this work with the registry 'ProfileImagePath' way? This way is like 10 times faster!

    Thanks.

     

     

    Sunday, January 08, 2012 10:18 PM

Answers

All replies

  • Hi,

     

    For a safe way, it is recommended to use “Copy to” function or USMT to migrate the user account.


    Alex Zhao

    TechNet Community Support

    Tuesday, January 10, 2012 11:02 AM
  • allow the domain user full rights to the profile folder.
    • Proposed as answer by Bill - MCSE Thursday, January 12, 2012 1:59 AM
    Tuesday, January 10, 2012 3:17 PM
  • allow the domain user full rights to the profile folder.

    I have tried that. It still doesn't work. UAC still has to be disabled in order to use the quick registry edit way for ProfileImagePath.

    Any other things that I could try?


    Thanks

    Monday, January 16, 2012 1:16 AM
  • Reset the owner permissions on the profile???

    • Marked as answer by kungpow112 Thursday, January 19, 2012 4:00 PM
    • Unmarked as answer by kungpow112 Thursday, January 19, 2012 4:00 PM
    Wednesday, January 18, 2012 9:05 PM
  • Reset the owner permissions on the profile???

    I have tried that as well. Didn't fix the problem. Still needed UAC off with ProfileImagePath method.
    • Edited by kungpow112 Thursday, January 19, 2012 4:01 PM
    Thursday, January 19, 2012 4:00 PM
  • noticed same problem in our 2008 R2 domain with user accounts in AD configured to a use network share (DFS) path as home folder under profile tab in User Account properties (AD object). The UAC must be disabled for it to work, otherwise home folder is inaccessible to user or even to a domain admin account (!!!)

    domain users have full control permissions over their home folders. normally (with UAC off) they still run on user rights and have profile path correctly mapped to DFS and full access to their files over there. same as they do when somebody opens CMD (it starts in that folder).

    With UAC turned on, that path is inaccessible (access denied).


    • Edited by fenixus Wednesday, January 29, 2014 9:39 PM
    Wednesday, January 29, 2014 9:39 PM