none
Unable to Set Startup Type to Automatic (Delayed Start) for "Windows Event Log" Service

    Question

  • What I Need to Do:

    I would like to know how to set the Startup type to Automatic (Delayed Start) for the Windows Event Log service on Windows 7 (64-bit). When I tried to do this, I got this error message:

    "The Delayed auto-start flag could not be set."
    "Error 87: The parameter is incorrect."


    Why I Want to Do This:
    I want to do this is because I've found out that this service causes a slow startup on my computer.

    When I Enable This Service in msconfig.exe:
    - I have to wait about 2 minutes before an internet connection can be established and a browser can be opened after I log on to Windows. Some other applications, such as Windows Update, cannot be opened as well during this wait time.

    When I Disable This Service in msconfig.exe:
    - I can open a browser or any other application right away after I log on to Windows.

    How can I set the Startup type to Automatic (Delayed Start)? Is this service important? Is it safe to disable this service?

    Thanks.

    Saturday, March 17, 2012 6:19 AM

Answers

  • Upon further investigation, I've discovered that the root cause of the slow startup problem is the TFSBuildServiceHost service, a service from the Team Foundation Server 2010 application. The unintelligent design of this service from the developers had caused me a lot of suffering.

    I have solved the slow startup issue by setting this service startup type to Automatic (Delayed Start), and thus no longer need to change the startup type of the Windows Event Log service.

    I have regained sanity thanks to the tool AutoRuns.

    • Marked as answer by Vincevdn Monday, March 19, 2012 10:04 PM
    Monday, March 19, 2012 10:02 PM

All replies

  • I guess it's a permissions thing.  How big are your logs?  (c:\windows\system32\winevt\logs\)  You should be able to set a limit on the size and export and clear a log in the Computer Management control panel.

    Monday, March 19, 2012 9:13 PM
  • Upon further investigation, I've discovered that the root cause of the slow startup problem is the TFSBuildServiceHost service, a service from the Team Foundation Server 2010 application. The unintelligent design of this service from the developers had caused me a lot of suffering.

    I have solved the slow startup issue by setting this service startup type to Automatic (Delayed Start), and thus no longer need to change the startup type of the Windows Event Log service.

    I have regained sanity thanks to the tool AutoRuns.

    • Marked as answer by Vincevdn Monday, March 19, 2012 10:04 PM
    Monday, March 19, 2012 10:02 PM