none
"Turn Windows Features on or off" dialog box in the Control Panel's Program and Features is empty

    Question

  • Hello I have a problem with Vista Enterprise with SP1 on x64 system where the "Turn Windows Features on or off" dialog box in the Control Panel's Program and Features is empty, nothing shows up at all. I am trying to install IIS7 and IIS6 but not able to do this due to this problem. I tried the following link but it still does not work.
    http://support.microsoft.com/kb/931712

    Also, I tried to install IIS6 and IIS7 using the WebPlatformBuilder and it also said Install failed too.

    So there are 2 problems above and not sure if they are related, but need to fix the "Windows Features" dialog box is empty problem first.
    Tuesday, April 21, 2009 6:51 PM

Answers

  • Hello,

     

    According to your problem description, please perform the following steps to narrow downs the issue.

     

    Temporarily disable/uninstall all Anti-Virus firewalls or programs

     

    Turn UAC off temporally

    1) Click the Windows Pearl (Start Button) in the lower-left corner of the screen-> Control Panel.

    2) Select Classic View on the left and double-click the User Accounts icon.

    3) Click Turn User Account Control on or off option.

    4) Uncheck the User User Account Control (UAC) to help protect your computer and click OK.

    5) If prompted, choose restart, otherwise restart from the Start Menu.

     

    Enable built-in Administrator account

    1) Logon to Vista using your usual account.

    2) Click Start -> type cmd in Start Search box, right-click the result item and select Run as administrator

    3) Type in Net user administrator /active:yes in the command line and press Enter.

    5) Logoff and Switch to the Administrator account

    6) Install the driver again and test the issue.

     

    Run the system file checker.

    1) Close all the open windows.

    2) Click the Start Pearl, click "All programs", and click "Accessories".

    3) Right-click "Command Prompt" and click "Run as administrator".

    4) In "Administrator: Command Prompt" window, type in "chkdsk /r" (without the quotes) and press Enter.

    5) Type Y and click Enter again.

    6) Restart the computer.

     

    Good Luck!

    Andy

     

    • Marked as answer by Andy Song Wednesday, April 29, 2009 11:06 AM
    Wednesday, April 22, 2009 9:48 AM

All replies

  • Perhaps your system administrator removed access to those features using Group Policy Editor.  Check with that person for assistance.


    Carey Frisch
    Tuesday, April 21, 2009 8:34 PM
  • Hello,

     

    According to your problem description, please perform the following steps to narrow downs the issue.

     

    Temporarily disable/uninstall all Anti-Virus firewalls or programs

     

    Turn UAC off temporally

    1) Click the Windows Pearl (Start Button) in the lower-left corner of the screen-> Control Panel.

    2) Select Classic View on the left and double-click the User Accounts icon.

    3) Click Turn User Account Control on or off option.

    4) Uncheck the User User Account Control (UAC) to help protect your computer and click OK.

    5) If prompted, choose restart, otherwise restart from the Start Menu.

     

    Enable built-in Administrator account

    1) Logon to Vista using your usual account.

    2) Click Start -> type cmd in Start Search box, right-click the result item and select Run as administrator

    3) Type in Net user administrator /active:yes in the command line and press Enter.

    5) Logoff and Switch to the Administrator account

    6) Install the driver again and test the issue.

     

    Run the system file checker.

    1) Close all the open windows.

    2) Click the Start Pearl, click "All programs", and click "Accessories".

    3) Right-click "Command Prompt" and click "Run as administrator".

    4) In "Administrator: Command Prompt" window, type in "chkdsk /r" (without the quotes) and press Enter.

    5) Type Y and click Enter again.

    6) Restart the computer.

     

    Good Luck!

    Andy

     

    • Marked as answer by Andy Song Wednesday, April 29, 2009 11:06 AM
    Wednesday, April 22, 2009 9:48 AM
  • I tried the above steps and still it does not work. I am not the only one experiencing this problem. If you search the internet for the key words "Windows Features on or off empty" you will get many user complaints.
    Wednesday, April 22, 2009 5:00 PM
  • I logout from the domain and login as administrator of the same machine and still have the same problem. See below for other steps but results with the same problem.
    Wednesday, April 22, 2009 5:01 PM