none
Win 7 RC Your computer could not connect to another console session on the remote computer because you already have a console session in progress

    Question

  • I have just installed Win 7 RC and when trying to use remote desktop I get

    Your computer could not connect to another console session on the remote computer because you already have a console session in progress

    This worked fine with Win 7 beta

    Any ideas?

    Sunday, May 24, 2009 7:21 AM

Answers

  • Hi,

    Are you using the Remote Desktop wizard in Windows 7 RC or a third party Remote Desktop program? Does the issue occurs every time? Additionally, how does it work after you restart the Remote Desktop host computer and try to connect to it with the current computer then?

    I suggest that you temporary disable the anti-virus and firewall on both computers, and then check the result.

    How many computers do you have? If there are other computers, please let us know if the Windows 7 RC computer can connect to the others.


    Arthur Xie - MSFT
    Monday, May 25, 2009 10:09 AM
    Moderator

All replies

  • Hi,

    Are you using the Remote Desktop wizard in Windows 7 RC or a third party Remote Desktop program? Does the issue occurs every time? Additionally, how does it work after you restart the Remote Desktop host computer and try to connect to it with the current computer then?

    I suggest that you temporary disable the anti-virus and firewall on both computers, and then check the result.

    How many computers do you have? If there are other computers, please let us know if the Windows 7 RC computer can connect to the others.


    Arthur Xie - MSFT
    Monday, May 25, 2009 10:09 AM
    Moderator
  • I had the same error message but the problem was simply that I was using the wrong IP address for the remote computer (i.e. the IP I was attempting to connect to didn't exist).  Seems the error message should be updated to something more useful.
    Monday, June 08, 2009 3:19 PM
  • I am having the same problem as above - here is more information:

    Are you using the Remote Desktop wizard in Windows 7 RC or a third party Remote Desktop program?

    The problem is occurring with the Remote Desktop program that is part of Windows 7 RC.  Windows 7 is running on both computers.  It is interesting to note, starting on Windows 7 i CAN create a remote desktop connection to computers running running Windows XP and Windows Server 2003 R2.  I can also connect TO a Windows 7 machine from XP or Server 2003.  My awkward work around to use Remote Desktop from Windows 7 to Windows 7 is to connect from Windows 7 to Windows Server 2003, then from Windows Server 2003 to a different Windows 7 machine - this works, it's just a silly way to do things.

     

    Does the issue occurs every time?

    Yes, this occurs every time - after reboots of both computers.

     

    Additionally, how does it work after you restart the Remote Desktop host computer and try to connect to it with the current computer then?

    I have never been able to make a connection

    I suggest that you temporary disable the anti-virus and firewall on both computers, and then check the result.

    I have tested this with anti-virus and firewall removed on both comptuers - this has not been effective.

     

    How many computers do you have? If there are other computers, please let us know if the Windows 7 RC computer can connect to the others.

    Fortunately, I have many comptuers at my disposal for testing.  The problem has only been duplicated in Windows 7 to Windows 7 - under these circumstances I have never been able to make a connection.

     

    I'm happy to supply more information if this will help in eliminating this problem.  Windows 7 is a GREAT product - one of the best in many years!  This is the biggest problem I've encountered in it.

    Ray Myers
    Friday, June 12, 2009 12:38 PM
  • I'm having the exact same error - it's just a bad error message.  My problem was I was trying to take over a computer that I had not set up with Remote Desktop rights.
    Saturday, August 01, 2009 12:09 AM
  • Same error message - same problem. Was due to remote machine being part of a VPN - disconnected it from VPN and RDP worked fine, just a bad message
    Tuesday, September 15, 2009 7:30 AM
  • I have the same problem. My PC run on win 7 RC 2 could not connect to VMware - windown server 2003 SP1. if anyone have a solution, please help me
    Wednesday, October 14, 2009 4:02 AM
  • I had the same problem.

    You can solve your problem, when you take a port e.g. 5029 instead the port 3390 for forwarding.

    Here an example: mstsc /v:host:5029 
    Wednesday, November 11, 2009 11:47 AM
  • I am running Windows Vista on the remote host machine.  I have 3 PC's attempting to connect VPN / Remote Desktop to this machine. One is running Windows 7 32bit, one is running Windows 7 64 bit, and one is running Windows Vista. All the machines can connect via VPN client (running Cisco Vpn client v 5.0 on the 32 bit 7 machine & on the vista machine, and running NCP secure entry client on the 64 bit 7 machine)
    ,the 64 bit 7 machine and vista machine can ALSO connect via Remote desktop.

    The problem is with the 32 bit windows 7 machine. It cannot connect via remote desktop. I get the error "Your computer couild not connect to another console sessin on the remote computer because you already have a console session in progress"

    What settings on the 32 bit machine need to be checked. Its obviously not an issue with the remote machine. Any ideas?

    NetworkingJ




    Monday, January 04, 2010 3:46 PM
  • I have the same problem but something came up before. it said that remote desktop could not connect for one of 3 reasons and all that. then i couldn't even see the network i was connected to and now this. A problem is probaly because i am using the schools laptops which has certain restriction so if anyone could help... please :(
    Saturday, February 13, 2010 11:39 PM
  • I have Windows 7 and had previously been able to connect to a WinXP machine on my network.  I was running mstsc.exe using a .rdp shortcut  I can't think of what changed, but I just started getting this message.  Fortunately, I discovered pretty quickly that I can just navigate to the Network list, right-click on my target machine and select "Connect with Remote Desktop Connection. "
    Sunday, April 04, 2010 5:33 AM
  • On this thread here is one to knock you back in your seat.

    Main workstation is Vista 64 Enterprise.

    Old workstation is WinXP sp3.

    Netbook, Was Win7 upgrade, retail, clean install. Now is Win 7 professional, Dell OEM.

    ==================================

    I had no problem with RDP to either workstation from the netbook with Win7 upgrade, which had been installed as a test as Microsoft said it would be a poor experience. (It ran just great with 2gb ram and a 1.6gHz atom cpu.) I ordered and bought the Dell OEM to run on the Dell Mini9 netbook.

    All is great except for RDP into the Vista64 workstation.

    I can still connect to the WinXP 32 workstation, and through it to the Vista64 workstation from the netbook.

    Anytime I try to connect to the Vista 64 from the Dell OEM Win7 it returns with:

         Your computer could not connect to another console session on the remote
         computer because you already have a console session in progress

    I can only suggest there is a code difference.

    Sunday, May 16, 2010 3:22 PM
  • I am also having the same issue.... Windows 7 laptop, connecting to a 2008R2 Server hosted at rackspace.  Yes, I do have a session logged in from work, but I came home expecting the ability to /admin or /console to override the mstsc session previously established.  The switches don't do anything.

    Both OS's are clean installed.

     

    Friday, May 28, 2010 6:06 AM
  • This worked for me. Rubbish error message though, would never have considered that is was a port issue.
    Wednesday, August 18, 2010 9:52 AM
  • Ok

    I figured it out

    Steps to reproduce

    Open up the host file of the machine from where you are trying to make rdp connection (c:\windows\system32\drivers\etc\hosts)

    Type the hostname of the target machine and provide the ip of the source machine

    Save it and try to make a rdp connection to target....Result..windows queries the host file and tried to redirect session to localhost

    Since you are already logged on it throws that mesage

    Nothing weird...is'nt it

     

    cheers..

    • Proposed as answer by maxnogreis Saturday, November 06, 2010 1:31 PM
    Sunday, September 12, 2010 2:33 AM
  • i had the same problem, at first i got connected very well, but then, suddenly that message happenned, well, for some reason I found out that it was the IP addres of the machine I was trying to connect had changed, so it was just change the addres in the remote desktop connection.
    Saturday, November 06, 2010 1:35 PM
  • the funny part was that I found out that the IP addres that I was trying to acces was of the computer I was using, maybe this is why we have a console session. find out the Make sure the IP address of the computers you are trying to connect are rights.
    Saturday, November 06, 2010 1:51 PM
  • Siddharth...

    thanks for your post! I realize it's rather old now. I spent all day and already started pulling my hair until I found your post. not only did the rdp not work, I also had problems connecting to the same PCs homegroup folders under win7. I was able to connect to every other machine on the net (4 total) from both machines, but I could only connect one-way between the two. I tried the rdp with the domainname\user but it would not connect. I refreshed the ips, assigned static ips to all machines, created new users, changed sharing, changed the PCs name, rebooted all machines and routers - and many other things - but nada. nothing would work.

    I added the line to my host file

    192.168.1.70  PCNAME  #PCNAME Alias#

    and tried to connect to the IP instead of the Name of the machine in rdp and was finally able to connect. It also sorted out the homegroup issues right away. I could see the remote PCs homegroup folders activate in my filemanager while I connected via rdp. Everything works again. So for some reason the wrong IP address got stored somewhere (god knows where, does he?) for the computers Net name (not in the host file anyway, not in the credentials either).

    thanks again


    tg
    Monday, January 03, 2011 2:42 AM
  • Check Terminal Services is enabled (manual at least, perhaps automatic preferred) on the target/host machine.

    ---

    I had a problem connecting to a WinXP machine from Win7, though Win7 to WinXP was fine.

    Lots of hair-pulling and frustration and no obvious answers - and some nasty work-arounds (on other posts).

    Finally today noticed something when browsing services on XP Machine - (Control Panel, Administrative Tool, Services)

    Under Terminal Services:

    "Allows multiple users to be connected interactively to a machine as well as the display of desktops and applications to remote computers. The underpinning of Remote Desktop (including RD for Administrators), Fast User Switching, Remote Assistance, and Terminal Server."

    Ho hum. And it was disabled. Set it to automatic, and everything is now fine.



    Andrew Mather
    • Proposed as answer by Nickh1979 Friday, June 03, 2011 9:59 AM
    Saturday, March 12, 2011 12:28 PM
  • the same error.

    but it was proved that I had input wrong IP address at last.

    Friday, September 09, 2011 12:01 PM
  • Same Error for me. I am Using WIN 7 64Bit and trying to RDP to W2k8 R2 VM Server. Funny thing it happens only with this Server.
    RDP to other Server works fine. Also when I connect from a different Client to the W2k8 R2 Server it is working. I tried with IP, added the hosts file,
    tried with different PORT , nothing... the problem just won't go ...

    Greetings

    Dimi


    ----------------------------------------------------------- ----------------------------------------------------------- Thanks a lot Dimi

    Wednesday, December 05, 2012 8:27 AM
  • I was having the same problem, and that was not IP address, wrong Remote Desktop settings, any of those things: I had Microsoft Firewall Client (ISA Server Client) installed and the remote desktop only worked without this annoying error when I disabled it.
    Tuesday, May 07, 2013 12:44 PM
  • [Window Title]
    Remote Desktop Connection

    [Content]
    Your computer could not connect to another console session on the remote computer because you already have a console session in progress.

    [OK] [Help]

    I receive the same message when I remote desktop from my Windows 7 to my local machine. Basically you are going in a loop.

    Try remote desktop to or from another machine and it will work.  

    Regards,

    • Proposed as answer by myounsi Tuesday, September 24, 2013 2:38 PM
    Tuesday, September 24, 2013 1:55 PM