none
Windows Vista Password Expiration? How to turn it off?

    Question

  • Hi guys,

    This may seem very strange, or infact be easy to fix... But I have Windows Vista Home Premium, and I have just got this little popup in the corner of my screen telling me my password will expire in 14 days.

    This may be normal if I were to belong to a domain, but I don't. In fact you can't even belong to a domain on Vista Home Premium.

    I am a computer technician, and am fairly familiar with Windows Vista, but during my studies this year I was never taught how to change this option in Windows Vista Home Premium because I don't think you are expected to encounter this problem.

    Anyway, does anyone know how to fix it? Here is a screenshot:

    http://i39.tinypic.com/10cpus1.png

    Thanks,

    Bobbobagan

    PS: Hope I posted in the right forum, I have never posted here before!
    • Edited by bobbobagan Wednesday, December 17, 2008 5:50 AM made the post more user friendly.
    Wednesday, December 17, 2008 5:47 AM

Answers

  • While you are in the command prompt with administrator privileges try this command also:

    net accounts /maxpwage:unlimited

    • Marked as answer by bobbobagan Friday, December 19, 2008 8:26 PM
    Friday, December 19, 2008 1:22 PM

All replies

  • I'm not in front of a Vista Home Premium machine so I am assuming the command is the same to open the Local User Manager.

    1. Go to start then select run, or press the Windows Key + R
    2. Type in lusrmgr.msc
    3. Expand the Users folder
    4. Select the account you use to logon and right click and select properties
    5. Check the box that says "Password never expires" and hit ok
    Wednesday, December 17, 2008 12:53 PM
  • Yes, I too thought that the solution might be found in there. But when I open the Local Users and Groups console, I am presented with a nice big red X.

    Heres another picture:
    http://i41.tinypic.com/2hdw5mq.png

    I am now up to 13 days until my password expires. Its very strange, I run Windows Vista on multiple computers, but this is the only one experiencing this problem.
    Thursday, December 18, 2008 9:06 PM
  • Have you tried the users accounts tool in Control panel?

    You can try this command from the command line

    net user username /expires:Never

    Just replace username with the name of the user you want to set to never expire.
    Thursday, December 18, 2008 9:34 PM
  • I have had a look around in the User Accounts tool in Control Panel, yes, but I could not find anything of relevance that would make my password expire.

    I have also tried the command you mentioned above, and it said the command had been applied, although I logged off and then logged back on to test, and was still told my password would expire. Please note that I did not restart.

    Anything else we could try?
    Thursday, December 18, 2008 10:35 PM
  • Try right clicking on the command prompt and selecting run as administrator. Then try running the command.

    You can also try this:

    1.Go to start run and type gpedit.msc
    2. Expand to Computer Configuration\Windows Settings\Security Settings\Account Policies\Password Policy
    3. Change Maximum Password Age to 999
    4. Restart your machine
    Friday, December 19, 2008 1:19 PM
  • While you are in the command prompt with administrator privileges try this command also:

    net accounts /maxpwage:unlimited

    • Marked as answer by bobbobagan Friday, December 19, 2008 8:26 PM
    Friday, December 19, 2008 1:22 PM
  • Spenceation said:

    Try right clicking on the command prompt and selecting run as administrator. Then try running the command.

    You can also try this:

    1.Go to start run and type gpedit.msc
    2. Expand to Computer Configuration\Windows Settings\Security Settings\Account Policies\Password Policy
    3. Change Maximum Password Age to 999
    4. Restart your machine


    I can not access gpedit.msc, because that does not come on Windows Vista Home Premium. I always work in an Administrative command prompt, so I orignally tried 'net user <my username here> /expires:Never' as Administrator, and as for 'net accounts /maxpwage:unlimited' I have just done that and will test the results.

    EDIT: It seems that 'net accounts /maxpwage:unlimited' has fixed the problem. Thanks for your help. If it stops working again, I will be sure to post back here.
    Friday, December 19, 2008 8:23 PM
  • Spenceation said:

    Try right clicking on the command prompt and selecting run as administrator. Then try running the command.

    You can also try this:

    1.Go to start run and type gpedit.msc
    2. Expand to Computer Configuration\Windows Settings\Security Settings\Account Policies\Password Policy
    3. Change Maximum Password Age to 999
    4. Restart your machine


    I can not access gpedit.msc, because that does not come on Windows Vista Home Premium. I always work in an Administrative command prompt, so I orignally tried 'net user <my username here> /expires:Never' as Administrator, and as for 'net accounts /maxpwage:unlimited' I have just done that and will test the results.

    EDIT: It seems that 'net accounts /maxpwage:unlimited' has fixed the problem. Thanks for your help. If it stops working again, I will be sure to post back here.
    okay, i'm trying both the net user <my username here> /expieres:Never and net accounts /maxpwage:unlimited, but i'm getting access denied... i am logged in under and Administrator account.  is there something else i need to do to gain access?

    UPDATE nevermind... just figured out how to run as administrator... got it... thanks!
    Monday, August 03, 2009 6:29 PM
  • Sorry guys I'm not a computer expert, so before I try to study the replies/answers above, was there any solution to the Windows Vista Password Expiration notice?


    Saturday, January 08, 2011 12:33 AM