none
Missing desktop icons

    Question

  • I am missing my desktop icon, where can I find it?
    • Moved by tonysoper_MSFT Thursday, April 15, 2010 9:12 PM wrong forum (From:TechNet Wiki Discussion)
    Thursday, April 15, 2010 4:54 PM

Answers

  • Do you mean the Desktop icons are missing when you switch on?

    If so, it can be caused by ‘malware’ but check this registry key before running your ‘anti‘ programs. Firstly, start Explorer via Task Manager by pressing Ctrl+Shift+Esc then on the Applications Tab click ‘New Task’ at the bottom, type explorer.exe and press Enter. If it doesn’t start, you are almost certainly infected.

    Now check the registry key by going to the Windows Orb (Start), type regedit, press Enter and in the left pane navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon. In the right pane, make sure there is a REG_SZ named Shell and it has a value of "explorer.exe" (no quotation marks). If it’s not there, create it by clicking Edit > New > String Value then right-click it and type explorer.exe then restart the computer.

    • Marked as answer by Linda Yan Wednesday, April 21, 2010 2:01 AM
    Friday, April 16, 2010 6:46 AM
  • Is the issue that all desktop icons are missing? If all the icons are missing, right click on the Desktop, click "View", check "Show desktop icons".

     

    If the issue persists, try the following suggestions:

     

    Check Desktop Icons Settings

    =========

    1.    Right click on the Desktop, clickPersonalization.

    2.    On the left pane, clickChange desktop icons.

    3.    In the Desktop Icon Settings window, select the icon you would like to display on the desktop.

    4.    ClickOK.

     

    If you are using Windows 7 Professional, Ultimate, and Enterpise editions, you can check the Group Policy settings as well.

     

    Check Group Policy Settings

    =========

    1.    Click theStart button, type gpedit.msc into the Instant Search box at the bottom of the Start menu and press Enter.

    2.    ClickAdministrative Templates under User Configuration.

    3.    Double-clickDesktop.

    4.    Double-clickRemove Name Icon, where Name is the name of the location for which the icons is missing. For example, if the Recycle Bin icon is missing, double-clickRemove Recycle Bin Icon.

    5.    Click theSetting tab, click Not Configured, and then clickOK.

    6.    Repeat for each of your missing icons in Windows 7.

     

    If the issue still exists, you can try BurrWalnut's suggestion to reload explorer.exe.

     

    Hope this helps.

     

    Regards,

    Linda

     

     

     

    • Marked as answer by Linda Yan Wednesday, April 21, 2010 2:01 AM
    Friday, April 16, 2010 7:13 AM

All replies

  • Do you mean the Desktop icons are missing when you switch on?

    If so, it can be caused by ‘malware’ but check this registry key before running your ‘anti‘ programs. Firstly, start Explorer via Task Manager by pressing Ctrl+Shift+Esc then on the Applications Tab click ‘New Task’ at the bottom, type explorer.exe and press Enter. If it doesn’t start, you are almost certainly infected.

    Now check the registry key by going to the Windows Orb (Start), type regedit, press Enter and in the left pane navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon. In the right pane, make sure there is a REG_SZ named Shell and it has a value of "explorer.exe" (no quotation marks). If it’s not there, create it by clicking Edit > New > String Value then right-click it and type explorer.exe then restart the computer.

    • Marked as answer by Linda Yan Wednesday, April 21, 2010 2:01 AM
    Friday, April 16, 2010 6:46 AM
  • Is the issue that all desktop icons are missing? If all the icons are missing, right click on the Desktop, click "View", check "Show desktop icons".

     

    If the issue persists, try the following suggestions:

     

    Check Desktop Icons Settings

    =========

    1.    Right click on the Desktop, clickPersonalization.

    2.    On the left pane, clickChange desktop icons.

    3.    In the Desktop Icon Settings window, select the icon you would like to display on the desktop.

    4.    ClickOK.

     

    If you are using Windows 7 Professional, Ultimate, and Enterpise editions, you can check the Group Policy settings as well.

     

    Check Group Policy Settings

    =========

    1.    Click theStart button, type gpedit.msc into the Instant Search box at the bottom of the Start menu and press Enter.

    2.    ClickAdministrative Templates under User Configuration.

    3.    Double-clickDesktop.

    4.    Double-clickRemove Name Icon, where Name is the name of the location for which the icons is missing. For example, if the Recycle Bin icon is missing, double-clickRemove Recycle Bin Icon.

    5.    Click theSetting tab, click Not Configured, and then clickOK.

    6.    Repeat for each of your missing icons in Windows 7.

     

    If the issue still exists, you can try BurrWalnut's suggestion to reload explorer.exe.

     

    Hope this helps.

     

    Regards,

    Linda

     

     

     

    • Marked as answer by Linda Yan Wednesday, April 21, 2010 2:01 AM
    Friday, April 16, 2010 7:13 AM
  • Thanks Linda, this worked perfect for me!
    Wednesday, March 23, 2011 10:06 PM