none
How to boot from a SATA drive on Drive 1

    Question

  • Hi,

    I have Windows 7 installed on my WDC SATA drive and I have another SATA drive from my netbook which is a Samsung 250GB drive.  The drive from the netbook is locked with a password which I can't remember.  I have downloaded HDD Unlock Wizard which will unlock the password on the Samsung drive but unfortunately it only run's on Master Drives.  I know there is no such concept as Master and Slave with SATA drives but HDD Unlock Wizard shows my SATA Drive 0 as the Master and SATA Drive 1 as the Slave.  When I switch the ports the drives are connected to on the motherboard to make the Samsung drive on Drive 0 the system will not boot as the Samsung drive on Drive 0 is locked.

     

    My question is how can I get my system to boot from the WDC drive which is on SATA drive 1?  In the boot sequence in the BIOS there is only the option to boot from SATA drive and not from a specific drive.

    Any help would be appreciated as I do not want to have to throw away an almost new Samsung 250GB drive.

    Thanks.

    Derrick

    Monday, December 06, 2010 6:38 AM

All replies

  • Open Disk Management, set that drive as Active. Then reboot. You may need to run Startup Repair to re-create the bootmgr on that drive. 
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, December 08, 2010 7:58 AM
  • How do I set Drive 1 as active.  My Drive 0 has 3 partitions on it (OEM Partition, Primary Partition and System, Boot, Page File, Active, Crash Dump, Primary Partition).

    When I have the second drive installed do I just make All 3 partitions of Drive 1 active and re-boot?  

    The problem with this is that I can't even boot the system with the Samsung drive as Drive 0 which seems to be the default drive number to boot from.   

    Would it work if I boot from the WDC driver, then go to Disk Management and set Drive 1 as active, then switch the cables on the mother board, then re-boot?

    Thanks.

    Saturday, December 11, 2010 5:28 AM
  • If you're not too familiar with the technical terms, this might be the easiest way for you to do it.

    Take out your Samsung drive, place the WDC drive in the Drive 0 and reinstall windows 7 to it (since I'm led to believe that you installed it while it was disk 1, it is not marked as active) this will automaticly mark the disk as active (means bootable). Once that is done, place connect the samsung disk to sata port 2/disk 2 drive bay.

    Fastest way would be by starting diskpart, and simply select disk 1, then type sel par 1 or 2, depends on what the boot partition is of that disk, if you did a normal disk install and did not change anything it would be partition 1 that needs to be marked as active. and then type active. So try the following first.

    Diskpart (must be openened with administrative privileges)

    Select Disk 1

    Select Partition 1

    Active

    Exit

    After that place your WDC into drive bay 0. And boot.

    I hope you manage to get it working now.

     

    Kind regards,

    Stephan Schwarz

     

     


    If you one of these posts answered your question or issue, please click on "Mark as answer". If a post contained helpfull information, please be so kind to click on the "Vote as helpful" button :)
    Saturday, December 11, 2010 5:26 PM
  • Hi Stephen,

    I have Windows 7 installed on the WDC drive and my system boots no problem with the WDC drive connected to Sata Port 0.  

    My problem is this, I need to have the WDC drive connected to Sata Port 1 and the Samsung drive connected to Sata Port 0.  

    My question is, how do I boot my system from the WDC drive when it is connected to Sata Port 1?

     

    Thanks

    Derrick

     

    Sunday, December 12, 2010 9:45 PM
  • Sorry, I suppose I read it wrong the first time!

     

    Is the entire Samsung drive encrypted? or do you still have access to write to a partition?

    Since by normal means, you would have to change the HDD priority within your BIOS.


    If you one of these posts answered your question or issue, please click on "Mark as answer". If a post contained helpfull information, please be so kind to click on the "Vote as helpful" button :)
    Sunday, December 12, 2010 11:37 PM
  • Hi Stephen,

    The entire Samsung drive is protected by a HDD password.  I would change the boot priority if I could but I don't see it anywhere in my BIOS. All I get is the option to boot from Onboard SATA Drive and not which one, so it always boots from Drive 0.  My BIOS is probably out of date, but there must be a way to do this.

    Maybe I can boot from the Windows 7 DVD and run the commands to unlock the Samsung drive.  I have tried booting from a Windows 7 repair disk but then I could not run the programs as it gave me some error about not being able to load drivers.

    Any other suggestions you have would be appreciated.

    Thanks

    Derrick

    Monday, December 13, 2010 1:30 AM
  • It seems if you cannot set this option within your BIOS, and also are not able to call up a boot menu during the POST. Then your only option would be to connect the samsung disk to regular PC (on the sata 0/1 port, some mainboards start with 0, some start with the more logical number 1) and then boot into that machine's regular OS (you most likely will have to connect the hd of that pc to a different sata port, since by default and best practice, the boot disk will be connected to the "first" sata port) by manually selecting that disk from the boot menu, or set the hdd priority within the bios of that pc.

    Due to the limitations you seem to have with your laptop, I do not think there's a real alternative

     

    Kind regards,

    Stephan Schwarz.


    If you one of these posts answered your question or issue, please click on "Mark as answer". If a post contained helpfull information, please be so kind to click on the "Vote as helpful" button :)
    Monday, December 13, 2010 2:34 AM
  • Hi Stephen,

    I am doing this on a regular desktop.  I can call up the boot menu on startup but the option for SATA does not allow me to specify a boot order.  By default the desktop boots from port 0.  If I connect the Samsung drive to port 0 the desktop will not boot at all as the drive is locked.

    My BIOS versions is as follows:

    BIOS Type: PhoenixB

    BIOS Date: January 10th 2005

    BIOS ID: Phoenix ROM BIOS PLUS Version 1.10 A06-None

    BIOS OEM: A06

    Chipset: Intel 2580 rev 4

    SuperIO: Unknown

    Manufacturer: Dell Inc.

    Motherboard: Dimension 4700

     

    I have seen other BOIS which will allow you to select which specific SATA port to boot from, but mine does not.  I don't know what else to try except for maybe a BIOS update which may give me other options.

    Thanks

    Derrick

     

    Monday, December 13, 2010 5:17 AM
  • Ah I see, however the solution still ends up being the same, you will have to do this on a regular computer and preferably not a brand like Dell, HP and so on, these manufacturers actually limit the kind of settings you have in your BIOS. So it's not guaranteed that you have the same options available on a normal brandless computer.

    I highly doubt that a bios update would allow you to select your HDD to boot from.


    If you one of these posts answered your question or issue, please click on "Mark as answer". If a post contained helpfull information, please be so kind to click on the "Vote as helpful" button :)
    Monday, December 13, 2010 12:59 PM