none
Windows 7 64 bit Keyboard and Mouse acting strange.

    General discussion

  • Often I will have trouble where the keyboard and mouse either don't respond or when I enter any key it will repeat that key many times.  It is quite frustrating when typing notes etc. and especially scary when configuring routers or switches.  My laptop keyboard and mouse work fine but when connected to my docking station is when I have the problem.  It occurs with a standard USB Keyboard and mouse as well as my Microsoft Wireless keyboard and mouse.  I was thinking that it may be a USB power issue as I have the following connected.  However, I have removed most of the USB devices and the problem still occurs.

    USB VGA adapter
    Iomega USB Hard Drive
    GigaWare USB power hub (with power adapter connected)
    USB Dell 1110 Printer
    USB Microsoft Natural Ergonomic Wireless Keyboard and Mouse (Have also tried standard usb keyboard and mouse)

    I don't think this is an issue with the 32bit version, definately not XP.

    I have tried removing all USB devices and controllers from Device Manager (Which is a bit tricky when you only have USB mouse and keyboard) and restarting the machine so that it reinstalls the drivers and it did not cure the problem.

    Any help would be greatly appreciated.  I may try removing those usb devices again somehow remotely.
    Friday, July 24, 2009 2:23 PM

All replies

  • Just to clarify... can you use your laptop keyboard when docked?  Is the effect the same as with a usb keyboard?  Have you tried installing the keyboard drivers?
    Never ever approach a computer saying or even thinking "I will just do this quickly".
    My hangouts Format and Reload or Windrivers
    Friday, July 24, 2009 5:37 PM
    Answerer
  • Same problem I have in similar setup. I have the 32 bit version installed so it affects both. You made me think about possibly an issue with the dock. I'm going to connect my keyboard directly to the laptop to see if the issue persists.
    Friday, September 04, 2009 7:17 PM
  • just did and Win found a new hardware - weird but anyway will try for the rest of the day to see what happens.
    Friday, September 04, 2009 7:19 PM
  • Typically if you plug it into any new USB port it will find new hardware.  I have also had mine hooked up to a USB port on the laptop and still had the same results.
    Friday, September 04, 2009 7:21 PM
  • Has been almost an hour and no issues so far.

    Friday, September 04, 2009 8:12 PM
  • Just want to report that I have not had any issues since I moved my USB keyboard to the laptop's USB port.
    Friday, September 04, 2009 8:55 PM
  • Dell Latitude D820
    PRO1X docking station
    Windows 7

    I was having the same issue. If my mouse and keyboard were plugged into my PRO1X docking station in Windows 7, they would pause randomly. This would cause my keyboard key to repeat when I was typing and make my mouse stop moving. Very annoying!

    I looked through a number of forums and didn't find anything. Finally, I decided to look at the USB Hubs in the Device Manager. I found that in the properties of each USB Hub there is a "Power Management" tab. Under this tab is a checkbox (checked by default) labeled "Allow the computer to turn off this device to save power". I unchecked this setting on all of my USB Hubs, and haven't had the problem since!

    I hope this helps.
    Wednesday, September 16, 2009 3:22 AM
  • Hi Jared... I think that did the trick for me too.... I have been searching everywhere for this.. THANK YOU!!
    Thursday, September 17, 2009 4:49 PM
  • It seems like Windows doesn't remember that setting... I restarted and it was checked again.  Do you know how to force windows to remember it?

    -Will
    Thursday, September 17, 2009 9:44 PM
  • Thanks Jared, You Rock!
    Wednesday, February 03, 2010 5:50 PM
  • Dell Latitude D820
    PRO1X docking station
    Windows 7

    I was having the same issue. If my mouse and keyboard were plugged into my PRO1X docking station in Windows 7, they would pause randomly. This would cause my keyboard key to repeat when I was typing and make my mouse stop moving. Very annoying!

    I looked through a number of forums and didn't find anything. Finally, I decided to look at the USB Hubs in the Device Manager. I found that in the properties of each USB Hub there is a "Power Management" tab. Under this tab is a checkbox (checked by default) labeled "Allow the computer to turn off this device to save power". I unchecked this setting on all of my USB Hubs, and haven't had the problem since!

    I hope this helps.

    Make/Model: HP 8510p
    Dock: HP 2008 120W (KP080UT)
    OS: Windows 7 Ultimate x64
    Keyboard: HP USB
    Mouse: HP USB

    I am having the same issue. It's been driving me nuts for months. I have just turned off the power management on my USB hubs in Device Manager. I will let you all know if that solves my problem.

    Tuesday, May 18, 2010 8:42 PM
  • It seems like Windows doesn't remember that setting... I restarted and it was checked again.  Do you know how to force windows to remember it?

    -Will

    Control Panel > Power Options > Change Plan Setting > Change Advanced Power Settings > USB Settings > USB Selective Suspend Settings > DISABLED
    Tuesday, May 18, 2010 9:02 PM
  • Dell Latitude D820
    PRO1X docking station
    Windows 7

    I was having the same issue. If my mouse and keyboard were plugged into my PRO1X docking station in Windows 7, they would pause randomly. This would cause my keyboard key to repeat when I was typing and make my mouse stop moving. Very annoying!

    I looked through a number of forums and didn't find anything. Finally, I decided to look at the USB Hubs in the Device Manager. I found that in the properties of each USB Hub there is a "Power Management" tab. Under this tab is a checkbox (checked by default) labeled "Allow the computer to turn off this device to save power". I unchecked this setting on all of my USB Hubs, and haven't had the problem since!

    I hope this helps.

    Make/Model: HP 8510p
    Dock: HP 2008 120W (KP080UT)
    OS: Windows 7 Ultimate x64
    Keyboard: HP USB
    Mouse: HP USB

    I am having the same issue. It's been driving me nuts for months. I have just turned off the power management on my USB hubs in Device Manager. I will let you all know if that solves my problem.


    Unfortunately, this didn't resolve my issue. I'm still getting mouse pauses and key repeats after turning off the power settings for the USB hubs. Continuing to trouble-shoot...
    Wednesday, May 26, 2010 8:05 PM
  • John Dylan,

     

    Have you found any other fixes for this issue. I too am experiencing the same problem with the pausing when typing. I have definitely pinned it down to the dock station and Windows 7. Previously, I was using the dock and Win XP with no issues. Once I upgraded to 7, the issue started. I ran without the dock for several months and never had the issue. I recently was given a second monitor and needed the DVI output of the dock (laptop only has VGA). I installed the dock and BAM, the problem was back.

    Tuesday, June 15, 2010 2:10 PM
  • I just installed Windows 7 this past weekend and immediately started having this problem with my docking station.  Like everyone else...didn't have this with XP. 

    So far the USB Power options mentioned earlier in this thread have not worked for me.  However, I have found that if I keep the laptop lid open, then I do not have this problem.  It only shows up if I close the laptop lid while using the docking station.

    Friday, February 18, 2011 4:22 AM