none
Error 0x00000006 while adding printer on Windows 7 64 bits

    Question

  • Dear Sir:

    I tried to add a local printer on Win7 64 bits but it didn't work.

    The error message shows:can not install printer. The operation can not completed (error 0x00000006)

    This error message happened when I typied the printer name and press next.

    (The next dialog should be a printer sharing dialog)

    Any information is welcome.

    Regards,

    Friday, February 18, 2011 2:35 PM

Answers

  • Hi,

    Please make sure that you have the Windows 7 64bit compatible driver installed or installed in the server side.

    In addition, trying to delete the server/printer entry from

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Side Rendering Print Provider\Servers and
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers

    You may also follow the steps below for a workaround.

    Control panel then Settings then Add Printer
    Choose "Add a local printer". Click on "Create a new port". Use Local Port.
    Next dialogue box is "Enter a Port Name."
    Type in the path to the printer: \\(computer name)\(printer name).


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, February 21, 2011 8:52 AM
    Moderator

All replies

  • upload the file "C:\Windows\inf\setupapi.dev.log" to your public SkyDrive, please and post a link here.
    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Friday, February 18, 2011 2:49 PM
  • Hi,

    Please make sure that you have the Windows 7 64bit compatible driver installed or installed in the server side.

    In addition, trying to delete the server/printer entry from

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Side Rendering Print Provider\Servers and
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Printers

    You may also follow the steps below for a workaround.

    Control panel then Settings then Add Printer
    Choose "Add a local printer". Click on "Create a new port". Use Local Port.
    Next dialogue box is "Enter a Port Name."
    Type in the path to the printer: \\(computer name)\(printer name).


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, February 21, 2011 8:52 AM
    Moderator