none
Problems in proxy Authentication (SOLVED)

    Question

  • Hi I have the following scenario:

    My laptop is connected in the customer network, that has a domain, but my computer does not join this domain, I only use internet and map some networks drives. So, when I tried to map the network drive everything went ok, but when I tried to connect to the company's proxy it was not possible to be authenticated in it. I disabled the windows integrated authentication in IE8 and input the correct credentials for the proxy, but it did not work, a message was shown telling that the proxy authentication failed. I've compared all the Windows 7 settings with my Windows Vista, everything seems to be ok.  Does anyone have a hint about this issue?

    Thanks Very much

    Daniel
    • Edited by dburla Tuesday, August 18, 2009 7:17 PM
    Wednesday, August 12, 2009 8:53 PM

Answers

  • Hi denisxu,

    I managed to how to bypass this problem, I did not find out what proxy is used here, but I used the following steps to solve the problem:

    "The problem is the autentificación NTLM of Windows7. It is necessary to create the following key in the registry to solve it (I'm using Squid Version 3.0.STABLE8 in Debian Lenny):

    1. In HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    If it doesn’t exist, create a DWORD value named LmCompatibilityLevel and set the value to 1 to use LM NTLM and NTLMv2 if is negociated, this is
    Also it works establishing the value to 0, and 3 though for more safety the value using 3 though with old operating systems it will not work on having used obligatorily NTLMv2.

    2. Reboot

    To follow the link for more information: http://technet.microsoft.com/es-es/magazine/2006.08.securitywatch(en-us).aspx"

    Source: http://www.nabble.com/Windows-7-beta-and-NTLM-td21377271.html

    This worked well, now I'm able to connect in internet through proxy server.

    Thanks
    Tuesday, August 18, 2009 7:04 PM

All replies

  • Does the issue occurs when using a third-party browser?

    Please try to clear the IE cache and history and try again. If you have a domain account, please try to type the user name as <domian name>\<username>

    Thank you.
    Friday, August 14, 2009 4:20 AM
  • Hi,

    thanks for response, I've done it but the problem is still happening. Can it be incompatibility with the network?


    thanks
    Monday, August 17, 2009 11:01 PM
  • Hi dburla,

    Do you mean that the issue occurs even we use a third-party browser?

    In some cases the "proxy authentication failed" issue might be caused by the incompatibility between the proxy server and the clients. In that situation, we can try to update the proxy server to the latest version to see if that helps.

    Based on current information we have. We cannot say what the root cause is. It depends on the configuration of the proxy server. Would you please let me know what the proxy application is? (ISA server or third-party proxy server)? I understand that you may not have adminitrative permission on the proxy server. In this case, you may need to contact the administrator for furhter troubleshooting.

    Thank you.

    Tuesday, August 18, 2009 3:01 AM
  • hi denisxu,

    Even if use 3rd party browsers the problem occurs. I think the problem is related to the proxy. I'm trying to get information about the proxy used in the company's environment.

    Thanks again
    Tuesday, August 18, 2009 6:44 PM
  • Hi denisxu,

    I managed to how to bypass this problem, I did not find out what proxy is used here, but I used the following steps to solve the problem:

    "The problem is the autentificación NTLM of Windows7. It is necessary to create the following key in the registry to solve it (I'm using Squid Version 3.0.STABLE8 in Debian Lenny):

    1. In HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    If it doesn’t exist, create a DWORD value named LmCompatibilityLevel and set the value to 1 to use LM NTLM and NTLMv2 if is negociated, this is
    Also it works establishing the value to 0, and 3 though for more safety the value using 3 though with old operating systems it will not work on having used obligatorily NTLMv2.

    2. Reboot

    To follow the link for more information: http://technet.microsoft.com/es-es/magazine/2006.08.securitywatch(en-us).aspx"

    Source: http://www.nabble.com/Windows-7-beta-and-NTLM-td21377271.html

    This worked well, now I'm able to connect in internet through proxy server.

    Thanks
    Tuesday, August 18, 2009 7:04 PM
  •  

    Hi Denisxu

    I am using squid proxy stable 2.6 and on client side am using windows server 2008

    With your solution in the above thread my IE authentication problem has been solved

    But when I try to update windows through windows update Its again asking me for proxy authentication and its not accepting

    Thursday, July 08, 2010 7:37 PM
  •  

    Hi Denisxu

    I am using squid proxy stable 2.6 and on client side am using windows server 2008

    With your solution in the above thread my IE authentication problem has been solved

    But when I try to update windows through windows update Its again asking me for proxy authentication and its not accepting

    Hi Sarang_Tinguria,

    This is not exactly related to the post in question, but I think you will be able to find your answer here:

    http://wiki.squid-cache.org/SquidFaq/WindowsUpdate#How_do_I_stop_Squid_popping_up_the_Authentication_box_for_Windows_Update.3F

    Hope this helps, even if its almost a year later :)

    Thursday, July 12, 2012 12:13 PM