none
Calendar Gadget is Blank in Windows 7 64 Bit. Tried registering vbscript.dll in both system32 and syswow64 but still nothing,

    Question

  • After searching around for a similar issue I applied the solutions which were proposed, such as re-registering vbscript.dll and resetting gadget defaults, deleting and restoring the gadgets etc. and still the calendar is blank.  Any suggestions?  Thanks.
    Saturday, May 01, 2010 7:01 PM

Answers

  • Hi Greg,

     

    It seems that the Calendar is corrupted, currently I recommend you to perform an in-place upgrade to fix the problem. In-place Upgrade is a special upgrade process to repair the system. In-place Upgrade will not affect settings like photos, movies, documents, etc. that are saved on the computer.

     

    1.Perform a clean boot in the current operating system.

    2.Insert the Windows 7 Installation Disc to your DVD-ROM drive. If AutoPlay pops up, click “Run setup.exe” directly.

    3.Click “Install now” on the “Install Windows” screen.

    4.In the “Get important updates for installation” screen, it is recommended to select the first option to download latest updates for installation, if Internet access is available.

    5.Check the box “I accept the license terms” to agree with the installation license and click “Next”.

    6.In the “Which type of installation do you want?” screen, click “Upgrade” to perform the In-Place upgrade.

    7.Then, follow the wizard to finish the In-place Upgrade process.

     

    Best Regards

    Dale

     

    Tuesday, May 04, 2010 3:10 AM

All replies

  • Hi,

     

    1.     Run sfc /scannow to automatically fix the corrupted system file.

    2.     Create a new profile and test if the issue occurs. If not, this can be caused by corrupted user profile, you may need to fix the corrupted user profile.

    3.     Try to uninstall and re-install Windows Gadget Platform.

    1)    Close all programs.

    2)    Click Start , and then click Control Panel.

    3)    Under Programs, click Uninstall a program.

    4)    In the tasks pane, click Turn Windows features on or off.

    5)    In the list of windows features, clear the check box next to Windows Gadget Platform.

    6)    You receive a warning message in a pop-up window. Click Yes.

    7)    Then repeat step 1) to step 4, and check box next to Windows Gadget Platform.

    Best Regards

    Dale

    Monday, May 03, 2010 4:01 AM
  • Boy Dale,

    I really thought you were on to something with creating a new profile, sfc / scannow from an administrative command prompt came back ok, nothing found.  

    Following your advice above, I created a new account with administrative privlages, and then proceeded through the steps which forced a reboot at the end.  After restarting I logged in under the new account and repeated steps 1-4 to reactivate the Windows Gadget Platform .  Unfortunately the Calendar gadget is still blank, even in the newly created profile.  One note of interest, for whatever reason when starting the Calendar either in my profile or the new profile the Calendar always starts with it's position half off the screen on the right side, like the start positioning doesn't get saved.  Other than that though, it's still blank.  Any other ideas?

    Thanks,

    Greg Huntoon

     

     

    Monday, May 03, 2010 6:23 PM
  • Hi Greg,

     

    It seems that the Calendar is corrupted, currently I recommend you to perform an in-place upgrade to fix the problem. In-place Upgrade is a special upgrade process to repair the system. In-place Upgrade will not affect settings like photos, movies, documents, etc. that are saved on the computer.

     

    1.Perform a clean boot in the current operating system.

    2.Insert the Windows 7 Installation Disc to your DVD-ROM drive. If AutoPlay pops up, click “Run setup.exe” directly.

    3.Click “Install now” on the “Install Windows” screen.

    4.In the “Get important updates for installation” screen, it is recommended to select the first option to download latest updates for installation, if Internet access is available.

    5.Check the box “I accept the license terms” to agree with the installation license and click “Next”.

    6.In the “Which type of installation do you want?” screen, click “Upgrade” to perform the In-Place upgrade.

    7.Then, follow the wizard to finish the In-place Upgrade process.

     

    Best Regards

    Dale

     

    Tuesday, May 04, 2010 3:10 AM
  • Dale,

     

    I did that and reactivated Windows.  It worked, thanks.  It just seemed like a little brute force approach to what seems to be a minor issue.  I tend to  experiment with my PC quite a bit so it could have been something I did while 'experimenting'.  While trying to get this fixed I did discover a confusing default convention used in Windows 7 that you may be able to shed some light on.  On a 64 bit system why did Microsoft name System32 the folder for 64 bit .DLL's and SysWOW64 as the folder for 32 bit .DLL's?  I would have chosen System64 and SysWOW32 respectively.

     

    Thanks,

     

    Greg Huntoon

    Wednesday, May 05, 2010 10:44 AM
  • Hi,

     

    I’m glad to see it worked. Moreover, according to my understanding, SysWoW64 wasn't intended for the dlls of 64-bit systems, it's actually something like "Windows on Windows64", meaning the bits you need to run 32bit apps on a 64bit windows. You can visit the following article for detailed explanation.

     

    Windows x64 – All the Same Yet Very Different, Part 7: File System and Registry Redirection, Registry Reflection

     

    Best Regards

    Dale

    Thursday, May 06, 2010 1:30 AM
  • Hi Greg,

     

    It seems that the Calendar is corrupted, currently I recommend you to perform an in-place upgrade to fix the problem. In-place Upgrade is a special upgrade process to repair the system. In-place Upgrade will not affect settings like photos, movies, documents, etc. that are saved on the computer.

     

    1.Perform a clean boot in the current operating system.

    2.Insert the Windows 7 Installation Disc to your DVD-ROM drive. If AutoPlay pops up, click “Run setup.exe” directly.

    3.Click “Install now” on the “Install Windows” screen.

    4.In the “Get important updates for installation” screen, it is recommended to select the first option to download latest updates for installation, if Internet access is available.

    5.Check the box “I accept the license terms” to agree with the installation license and click “Next”.

    6.In the “Which type of installation do you want?” screen, click “Upgrade” to perform the In-Place upgrade.

    7.Then, follow the wizard to finish the In-place Upgrade process.

     

    Best Regards

    Dale

     


    Hi Dale,

    i am facing the same issue for calendar gadget, but to try the in place upgrade i need the installation media, which i have not received when i bought my laptop. Is there any other workaround ?

     

    Thursday, November 04, 2010 4:06 PM
  • Found this on another forum. It worked for me. Worth a try as long as you aren't afraid of using regedit.

    Stop sidebar.exe and use regedit to delete the following key. You must have administrator privileges.

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\

    Restart sidebar.exe

    Good luck.
    • Proposed as answer by popeye1953 Tuesday, November 16, 2010 8:43 PM
    Sunday, November 14, 2010 7:34 PM
  • Deleting the key was the answer I needed, thank you very much.

    All of my gadgets quit after some malware tried to get on my system, that cleaned them all up..

    Sunday, November 21, 2010 3:38 PM
  • I think I found a solution that worked for me which doesn't require any registry tweaks. Surprisingly the culprit was internet explorer.
    Try the following:

    Open one only window of internet explorer.

    Click tools->internet options

    Click the Advanced tab

    Click Reset (Not restore advanced settings)

    If you want, also delete your personal settings

    Press ok

    Close internet explorer.

     

    Now everything should work. As far as I have understood, the problem lies in the security settings. This may also create problems such as not being able to run some .exe files. The error that appears in those cases is "Your internet security settings prevented one or more files from being opened". 

     

    Sunday, November 21, 2010 5:46 PM
  • hi.. i have windows 7 64 bit.. and i usually keep my pc running all day and put it to sleep at night.. around once a week i shut it off for the night ... u know.. let the hamster rest a lil ;)
    after some windows patch i seem to have lost all visual of my gadgets (not sidebar) that i keep on my 2nd monitor.. i have network card monitor.. temperature.. and a processor monitor... all of which seem to be blank... also .. it might be useful to note that my yahoo messenger is blank as well.. i see my list of contacts but when i receive or send messages.. its entirely blank..
    also tried to register umm.. some cmd you put in dos.. the 32 bit and 64 bit cmds did not work.. sfc cmd found zip as well
    if anyone could help me.. id greatly appreciate it...
    Thursday, November 25, 2010 3:35 AM
  • nvm.. fixed it myself
    Sunday, November 28, 2010 8:13 PM
  • What exactly do you delete?

     

    Tuesday, March 15, 2011 9:12 PM
  • What exactly do you delete?

     


    use this automated FixIt:

    Windows7 Gadgets may not work or display properly
    http://support.microsoft.com/kb/2515657/en-us


    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Tuesday, March 15, 2011 9:16 PM
  • i've tried any other suggested workarround to no avail but this one works like a charm. Thank you.

    but i don't know what zones are for put by Microsoft in the registry so i export it, delete, and reinstate it back and my calendar still doing fine.

    and as an extra gift from this workarround, it also fix another problem that is a folder which i put on my desktop, the folder icon didn't show it content and now i can see the content.


    Visual Basic 6.0
    Saturday, April 09, 2011 7:21 AM
  • The real fix:  In folder options change view to show hiden files and system files.

    Go to users/your logged on name/AppData/local/Microsoft/Windows Sidebar.

    After you have stopped the sidebar process, delete settings.ini.

    Change settings so that hidden and system files are hidden.

    Reboot.

    Bring out your calandar gadget and enjoy.

    • Proposed as answer by D-Ray-Y Thursday, May 12, 2011 2:21 AM
    Tuesday, May 10, 2011 2:10 PM
  • Thanks for that input, worked perfectly for me !
    Sunday, May 29, 2011 10:34 PM
  • The automated Fix It worked for me - thanks!!  Last time I checked there was no Fix It for this (the widget broke on my Toshiba laptop at least 6 months ago).  The interesting thing is I have a brand-new Dell and the Calendar widget did not work on it, either, which means (as far as I can tell) Windows 7 is shipping with incorrect Internet Zone settings or all the updates that downloaded and installed in the first 2 - 3 days broke this widget.  The widget appears to be out of date and/or its registry code is being overwritten.
    Monday, May 30, 2011 2:37 PM
  • Close Gadgets.

    Re-register vbscript.dll by running

    regsvr32.exe vbscript.dll

    Should get DllRegisterServer in vbscript.dll succeeded.

    Add gadgets, should work. If not, restart Windows.

     

     

    Wednesday, June 08, 2011 10:38 AM
  • Found this on another forum. It worked for me. Worth a try as long as you aren't afraid of using regedit.

    Stop sidebar.exe and use regedit to delete the following key. You must have administrator privileges.

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\

    Restart sidebar.exe

    Good luck.
    Thanks popeye1953 this work perfectly for me, wish id seen it before I ran windows protected file scanner etc!! :-)
    Thursday, June 16, 2011 11:50 AM