none
Internal error 0x80070057 (Backup windows 7)

    Question

  • Hi,
    I am running windows 7 professional (final release) just downloaded from msdn-aa of my university.
    First thing I checked was the backup feature, since I was really unsatisfied with vista's one.
    I did a backup, choosing those few folders I needed to backup and run it.
    The process halted before completion and gave me this error:
    "An internal error has occurred:
    The parameter is incorrect: (0x80070057)"

    Now, every time I try to use the backup feature (by clicking on start -> all programs -> maintenance -> Backup and restore) I immediately see this error window, and I can't do anything. I can neither backup, neither restore.

    I have 2 hds on my machine. Fist one is a 750 Gb one, divided in 2 partitions C and D (400Gb and 350Gb) and the second one is a 300Gb hd with letter E in a single partition.
    I also have a virtual drive (by magic disk).

    Can someone help me please?
    Thank you very much,
    sfabriz
    Sunday, August 30, 2009 10:46 PM

Answers

  • This issue might be due to a bad sector located at the very end of volume that you are trying to backup.

     

    However, as a workaround you can try the following methods:

     

    A, If you save the backup files in the first 750GB hard drive, you can save the backup files in second 300GB hard drive with letter E to test this issue. However, if you save the backup files in second 300GB hard drive with letter E firstly, you can try to save the backup files in first 750GB hard drive with letter C or D.

    B,  Run check disk to check the hard drive

     

    Note: Please ensure that the DVD-ROM is the first booting device.

     

    1. Please insert the Windows 7 DVD and reboot the computer.

     

    2. When we are prompted to press a key to boot from the DVD, please press Enter or the space bar.

     

    3. Click "Next" and click "Repair your computer".

     

    4. Please highlight "Windows 7" and click "Next".

     

    Note: A computer may store more than one copy of Windows 7. Please highlight the one which encounters issues. The order of the items in the dialog-box is identical with the one on the boot menu.

     

    5. In the dialog box titled "System Recovery Options", click "Command Prompt" and type in the following commands. Please press the Enter key after entering each command.

     

    C:

    CHKDSK /R

     

    Note: Please replace "C:" with the actual drive letter of the system drive on which Windows 7 is stored.

     

    6. Please let me know if any error is detected.

     

    C: Use other backup tool to test if you can backup files on the computer properly.

     

    Regarding the other backup fail issue, you can check this website Common causes and solutions to Backup, System Restore, and Complete PC Backup problems

     

    Betty

    • Marked as answer by sfabriz Tuesday, September 01, 2009 9:45 PM
    Tuesday, September 01, 2009 8:11 AM

All replies

  • This issue might be due to a bad sector located at the very end of volume that you are trying to backup.

     

    However, as a workaround you can try the following methods:

     

    A, If you save the backup files in the first 750GB hard drive, you can save the backup files in second 300GB hard drive with letter E to test this issue. However, if you save the backup files in second 300GB hard drive with letter E firstly, you can try to save the backup files in first 750GB hard drive with letter C or D.

    B,  Run check disk to check the hard drive

     

    Note: Please ensure that the DVD-ROM is the first booting device.

     

    1. Please insert the Windows 7 DVD and reboot the computer.

     

    2. When we are prompted to press a key to boot from the DVD, please press Enter or the space bar.

     

    3. Click "Next" and click "Repair your computer".

     

    4. Please highlight "Windows 7" and click "Next".

     

    Note: A computer may store more than one copy of Windows 7. Please highlight the one which encounters issues. The order of the items in the dialog-box is identical with the one on the boot menu.

     

    5. In the dialog box titled "System Recovery Options", click "Command Prompt" and type in the following commands. Please press the Enter key after entering each command.

     

    C:

    CHKDSK /R

     

    Note: Please replace "C:" with the actual drive letter of the system drive on which Windows 7 is stored.

     

    6. Please let me know if any error is detected.

     

    C: Use other backup tool to test if you can backup files on the computer properly.

     

    Regarding the other backup fail issue, you can check this website Common causes and solutions to Backup, System Restore, and Complete PC Backup problems

     

    Betty

    • Marked as answer by sfabriz Tuesday, September 01, 2009 9:45 PM
    Tuesday, September 01, 2009 8:11 AM
  • Hi Betty,
    I run the check disk on all my disks and they resulted perfectly healty.
    I removed manually the backup file and the other one (media.bin? could be?) that gets created in the process.
    After having run the checkdisk on my drives, the backup function has been restored.
    I gave it another try but it got stuck again. At that point I run another checkdisk, made sure the backup function works again, removed the backup, turned off the job schedule and installed nero backitup express that came with my external hard disk.
    Works like a charm. No way I'm using windows backup again, until they fix it, because deleting files and running checkdisks on a 750 Gb disk takes time I don't like to waste any more.
    But thank you really for your kind reply, I've printed it in case I'll need those informations.

    Kind regards,
    Fabrizio
    • Proposed as answer by Fairbanks123 Wednesday, September 07, 2011 11:07 AM
    • Unproposed as answer by Fairbanks123 Wednesday, September 07, 2011 11:08 AM
    Tuesday, September 01, 2009 9:42 PM
  • Hi Fabrizio,

    Regret the inconvenience caused to you. Have you got a chance to try Windows backup again? Can you zip and pass on the contents of <<SystemDrive>>\Windows\Logs\WindowsBackup to sneham_at_microsoft_dot_com (Remove underscores and replace words with characters wherever applicable)? Please also pass me the following:
    1. Screenshot of your disk management UI (Run-> diskmgmt.msc).
    2. Screenshot of Windows backup and restore center (Control Panel -> System and Security -> Backup and Restore)

    This will help us in identifying the issue. Thanks in advance.

    Regards,
    Sneha
    [MSFT]
    Tuesday, September 15, 2009 6:32 AM
  • Allright, as soon as I have some time I'll do that.
    Cheers,
    Fabrizio
    Thursday, September 24, 2009 4:47 PM
  • Hi, I did the same thing, I manually deleted everything on my back up external HD (it's now completly empty) and now I cannot create a new back up.

    Message (translated from dutch):

    Internal error
    Bad Parameter (0x80070057)

    Is there a solution to this.

    Greets
    Jan
    The Netherlands
    Monday, November 09, 2009 3:41 PM
  • Hi Jan,

    Can you contact me offline at sneham_at_microsoft_dot_com (Remove underscores and replace words with characters)?

    Thanks,
    Sneha
    [MSFT]
    Monday, November 09, 2009 3:56 PM
  • Hi Sneha,

    are you still collecting data on this error? Perhaps it is an issue with usb-devices. I recently tried to do a backup on my 8 Gb usb-memory stick. I figured it had capacity enough to hold my Office documents, images and and such. After the backup started the Backup-program window would just display the error message. So I closed and reopened the backup application, but with no luck- The error message was still there.
    I sort of came up with a workaround. As I unplugged the memory stick the Backup-application would return to somewhat normal state. Though it would tell me that the backup had ended with an error. But every time I reatached the stick it would return to its catatonic state again.

    So I got rid of the usb-memory,  changed the settings to make the backup to an optical disk instead of the memory stick, and when the program would ask me to present an empty optical disk I would stop the backup process.

    Now I don't have a backup of my files, but dragging the My Documents out of the library to the removable media works just as well. I'm not sure if it's a good way of making a backup, but it's an easy way.
    Sunday, November 22, 2009 6:50 PM
  • Hi,

    I am investigating on this issue with the infomation provided by some customers. Will post back with updates.

    Thanks,
    Sneha
    [MSFT]
    Wednesday, November 25, 2009 5:01 PM
  • Hi,
    Can you please remove/disable the virtual drive and try the backup again?

    Thanks,
    S.Soudamini.

    This posting is provided "AS IS" without warranties and confers no rights.
    Wednesday, December 02, 2009 1:07 PM
  • Hi,

    We have found this issue to be related to the number formatting (region and language settings) of the machines. Can you post if your settings are Dutch(Netherlands) or otherwise? Is there any customization done to the settings?

    Thanks,
    Sneha
    [MSFT]
    Sunday, December 06, 2009 1:56 PM
  • Got the exact same problem.

    Windows 7 Home premium English

    Region format : French (Canada)
    Location : Canada
    Language for non-unicode programs : English (US)   ...cause I prefer being redirected on english us pages (Google, etc..)


    Sunday, December 06, 2009 3:49 PM
  • Ciao.
    I've the same problem. Backup on a usb external driver give me a "parametro non corretto 0x80070057".
    But it seems like the backup is proceeding (a "clock" icon over the "message" flag in the "desktop" bar).
    I've a "pc-alessandro" backup icon in the external hard disk and a "MediaID.bin" file has been created (1kb...)
    Have some answer?
    Thanks
    Sunday, December 06, 2009 11:09 PM
  • Hi
    I have the same problem too, Backup on a standalone blank formated internal S-ATA drive, no customization done to the settings

    Windows 7 Ultimate 64 bit

    Region format : German(Austria)
    Location : Austria

    Thanks
    Monday, December 07, 2009 7:12 AM
  • Hi,

    I have similar problem to alecaliaro. The backup seems to work on backgroud and there is backup folder and mediaid.bin on external drive
    But when going to Control Panel\System and Security\Backup and Restore it gives the error

    Win 7 Enterprise 32 bit
    Region: Finland
    Location: Finland

    Regards, Riku Partanen
    Tuesday, December 08, 2009 6:36 AM
  • El problema sucede por que se exceden los caracteres del nombre de alguno de los archivos que queremos copiar.
    Para resolverlo tenemos que detectar que nombre de archivo es demasiado largo y modificarlo por uno mas corto.
    Saludos desde Argentina
    Thursday, December 10, 2009 2:27 AM
  • i have the same problem with restore through lan
    in windows 7 prof ita 32 bit when i try to restore (from cd recovery) image from lan i have "parametro non corretto (0x80070057)"

    from nachinSA info i try to rename file in < 8 char but the problem persist

    thanks


    Fabio Masterb
    Thursday, December 10, 2009 4:19 PM
  • The same problem in Windows 7 Professional Polish 64-bits version trying to store it on mapped drive on other computer.

    Waiting for fast update solving this issue. Thanks in advance.
    Thursday, December 10, 2009 10:31 PM
  • The information is in many subfolders?
    Note that characters accumulate, for example:
    A folder named "My information" within this one named "Photos", in this one file called "me", adding the characters are Deven (mi_informacionfotosyo = 20)
    1_Copiar information on the root system, usually c:
    2_Deshabilita the UAC from the Control Panel (very strongly recommended)
    3_Si not work you can do a scan disk on the disk.

    Tell us how you did please.
    Thursday, December 10, 2009 11:03 PM
  • hi,
    i  can successfully complete the backup network

    Windows backup image tool automatically creates files and folders in the remote directory "WindowsImageBackup"
    under this folder there are all the necessary files for restore
    whith computer with hard drive blank (no partition/volume) i try to do restore from recovery cd
    when i select the image from network the restore tool correctly identifies the backup under folder "WindowsImageBackup" , identifies correctly the partition but when try to restore the images there is a error reported
    in the windowimagebackup (folder created automatically) are folder "#myhostname#" and under folders "backup #date#","catalog" and "SPPMetadataCache"
    in the "backup" are .vhd files, i try to rename only this file
     
    not having a win system up and a partitioned disk i don't try to copy file in c: , disable UAC and do a scandisk

    thanks for updates/suggestions bye


    Fabio Masterb
    Friday, December 11, 2009 10:22 AM
  • The same problem in Windows 7 Professional Polish 64-bits version trying to store it on USB drive.
    Saturday, December 12, 2009 5:12 PM
  • Same problem here. Tried backing up to both a USB hard drive and a USB memory stick. Only way to get rid of the error is to remove the device and then choose another target for the backup, e.g. the DVD player. USB devices formatted with NTFS.
    System image works as expected as long as it is performed separately from the other backup feature.

    Windows 7 x64 (swedish)
    Locale = Sweden
    Format = Swedish (Sweden)  - no custom changes
    Saturday, December 12, 2009 7:38 PM
  • Hi,

    Can anyone facing this issue get in touch with me on email at sneham_at_microsoft_dot_com (Remove underscores and replace words with characters wherever applicable)?

    Thanks,
    Sneha
    [MSFT]
    Tuesday, December 15, 2009 7:07 PM
  • just sent you an email
    Wednesday, December 16, 2009 10:04 AM
  • i sent you email
    thanks
    Fabio Masterb
    Wednesday, December 16, 2009 3:00 PM
  • This is time wasting...
    I decided to go with Acronis True Image Home, works perfectly and have better options than the Windows 7 Backup.
    Wednesday, December 16, 2009 4:24 PM
  • Hi,

    I have gotten in touch with a couple of customers. Will post back the updates. Thanks for your patience.

    Thanks,
    Sneha
    [MSFT]
    Thursday, December 17, 2009 12:48 PM
  • Good luck!
    Friday, December 18, 2009 9:17 AM
  • I had the same issue, and solved it on this way:

    Open registy editor (regedit)
    Go to HKEY_LOCAL_MASCHINE > Software > Policies > Microsoft > Windows > System (Create System by yourself if it's not there)
    Add DWORD: CopyFileBufferedSynchronousIo and set it's value to 1.

    Restart your PC

    After that the backup function works fine for me.
    • Proposed as answer by Thijs82 Saturday, December 26, 2009 1:39 PM
    Tuesday, December 22, 2009 10:36 AM
  • I've same problem... does exist a fix?
    Thanks!
    Saturday, December 26, 2009 12:07 PM
  • I had the same issue, and solved it on this way:

    Open registy editor (regedit)
    Go to HKEY_LOCAL_MASCHINE > Software > Policies > Microsoft > Windows > System (Create System by yourself if it's not there)
    Add DWORD: CopyFileBufferedSynchronousIo and set it's value to 1.

    Restart your PC

    After that the backup function works fine for me.

    This is the solution on my system. The backup application is now running fine.
    What exactly made the registery change above needed...?
    Saturday, December 26, 2009 1:40 PM
  • hi all,
    sneha you have news for us?

    thijs82/phin87  you had the error at backup or restore?
    I can try to modify the registry re do the backup(I have always worked) and retry the restore via network
    thanks


    Fabio Masterb
    Wednesday, December 30, 2009 9:04 AM
  • I had the same problem with backup - and now, after changing registry value, I have - error 0x81000031
    Wednesday, December 30, 2009 10:44 AM
  • Hi All,

    We were analyzing the traces from a customer and he lost the repro as he changed the locale back to English.
    To re-iterate, we are investigating the scenario where the control panel blanks out with the error "parameter incorrect".
    Please drop a mail to lokkum [at] microsoft [dot] com if you are willing to help us in the investigation.

    Thanks,
    S.Soudamini.
    This posting is provided "AS IS" without warranties and confers no rights.
    Thursday, December 31, 2009 5:42 AM
  • Hi!
    I have the same problem, I use Windows 7 Ultimate 32bit (German). When I try to open the control applet, I often see this internal error without starting an backup. However, when I want to backup my computer, I could just access sometimes to it and it just works then, sometimes I only see the progress in the taskbar and the applet shows the internal error.
    Regards,
    Jochen
    Monday, January 04, 2010 5:12 PM
  • Hello Guys,
    We were able to root cause and fix the issue on one of the customer's machine. The issue was with an external software, 'Gnu Privacy Guard' (GnuPG), installed on the machine which was causing changes to the run time locale of the machine and not resetting it back to normal. Un-installing the app fixed the issue.
    Can you guys check if this software is present on your machine(Control Panel->Programs->Programs and Features)?
    If yes, un-install, reboot and see if the Backup and Restore CPL shows up fine(without the 'Parameter Incorrect' error). 

    If no, I would like you to collect some diagnostic information. Please send an email at lokkum"at"microsoft"dot"com so I can provide you the steps. 

    Thanks,
    Lokesh [MSFT]
    Friday, January 08, 2010 8:03 AM
  • I have the same problem on Windows 7 Enterprise Edition Dutch (x86). Adding the CopyFileBufferedSynchronousIo registry value didn't work for me.
    I'm trying to backup to network storage. (UNC path).

    I cannot modify the backup anymore and get the incorrect parameter error: 0x80070057
    I do not use the 'Gnu Privacy Guard' software.
    My regional settings are set to dutch.
    Backup function is useless now. Do you want me to send you the logfiles?
    Please let me know.
    Thanks!
    Wednesday, January 20, 2010 12:33 PM
  • I have the same problem on Windows 7 Enterprise Edition Dutch (x86). Adding the CopyFileBufferedSynchronousIo registry value didn't work for me.
    I'm trying to backup to network storage. (UNC path).

    I cannot modify the backup anymore and get the incorrect parameter error: 0x80070057
    I do not use the 'Gnu Privacy Guard' software.
    My regional settings are set to dutch.
    Backup function is useless now. Do you want me to send you the logfiles?
    Please let me know.
    Thanks!

    I have ran a chkdsk on my OS partition and now backup works again.
    Thursday, January 21, 2010 2:25 PM
  • I cannot modify registry or any on basic windows7 installation
    I cannot have 'Gnu Privacy Guard' software installed

    Backup function correctly but the restore have 0x80070057
    thanks

    Fabio Masterb
    Friday, January 22, 2010 9:43 AM
  • Hi,

    Sorry for the late reply. From our investigation, we have seen that this issue can occur due to a number of applications outside backup. The issue occurs when the decimal symbol is set to anything other than '.' (dot). This is common in languages / locales other than English, such as Dutch, German. Please note that your backups are still running fine and you can restore your data from them.

    To close on this issue, we need your help in getting hold of such applications. Please send a mail to lokkum[at]microsoft[dot]com if you are willing to help us.

    Meanwhile, as a workaround, please do the following:
    1. Go to Control Panel->”Clock, Language, and Region”->”Region and Language”->”Additional settings”.
    2. Change the decimal symbol from “,” to “.”
    3. Open an elevated cmd(search->cmd->right click->run as administrator).
    4. C:\windows\system32> taskkill /f /im explorer.exe
    5. C:\windows\system32> explorer.exe (// restarting explorer)

    Thanks in advance for your help.
    Regards,
    Lokesh
    [MSFT]
    • Proposed as answer by Henrik75 Wednesday, January 27, 2010 12:02 AM
    Monday, January 25, 2010 6:31 PM
  • Hi Lokesh,

    After wasting 2 days now this error message was my last error message I investigated on my Windows 7 box, and I can confirm that your solution works.

    But I am sorry to say, that the solution in general to all problems with Windows Backup is simple:

    Do not use Windows Backup. It's fubar.

    You can see the full story at http://my-tech-talk.blogspot.com/2010/01/do-not-use-windows-backup.html

    Tobias
    • Proposed as answer by Tobias Manthey Tuesday, January 26, 2010 12:13 PM
    • Edited by Tobias Manthey Tuesday, January 26, 2010 8:00 PM create link
    Tuesday, January 26, 2010 12:13 PM
  • I've tried solution proposed by Lokesh [MSFT] , and now I've got an error - 0x81000015, so I think Tobias Manthey solution is the best from proposed here - use 3rd party software for backups. Anyone nows a good free for home use program?
    Tuesday, January 26, 2010 3:39 PM
  • Hi,

    Windows 7 Backup worked for me as long as I had not encrypted my harddisk with TrueCrypt.

    Having encrypted it, the backup did not work any more:
    Check your Backup
    The parameter is incorrect.
    -> Try to run backup again
    -> Change backup settings
    Error code: 0x80070057

    I tried
    • your workaround (changing decimal symbol to '.')
    • checkdisk
    • registry change mentioned by Phin87.
    • only backing up the image
    • only backing up personal files
    Neither of them works. So it seems as if, with an encrypted system partition using TrueCrypt, Windows7 Backup does not work. If anybody knows how to pass, I would be glad to hear from you.
    Thursday, February 11, 2010 9:17 AM
  • I also have partitions encrypted with truecrypt,
    but I didn't think this is relevant since the partition I'm trying to back up and the target partition are not encrypted...
    Thursday, February 11, 2010 9:26 AM
  • The issue occurs when the decimal symbol is set to anything other than '.' (dot). This is common in languages / locales other than English, such as Dutch, German.
    Hi,

    I can confirm that this is the root of the error on my computer too. When the patch will be released?

    Vaclav
    Saturday, February 20, 2010 12:54 PM
  • I'm experiencing this problem too. I'm going to send you a mail at specified address.

    Have you any information about a release date for a patch ?
    Fremy - Developer in VB.NET, C# and JScript ... - Feel free to try my extension
    Saturday, February 20, 2010 3:44 PM
  • Microsoft Backup seems to fail miserably also with very simple case: 
    c:\ 160GB
    d:\ 160GB

    c=70GB used
    d=empty

    Computer starts to jam at around backup time and when trying to disable backup from bothering, you get internal error 
    "Internal error has occured The parameter is incorrect. (0x80070057)

    I am guessing that this has something to do with updates of drive letters during the backup by using for example memory cards etc.

    But hey, its so easy to fix this, just install linux..

    Br,

    -Salo
    • Proposed as answer by emaNyalpsiDyM Monday, March 01, 2010 4:31 AM
    Sunday, February 21, 2010 6:36 PM
  • WOW hes a genius!!!!! What an easy fix.

    But....

    If you have trouble with linux....omg i cant just point and click...try using SyncEXP http://www.soft32.com/download_9098.html its rly easy and FREE.
    Monday, March 01, 2010 4:35 AM
  • I have the same problem on a Win7 Home Italian 64 bit. Backup worked fine on a external disk USB 2.0 3.5". The disk was a WD 160 gb 7200 RPM 16 Gb cache. I've bought a new external drive, a Samsung S2 portable 2.5", 640 GB, and the error has occured. I've not installed any new program, I've no changed any setting in Windows. It works on the 3.5" disk, and doesn't work with the 2.5".
    Wednesday, March 17, 2010 10:37 AM
  • Hi everyone,

    One more guy with the same problem! I'm running an update Vista 32bit toward a French Win 7 Pro 32bit on a Blackfeet Core2Duo 6750, 2,67Ghz. The regional settings are:    (sorry for the translations mismatch, I'm running a French win ;-))

    Region format : French (Switzerland)
    Location : Switzerland
    Language for non-unicode programs : French (Switzerland)

    My decimal symbol is set on "." (dot)

    I've run the chkdsk and there's no problem found with my disk.

    I've tried every trick listed here above I think, but nothing helped. I still have my problem. The symptom is: I've made the backub perfectly with Win backup. But when I want to create a recovery disk, as soon as I clic on [Create disk] (after selecting the DVD read/writer with a blank disk in it), it says as you well know:  "The recovery disk couldn't be created:  The parameter is incorrect: (0x80070057)"

    No need to say how much I'm dissapointed for I finally choose the PRO edition just in order to have the backup tool included... Everything's fine BUT the recovery disk creation. So if my computer crashes...

    Saturday, March 27, 2010 9:16 AM
  • Hello

    During the creation of a compensation system disk, I also had the error: invalid parameter 0 x 80070057 I made a small tutorial on this subject:

    http://www.pcloisirs.eu/entraide-informatique/topic718.html


    Cordialement.
    Thursday, April 01, 2010 4:00 PM
  • Hi,

    Your solution seems to work.

    However, I don'tunderstand why we should have to change our regional settings to solve Microsoft's problems.

    Regards

    Dirk (Belgium)

     

    Friday, April 02, 2010 5:44 AM
  • Hi,

    My windows regional setting is Indonesia

    I have done everything as listed in here, but the problem isn't solved.

    When will the patch will be released? Because I need to manage my backup files.

     

    ID

    Sunday, April 04, 2010 2:30 PM
  • Hello thierryiv,

    Aaaahhh, :amen: thank you so much for your message! I am not certain to have exactly followed the  instructions of your post (http://www.pcloisirs.eu/entraide-informatique/topic718.html ) but thanks to it, I have in any case been able to solve my problem of incorrect parameter 0x80070057. In fact I plainly repatriated all my documents on the disk c:\ then redid a saving but this time by letting Windows choose the parameters (I did not find how to make sure it would made the complete saving of c: \). Further to this saving, I was able to create my repair disk.

    For the state of the art, I put back my documents on a separate disk of c:\ and redid the saving at first by letting Windows choose, then created a new repair disk and then reset the saving with the locations I wanted. Everything works.

    So it seems that the key of the problem is to make at first a backup by letting Windows choose itself the parameters, then create the repair disk and then redo ones own settings.  :malin1:


    Bye and thanks again !
    Friday, April 09, 2010 4:21 AM
  • I am running Windows 7 Professional (32-bit) on my desktop system.  I have a scheduled backup that runs every morning at 4:00 am.  It has been running without problem for at least a month. A few days ago, I got a similar "The parameter is incorrect: (0x80070057)" error.

    I did a a bit of searching, but had to leave for an appointment; so, I made no attempts to correct the problem.  The next day I checked and there was no error during the 4:00 run.

    The only difference between the two days was that in the error scenario, my laptop (XP-Pro SP3 + all appropriate HF) was not connected to the LAN.  I normally have 3 administrative shares from the laptop mapped as drives on the desktop.  These mapped drives are not supposed to be part of the backup (they are not checked in the "do-it-my-way" setup).

    I have not attempted to reproduce the error, but I've had my laptop connected everyday since the initial error.

     

    on edit: Opps, forgot to mention that the backup is made to an external eSATA drive which was connected to the desktop system in both the working and failing scenarios.

    Hope this helps,

    Regards,

    Rick

    Monday, May 17, 2010 4:52 PM
  • Win 7 x64 Ultimate, I got a "The parameter is incorrect: (0x80070057)" error this morning, chkdsk + restart with bluescreen was the "solution" for me.
    Sunday, May 30, 2010 2:17 PM
  • Hi

    Backup used to work fine, but has recently stopped working with same error code x80070057.

    I have checked the discs, applied the registry patch, checked the . issue in date/time.

    My PC is set to UK English.

    Would be really good to get backup working again.

    Received many windows 7 updates today.

    Tried backup again after applying updates and restarting - still doesnt work.

     

    Wednesday, June 09, 2010 7:59 PM
  • for me: this was caused by a change to another local (Dutch to English).

     

    Date of this writing is: JULY 3 2010 and the first post of this thread is AUG 30 - 2009.  Some questions do arise:

     

    - Does MS consider backup software as a crucial part of Windows ?

    - Does MS understand that people sometimes depends on backups made by Windows Backup?

    - Does MS understand that a patch is overdue like at least 11 months?



     


    Saturday, July 03, 2010 9:23 AM
  • Download the windows 7 usb dvd tool...expand the iso image with the tool... onto your device of choice!!

    Now boot the device and you can Install win 7 and also any version of windows server 2008 r2 ( i have already tested)

    Friday, July 16, 2010 4:43 PM
  • The last post by MSFT was January 25, 2010, exactly 6 months ago.  I just got a system with Windows 7 Professional. All Windows updates have been installed. Region is United States.  Initial attempt at making a backup failed with Parameter is Incorrect (0X80070057) with and now I can't create a system repair disk. When does Windows 8 ship?
    Saturday, July 24, 2010 10:18 PM
  • on my other computer i had a 1 tb hd with 4 partiions, when i got the new computer i decided i didnt need all those partitions, so i shrunk the volume and merged them all together into one dynamic drive.

    when i tried to a back up on the new computer or even create a system repair disk, i had the same issue and found that if i disabled the dynamic hard drive every thing worked fine, im not sure why...

    windows 7 x 64  w/ core i7 and 12gb ram 2-2tb hd 1-1tb hd 1-100gb ssd (system disk)

     

    i dont know if this will help any one, but i figured since i just got mine working i would post what i had to do

    • Proposed as answer by michaelcycle Sunday, September 19, 2010 5:12 AM
    Sunday, September 19, 2010 5:11 AM
  • I have the exact same problem.

    Did you ever work it out?


    -Cheers!
    Thursday, September 23, 2010 3:52 PM
  • ei, thanks! I found this helpful 1 vote for you!

     

    Ceasar

    Free Tech

    Thursday, September 23, 2010 5:29 PM
  • ei, thanks! I found this helpful 1 vote for you!

     

    Ceasar

    Free Tech


    You got same problem too? did you resolve it?
    Saturday, September 25, 2010 10:02 PM
  • nop just reading through it. :)
    CESabarre Free Tech Support
    Bad News: There really is no such thing as Free Tech Support.
    Good News: Oftentimes a simple thank you is the best form of payment!
    Tuesday, September 28, 2010 7:43 AM
  • Got the exact same problem.

    I am in the process of creating a win7 image for worldwide deployment for a customer. A working backup solution is a must have. I simply cant instruct the users to change the decimal symbol, they would never understand.

    Looks like we are going to have to buy a third party solution.

    I cant believe this thread is open since august and ms hasent released a patch.

    Thx so much for that

    Friday, November 12, 2010 12:34 PM
  • Yes this work for me, but like some people have mentioned earlier. Why isn't this fix after 1 year has passed? Isn't backups important?

    You and others have said it your self. "We need your help ... send mail to ... if you are willing to help us.
    We are, but are you guys willing to resolv this?

    Peace

    Wednesday, November 24, 2010 10:14 PM
  • I had the same problem and I got it fixed by changing the decimal dot setting. I understood that this was going to be a temporary solution until Microsoft fixes it. I would prefer to keep my default regional settings. How hard can it be to correct this problem? Why it isn't fixed after all this time? Answer, please!

    Tuesday, February 01, 2011 3:57 AM
  • Got the same error message here. Started the backup and then got the error message.

    But the weird thing is that Action Center in Control Panel reports that a back-up is being made on the disk I assigned it too. And I see that the same disk is active as well, stating that data is being transfered to it.

    I'm able to use the methods mentioned above to solve the error. But I'd still like to get it fixed the proper way.

    Monday, February 07, 2011 7:21 PM
  • Hi all,

    This solution works:

     

     

    1. Go to Control Panel->”Clock, Language, and Region”->”Region and Language”->”Additional settings”. 
    2. Change the decimal symbol from “,” to “.”
    3. Open an elevated cmd(search->cmd->right click->run as administrator). 
    4. C:\windows\system32> taskkill /f /im explorer.exe 
    5. C:\windows\system32> explorer.exe (// restarting explorer) - I did a CTRL+ALT+DELETE and ran c:\windows\explorer.exe, but fell free to do whatever you like.

    Thanks in advance for your help.
    Regards,
    Lokesh
    [MSFT]
    I tried it on multiple machines. How ever this error should be fixed by Microsoft ASAP. Also, it is very easy to fix aswell in an update next Wednesday.
    Personally I buy my software for my hard earned cash, but I am starting to understand why some people are downloading it. The backup future builded into Windows is a CRUCIAL future for me. And it should work in my Windows 7 Ultimate without me spending time looking for solutions on google.
    Well my two cents anyway.

     

    • Proposed as answer by Marek1712 Sunday, February 27, 2011 5:58 PM
    Friday, February 18, 2011 1:18 PM
  • Hi all,

    This solution works:

     

     

    1. Go to Control Panel->”Clock, Language, and Region”->”Region and Language”->”Additional settings”. 
    2. Change the decimal symbol from “,” to “.”
    3. Open an elevated cmd(search->cmd->right click->run as administrator). 
    4. C:\windows\system32> taskkill /f /im explorer.exe 
    5. C:\windows\system32> explorer.exe (// restarting explorer) - I did a CTRL+ALT+DELETE and ran c:\windows\explorer.exe, but fell free to do whatever you like.

    Thanks in advance for your help.
    Regards,
    Lokesh
    [MSFT]
    I tried it on multiple machines. How ever this error should be fixed by Microsoft ASAP. Also, it is very easy to fix aswell in an update next Wednesday.
    Personally I buy my software for my hard earned cash, but I am starting to understand why some people are downloading it. The backup future builded into Windows is a CRUCIAL future for me. And it should work in my Windows 7 Ultimate without me spending time looking for solutions on google.
    Well my two cents anyway.

     

    That one helped me (as I've just got this error today). I don't get why there's a difference between full stop and comma but whatever - I've seen many different things...
    Sunday, February 27, 2011 6:00 PM
  • I run Windows 7 Ultimate x64 Dutch, and I had the error:

    "An internal error has occurred:
    The parameter is incorrect: (0x80070057)"

    After changing the decimal symbol to a dot the Back-up function works fine.

    Thanks Lokesh, your solution worked for me!

    Regards,
    F-F
    The Netherlands

     

    Monday, March 14, 2011 10:49 AM
  • Thanks, Registry Fix worked fine on x64 Windows 7 SP1 Ent.
    Wednesday, March 16, 2011 7:18 PM
  • And for me doesn't work...

    The fresh installation made 2 days ago (Windows 7 Professional, Polish language):

    1. chkdsk - made

    2. comma replaced to dot - made

    3. the new key in registry (decribed above) - made too

    4. Service Pack 1 - installed (with a BIG troubles because I've 2nd OS on my PC - SuSE Linux & boot manager: GRUB, but I found solution for this MS-Bug. Of course NOT in MS support)

     

    And... still nothing... I can't run the Backup because of: "0x80070057, Incorrect parameter"

     

    Is this realy a very big problem for MS to develop  an operating system running properly???

    Thursday, March 17, 2011 6:00 PM
  • I was able to perform file back-ups for approximately 2 years and now this error has appeared: after invoking the Back-upcenter nothing can be done due to error 0X80070057. My system is a Vista Home Premium SP2 (32 bit), all MS fixes installed. (I think, concerning this problem, it doesn't matter whether it's Windows Vista or Windows 7.)

    I've tried all kind of fixes, mentioned in whatever forum. The last thing I've done is install the initial state (as if a back-up was never performed) of my Back-upcenter by:

    1. Deleting everything related to back-ups on the target (i.e. back-up) F-disk, including MediaId.bin
    2. Removing directory WindowsBackup from C:\windows\system32\tasks\microsoft\windows
    3. Deleting all underlying keys from HKLM\software\microsoft\windows\currentversion\windowsbackup (but not windowsbackup itself) from the register

    These actions have also been mentioned in the fora. Perhaps there is more needed to be done, but I checked on a Vista system of a friend, where a back-up was never made, and it looks rather OK.

    I've tried to send a mail to lokkum[at]microsoft[dot]com with a more extensive description, but that mail was refused with message  "lokkum@microsoft.com: Recipient address rejected: Access Denied". I keep hoping there is a simple solution...

    Monday, March 28, 2011 3:05 PM
  • I have 2 computers at home. Locale EN-US, Win7 PRO, backing up on a NAS here at home via a mapped drive.

    Today I faced this ugly error on MY PC and get here reading all through. Throwing crazy solutions without foundation.

    Imediately asked to my wife to see if her PC was working and it is, actually, it was currently running the backup at the time.

    No Updates installed this week and already SP1 installed.

     

    So just to be sure, I went to the NAS and see if there was the bkp.

    My schedule is every monday 7.00 pm and last backup is from last monday (current time at this writing: 5.45 pm) so that means to me that the backup IS indeed running but the problem in in the control panel.


    Anyway, a BACKUP is the first thing one wants to rely on. I can't afford to suppose that "anyway, it's running".

    It's unnaffordable that MSFT didn't solve this in 1 1/2 year!!!

     

    Going to move off to anything else. 

    Again, MSFT fails and bites the dust. That took me off the happyness of win7

    Sunday, April 10, 2011 8:54 PM
  • The "Create a system Image" backup software DOES NOT WORK!!!  Microsoft DOES NOT CARE!!!!!

    Obviously Vista and Windows 7 can't support backup.  Microsoft has failed and ripped me off twice. I have spent weeks of time dealing with the consequences.  Search the Internet and you'll find soo many people on all types of computers with fresh clean installations that have this problem.

    Vista's backup failed and NEVER worked.  MS support tried to work with me and after 3 months of every level of tech support could not fix the problem, they told me the answer was to wait for Windows 7 for the fix.  My Vista system had many major meltdowns. Having no backup or repair disk I was not able to recover and every few months I needed to spend a day rebuilding the operating system.

    I resisted paying $100 for an upgrade to fix a problem that should have worked in Vista. Desperation must be Microsoft's marketing plan. I broke down and bought Windows 7 Pro, installed all the updates and ran the backup "Create a system Image".  It backed up to a Blu-Ray disk. At the end of the backup, Windows asked if I wanted to create a "System Repair Disk"?   I selected to create one on a DVD in the Blu-Ray burner.  It FAILED giving me the error number I will remember as long as I live, 0x80070057.  I tried this again on the DVD burner and the same error occurred. 

    I've tried a few of the fixes posted on-line and none worked so Microsoft has Flunked again.  I don't expect Microsoft to fix this problem. They are quitters and as the Donald would say "Your fired". It's time to move on.

    Has anyone used a backup software that has restored Windows 7 or Vista from a major corruption?  I tried Acronis and it backed up but would not restore Vista. There were other issues that makes me not trust Acronis.  I've considered Retrospect, has anyone used it?

    Thanks Nick Brown nickb201 AT gmail DOT com

    Monday, May 09, 2011 5:39 PM
  • Hi!

    PINNED!

    The fix is simple. Just change the "," into "." - then ctrl+alt+del and kill explorer, then log out - and in again. For more details see post JA-Wrathier
     a couple of posts further up.

    For all you else: reinstall will be the easiest. Then: dont install all your software at once. It probably is some software that interferes. So: a couple of updates/installs then restart if you want to find an answer.

     

    Thanks JA-W!

    Sunday, July 17, 2011 10:38 AM
  • It´s UNBELIEVABLE that someone could consider manually changing the Locale settings as a FIX. I did that, which apparently SOLVED the backup problem, but gave me a bunch of serious issues with other programs that rely on number locale settings to display user data.

    Additionally, "reinstall" seems to be the BEST way that most of Microsoft´s users are used to. It´s  just unfortunate...

    Monday, July 25, 2011 12:43 AM
  • It´s UNBELIEVABLE that someone could consider manually changing the Locale settings as a FIX. I did that, which apparently SOLVED the backup problem, but gave me a bunch of serious issues with other programs that rely on number locale settings to display user data.

    Additionally, "reinstall" seems to be the BEST way that most of Microsoft´s users are used to. It´s  just unfortunate...

    First post: August 30th, 2009 (NINE!)

    My/this post: August 3rd 2011 (ELEVEN!)

    Two years...

    Agreed with the quotee above: the decimal point fix resolves the incident but does not resolve the problem, or is ITIL-lingo too hard for MS? In other words: changing [,] to [.] in the system makes me able to run backups again, but - as stated above - is not a permanent resolution. It means I can no longer use Excel properly, where decimal points are - one could easily say - rather important.

    So MS: I have in hand a fix for the incident. Now, where's the resolution to the problem

    Wednesday, August 03, 2011 8:51 AM
  • official support: http://support.microsoft.com/kb/982736
    • Proposed as answer by vodomar Thursday, August 04, 2011 12:40 AM
    Thursday, August 04, 2011 12:36 AM
  • Thanks.

     

    But that didn't help.

    I tried the registry fix, but BU still told me Internal error 0x80070057.

    So I'm stuck using the fix (replacing [,] with [.] systemwide).

    Using w7 Ultimate SP1 64b Se/Sv on a C2D E8400, if that's of any relevance.

     

    This error is really irritating. 

    Saturday, August 13, 2011 3:24 PM
  • Hi,

    the change from "," to "." did the trick! Thanks again!

    Settings --> Hungarian

     

    Regards, Bernie

    Sunday, August 21, 2011 7:35 PM
  • Hi all,

    This solution <strike>works:</strike>

     

     

    1. Go to Control Panel->”Clock, Language, and Region”->”Region and Language”->”Additional settings”. 
    2. Change the decimal symbol from “,” to “.”
    3. Open an elevated cmd(search->cmd->right click->run as administrator). 
    4. C:\windows\system32> taskkill /f /im explorer.exe 
    5. C:\windows\system32> explorer.exe (// restarting explorer) - I did a CTRL+ALT+DELETE and ran c:\windows\explorer.exe, but fell free to do whatever you like.

    Thanks in advance for your help.
    Regards,
    Lokesh
    [MSFT]
    The above
    is not the problem.
     
    I am in the en_US My setting's page has period as the decimal point.  I CHECKED....
     
    This SW is still broken.
     
    BRink back MSBackup from Win2000....it was more reliable in scheduling backups though never used it for a restore...
     
    When this was working -- hae used it twice to restore over the net (I'm backing over the net to the same location), so  (tiny pinch) pretty sure it works...(i.e. damn sure it works)...
     
    But was referred from http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/windows-backup-parameter-incorrext-x80070057/8bdb0792-17f6-4297-a974-91e8d1efc412, where they've all but given up...  referring me to a post
     
    whee the solution was exctly what the guy above me suggested....(i.e. check decimal point....ARGGGGGGG)...
     
    Thursday, November 10, 2011 3:06 AM
  • To be clear ... IT DOES NOT WORK... The above was HTML .. and had strikeout over 'works'....but of course, like so much of MS SW, , it didn't work..,.
    Thursday, November 10, 2011 3:09 AM
  • It works for me!! MS Team, If It´s the solution, please apply it in any patch.....
    Monday, November 21, 2011 11:13 PM
  • This is so stupid. They finally figured out, that this is a non-US problem. And yeah, I will not set my comma to dot, because we in germany use it differently and my Excel will look stupid with it. I don't understand, that there is no patch. Is the non-US market not worth it? Or is it just stupidity or ignorance? The problem is known for YEARS! Folks, after having hours of problems with this crap, don't use it! Your data is not safe! Have a look: http://my-tech-talk.blogspot.com/2010/01/do-not-use-windows-backup.html
    • Edited by Thorzten Friday, December 02, 2011 1:09 PM edit
    Friday, December 02, 2011 1:08 PM
  • A solution without restarting your machine:

    • goto Computer Management
    • goto Task Sheduler
    • goto Microsoft > Windows > WindowsBackup
    • doubleclick on AutomaticBackup
    • delete the trigger
    • OK

    Now goto Backup and Restore in ControlPanel and you will see... Error is gone, reconfigure and it'll work again!


    Kleajmp
    • Proposed as answer by Kleajmp Tuesday, December 27, 2011 12:06 PM
    Tuesday, December 27, 2011 12:05 PM
  • Kleajmp solutions works for me. Thx
    Monday, January 02, 2012 7:15 AM
  • Hi,

    Incredible but the change of the decimal symbol worked for me.

    Thank you very much!

    Gabor

    Hungary

    Thursday, January 05, 2012 11:37 AM
  • Hi,

    Incredible but the change of the decimal symbol worked for me.

    Thank you very much!

    Gabor

    Hungary

    Are you also going to change your currency symbol from € to $ then ? This "solution" is to  stupid to even suggest.

    I have done all the other suggestions but nothing works. Well the 0x80070057 has gone. However nothing else related to BU works. I can not even change the back-up drive or schedule.

    Then I get a window saying: "Windows Backup is starting, one moment please" and that hangs forever. Even the Windows System Manager has a problem....

    So I still need to make a backup. MS what is the fix for this please !

     

    Sunday, January 22, 2012 2:23 PM
  • A solution without restarting your machine:

    • goto Computer Management
    • goto Task Sheduler
    • goto Microsoft > Windows > WindowsBackup
    • doubleclick on AutomaticBackup
    • delete the trigger
    • OK

    Now goto Backup and Restore in ControlPanel and you will see... Error is gone, reconfigure and it'll work again!


    Kleajmp

    Ahhh ... I deleted the entry AutomaticBackup . I have put it back again but do not know the Parameter value that was on the program (assuming that is the same sdclt.exe ).

    Could someone please tell me the PARm vallue ?? Thanks,

     

    Sunday, January 22, 2012 3:04 PM
  • That worked for me too.  Running French-Canadian version of Windows 7 with comma as number delimiter. 
    Monday, January 30, 2012 4:15 PM
  • Hi everyone,

    By trial and error I arrived at the same solution, that Karesansui did. However I deleted the entire task from the scheduler, not only the trigger. I must say that I was using a configured Windows Backup to a Network Attached Storage without any problem until after I converted the NAS drive it to a GPT disk, repartitioned it a formatted it (thus erasing all files that were pointed to by the scheduled task), without regarding o attempting to previosuly change the Windows Backup that I had configurred for that disk. Perhaps Microsoft could work a little on the application so from it one can delete or reset the configured backup to none.

    By the way, It makes no sense to me having to change regional and language settings (decimal character from "," to ".", since my version of Windows 7 and Office 2010 are in spanish, so I would have to work on all the Excel and Project files to adjust for that.

    As I write this, my Backup is running (display of progress and all) without any apparent problems.

    Carlos

    Friday, February 10, 2012 5:12 PM
  • Method 1:

    Microsoft released the Fixit Microsoft Fix it 50719 for the above issue. The same will be available from the below link

    http://go.microsoft.com/?linkid=9777176

    Method 2:

    Change the decimal symbol setting

    This problem can occur if the decimal symbol is not set to '.' (dot). This is common in languages and locales other than English (United States), such as German (Germany).  To change the decimal symbol setting, follow these steps:

    1. Open Control Panel, click Clock, Language, and Region, and then click Region and Language.
    2. Click the Formats tab, and then click Additional settings.
    3. In the Decimal symbol field, type . (dot), and then click OK two times.
    4. Restart the computer.

    Method 3:

    Open the registry editor by typing the regedit.exe command and locate the below path.

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\System.

    Create a DWORD value CopyFileBufferedSynchronousIo and modify the value to 1.Close the registry editor and reboot the computer.


    Regards Jinish.K.G|HCL Infosystems LTD

    Thursday, July 05, 2012 5:50 PM
  • If someoe stumbles upon this thread when restoring, then try to use the Windows Backup CD ("Datenträgerwiederherstellungs CD" in German) instead of booting the Windows installation CD.
    Thursday, August 23, 2012 10:19 AM
  • This issue is now happening on Windows 8 when using the File History and Choosing Windows 7 File recovery to restore backups created with Windows7.  Then I chose: "Select Another Backup to restore files from" and selected the USB drive onto which I had backed up my files from my Windows7 machine.  I received the error described in this thread.  I attempted to use the  Microsoft Fix it 50719 (See: http://support.microsoft.com/kb/982736) but was informed that it does not work on the Widows 8 Operating System.  I then looked for the registry Key, manually.  Of course, it does not exist in Windows 8.

    It only seems to happen when I select my most recent Backup Period.  If I choose an earlier back Period, it will allow me to restore from that.  Of course I need the most recent information.

    Please tell me that there is a fix for this.

    Thank you.

    Bob Oxford

    Windows8; Backup; Restore; Windows7


    Bob Oxford Software Wizards, Inc.

    Thursday, November 01, 2012 9:55 AM
  • I have the same problem and find this post:

    This error is caused by a bug in File Backup where if you don't back up at least one file during the full backup, every backup after that fails. The workaround is to go through the Backup wizard again and choose a new full file backup at the very end.

    I will make a new complete backup tonight.

    Wednesday, November 21, 2012 6:38 PM
  • i also have the same exact problem.  i have had this problem since i purchased this computer.

    Windows 7 Home premium English

    colorado USA

    cant run backup as well as several other issues. please help.

    Saturday, November 24, 2012 7:58 PM
  • That sounds interesting.  Thank you.  I really appreciate your suggestion.  What you are proposing is what I call a "Workaround", not a real fix. If I still had that drive mounted, that would be possible, although not a real permanent solution.  Since I no longer have that drive mounted, backing up again is not a solution.

    I really would appreciate Microsoft chiming in here to indicate that a real fix is forthcoming or propose something I can do on my Windows 8 machine that will allow me to access the most recent backup information from my Windows 7 (32 bit) backups.

    Thanks.


    Bob Oxford Software Wizards, Inc.

    Thursday, December 13, 2012 2:30 PM
  • I've changed the decimal symbol to "." and Windows Backup is going fine now.

    Thursday, May 23, 2013 6:35 PM