none
Change "Unidentified Network" networ location from public to private

    Question

  • One of our Windows 7 is located in our SAN VLAN and doesn't need to access The internet so that it doesn't setup default gateway. I have enabled remote desktop, but can't access it from other computer in the same subnet using RDP. I found the firewall disabled remote desktop on Public location (note: remote desktop is enabled in the private network). I must enable the remote desktop in the public location to be able to access it remotely. That is OK. My question are:

    1. Why the LAN display "Unidentified Network"? It is because it doesn't have default gateway?
    2. Do you know a way to change the "Unidentified Network" network location from the Public to Private? It doesn't give you the option to make the change when it is "Unidentified Network".

    thank you.
    Bob Lin, MS-MVP Networking, Internet, Routing, VPN Troubleshooting on

    http://www.ChicagoTech.net

    How to Setup Windows, Network, VPN & Remote Access on

    http://www.howtonetworking.com

    Wednesday, February 03, 2010 4:02 AM

Answers

  •   You can't change the unidentified network to private because that is prevented by a default security setting.

        You can change the security setting so that the network is not made public in the first place.

       Here is what you need to do from a previous discussion on this.

    To do this on your local server , follow these steps:

    1. Start --> run --> MMC --> press enter

    2. In MMC console , from menu file select Add/Remove Snap-in

    3. Select Group Policy Object editor --> Press Add --> select Local computer --> press OK -->press OK

    4. Open Computer configration -->Windows Settings -->Security Settings -->select Network list manager policies
    on the right Side you will see options for :

    double click -->Unidentified networks

      Then you can select the option to consider the Unidentified networks as private and if user can change the
    location.

    I hope that is will help you and is clear .

    --------------------------------------------------------------------------------
    Hikmat Kanaan Amman-Jordan MCSE


    Bill
    • Marked as answer by Novak Wu Monday, February 22, 2010 1:19 AM
    Thursday, February 04, 2010 11:17 PM

All replies

  • Hi,

     

    The "Unidentified Network" issue can be caused if the computer cannot obtain invalid IP address. You can configure the gateway to default and check the result. Does the issue persist? If so, please let me know. Otherwise, we can consider that the issue is caused by the current gateway and you should set it to default one. When the "Unidentified Network" message disappears, the Network Location will be changed automatically.

     

    Thanks,

    Novak

    Thursday, February 04, 2010 6:29 AM
  • Forgot to mention that the computer is setup static IP address without DHCP. Adding default gateway doesn't make any different. Any other suggestions?
    Bob Lin, MS-MVP Networking, Internet, Routing, VPN Troubleshooting on

    http://www.ChicagoTech.net

    How to Setup Windows, Network, VPN & Remote Access on

    http://www.howtonetworking.com

    • Proposed as answer by FlatspinZA Saturday, January 18, 2014 6:19 PM
    Thursday, February 04, 2010 6:42 PM
  •   You can't change the unidentified network to private because that is prevented by a default security setting.

        You can change the security setting so that the network is not made public in the first place.

       Here is what you need to do from a previous discussion on this.

    To do this on your local server , follow these steps:

    1. Start --> run --> MMC --> press enter

    2. In MMC console , from menu file select Add/Remove Snap-in

    3. Select Group Policy Object editor --> Press Add --> select Local computer --> press OK -->press OK

    4. Open Computer configration -->Windows Settings -->Security Settings -->select Network list manager policies
    on the right Side you will see options for :

    double click -->Unidentified networks

      Then you can select the option to consider the Unidentified networks as private and if user can change the
    location.

    I hope that is will help you and is clear .

    --------------------------------------------------------------------------------
    Hikmat Kanaan Amman-Jordan MCSE


    Bill
    • Marked as answer by Novak Wu Monday, February 22, 2010 1:19 AM
    Thursday, February 04, 2010 11:17 PM

  • I had networking problems as well. 3 computers running Windows 7. 2 had Adobe CS3 installed which brings with is a piece of software called Bonjour. These two computers had no end of networking problems. 1 was a desktop connected to the router and the other was a laptop connecting via WiFi. Third computer didn't have CS3 and didn't have any trouble at all.

    In trying to find a solution (nothing seemed to work), I came across the solution shown below in a different thread and thought I would share it. I installed the upgrade for Bonjour (it's listed as Windows Vista 64 software) and all of my network problems cleared up. My thanks to "PDX Prod Mgr". Brilliant!


    "
    PDX Prod Mgr Users Medals Users Medals Users Medals Users Medals Users Medals
     Proposed Answer
    I had the same problem when I rebuilt my Windows 7 system.  I had CS3 installed on my system, it installs an old version of bonjour.  If you inspect your program files\bonjour directory, see if you have an EXE and DLL file dated 2006.   Jump over to apple's website and search for windows bonjour.   I found the newer download here:  http://support.apple.com/downloads/Bonjour_for_Windows    

    Download and install this (you don't have to uninstall the old Bonjour)  and reboot.  This fixed my install and I no longer have the network error you describe.  If you look at that folder now,  you will have the newer DLLs (and some other gunk.)   
    "
    Sunday, February 14, 2010 5:43 PM
  • Make sure your router firmware is up-to-date.  We upgrade all the drivers in our PC for Windows 7 but forget to upgrade the router firmware.  I upgraded my router firmware and all those unidentified network problems went away.  It is much easier than forcing windows 7 to work with an out-dated router firmware.  I wish this forgotten upgrade of the router is promulgated by Microsoft.   Consequently many of us wasted a lot of time on this one.

    Friday, July 02, 2010 2:45 AM
  • We are having the same (similar) problem.  Windows7 changes our very very small Ethernet LAN network (2 Windows7 pcs and 1 XPsp3 pc and 1 high-speed printer) from a named workgroup to unidentified public when I connect one of the windows7 pc's to a smartphone.  

    This results in the printer sharing on the Etherlan LAN being disabled.  

    I tried the solution above:  Group Policy Object editor does not appear on the list when I select Add/Remove Snap-in.  I have Windows7 Home Premium (64)

    ?? Any other approach ??  

    I need a quick/easy way to set the LAN configuration back, because this happens EVERY time.  

    Or a way to prevent Windows7 from clobbering the configuration/identification of the named workgroup LAN.  

    Thanks.  

    PS  Is this different enough - should I start a new thread?  Thanks again.  


    abideth all three



    Thursday, May 31, 2012 12:41 PM
  • This ^ is what worked for me - thanks so much! No more unidentified public network. (router firmware update).
    Wednesday, August 27, 2014 3:51 AM