none
Desktop does not fit monitor after Windows 7 upgrade

    Question

  • I upgraded my computer yesterday to windows 7, my resolution was set at 1920x1080 and after the upgrade there are black borders all around the desktop where it should stretch to fit the screen.  I have a HP w2338h monitor, with a ATI Radeon HD 4350 the OS says my resolution is set to 1920x1080 but the monitor is saying it's set to 1080p and the recommended setting is 1920x1080.  This used to work in Vista, i have called HP and they don't understand what I'm talking about and I have updated all the drivers for the video card with no luck.  The monitor does not have the option to adjust the setting like the old CRT monitors did if the desktop was not fitting to the screen size. 
    Thursday, December 17, 2009 6:33 PM

Answers

  • marc03 schreef op 17-12-2009 19:33:
    > I upgraded my computer yesterday to windows 7, my resolution was set at
    > 1920x1080 and after the upgrade there are black borders all around the
    > desktop where it should stretch to fit the screen. I have a HP w2338h
    > monitor, with a ATI Radeon HD 4350 the OS says my resolution is set to
    > 1920x1080 but the monitor is saying it's set to 1080p and the
    > recommended setting is 1920x1080. This used to work in Vista, i have
    > called HP and they don't understand what I'm talking about and I have
    ivers for the video card with no luck. The monitor
    > does not have the option to adjust the setting like the old CRT monitors
    > did if the desktop was not fitting to the screen size.

    Look at the solution by "Schmutzli" in
    http://social.technet.microsoft.com/Forums/en/w7itproui/thread/85d77ff8-738a-4e1d-aff2-f837894d6194

    --
    Karel Vos [MVP - Windows Desktop Experience]
    • Marked as answer by Linda Yan Wednesday, December 23, 2009 5:36 AM
    Thursday, December 17, 2009 6:52 PM
  • Hi,

    First make sure you have proper graphic card driver installed.

    Then I noticed from the picture of your monitor, there is a AUTO button, this should enable the full screen automatically.

    Apart from that, there used to be a display card control panel offerring the options to adjust the settings. According to your display card model, you should have CCC (Catalyst Control Center) installed. If so, open "Desktops and Displays",  click "Configure" of your monitor, choose "Full Screen" under the properties.
    • Marked as answer by Linda Yan Wednesday, December 23, 2009 5:36 AM
    Friday, December 18, 2009 8:32 AM

All replies

  • marc03 schreef op 17-12-2009 19:33:
    > I upgraded my computer yesterday to windows 7, my resolution was set at
    > 1920x1080 and after the upgrade there are black borders all around the
    > desktop where it should stretch to fit the screen. I have a HP w2338h
    > monitor, with a ATI Radeon HD 4350 the OS says my resolution is set to
    > 1920x1080 but the monitor is saying it's set to 1080p and the
    > recommended setting is 1920x1080. This used to work in Vista, i have
    > called HP and they don't understand what I'm talking about and I have
    ivers for the video card with no luck. The monitor
    > does not have the option to adjust the setting like the old CRT monitors
    > did if the desktop was not fitting to the screen size.

    Look at the solution by "Schmutzli" in
    http://social.technet.microsoft.com/Forums/en/w7itproui/thread/85d77ff8-738a-4e1d-aff2-f837894d6194

    --
    Karel Vos [MVP - Windows Desktop Experience]
    • Marked as answer by Linda Yan Wednesday, December 23, 2009 5:36 AM
    Thursday, December 17, 2009 6:52 PM
  • Hi,

    First make sure you have proper graphic card driver installed.

    Then I noticed from the picture of your monitor, there is a AUTO button, this should enable the full screen automatically.

    Apart from that, there used to be a display card control panel offerring the options to adjust the settings. According to your display card model, you should have CCC (Catalyst Control Center) installed. If so, open "Desktops and Displays",  click "Configure" of your monitor, choose "Full Screen" under the properties.
    • Marked as answer by Linda Yan Wednesday, December 23, 2009 5:36 AM
    Friday, December 18, 2009 8:32 AM
  • Did you get it to work. Im dealing with this very same issue =(

    Wednesday, February 10, 2010 6:31 PM
  • If you have a Radeon graphics cardéchip (and thus use catalyst control center), open CCC and go to desktops/displays, then right click on your monitor and it'll allow you to "configure". Then near the top of that window there is an option for "scaling". If you are experiencing black borders, then simply raise the number (to overscale it). A couple bumps ought to do it.


    Thanks to the people who clued me in. I had to suffer from this for a year or two. Good to finally have it fixed. Spread the word.

    Tuesday, August 24, 2010 5:09 AM
  • awsome, you are the man! man almost made the year mark suffering this border
    Wednesday, August 03, 2011 3:02 PM