none
Windows 7 Enterprise x64 Print Spooler issue

    Question

  • Hello,

    I am running Win 7 Enterprise x64 and have several users that will have intermitent print spooler crashes.  The only system event I get says "A timeout (3000 milliseconds) was reached while waiting for a transaction response from the spooler service.".  When I try to restart the Print Spooler Service it will freeze up, give me an error message, and then go to a stopped state.  I can then simply start it again and everything works for a time, but then it rears it's ugly head again.  I have tried to delete all old printers in the spool folder and registry as well.

    Any tips are appreciated.

    Thank you

    Friday, January 25, 2013 1:40 PM

All replies

  • Increase the service timeout to a higher  value in the below registry hive:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control

    Dword value: ServicesPipeTimeout=12000,

    If its not present, please create one.

    • Proposed as answer by Adil Rathore Friday, January 25, 2013 2:21 PM
    Friday, January 25, 2013 2:21 PM
  • I'll give this a shot and see if the issue comes back.

    Thanks!

    Friday, January 25, 2013 2:41 PM
  • Unfortunately this was not the fix I was looking for.  My user tried to open a word document and the splash screen for Office got stuck on "Connecting to Printer"  I had to restart the spooler.  When I tried to restart the spooler it again got stuck and put a 7011 event ID error in the System logs.

    Friday, January 25, 2013 3:44 PM
  • Hi,

    Please install the latest version of the printer driver to see if it helps.

    Regarding the event id 7011, please refer to the following article:

    Event ID 7011 — Basic Service Operations

    http://social.technet.microsoft.com/wiki/contents/articles/event-id-7011-basic-service-operations.aspx


    Tracy Cai

    TechNet Community Support

    Tuesday, January 29, 2013 2:46 AM
    Moderator
  • That actually did not fix it.  The latest printer drivers are installed on the machine, and I tried the recommendation in the link.
    Thursday, February 14, 2013 2:26 PM