none
Unable to connect to file share on network copier/scanner

    Question

  • I am using a Vista Business client on a Windows domain network. We have a multifunction copier/scanner connected to the network. This device is accessed by the XP clients with a shortcut on their desktop, which simply points to \\COPIERNAME\File_Share folder. Technically, this device isn't a member of the domain, and it doesn't really show up as part of a workgroup either. It's just a device sitting out there on the same subnet.

    On the Vista client, I can ping COPIERNAME and I get a reply, however I cannot connect to the File_Share folder, which is where the scanned documents are.

    I disabled the Vista firewall but this didn't help. I assume there's some security "feature" in Vista that is preventing access to this device since it's not part of the domain, but I can't find a workaround.

    Any help is greatly appreciated!
    Monday, December 15, 2008 2:08 PM

Answers

  • This issue has now been solved.  Here's the solution:

    The problem is one of SMB signing. 
    By default, Windows 2003 Server has SMB signing enabled for all client connections, and this was preventing the Windows Vista client from communicating with the file share.  While it is possible to change the default setting for the entire domain, for security purposes I much prefer to make the change on the copier/scanner device.  The instructions below apply to the Toshiba eStudio Copier/Scanner, but similar configuration can be done on other devices.
     
    Connect to copier/scanner using web browser.  Click Administration tab, and logon use the copier's username/password.
    Click Network
    Click SMB Session
    Click SMB Session box
    In section called "SMB Signing of SMB Server", the default of "If client agrees, digital signature is done for communication" needs to be changed to "Digital signature isn't done for communication for the server"
    Click Set button at top, then Save button, and the copier will reset.
     
    You should now be able to connect to the file share using Vista.  No drivers are needed.
    • Marked as answer by guitarfish Monday, December 29, 2008 3:09 PM
    Monday, December 29, 2008 3:09 PM

All replies

  • Hi,

     

    We should be able to access that folder.

     

    Please let us know the following facts. 

     

    1. Do you mean that the device is located in the \\COPIERNAME\File_Share folder?

    2. Is the device a network device that has its own IP address, or it is installed on the server computer and shared in network?

    3. What is the system of the server? What is the error message when the issue occurs?

    4. Is file sharing between the computers works properly?

    5. please let us know if you have create a shortcut that is point to the \\COPIERNAME\File_Share folder. If so, please try to access \\COPIERNAME\File_Share from Start Search box and let us know if it is accessible.

     

    I suggest that you disable the anti-virus and firewall on the computer COPIERNAME and check if the issue occurs.


    Arthur Xie - MSFT
    Tuesday, December 16, 2008 9:01 AM
  • Arthur,

    Thank you for the reply.

    1. Do you mean that the device is located in the \\COPIERNAME\File_Share folder?

    No.  COPIERNAME is the NetBIOS and DNS name of the copier.

    2. Is the device a network device that has its own IP address, or it is installed on the server computer and shared in network?

    The device is a Toshiba copier/scanner with an ethernet card, connected to the network switch, and its own IP address.  No servers involved.  The device has a built in storage drive where scanned documents are saved.  This is accessible to all on the network without any authentication, except Vista Business clients.

    3. What is the system of the server? What is the error message when the issue occurs?

    Our company network is running a Windows Server 2003 domain, however, the device doesn't have an OS that I know of.  No servers are involved in what we're trying to do.  We're attempting to go from a Vista Business client direct to the device.

    4. Is file sharing between the computers works properly?

    Yes, working fine on all levels.  All the XP machines can access the device simply by entering \\COPIERNAME\File_Share in the Address bar of Windows Explorer. 
    It's only the Vista Business system that can't connect to it.

    5. please let us know if you have create a shortcut that is point to the \\COPIERNAME\File_Share folder. If so, please try to access \\COPIERNAME\File_Share from Start Search box and let us know if it is accessible.

    Unable to create a shortcut. 

    When trying to connect, a dialog box says: 

    "Windows cannot access file://COPIERNAME/file_share
    Check the spelling of the name.  Otherwise there might be a problem with your network."
    There's a details button which reveals the code "0x80004005 unspecified error"  (gotta love those developers...)

    There's nothing in the Windows logs.

    Interestingly, when I open the "Network" icon in Vista, and go to Desktop - Network, I see it listed along with the other XP clients on the network.  When I single click on it, the bottom of the window says "Categories: Multifunction Devices".  So Vista is seeing it on some level.  (And remember, I can ping it in Vista).

    But that's as close as I can get to it.

     
    • Edited by guitarfish Tuesday, December 16, 2008 1:35 PM correciton
    Tuesday, December 16, 2008 1:29 PM
  • One additional detail: when I get the dialog box saying saving it cannot access it, I clicked Diagnose.  It came back with this:

    "\\COPIERNAME is not setup to establish a connection on port "File and Print Sharing (SMB)" with this computer"
    Tuesday, December 16, 2008 1:33 PM
  • Hi,

    This issue occurs if the scanner driver is not installed properly on the Windows Vista computer. What is the model of the scanner? You may access the following website and check if the device is compatible with Windows Vista.

    http://www.microsoft.com/Windows/compatibility/Default.aspx Also try to search if there is any available device driver of the scanner for Windows Vista. 


    Arthur Xie - MSFT
    Friday, December 19, 2008 8:57 AM
  • Arthur,

    Thank you very much for the reply.  I don't think you're following me however.  There is no driver - all I'm trying to do is connect to a network share.  I'm not trying to control any functions of the device.  The scanner/copier actually has a USB thumb drive plugged into the back of it where it stores the scans.  All the clients are doing is connecting to the share as any other share.  All the XPs do it without a driver. 

    The device does have a driver for printing purposes, but we don't print to the device.

    For what it's worth, it's a Toshiba eStudio 2500c.  Maybe I will give Toshiba a call.  I am almost certain that my issue has something to do with the fact that this device isn't a member of the domain, or a workgroup for that matter, and I think Vista's more stringent policies are preventing access.
    Friday, December 19, 2008 2:46 PM
  • Hi,

     

    It seems that we do not have problem to access the scanner, but cannot establish connection with the scanner. Have you tried to disable the anti-virus and firewall?

     

    Toshiba website has provided drivers, however, none of them is for Windows Vista. I suggest that you try to download the driver for Windows XP and install it. Then check the result. 

     

    http://www.digipro.co.uk/toshiba-products/photocopiers/colour-copiers/e-studio2500c/drivers.html

     

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

     

    If the issue persists, it is better to contact Toshiba and confirm if we need any compatible driver, also check related settings on the scanner.


    Arthur Xie - MSFT
    Thursday, December 25, 2008 8:40 AM
  • THIS IS NOT A DRIVER ISSUE.  REPEAT.  THIS IS NOT A DRIVER ISSUE.

    The questions you ask (firewall, antivirus) have been answered already in my posts above.

    None of the XP boxes have drivers installed.  We're trying to connect to a file share on the network.   I am currently working with Microsoft Support on this issue, and I will report the correct answer back when the issue is resolved.

    Monday, December 29, 2008 2:38 AM
  • This issue has now been solved.  Here's the solution:

    The problem is one of SMB signing. 
    By default, Windows 2003 Server has SMB signing enabled for all client connections, and this was preventing the Windows Vista client from communicating with the file share.  While it is possible to change the default setting for the entire domain, for security purposes I much prefer to make the change on the copier/scanner device.  The instructions below apply to the Toshiba eStudio Copier/Scanner, but similar configuration can be done on other devices.
     
    Connect to copier/scanner using web browser.  Click Administration tab, and logon use the copier's username/password.
    Click Network
    Click SMB Session
    Click SMB Session box
    In section called "SMB Signing of SMB Server", the default of "If client agrees, digital signature is done for communication" needs to be changed to "Digital signature isn't done for communication for the server"
    Click Set button at top, then Save button, and the copier will reset.
     
    You should now be able to connect to the file share using Vista.  No drivers are needed.
    • Marked as answer by guitarfish Monday, December 29, 2008 3:09 PM
    Monday, December 29, 2008 3:09 PM
  •   Thank you for your sharing.
    Arthur Xie - MSFT
    Tuesday, December 30, 2008 7:35 AM
  •  guitarfish:

    THANK YOU,    T H A N K   Y O U !

    I have been searching for the answer to this for some time.

    Note: I believe this started when I installed SP1 on my Vista Business.

     

    Wednesday, January 28, 2009 6:42 PM
  • You are welcome!!  That was a real pesky problem to solve !!
    Wednesday, January 28, 2009 7:01 PM
  • I have the same problem but, i use windows 2000 sp4.

    I have this problem only in one computer... All the other computers can acces to the file share of the thoshiba scanner.

    I have disable SMB but the problem is the same...

    I can get ping from the printer and i can acces to anyone computer of the domain, when i use this computer...

    (I have disable all firewalls,etc etc)

    Can anyone help me please?

    Sorry, i speak bad english.

    Friday, January 30, 2009 5:07 PM
  • THANK YOU THANK YOU THANK YOU, I have searched for 3 days for this this.  Now it works perfectly!  WHEW!
    Tuesday, July 28, 2009 11:12 PM
  • Thank you, Thank you!!
    How in the world did you track that one down?
    Anyway... thank you VERY much. That gets us going again for migrating from XP to Win7.

    In defense of the confusion - unless you happen to have experience with the way Toshiba does their network scanner access (i.e., it scans to the local drive on the copier, and then makes the file available via an SMB share, rather than as a remote scanner per-se) - I can see why there was some confusion.
    Thursday, November 19, 2009 6:03 PM
  • Thank you, Thank you!!
    How in the world did you track that one down?

    As much as I'd like to take credit for finding the solution, I ended up calling Toshiba.  I figured since it's their copier, they ought to know.  It was a very frustrating problem!  Glad I could help.  I knew others would have this issue.
    Friday, November 20, 2009 1:28 PM
  • Thank you so much for your solution.  I had been trying to figure this one out for a while! Your advice worked like a charm!
    Friday, April 23, 2010 3:24 PM
  • Arthur,

    I have a similar problem mentioned in this thread. We are using a Toshiba e-studio 351c all-in-one that uses the SMB protocol to save faxes to a network file share on windows server 2003 sp2 server box. The w2k3 server has SMB signing enabled (value of 1 in the registry) on all client connections and we have the copier set to both set to disabled (value of 0 expected on the server) and so with SMB enabled on the server it stops the copier from saving the faxes to the file share until we reset the value back to 0 on the server to get the copier storing the files again until the server checks and changes the value back to 1. Do I need to change the SMB settings to log on to a domain instead of a workgroup on the copier? or Do I need to change the SMB settings dealing digital signatures? Both are set to "Digital signature isn't done for the client or the server". Any help would be greatly appreciated. 

    Thanks,
    Skeeter

    Friday, June 04, 2010 3:35 PM
  • THANK YOU guitarfish!

    We had this Problem with Windows 7! Your solution worked perfectly!

    thanks from Germany! :-)

     

    Wednesday, October 13, 2010 12:55 PM
  • Thanks guitarish.

    Your solution really works.And also thanks for the step by step instructions.

    Cheers!

    Thursday, April 14, 2011 3:59 AM
  • Here is another good thread on the issue http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/c1d2e480-65e8-41ad-b7a4-73d4ba3ca09d. Basically this was the solution to my problem (Server 2008). I know the issue has been resolved here, but I thought I'd add this solution as well.

    Hi This is your answer,

    Got windows 7 installed and found an interesting setting. NTML version 2 is set by default and doesnt negotiate with v1 servers i.e Ricoh MFC'S SMB Scanning.  Connecting to a mac os share would state access denied regardless of the credentials.  The trick is to enable v1 if v2 doesn’t negotiate.

    Open up the local security policy by running secpol.msc

    Navigate to Local Policies -> Security Policies

    Change Network Security: LAN Manager authentication level to: Send LM & NTLM - Use NTLMv2 session security if negotiated.

    Close security policy and reconnect to the share.  If it still doesnt work change the encryption level to not require 128 bit encryption.

    Open Network security: Minimum session security for NTLM SSP based (including secure RPC) clients and uncheck the require 128 bit.

    Open Network security: Minimum session security for NTLM SSP based (including secure RPC) servers and uncheck the require 128 bit.

    Reconnect to the share and it should connect correctly.

     

    Hope this helps

    Regard's

    Adam Masemann

    Ricoh Tech

     

    Email djpreadotor@live.co.nz

     


    -- Sam Athanassov
    Tuesday, January 31, 2012 8:44 PM
  • Thank you sooooooooooo much..
    Wednesday, August 01, 2012 5:21 AM