none
USB Mouse random disconnects

    Question

  • Iinstalled windows 7 64-bit windows ultimate

    PC : Pentium Dual core E5200 2.0 + 2.0 , 4 GB Ram, Invidia geforce 9600 GT, USB mouse is a logitech 510 MX

    the mouse randomly disconnects then reconnects I hear the windows Da-Bum sound and the mouse stops moving for about 5-10 seconds

    then windows makes the reconnect Bum-Da sound and it works a while till it does it again ,  the time frame can be anywhere from 5 minutes to 20 minutes

    that it works then it will disconnect/reconnect again.

    I have all the windows updates , I have downloaded the logitech multi drivers that they say are windows 7 drivers ...directly from logitech

    the drivers recognize my 510 MX mouse I have manually removed and replaced the mouse and windows 7 says the drivers are installed

    the device manager says its there and working

     

    Now here is my MAIN issue in windows 7 in the device manager the USB ROOT HUB has a setting  "allow the computer to turn this device off, to save power"

    I have gone through and unchecked this setting several times , it seems that when I do this the mouse does NOT disconnect ..

    However if I plug in a new USB device for example a camera , all the USB ROOT HUBS go back to the default "allow the computer to turn this device off, to save power" and again the Mouse disconnects/reconnects until I manually go back and uncheck all 5 boxes in all 5 root hubs to turn it off , Also if I turn off or reboot the PC all 5 root hubs reset to the default "allow the computer to turn this device off, to save power" again I have to manually turn this default OFF

    Can anyone tell me how to set this OFF permanently ? I don't have nay USB devices I need the System to turn off

     

    Tuesday, April 27, 2010 2:04 AM

Answers

  • Hi,

     

    I would like to suggest you update the BIOS and the chipset drivers to test the issue.

     

    If the issue persists, you may also try to change the Power Plan to High Performance.

     

    Does it work?

     

    Regards,


    Arthur Li - MSFT
    Wednesday, April 28, 2010 2:41 AM

All replies

  • Refre to this kb on how to set this setting permanently. Although it is a article dor Windows Vista, the same procedure helps in Windows 7
    MCSA/MCTS/MCP
    Tuesday, April 27, 2010 1:19 PM
  • Hi,

     

    I would like to suggest you update the BIOS and the chipset drivers to test the issue.

     

    If the issue persists, you may also try to change the Power Plan to High Performance.

     

    Does it work?

     

    Regards,


    Arthur Li - MSFT
    Wednesday, April 28, 2010 2:41 AM
  • For what it's worth, my mouse cord was faulty and was causing exactly what you describe. Got a new mouse and problem was solved. Apparently logitech mice are known for this problem.
    Wednesday, November 03, 2010 11:25 PM