none
Vista Network Identification for Loopback Adpater

    Question

  • I'm running Vista on my laptop and frequently use Virtual Server images and Virtual PCs to perform various tests and because I need a network stack that works even when I'm on the road, I have the Lookup Adapter installed.  I have assigned the loopback adapter a static IP address and use it to host a private network among my virtual machines.

     

    The problem I keep having is that Vista lists the network for the Loopback Adapter as "Unidentified Network" and keeps calling it a "Public Network".  This turns off features like File Sharing that I would like to use on my private network.  Once I go into the Network and Sharing Center and tell Vista that it's a private network, everything works fine.  However Vista seems to re-detect the networks every once in a while and sets the Loopback Adapters back to public again.

     

    Does anyone know how I can permanently identify this network for Vista and have it always marked as private?

     

    Thanks.

    Friday, August 03, 2007 5:17 PM

Answers

  • I don't know why a MS person hasn't responded to this yet, but I did find an answer to this...  If you make the following modification to the registry, Vista will ignore your adapter in the Network and Sharing Center and always consider that adapter on a private network.

     

    WARNING: Modify your registry at your own risk!

     

    Open regedit and navigate to the key

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}

     

    There will be multiple keys with similar names, the key is that the default value on this one should read 'Network Adapters'

     

    Under that key there will be a bunch of subkeys (depending on how many network adapters you have installed) and they will be four digit numbers, such as 0008.  So you have to find the key that corresponds to the network adapter you want to modify; use the DriverDesc value to help you identify it.  For those of you that want to do this for a loopback adapter, the DriverDesc will say 'Microsoft Lookback Adapter'.

     

    Once you have found the key, add a DWORD value to the key called *NdisDeviceType with a DWORD value of 1.  Note: common mistake is to leave off the asterisk, which should be included as part of the value name.

     

    For more information on the values for this setting, check here http://msdn2.microsoft.com/en-us/library/bb201634.aspx

    Essentially you are setting the device to be an endpoint mapper which causes Vista to ignore it but still leaves it functional as a network device.

     

    Usually you have to disable and then enable the network adapter in the Network Connections control panel in order for this to take effect.  In some cases you may also need to reboot.

     

    Your milage may vary, but I hope this helps solve the problem for you.  I wish I could take credit, but I found the solution bacause I started using VMWare and someone on their message boards was smart enough to figure it out.  http://communities.vmware.com/thread/85154?tstart=0&start=43 

     

    - Mark

    Thursday, June 05, 2008 7:15 AM

All replies

  • I have exactly the same problem! I am extremely disappointed with the whole networking implementation on Vista. From trying to configure, to repairing and troubleshooting issues. The idiot "diagnose" screen is laughable and unhelpful in every instance. I cannot think of a worse advertisement for MS than Vista Networking.

     

    Tuesday, December 18, 2007 4:11 PM
  • Sorry to raise an old post but I could use an answer to this. I've got similar... my internal network has a an Xbox and a laptop on it (so no gateway is set), my external network has a cable modem plugged into it. Both go into my Vista Ultimate x64 machine and I have ICS turned on so the local network can access the Internet.

    Vista identifies the internal network as a public "Unidentified Network" and switches my media sharing off. I change it back to private it works, I reboot, it goes back to "public" and media sharing / ICS is switched off. This is a pain since I have to keep going upstairs to mess with the computer every time I want to use my Xbox.

    Pre-SP1 I found an imperfect solution to this was to set the gateway of my private network to the same address as the network adapter. Since SP1, Windows validates that and won't accept those settings. Without a gateway set, it uses this "Unidentified Network" which doesn't appear in my network locations and loses it's settings on every reboot.

    I can't believe that every network needs to have a gateway set or it won't work but that seems to be the case.
    I don't think I'm doing anything wrong, this seems like a fairly major bug in Windows networking to me. Does anybody have a workaround?

    Cheers,
    Matt
    Friday, April 04, 2008 7:58 PM
  • Hi, I've just updated my dev laptop to vista x64 and have hit the same problem.  I've still not found a solution.  Have you had any luck

     

    thanks

     

    james

     

    Saturday, May 17, 2008 9:30 AM
  • Your post prompted me to take another look and I've found a workaround.

     

    Looking in the registry it seems the way that Vista identifies networks is by the MAC address of the gateway the adapter uses. Looks like nobody thought of, say, a straightforward local area connection without a gateway involved... So, the way around it is to set the gateway to something valid on your network, then tweak your network metrics if necesarry to make sure that fake gateway is never used, I didn't have to take that step though.

     

    I've just set the gateway of my local area network to the IP address of my Xbox and it's happily identified the network.

     

    If you're using the loopback adapter as in the posts above, add a second loopback adapter on the same subnet, give it a MAC address, and set the gateway of the first loopback adapter to the second and vice versa.

     

    If you're not too technically minded get back to me and I'll give you some step-by-step instructions. (edit: sorry, since it's your dev laptop you're talking about you probably know what I mean, lol)

     

    --Matt

    Saturday, May 17, 2008 11:26 AM
  • Thanks Matt for the quick reply. 

     

    Unfortunately it didn't work although it did look like was going to work for a while.  Basically after creating the second loopback adapter (setting them up as you suggested) vista detected the network, named it Network and popped up the dialog to allow me to select home as the type of network.  All looked good on the network and sharing centre.  But after a short time it did it's usual refresh, and changed back to a unidentified public network.

     

    Not sure where to go next ???

     

    james

     

    Monday, May 19, 2008 12:43 AM
  •  

     

    Got the same problem, tried several thing, but if I got the Loopback Adapter to work, the normal Network Connection failed. The network connection of the "unidentified network" has to be private to run without problems (access to network ressources, etc.).

     

    Two Loopback Adapters don't work, because referencing each other as standard gateway pops up a message and one gateway is removed. As mentioned by James, it only works a short time.

     

    There is one thing I know which is promising:

    Go to [Administrative Tools] [Local Security Policy] [Network List Manager Policies] [Unindentified Networks], there change location type from "Not configured" to "Private".

    But I don't really like this solution because I expect (not tested) that new connections will automatically be mapped to private, and you manually have to switch to public (i.e. using a hotspot), which poses a threat for a short time because of the disabled firewall.

     

    Does anyone found a way to convince Vista to remember the setting of the Network with the Loopback Adapter to private?

     

    Peter

    Wednesday, May 21, 2008 6:30 PM
  •  

    Thanks for that a-i.. That's my problem fixed at least since I'm using wired networks.

     

    I looked into this again and couldn't find a good solution. I'll record what I found for if anyone wants to take it further:

     

    It seems that Windows looks up the gateway MAC address using ARP, then looks for a "network location" in the registry that matches that MAC address. No gateway MAC = unidentified network.

     

    The only working bodge I could find was to point the gateway of the unidentified networks to something always switched on, on the network, with a valid MAC (it didn't need to be on the same subnet and doesn't need to be providing a gateway). I could put a static ARP entry in the table for a loopback adapter using "arp -s" which was able to provide the necesarry MAC address, but only until I logged out again. I suspect the hardware address of the loopback adapter is initialised too late for Windows to use it to detect a network location. I was going to try using a TAP32 adapter to provide a MAC but found out there wasn't a TAP64 version.

     

    Since this effectively says no gateway = no network services I think it should be recorded as a bug. No gateway at all should be a special case for the network location identifier, otherwise ICS is all but unusable.

     

    Thanks for your help again and good luck.

     

    --Matt

    Thursday, May 22, 2008 9:06 AM
  • I don't know why a MS person hasn't responded to this yet, but I did find an answer to this...  If you make the following modification to the registry, Vista will ignore your adapter in the Network and Sharing Center and always consider that adapter on a private network.

     

    WARNING: Modify your registry at your own risk!

     

    Open regedit and navigate to the key

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}

     

    There will be multiple keys with similar names, the key is that the default value on this one should read 'Network Adapters'

     

    Under that key there will be a bunch of subkeys (depending on how many network adapters you have installed) and they will be four digit numbers, such as 0008.  So you have to find the key that corresponds to the network adapter you want to modify; use the DriverDesc value to help you identify it.  For those of you that want to do this for a loopback adapter, the DriverDesc will say 'Microsoft Lookback Adapter'.

     

    Once you have found the key, add a DWORD value to the key called *NdisDeviceType with a DWORD value of 1.  Note: common mistake is to leave off the asterisk, which should be included as part of the value name.

     

    For more information on the values for this setting, check here http://msdn2.microsoft.com/en-us/library/bb201634.aspx

    Essentially you are setting the device to be an endpoint mapper which causes Vista to ignore it but still leaves it functional as a network device.

     

    Usually you have to disable and then enable the network adapter in the Network Connections control panel in order for this to take effect.  In some cases you may also need to reboot.

     

    Your milage may vary, but I hope this helps solve the problem for you.  I wish I could take credit, but I found the solution bacause I started using VMWare and someone on their message boards was smart enough to figure it out.  http://communities.vmware.com/thread/85154?tstart=0&start=43 

     

    - Mark

    Thursday, June 05, 2008 7:15 AM