none
Windows Update error code: 80040154

    Question

  • I've had this error code for months now, I've searched all over and even tried a few recommendations, nothing worked.  I was happy to see that SP1 was finally available, after searching for how to install that too, I finally found it, but wouldn't you know, I guess I can't install it because of the same error... using the windows update utility I can't install ANY update!!!  Very frustrating, my USB port isn't quite working 100%, I saw a patch for that too, for the stack, but no, I can't even install that because my windows updater is all messed up or something.  If anyone can help me with this it would be very much appreciated.  I'm about to go back to XP any day now if I can't get this going....

    Thursday, February 21, 2008 4:58 PM

All replies

  • So what do we do now - I have exactly the same issue with exactly the same results.  No updates possible, no SP1 possible, is there anyone at Microsoft listening????

     

    Tuesday, June 03, 2008 9:34 PM
  • Just a note i had this same problem about 3 months ago then it went away , but guess what its back again dont know what i did to get rid of it and dont know what i can doo to get rid of it again no help from microsoft i have checked all the usual refrences but nothing helps wish i cud help you maybe someone out there will !

     

    Thursday, July 31, 2008 9:21 PM
  •  

    I spent hours and hours on the phone with Dell then with Microsoft and neither was able to give me any better answer than reformatting the hard drive back to the original factory condition.  Like all help desks they are lower level technicans that are reading from a script - anything that occurs that is 'outside of the box' and they are lost. 

     

    Don't waste any more time trying to figure it out........Save off all of your files onto a backup drive and reload the operating system that was delivered with the PC from Dell or whoever. 

     

    It takes about a day to work through the tasks of reconstructing windows then reloading all of your applications again.

     

    Once I did that - everything works fine. 

     

     

     

    Thursday, July 31, 2008 9:37 PM
  • Has there even been any fix for this or is Microsoft just ignoring it???  I've had this problem for MONTHS and have NEVER been able to update my computer.  The laptop that I bought did not come with Windows installation disks, so now what am I supposed to do?

    MICROSOFT - ARE YOU THERE??????????????????  Every support person I talk to has no idea of how to fix this!!!!!!!!!!!!
    Saturday, September 26, 2009 12:41 AM
  • Same problem. I've had it for months and I cannot find a fix. I have Dell inspiron 1525. I'm in IT so I'd like to think that I'm pretty savvy with computers but I've been completely unable to resolve this issue. 

    Wish I could help, but I feel your frustration. What's really dumb is that there is no way to just do manual updates. 

    I'm probably just going to reformat the computer as I don't see any other choice. 
    Thursday, October 22, 2009 3:17 PM
  • Here's your solution.  It will require you to re-download any downloaded but not installed updates:

    Run a Command prompt as Administrator and type the following:

    net stop wuauserv
    cd %systemroot%\SoftwareDistribution
    ren Download Download.old
    net start wuauserv
    net stop bits
    net start bits

    This is MUCH easier than a complete rebuild and resolves the problem within minutes!
    Wednesday, November 18, 2009 5:58 PM
  • inmortal777 it didnt work,


    or maybe can u be a little bit moe specific with those instructions.  does it require to restart windows?
    Wednesday, November 18, 2009 11:55 PM
  • i receive this message ren dowload download.old A duplicate fie name exists, or the file cannot be found
    Wednesday, November 18, 2009 11:58 PM
  • check also if the Background Intelligent Transfer  (aka BITS) and Windows Module Installer services are running.

    for some reason the latter service was deactivated on my machine, I do not know why.. but starting and setting it to automatic startup made my windows update working again.

    good luck.

    Monday, November 30, 2009 8:31 PM
  • I tried the above mentioned steps and STILL cannot download updates. I had this problem almost a month ago when I got some nast malware and had to reinstall everything to factory settings. I finally managed to update by selecting and slowly doing a handful. But I can't even check for updates. I've disabled windows defender, ad-aware stuff, anti-virus and still nothing. I wasted an hour and a half when the aforementioned update problem happened, only to fix it myself. Any other suggestions?
    Monday, December 21, 2009 5:38 AM
  • Additionally, I've tried to install the updates manually (from doing a search) and I get the following message: installer encountered an error: class not registered.

    Help!
    Monday, December 21, 2009 8:12 AM
  • I've had this error code for months now, I've searched all over and even tried a few recommendations, nothing worked.  I was happy to see that SP1 was finally available, after searching for how to install that too, I finally found it, but wouldn't you know, I guess I can't install it because of the same error... using the windows update utility I can't install ANY update!!!  Very frustrating, my USB port isn't quite working 100%, I saw a patch for that too, for the stack, but no, I can't even install that because my windows updater is all messed up or something.  If anyone can help me with this it would be very much appreciated.  I'm about to go back to XP any day now if I can't get this going....


    try making sure your date timzone and clock are all correct and see if it makes a differance

     

    Monday, May 24, 2010 5:58 PM