none
Microphone output sound delay

    Question

  • Hello,

    I'm a musician. Often, I plug my headphones into my laptop and listen to music. Then I plug my guitar in the microphone jack and enable the microphone sound output so I can play along with the music on my laptop. In other words, I use the laptop as a mixer.
    Now with Windows 7 RC x64, the mic in output has quite some delay, between 0.5 and 1 second. The laptop is an HP 2510p with ADI SoundMax HD integrated audio.
    With Windows XP, this has not been an issue.
    The driver is the one that Win7 automatically got via Windows Update. I also tried the Vista x64 driver provided by HP, no difference.

    As you can imagine, such a delay makes playing along songs impossible. When I strike the guitar, half a second later I hear it from the speakers.

    Is there any suggestion what I could try? Change settings, regkeys, drivers?

    Best regards,

    Jay
    Saturday, July 18, 2009 4:37 PM

Answers

  • Hi Jay,

    This should be a driver issue. The driver update may not be installed properly. I suggest that you remove the driver, and then run Windows Update to install it again.

    How to remove.

    1. Click Start. In the Start Search box type "devmgmt.msc" and press Enter.
    2. Expand "Sound, video and game controllers", double-click on the entry of the sound card.
    3. Click the tab "Driver", click "Uninstall".
    4. Click Start. In the Start Search box type "appwiz.cpl" and press Enter.
    5. Remove the entries related to the display adapter.

    Then, I suggest that you temporary disable the anti-virus, then run Windows Update to install the audio driver.

    Please understand that Windows 7 RC is for test. The drivers on Windows Update website were released by hardware manufacturer. Microsoft has tested these drivers and involved them in Windows Update. However, since currently the whole system is for test, the audio driver may be not fully compatible. It just help the device to work, but the performance may be not perfect. If the issue persists after reinstalling driver, we may need to wait for new compatible driver from hardware manufacture.


    Arthur Xie - MSFT
    Monday, July 20, 2009 8:15 AM
    Moderator

All replies

  • Hi Jay,

    This should be a driver issue. The driver update may not be installed properly. I suggest that you remove the driver, and then run Windows Update to install it again.

    How to remove.

    1. Click Start. In the Start Search box type "devmgmt.msc" and press Enter.
    2. Expand "Sound, video and game controllers", double-click on the entry of the sound card.
    3. Click the tab "Driver", click "Uninstall".
    4. Click Start. In the Start Search box type "appwiz.cpl" and press Enter.
    5. Remove the entries related to the display adapter.

    Then, I suggest that you temporary disable the anti-virus, then run Windows Update to install the audio driver.

    Please understand that Windows 7 RC is for test. The drivers on Windows Update website were released by hardware manufacturer. Microsoft has tested these drivers and involved them in Windows Update. However, since currently the whole system is for test, the audio driver may be not fully compatible. It just help the device to work, but the performance may be not perfect. If the issue persists after reinstalling driver, we may need to wait for new compatible driver from hardware manufacture.


    Arthur Xie - MSFT
    Monday, July 20, 2009 8:15 AM
    Moderator
  • I did what you said, but it didn't fix the issue. Anyway, I understand that this is still in a testing state. So, see this as a bug report ;-)
    Monday, July 20, 2009 6:01 PM
  • Hello,

    I'm just noting that Jay isn't the only one with this issue - I've seen it discussed on other forums (with no solution offered) and I'm also affected by this bug (using W7 RC, didn't have this problem in XP SP3). I think it's not a sound driver-specific issue but rather a more general W7 issue as it has appeared with several different sound cards (including different onboard devices) which would, by my reckoning, use different drives. Personally I use an X-Fi XtremeMusic with a guitar plugged into the microphone input and there's also a noticeable delay between me playing a note and said note being played from the speakers.

    It most likely hasn't been more widely reported since most people probably don't use their computers as mixers/amplifiers. Hope it'll be fixed eventually! :)
    Monday, August 24, 2009 1:26 PM
  • I believe this is a problem caused by the way Windows 7 handles "through routing". While earlier versions of the mixer used the "on board" analogue mixer of the sound card, Windows 7 always digitizes analogue input and than optionally outputs it.
    This AD and DA conversion causes the delay (especially because it is not optimized for real time AD-DA). I believe Microsoft had some reasons to change it, but they forgot about people like us, who need real-time mixing. Hopefully there will be some utilities available that re-enable the analogue mixing capabilities.
    Tuesday, August 25, 2009 9:44 AM
  • Hi there... I've had this problem as well, not on the beta or the RC... but on the full legal version of Win 7 Pro x64, which I bought a few days ago.... I'm a musician as well, and I really need to get rid of this lag.... any help would be greatly appreciated.. thanks!
    Sunday, October 25, 2009 12:06 AM
  • I am having the same problem.  I am using the onboard Realtek sound card which worked fine for me in XP.  I do a lot of recording through my PC and this problem is making me think I should go back to XP.  I have downloaded a couple of other drivers to try but it keeps saying that my driver is already up to date.  I've tried to uninstall the driver and run windows update, but the problem persists.

    This Stinks!

    Chris
    Saturday, November 07, 2009 4:50 PM
  • I am having the same issue.. also a musician.. also worked fine in XP.. also onboard Realtek sound card.. I hooked my PA into my PC, so that I could play along with music that I am practicing on, and there is a slight delay between the time you hit the string and the time you hit the note.. really sucks..
    Thursday, November 12, 2009 7:15 PM
  • I'm sadly having the same issue. Any help would be greatly appreciated as I use my computer for this most of the time.
    Thanks in advance
    Admir
    Thursday, November 19, 2009 5:03 PM
  • Same issue for me. And the delay it pretty much not acceptable.
    It forces people to abandon W7 for mixing purposes. And i blamed on my soundcard ........
    Thursday, November 19, 2009 6:06 PM
  • sad musician here too :( everything was cool for recording til i got win 7, now im just like what to do
    Sunday, November 22, 2009 12:48 AM
  • As I have biostar motherboard I went
    http://pcsupport.about.com/od/driverssupport/tp/windows-7-drivers.htm
    then
    http://www.biostar.com.tw/app/en/event/windows7/index.php

    downloaded new drivers and it works perfectly. I guess every manufactor fixes the problem by himself. Just go find new drivers for the soundcard or wait for one to come out :]
    ( easy to say for me as I was lucky enough to solve it =P )
    Good luck to you who hadn't i hope you fix the problem.

    • Proposed as answer by Salival Sunday, November 22, 2009 1:18 AM
    Sunday, November 22, 2009 1:11 AM
  • thats interesting if this is true you are now the first person of about 30 i've seen to have figured out a solution. i guess i'll check hp for more latest drivers. what did you install? chipset? audio?
    http://scodal.com
    Sunday, November 22, 2009 8:29 PM
  • I installed On-Board Audio driver. Works perfectly now :)
    Sunday, November 22, 2009 8:36 PM
  • Awesome, this didn't work for me. I used Windows Updates to update the drivers as it suggested (no difference) then I went to my laptop manufacturers website and searched this make and model and downloaded the latest audio driver and installed it TWICE just to be sure because I was really hoping it would work.

    End result: Still a delay.. can't play piano
    http://scodal.com
    Thursday, November 26, 2009 2:26 PM
  • If it is a driver issue, I can't find a driver for ANY sound card (and I have tried several) I have tried, that doesn't have this delay.  It wouldn't appear to me to be a driver issue, since Microsoft's drivers don't work either.  Windows 7 is unusable for live music in it's present form.    We need a solution to this problem.   I had to go back to Windows XP, which works perfectly with the same hardware.     The only thing that I was able to do with Windows 7, was to use a usb audio device from Behringer (UA202), with has monitoring built in and bypasses the latency of Windows 7.   However, there were other quirks that popped up, such as audio breaking up when used with certain wireless networking cards.   I did have to finally give up finding Windows 7 audio useless for recording and live music.
    Tuesday, December 01, 2009 3:13 PM
  • Same problem. I still have got no solution in window 7. Probably I'll have to downgrade to xp.
    • Proposed as answer by Salival Saturday, December 08, 2012 5:51 PM
    Friday, December 11, 2009 10:40 AM
  • I have the same problem. Dell GX620 with ADI 198x Integrated Audio, Windows 7, and an audio delay. I don't seem to have an issue using mic input, but the line input (the one I need to plug in my external mixer board) has a lag to the line output sound.

    At least you have all saved me the expense of purchasing a new sound card (which I was about to do today). 
    Wednesday, December 16, 2009 1:49 PM
  • Hi! Im a musician and I depends on this for my work. I bought an HP laptop and install all the lastest drivers with windows 7, I just want to carry my documents and audio files, or eventually to record some pre-production for any client... All this tasks works fine, games, apps, to hear my music normally... But the live mic playback has a delay that makes impossible to play and hear at the same time. In Windows XP it works fine... So, no solution for this so simple issue??? Downgrade to XP AGAIN... It seems to be the only way to get it work... Im disappointed.
    Monday, December 21, 2009 2:15 PM
  • its hilarious to see the the same response from microsoft on this forum too, i posted the same issue issue on another topic. THIS IS AN OS ISSUE, NOT A DRIVER ISSUE. I've tried multiple sound cards, all with their respective latest driver. UNSUCCESSFUL!!!! PROPOSED SOLUTION: HACKINTOSH, OOPS I MEAN MACINTOSH.. or run a dual boot OS system and use XP for recording, then when you buy your next computer... stay away from MS... 
    Friday, January 08, 2010 7:27 PM
  • i thought the same thing, every microsoft page i find with a solution just had the same solution copy and pasted twice about the drivers.. trying to make it sound like it's OUR fault. but clearly we've all narrowed it down to a windows 7 issue. i dont think the solution is to stay away from MS... i can't record the way I do with Linux either. We need a happy Microsoft solution. this whole scenario is bogus! a lesson in "dont fix what isn't broke" recording properties were fine before.. why have they been altered? whatever benefits there are certainly aren't great enough for me to be interested or happy about it. we all just wanted to be musicians again!
    http://scodal.com
    Monday, March 15, 2010 9:13 PM
  • Hey guys

    I've tried almost every solution posted so far, and now of them have worked for me except for THIS.

    When i updated from vista -> 7 (32 bit) i noticed that the sound device manager no longer existed...and i then decided that somehow, this could be what is causing the delay issue.  Downloaded it and it FIXED IT !!!

    ***

    Do you have the "Realtek HD Audio Manager" ?

    check your notification area, should be an ORANGE sound icon.

    ***

    If you haven't, you might try and do what i did because it worked for me.

    site: http://www.realtek.com.tw/downloads/downloadsCheck.aspx?langid=1&pfid=24&level=4&conn=3&downtypeid=3

    1 - Get the "Vista, Windows7 Driver(32bits) Driver only (Executable file)" or " Vista, Windows7 Driver(64bits) Driver only (Executable file)"

    2 - Install it

    3 - Restart ya computer

    4 - If you're as lucky as i am, you'll be very happy to know all your sound delays has dissappeared

     

    Wish everyone luck, Cheers

     

     

    • Proposed as answer by Azu_icHi Wednesday, April 21, 2010 4:39 PM
    Friday, March 26, 2010 12:57 PM
  • Well, I might have stumbled upon something here....

     

    First I separated all the input devices from my hardware manufacturer's Audio manager as was said earlier.

    It didn't make a difference. I still had a playback lag. (It seemed to go away for the moment, but returned soon enough.)

     

     

    Second, I unticked "Listen to this device" in the Recordings settings from Microsoft's Audio Manager.

    (Right click volume control > Recording Devices > Microphone Properties > 'Listen' tab)

    Did this so that the sound from the mic didn't playback anymore.

     

    Thirdly, I enabled playback of the mic from the Manufacturer's Audio Manager.

    And now I can hear the audio playback without any delay, just like in WinXP.

     

    ( When I checked in Device manager, HD Audio Device (Microsoft) and Realtek HD Audio were shown as 2 separate devices.Maybe microsoft's manager controls the OS's mixer, and manufacturer's manager uses the card as it's primary mixer. Well, that's my theory anyway.)

    I still don't know about whether this will make any difference in the issue about recording exclusively by a software.

    So If you can control audio playback from ur manufacturer's audio manager. Use that instead of Microsoft's manager.

    NOTE: Listen to this Device in Microsoft's manager is not the same as the Playback controls for Mic in the Hardware manufacturer's Audio Manager (Atleast in my case)

     

    Ok I'm a n00b. Please bear with me.

     

    Hardware:

    AMD Phenom Tricore

    AMD 780G (ASUS M3A78-EM)

    Realtek HD Audio (Driver version 6.0.1.5904)

     

    OS: Win7 / WinXP


    • Proposed as answer by Azu_icHi Wednesday, April 21, 2010 4:39 PM
    Friday, April 16, 2010 10:12 PM
  • Well, I might have stumbled upon something here....

     

    First I separated all the input devices from my hardware manufacturer's Audio manager as was said earlier.

    It didn't make a difference. I still had a playback lag. (It seemed to go away for the moment, but returned soon enough.)

     

     

    Second, I unticked "Listen to this device" in the Recordings settings from Microsoft's Audio Manager.

    (Right click volume control > Recording Devices > Microphone Properties > 'Listen' tab)

    Did this so that the sound from the mic didn't playback anymore.

     

    Thirdly, I enabled playback of the mic from the Manufacturer's Audio Manager.

    And now I can hear the audio playback without any delay, just like in WinXP.

     

    ( When I checked in Device manager, HD Audio Device (Microsoft) and Realtek HD Audio were shown as 2 separate devices.Maybe microsoft's manager controls the OS's mixer, and manufacturer's manager uses the card as it's primary mixer. Well, that's my theory anyway.)

    I still don't know about whether this will make any difference in the issue about recording exclusively by a software.

    So If you can control audio playback from ur manufacturer's audio manager. Use that instead of Microsoft's manager.

    NOTE: Listen to this Device in Microsoft's manager is not the same as the Playback controls for Mic in the Hardware manufacturer's Audio Manager (Atleast in my case)

     

    Ok I'm a n00b. Please bear with me.

     

    Hardware:

    AMD Phenom Tricore

    AMD 780G (ASUS M3A78-EM)

    Realtek HD Audio (Driver version 6.0.1.5904)

     

    OS: Win7 / WinXP


    Friday, April 16, 2010 11:24 PM
  • is this driver is a universal driver for any type and model of sound cards including laptops?

    -sorry, I'm a novice without experience-

    Wednesday, April 21, 2010 4:21 AM
  • What software are you using to play the guitar output through your speakers?

    If you're not using any 3rd party software, there are two options for what's happening here:

    1) You're using the Windows 7 "Capture Monitor" feature (also known as "Listen To").

    2) You're using your audio solution's built-in loopback feature (sometimes known as a line in control on your speakers).

     

    If it's option #2, then this is a problem with your audio solution - Windows has no code which handles this functionality.

    If it's option #1, the capture monitor was designed for listening to portable media devices (kinda like the "Aux" input on many car stereos), it wasn't designed for real-time audio rendering like you're trying to do (although I'm surprised at the 500ms latency you're describing - my tests of the capture monitor showed that the latency was less than 100ms - enough to be audible but not that bad).

     Edit to add: For Windows XP, there was no capture monitor, so many audio solutions implemented loopback in hardware (option #2 above).  That functionality was removed when the audio manufacturers switch from AC'97 to UAA.

    Larry

    Friday, May 07, 2010 6:28 PM
  • Hi people... try refreshing your computer's Windows Experience Index . After clicking on the "Re-run Assessment " link, you will be informed of your key system components rate. i had sound delay when i got a 1.0 base score coz windows informed me i should install a higher version video card. i have a 2.5 base score now and i don't have any sound delay anymore. btw, i also am using Vista_Win7_R246 for audio. i can play my guitar through the computer's speakers now ^_^
    Friday, May 21, 2010 2:35 PM
  • Has anyone tried something like running a teamspeak server and using that to echo back? Because I use one daily for gaming and the delay is significantly lower than that which is introduced by windows. The current teamspeak client version doesn't seem to allow multiple instances, but maybe someone out there knows something similar that does?

     

    Of course, a solution does present itself here - if you have more than one computer (and who doesn't :P) plug your microphone into one, your speakers into another, use teamspeak (or some other) and bam! the latency will become network latency, somehow much much lower than the latency within your own computer.

     

    Somewhat more complicated, you could just use a proper operating system, like anything _except_ windows. OS/2 would probably not struggle with this :P Linux certainly doesn't. But it does still struggle with other things, which is why I still use windows. Things like this just make me use it for one less thing. I mean, come on - two computers needed to hear a realtime echo from microphone to speakers?

    Saturday, June 05, 2010 1:21 AM
  • Okay. I have the solution. Right click the speaker icon (on windows 7) on the task bar then left click on "recording devices". Right click on the microphone and left click on properties. Go to the "listen" tab and make sure the "listen to this device" check box is unchecked. Okay now close the microphone properties window. The "sound" window should still be open. Go to "playback" tab,right click on speakers and left click on properties. Then click on the "levels" tab. You should see a microphone section with its playback volume muted. Unmute it and increase or decrease the playback volume as desired. There should be no noticeable delay when you speak into the microphone now. :)
    • Proposed as answer by m-a-r-t-i-n Saturday, March 05, 2011 1:24 AM
    Friday, September 03, 2010 9:36 PM
  • This doesn't work either.

     

    The Windows 7 monitoring live audio while recording problem is an OS issue, not a driver issue.   Many months have gone by with no fix in sight.   In appears Microsoft is either unaware or cannot fix the problem.

    Stick with XP until Windows releases a more musician/recorder friendly OS.    THAT is the solution.   Stick with XP.

    Monday, September 13, 2010 5:19 PM
  • Confirmed that Priestest's workaround fixed my problem.
    Monday, September 27, 2010 12:36 AM
  • Sadly, XP is not a solution either, at least for some of us.  I'm running XP Pro on a fairly robust system.  The latency problems described here for Windows 7 are EXACTLY what I am experiencing with XP.  I've tried 2 different soundcards (the onboard Realtek and an add-on SB Live) and have horrible latency problems on each.  Problems exist on both the line input and the mic inputs.  And yes, I have the latest drivers for the cards.

    What's most distressing is one of the earlier replies in this thread by a MSFT moderator, essentially saying their OS wasn't built to support real-time monitoring of the line-in or mic inputs of a sound card, or blaming the problems on the hardware/drivers.  This is not rocket science.  I've been writing device drivers for 25 years and know better than to fall for the story that latency problems this severe are in the drivers of every sound card I've tried. 

    Up to now, the only reason I haven't moved my music production software to a Mac is that my favorite VST soft synth is only supported on Windows.  Now that I've started working with vocal recording, the line-in/mic latency problems on Windows are so bad I'm going to have to make the move anyway if I want to record vocals.

    Friday, October 15, 2010 3:08 PM
  • Right click on the microphone and left click on properties. Go to the "listen" tab and make sure the "listen to this device" check box is unchecked. Okay now close the microphone properties window. The "sound" window should still be open. Go to "playback" tab,right click on speakers and left click on properties. Then click on the "levels" tab. You should see a microphone section with its playback volume muted. Unmute it

    Works! Awesome! Thanks!
    Saturday, March 05, 2011 1:27 AM
  • Worked for me to.  Or a similar workaround, under the microphone "Listen to this device", play around with the playback device selection.  Only one of my 3 choices there took the delay out.
    Wednesday, March 23, 2011 1:53 PM
  • Thanks Priestest!

      I have had that problem for too long.  Now I can jam again!  I bow to the priestest...


    Thursday, March 24, 2011 10:01 PM
  • Okay. I have the solution. Right click the speaker icon (on windows 7) on the task bar then left click on "recording devices". Right click on the microphone and left click on properties. Go to the "listen" tab and make sure the "listen to this device" check box is unchecked. Okay now close the microphone properties window. The "sound" window should still be open. Go to "playback" tab,right click on speakers and left click on properties. Then click on the "levels" tab. You should see a microphone section with its playback volume muted. Unmute it and increase or decrease the playback volume as desired. There should be no noticeable delay when you speak into the microphone now. :)
    The "sound" window should still be open, then go to "playback" tab,right click on speakers and left click on properties. Then click on the "levels" tab, but I don't see any microphone section! Help me !!!!!!!!!!!!!!!!! :((
    Tuesday, April 19, 2011 9:23 AM
  • Excelent Solution ! u rock !
    FX
    Friday, May 13, 2011 2:03 AM
  • Hi, i tried to remove and reinstall the driver but it doesn't work. I use my laptop to sing with a karaoke but with this delay it's almost impossible to synchronize. I have a HP ProBook 4510s, and for what i read, it's not a driver issue.

    Hope you can help us soon, this is annoying.

    Regards.

    Tuesday, May 17, 2011 3:12 AM
  • This thread is almost 2 years old and we're still having the same issues.  I have a Toshiba satellite laptop running Windows7 and cannot get any solution to the microphone delay.  When I follow the instructions by Priestest, I also do not see the muted microphone option.  I have been recording with an XP desktop without any issues.  When I hit the strings, I hear the guitar.  With Windows 7, there is a delay that doesn't even seem to be consistent.  Sometimes the delay is around 1 second and sometimes shorter.  But never immediate.  I'm really frustrated that all these smart people who know more about computers can't come up with a consistent solution.  Kind of like our economy.  Everyone is an expert but they can't fix anything.  Why can't the microphone input go straight thru to the mixer and to the speakers?  What is processing the sound/signal to delay it to the speakers?  That's got to be where the problem is... but what do I know?
    Wednesday, May 25, 2011 3:22 AM
  • Hi everyone,

    Thanks so much for your input! I solved this problem on my laptop... I signed up to this website just to write about how I went about solving this issue in hopes that I can help even one musician out there in the world... I literally could not record for about a year and had almost given up on this issue :(

    Also, I should note that Priestest's solution is probably the one you want to try first. I only went about it another way because I encountered the same issue as VietTrung:

    "The "sound" window should still be open, then go to "playback" tab,right click on speakers and left click on properties. Then click on the "levels" tab, but I don't see any microphone section! Help me !!!!!!!!!!!!!!!!! :(("

    Me too. I'm not sure why I couldn't see the microphone section in the levels tab, but when I did a search online, I found this: http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-70822&selectarea=SUPPORT&tempselected=5 Pretty interesting read. If you are curious, query for "MIGR-70822" online to find out more about this issue.

     

    ---- My solution -----

    I am using a recording software by the name of Reaper (I'm thinking other softwares may work too, I haven't tried Audacity but that's the most my friends use). I went to Options> Preferences > Audio > Devices > and Selected "ASIO" for my driver. The default option selected was "WaveOut" which gave me a HUGE DELAY.

    It gave me no ASIO drivers are found! But a quick search online will tell you you can download ASIO4all. Restart Reaper and go back to Devices menu to select ASIO.

    If you are still having problems after selecting ASIO, I highly recommend this forum: http://forum.cockos.com/showthread.php?t=21590 (look at Diogene's post please)

     

    --- Results ---

    There was a huge difference between "WaveOut" and "ASIO" and I can record now.

    ------------------

    I really hope that helps some musicians out there in the world. Recording is a huge motivation to improve your skills :)

     

    References:

    ASIO4all: http://www.asio4all.com/

    Sunday, June 05, 2011 10:26 AM
  • Priestest - You are a shining star!

    You've just rescued me from buying an external mixer just to have the sound in sync with audio. I only wish it was better documented somewhere. Microsoft, anyone?

    Thank you :)

    Monday, June 27, 2011 3:10 PM
  • Priestest you're a superstar!  How come NO ONE ELSE ON THE WEB found this fix and you did!

    An honestly, SHAME SHAME SHAME on microsoft for the rubbish "this is a driver issue" responses.  I'm a big Windows fan but honestly they wonder why people don't want to pay for Windows... if the added value of legal ownership is so rubbish why would people spend their money on something they can't be sure does something so basic.  Mind you typical Microsoft, stuck in the 90s... using your PC to record sound?  Gosh....

    But, again thanks Priestest, made my day finding this fix :)

     

    Thursday, June 30, 2011 3:23 AM
  • Many thanks buddy...

    Ur solution is d best way to fix it..

    I guess when we have the option listen to this device enabled, it by default process d sound for the second time n hence it over laps with a little delay... we actually end up listening d amplified sound with the delay issue.

    Friday, August 19, 2011 5:47 PM
  • This is the one that worked for me, and I'm happy now I get real time recording in Windows 7! In Windows Audio Manager\Recording devices, select your mic and turn off "Listen to this device". Now go to your Realtek HD Audio Managert (orange speaker icon) andtest your microphone there. Mine stopped the delay and works great now. Likewise when I open audition or fruity loops, using the audition driver now works with no latency.

     

    My PC is an ASUS but I had this same issue with my old Dell, any damn sound card. It's clearly a Windows issue that started in Vista.

     

    Nice fix piewhy :-)

    Tuesday, September 27, 2011 6:05 PM
  • Hey man can u walk me though testing the microphone. i went to what u said and they are not letting me test the microphone for some reason.
    Thursday, November 17, 2011 1:14 AM
  • i found out how to here it it does fix the lag problem but now ii hear the sound through one side of my headphones and it plays back on both after i record it on asid home studio. ican live w that but now the issue is that is sounds like crap after iplay it back it sounds real muffled and i cant understand my words at all.

    Thursday, November 17, 2011 2:19 AM
  • hey bro i did that now i only hear through one side of my headphones. and when i play it back after i play it through acid home studio after i record it it sounds really bad. i feel like giving up on this bro. any suggestions?

    Thursday, November 17, 2011 2:29 AM
  • I had this problem for a long time. Until I solved it today. 

    In the Realtek HD Audio Manager, there's a button above the "OK" button. Right next to the "i" button. It looks like a battery. Click that. 

    Set it to power down when battery only, or remove the blue dot from where it says "Power management enabled" by clicking it. Or do both. 

    Problem solved. Well, obviously there's the making sure it's muted in windows's recording devices thing and not in the realtek manager, but that goes without saying at this point. 

    Friday, November 25, 2011 9:34 AM
  • I have just set up my Tascam 424 MKIII 4 track recorder in my computer room to finally record to my computer. I just bought an expensive HP that came with "Beats" audio. It does have a nice graphic EQ section but I regard the "Beats" system as a lot of "Fluff"! I have KRK rockit5's installed along with a 27" HP monitor. After all these years being an "Analog Dinosaur" I finally figured I would go "Digital". (I have a recording studio filled with Tascam Analog goodies). So after spending all Thanksgiving weekend setting up my guitars, amp, effects, mike stands, recorder, cables, lava lamp, and other toys, I do a sound check. I play my guitar and it sounds great, I play some songs from YouTube and they sound great also. It wasnt until I tried to play along with "Rush" that my "Digital Bubble" was burst! OMG I panicked! There is a tiny sign on the wall in my recording studio, it reads "Digital Sucks!". So I found a temporary way around this nonsense, I have 2 seperate inputs on my speakers, the computer goes to the balanced inputs and the 4 track goes to the unbalanced. I can play along with YouTube in real time. If I want to mix down I turn down the 4 track monitor to kill the delay. I just hope I can get this delay to go away like some of you lucky people. Wish me luck!

     

    VP

    Saturday, December 03, 2011 7:02 PM
  • Okay. I have the solution. Right click the speaker icon (on windows 7) on the task bar then left click on "recording devices". Right click on the microphone and left click on properties. Go to the "listen" tab and make sure the "listen to this device" check box is unchecked. Okay now close the microphone properties window. The "sound" window should still be open. Go to "playback" tab,right click on speakers and left click on properties. Then click on the "levels" tab. You should see a microphone section with its playback volume muted. Unmute it and increase or decrease the playback volume as desired. There should be no noticeable delay when you speak into the microphone now. :)
    The "sound" window should still be open, then go to "playback" tab,right click on speakers and left click on properties. Then click on the "levels" tab, but I don't see any microphone section! Help me !!!!!!!!!!!!!!!!! :((

    I dont see this section either! The hunt continues!

     

    VP

    Saturday, December 03, 2011 7:20 PM
  • Unfortunately, none of the answers above worked for me (Gigabyte Z68X-UD3H-B3 using Realtek ALC889 codec and Win7 x64 Ultimate), the delay never decreased to the point where it was useable, but it did change from setting to setting.

    I did find a workaround though. In desperation, I installed a PCI soundcard and installed the drivers for that. The type of additional sound card seems to be irrelevant, it worked perfectly with a Creative Audigy2ZS and a Lynx L22.

    The trick is to continue to use the same settings as before, but to enable the "Listen to this device" option - and use the second soundcard to route the delayed output to.

    This means you can't hear what you're saying in the mike, but you can record it just fine on the original soundcard, and it seems to be synced properly. It's just the remixed output from the mike that's delayed.

    The L22 card doesn't suffer from this bizarre marketing issue, as it routes and mixes internally, bypassing the stupid Microsoft "design". But for microphone-based recording, the onboard soundcard works better.

    I hope this works for someone else.

    I find it interesting that after the massive rejigging MS had to do to move from WDM to UAA, and after the hundreds of whitepapers and feedback from the industry before UAA was rolled out, Microsoft basically ignored everything the industry had to say about realtime mixing and streaming, and created a far more difficult-to-use architecture that basically does LESS than WDM ever did.

    Good one, Microsoft. And thanks for the great support for issues like this. No wonder so many users are moving to linux. Now that I've seen what the sound architecture can do on that OS, I'm severely tempted myself. The only drawback for me (and it really is only one tiny application issue) is that the editing tools aren't up to snuff on linux. Yet.

    Tuesday, December 20, 2011 12:18 AM
  • First time poster so please bear with me.

    For those of you with the problem, "click on the "levels" tab, but I don't see any microphone section!", I think you might be looking for the actually word "microphone".  Please understand that in Priestest's workaround the "microphone SECTION" referred to under 'Levels' probably does not actually show the word "microphone".  Although other sections listed could be "CD Audio" and "Subwoofer", nothing is actually listed as "microphone" in the Levels tab.

    I have Realtek onboard audio so it is the only reference I can give.  Realtek allows you to set any jack for either output (speaker) or input (microphone/line-in).  Go to Realtek's HD Audio Manager in the control panel and identify which jack you plugged the microphone in.  Go back to the MS sound, speaker properties, levels tab, and then follow the rest of Priestest's workaround (unclick mute and set the volume and balance). 

    I have a mic and tried the workaround.  Works for me.  Sorry if this is not the same problem people were referring too.  If it is not, please give more details as to what you are seeing when you look at the levels area.

    ---

    I read somewhere that MS changed the audio driver in relation to hdmi and hdcp.  Without the change, people couldn't use hdcp features with their computers.  This was MS's way of assuring the entertainment industries that hd sources (ie, blu-ray) would be near impossible for people to record using Windows.

    Hope that helps.

    Tuesday, April 03, 2012 6:13 PM
  • I was playing my guitar through my PC today and forgot to mute the line in when I was done, PC wouldnt sleep. As soon as I muted the line in it slept like a baby!

    VP

    Tuesday, April 03, 2012 6:27 PM
  • This is for the on board Realtek HD Audio Driver version R268 and Window 7. The driver can be located on the http://www.download.com site.

    The delay is caused by the bit rate settings. There is too much information flowing through the Default Audio card settings. Here is how to fix your delay:

    1. Right click on the speaker icon in the system tray. Choose recording properties. Select Properties for the Microphone. Go to the advanced tab. Select the Default Format pulldown. Make sure STUDIO QUALITY is selected. Apply and exit.

    2. Right click the speaker again and go into Playback devices. Select Properties for the Speakers. Select the Advanced tab. Go to the pulldown and select the bottom Studio Quality. Go to the Enhancement tab and deselect everything, but Voice Cancellation.

    This is for the on board Realtek HD Audio Driver version R268 and Window 7.

    Sunday, June 24, 2012 3:41 AM
  • I looked for the microphone level too but I have never found it.

    The issue discussed in this thread is caused by the sound architecture of Windows 7.

    To listen to the input sound so called Hardware Monitoring is neccessary. But the audio architecture of Windows 7 does not allow direct access to the hardware.

    Microsoft has clarified this in the following paper about Audio Processing in Windows 8: http://msdn.microsoft.com/en-us/windows/hardware/br259116

    Windows 8 will bring back Full-Duplex known from Windows XP.

    To monitor sound on Windows 7 without delay you need a USB Sound Card or an internal card with monitor.

    The issue was introduced with Windows Vista, cf. http://support.lenovo.com/en_US/detail.page?LegacyDocID=MIGR-70822&selectarea=SUPPORT&tempselected=5

    Windows 7

    No microphone level with Windows 7

    Windows 8 Release Preview

    Microphone level is back again in Windows 8 Release Preview

    • Edited by me11 Tuesday, July 17, 2012 9:50 AM Images added
    Thursday, July 05, 2012 12:05 PM
  • Hello,

    I have another answer:

    On the "Sound" window, in "Playback" tab I marked the first (notebook inner speaker) speaker icon as «Default device»,
    and the second speaker icon (witch appear when I connected microphone) as «Default communication Device»,
    by the right mouse button.

    Anyway, it's work for me.

    Regards.

    Ivannof

    Hardware:

    Dell Vostro 131
    Intel Core i5
    Conexant SmartAudio HD
    (Driver version 8.5413.40)

    OS:

    Windows 7 (64)



    • Edited by Ivannof Wednesday, February 13, 2013 10:52 AM
    Wednesday, February 13, 2013 10:51 AM
  • This DID work for me - finally !

    I have an HP Win 7 pc with a Realtek sound card. I have had this for almost a month and just the other day figure out to get the mic working without that delay or echo.

    FIRST: In the Record section of your sound card settings, highlight Microphone and click on Properties. Then click on the Listen Tab and uncheck 'Listen To This Device'. 

    SECOND: In the Playback section of your sound card settings, highlight Speakers and click on Properties. Click on the Levels Tab and uncheck or unmute both the MICROPHONE - AND - the REAR PINK IN (it may read REAR PINK FRONT if you are connecting your mic on the front of your pc) sections. 

    Presto - finally I finally have my mic working on my Win 7 pc just like it does on my XP pc.

    However this doesn't seem to work on our two Win 7 laptops, as there is no  'Rear or Front Pink In' section under the Speakers section of the Playback sound card settings on those machines. But hopefully this will be a solution for some of you.

    Ramtown Mike


    Tuesday, May 28, 2013 10:01 PM
  • This is how I solved it:

    Hi everyone, I'm not a musician but a karaoke enthusiast :D and had the same latency problem; I could hear my voice like 0.5 to 1 sec after I sang.  I have a Sony VAIO laptop that came with Win XP and never had this type of problem before; but since I upgraded it to Win 7 I started experiencing this problem.  To make a long story short: I was able to solve it with this two key steps:

    1. Downloaded and installed Realtek HD Audio driver from SONY website.

    2. Followed instructions about unchecking the "listen to this device" option and looking for the Mic section in the Playback window, which BTW I couldn't see before installing the propper drivers.

    And that was it, no more delays at all.  So I could say mine is a combined solution from other guy's advices.

    Thanks everyone for sharing your knowledge and experience, cheers!

    Tuesday, June 04, 2013 5:38 AM
  • Same problem here, I just spent forever trying to get ahold of the realtek am, and that was a maze! You hafta ask just right I said Google, oh mighty Google, search for "Audio Manager" and boom! it pops up. Frustrating, it's getting better tho, anyways, so im a try the realtek thingy and hope it works
    Monday, October 21, 2013 3:44 AM
  • IT WORKED! Realtek HD Audio Manager is what fixed it. Got it off the acer (my manufacturer) website, 97 Megabytes! Fixed it right up, I had to unmute the playback option in the settings which you can find under control panel - Realtek HDAM Settings whatever just make sure you list large icons. No delay in my playback gonna rock out to some tunes now peace!
    Monday, October 21, 2013 5:07 PM
  • This worked perfectly. I can put the mic right up to the speaker with no feedback if I wish to.
    Tuesday, December 31, 2013 9:30 PM