none
Windows 7 can't access Share in a workgroup

    Question

  • Hi,

    I'm having a problem with windows 7 & connecting to a share on a workgroup.

    The domain has 3 windows xp machines & 1 windows server 2000 all on the same workgroup.

    The computer is on the same workgroup as all the others.

    The server has some shared folder, with sharing permissions set to "Everyone".

    Problem is, when I try to connect to the share, he requests a username and password, when I enter: \\w2kserver\admin + password, or w2kserver\admin + passowrd he keeps saying I do not have permisson to access the share??

    Can someone please help me with this? Username & password are correct, it always worked fine on XP....

    I've recorded the problem as well: http://users.pandora.be/Desteny-/share.zip

    Thanks in advance,

    Filip Wilms
    Monday, December 21, 2009 12:22 PM

Answers

  • does no one here search for answers???
    answered here many times...

    click the start button and type secpol.msc in the search function.

    Browse to "Local Policies" -> "Security Options".  Now look for the entry "Network Security: LAN Manager authentication level" and open it.  Click on the dropdown menu and select "Send LM & NTLM - use NTLMv2 session security if negotiated".  Apply the settings.

    In the Advanced sharing settings page of Network and sharing center, you need to have it set as Work/Home profile.  Try

    -Enable network discovery
    -Turn on  file and print sharing
    -Turn off password protected sharing
    -Use user accounts and passwords to connect to other computers

    The other settings such as encryption I have set as use 128 bit encryption.

    Please check related policies.

    1. Enter “gpedit.msc” in the Start Search box.
    2. Open “Computer Configuration”/Windows Settings/Security Settings/Local Policies/Security Settings.
    3. In the right pane, enable the following policies:

    Network access: Allow anonymous SID/name translation
    Network access: Let Everyone permissions apply to anonymous users

    Also please disable the following policies.

    Network access: Restrict anonymous access to Named Pipes and Shares
    Network access: Do not allow anonymous enumeration of SAM accounts
    Network access: Do not allow anonymous enumeration of SAM accounts and shares

    • Marked as answer by Novak Wu Wednesday, December 30, 2009 3:23 AM
    Tuesday, December 22, 2009 2:40 PM

All replies

  •  

    Hi,

     

    First, I would like to confirm whether the Windows 7 machine is in the domain. Is the domain name "MIA-PC"? And the domain user profile is Supervisor?

     

    Please type the domain and user credentials by following format:

     

    User Name: Domain name\user name

    Password:

     

    If the error persists, I suggest you add the Windows 7 machine to the domain and map the drive for a test.

     

    Thanks,

    Novak

    Tuesday, December 22, 2009 8:42 AM
  • Hi Novak,

    The windows 7  machine is on the same Workgroup, no domain installed.

    I can see the WK2Server fine, but I can't login, it keeps telling me the username is wrong, but it is in fact supervisor...

    I've tried about everything, but without any luck.

    Filip
    Tuesday, December 22, 2009 9:45 AM
  • does no one here search for answers???
    answered here many times...

    click the start button and type secpol.msc in the search function.

    Browse to "Local Policies" -> "Security Options".  Now look for the entry "Network Security: LAN Manager authentication level" and open it.  Click on the dropdown menu and select "Send LM & NTLM - use NTLMv2 session security if negotiated".  Apply the settings.

    In the Advanced sharing settings page of Network and sharing center, you need to have it set as Work/Home profile.  Try

    -Enable network discovery
    -Turn on  file and print sharing
    -Turn off password protected sharing
    -Use user accounts and passwords to connect to other computers

    The other settings such as encryption I have set as use 128 bit encryption.

    Please check related policies.

    1. Enter “gpedit.msc” in the Start Search box.
    2. Open “Computer Configuration”/Windows Settings/Security Settings/Local Policies/Security Settings.
    3. In the right pane, enable the following policies:

    Network access: Allow anonymous SID/name translation
    Network access: Let Everyone permissions apply to anonymous users

    Also please disable the following policies.

    Network access: Restrict anonymous access to Named Pipes and Shares
    Network access: Do not allow anonymous enumeration of SAM accounts
    Network access: Do not allow anonymous enumeration of SAM accounts and shares

    • Marked as answer by Novak Wu Wednesday, December 30, 2009 3:23 AM
    Tuesday, December 22, 2009 2:40 PM
  • And If I am an unlucky user of Windows 7 Home, how do I proceed to apply these settings to access the win2k computer?  (I'm having the exact same problem)


    Thank you!
    Thursday, December 31, 2009 6:44 AM
  • The solution may be simpler then you think. I just spent days banging my head against the wall trying to figure it out and here what I found:

    Make sure the clocks are in sync on Win 7 and Win2K boxes. Thats all it is. My Win2K clock was 2 hours two fast. Once I changed the time I was able to connect with no problems. I actually validated that by changing the clock again I had re-introduced the problem.

    Happy sharing!
    • Proposed as answer by get2brad Friday, July 30, 2010 12:29 AM
    Friday, January 08, 2010 8:43 PM
  • Wow your rock man. I have had Win 7 since it first came out and I have never found and answer to this I can't access network password protected shares on my local network. I did what you mentioned to the letter and it worked like a charm in just seconds.

      Super thanks

    Just a follow-up programming note this only works on the Pro and up versions of Win7 I had no luck with Win7 Home Premium.
    Thursday, January 14, 2010 4:08 PM
  • Bought a new HP quad core machine with Windows Home pre-installed. Windows 7 Home was working until I did a clean install of Windows 7 Professional with Virtual PC and the XP emulator. (I have some expensive CAD and other 32 bit  software that I didn't wish to replace). At that point my other computers (Win 2000, Win XP, Win Vista) could all grab files from and share folders on my new 64bit Windows 7 Pro machine) but my Windows 7 pro machine couldn't access the files on my Windows 2000 machine. My network user name and password was not being accepted when prompted to do so. Interestingly, My Windows 7 pro machine could see and access files on all my other computers.

    I can't believe it was this easy.  My time clocks were set to the same hour BUT set to PM rather than AM (oops!).  This also set the date 12 hours off so it was wrong, too, half the time.  I was dumb enough to spend days on this issue without noting the clock settings...

    Thank you big_nk
    Tuesday, March 09, 2010 4:18 PM
  • still no answer for Home users? if anything give a list of the registry lines to edit.
    Monday, March 15, 2010 5:52 PM
  • Same here. Interesting if I change the time on the w2k server to 1 hour behind (2:30 -> 1:30) I can connect. I was good until time changed. Tried everything. I also run a mail sever on w2k and the mail that I recieve in the 'Live Mail' is always one hour ahead of the correct delivery time
    Wednesday, March 31, 2010 9:33 PM
  • Kerberos strikes again. 
    Saturday, April 17, 2010 7:04 PM
  • Hi everyone,

    I just solved a similar problem with my Windows 7 laptop connecting via wireless. I discovered that there were over 200 Microsoft 6to4 adapters that had been created in the Device Manager. After uninstalling each one, I was able to browse my home network and see my shares as well as reconnect to them. Prior to uninstalling these devices, I could ping and tracert both the machine name and the IP of the machine hosting the network shares, but I wasn't able to browse the workgroup and see anything other than the Windows 7 laptop. This is a known issue with Vista and Windows 7, Microsoft has admitted this problem in a KB article and their suggestion of running a commandline statement to start/stop the homenetwork before logging off and after rebooting does not work. Just FYI, hope this helps someone.

     

    Tass23-The Man With The Plan.

    Tuesday, April 20, 2010 4:20 PM
  •  

    I fixed this probleme - windows 7 can not connect to share on server 2003,  by this single step:

    Browse to "Local Policies" -> "Security Options".  Now look for the entry "Network Security: LAN Manager authentication level" and open it.  Click on the dropdown menu and select "Send LM & NTLM - use NTLMv2 session security if negotiated".  Apply the settings.

    --------------

     Jonathan Ravzin

    MCT - Microsoft Certified Trainer

    MCSE since NT4 up to MCITP 2008

     

    Monday, May 24, 2010 8:56 AM
  • You, sir, are a genius.  After mucking around with the super-prop-top answers/solutions, which were quite misleading, I tried your trick.  I had changed the BIOS in my Windows 2000 PC and the time settings were way off.  Once I put the Windows 2000 PC back to the correct time, my problems went away.  Thanks.
    Saturday, July 03, 2010 4:22 PM
  • This has been so frustrating for me. We have a Win2k server, no domain, shared folder all full control- and 3 other W7HP 64bit machines that access the share without issue.

    I have the W7 account exact same as others and exists as user on Win2k server.

    I tried the registry edits suggested.

    I am able to access the public folder on the W7 machine from the Win2k machine and copy files there.

    I tried setting the clocks as suggested. (reboots required?)

    It would be nice if there were a policy editor or group of .reg files I could use.

    In any event I am very flustered by this issue.

    O

    Thursday, July 15, 2010 12:47 AM
  • How in the world could this be the solution? Real quick back story. Built 2 workstations, identical everything. Put Windows 7 Pro on machine A with no license (30 day trial or whatever). Installed all of our apps and set it up to our liking. Cloned the hard drive to machine B and changed only the computer's name and IP address. Computer A has no issues accessing Windows servers, computer B would NOT. Finally I found big_nk's post about the time. Computer B was TEN minutes behind the current time. We updated the time, and presto! All network shares are accessible.

    Why?! Don't get me wrong, I love that we found a solution. And maybe I could see an issue with big_nk's being off by 2 hours. But 10 minutes? Anyone know? Thanks for the solution and also any additional input anyone has.

    Friday, July 30, 2010 12:33 AM
  • The solution may be simpler then you think. I just spent days banging my head against the wall trying to figure it out and here what I found:

    Make sure the clocks are in sync on Win 7 and Win2K boxes. Thats all it is. My Win2K clock was 2 hours two fast. Once I changed the time I was able to connect with no problems. I actually validated that by changing the clock again I had re-introduced the problem.

    Happy sharing!
    That fixed it for me. Thanks!
    Wednesday, August 25, 2010 9:35 PM
  • The solution may be simpler then you think. I just spent days banging my head against the wall trying to figure it out and here what I found:

    Make sure the clocks are in sync on Win 7 and Win2K boxes. Thats all it is. My Win2K clock was 2 hours two fast. Once I changed the time I was able to connect with no problems. I actually validated that by changing the clock again I had re-introduced the problem.

    Happy sharing!


    This works

    Change Regional settings Date Time & seconds to be the same as the Y2K server and all networking works perfect now.

    What time & Date has to do with networking beats me!!!! WINDOWS 7 NOT MY IDEA

    Friday, September 17, 2010 12:24 PM
  • OMG I can not believe that was the solution! how silly of us not to realise all computers should be connected to the same time server (note: I was in the same time zone, but that's not good enough for windows)

     

    makes me wonder if this was something popped in to make us poor users tear our hair out in frustration...

    Wednesday, September 22, 2010 9:26 PM
  • The solution may be simpler then you think. I just spent days banging my head against the wall trying to figure it out and here what I found:

    Make sure the clocks are in sync on Win 7 and Win2K boxes. Thats all it is. My Win2K clock was 2 hours two fast. Once I changed the time I was able to connect with no problems. I actually validated that by changing the clock again I had re-introduced the problem.

    Happy sharing!

    big_nk.

    I had already started banging my head against the wall just as i'm sure you did. All the network sharing parameters seemed to be in order, but it still was not accepting my usual administrator credentials over the network. Then i realized that the timezone for this laptop is different than where i am because the user is going to be using it in Hawaii, not Pacific time.

    I changed the timezone and now our shared resource takes the password! It would have been nice if stupid windows 7 would report there is a time discrepancy, and not just a bad username / password combination. Another useless error message.

    Thanks for the great post!

    Wednesday, October 13, 2010 7:37 PM
  • Although this may be a work around, this is NOT a solution.  I have a stand alone server, off my domain, specifically for the purpose of changing the time to test our code.  The only purpose of this server is so that we can make the date months in advance to test software that is time sensitive.  I still need to access shares on this box from my Windows 7 machine.  It was never a problem with XP, why is it now a problem with Windows 7?

    There's got to be a policy or registry setting to allow this to happen, don't you think? 

     

    Thursday, October 14, 2010 6:45 PM
  • u r really big :D 10x man it works :D
    Monday, October 18, 2010 11:32 AM
  • This isn't helpful - the search terms do not bring up any programs, and I can't find all the settings mentioned.
    Saturday, October 30, 2010 10:19 PM
  • Kerberos uses a ~5 minute window.
    Monday, November 15, 2010 5:07 AM
  • Great Answer, worked perfect- thanks just wondering why they made it so elaborate.

    Rundavo

    Monday, December 20, 2010 11:15 PM
  • I am having a similar issue.  I can not connect from the Windows 7 machine to an XP allow I can see them.  I can access the 7 from the xp's.   I followed your instructions typing secpol.msc into the search bar.  Nothing found
    Thursday, December 23, 2010 1:07 PM
  • This worked for me!!

    Friday, January 14, 2011 7:47 PM
  • The solution may be simpler then you think. I just spent days banging my head against the wall trying to figure it out and here what I found:

    Make sure the clocks are in sync on Win 7 and Win2K boxes. Thats all it is. My Win2K clock was 2 hours two fast. Once I changed the time I was able to connect with no problems. I actually validated that by changing the clock again I had re-introduced the problem.

    Happy sharing!

    I spent hours to solve this problem until I read this helpful answer. Thanks a lot, you save my life.
    • Proposed as answer by lairg Monday, January 31, 2011 4:12 AM
    Monday, January 31, 2011 4:04 AM
  • Hi all,

     

    Just found this forum, and try to follow all the suggestions above. But unfortunately, I didn't find the solutions, IMHO maybe because win 2003 has been updated into new patch.

    editing secpol.msc, gpedit.msc,  do a time synchronization between win 7 and win 2003. But still..got a zero result.

    anyone can sharing another method?

    FYI, When I try to open my server (\\server\) it's appear an error message :

    \\server\ is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

    Logon failure: user account restriction. Possible reasons are blank passwords not allowed, logon hour restrictions, or a policy restriction has been enforced.

     

     

    Monday, January 31, 2011 6:05 AM
  • hello,

    I have windows 7 Ultimate and I'm having the same problem cannot connect to my shared folders on my Windows Home server. I tried entering secpol.msc and gpedit.msc and there are no matches. Any help this is a problem I cannot figure out. Thanks in Advance

    On my Windows Home Server, under computer>properties> it says Power pack 2, but under WHS console it shows Power pack 3, not sure why. The remote desktop works fine

    GDips


    gary w dipple
    Tuesday, February 01, 2011 2:51 AM
  • The solution may be simpler then you think. I just spent days banging my head against the wall trying to figure it out and here what I found:

    Make sure the clocks are in sync on Win 7 and Win2K boxes. Thats all it is. My Win2K clock was 2 hours two fast. Once I changed the time I was able to connect with no problems. I actually validated that by changing the clock again I had re-introduced the problem.

    Happy sharing!

    Hahahahaha amazing !!! That fixed it for me! 

    Thanks for your help!

    Diego.

    Friday, February 11, 2011 1:32 PM
  • Hi All!!

    I just tested your recommendation settings/Policies (from Bubbapcguy) but the problem is still there.

    I can access the Windows 2000 Computer from a machine with Windows Xp, but no with computers with Windows 7.

    Date and Time are the same and correct.

    I also tried this: http://www.sevenforums.com/network-sharing/152566-windows-7-can-t-access-windows-2000-share.html

    Any help or guide would be really appreciate it.

    Thanks!


    abasilis
    Tuesday, March 29, 2011 5:45 PM
  • Checked server clock vs. client clock.  They were about 5 minutes off so we trued them up.  That did not solve the problem. 

     

    Tried the following step and it immediately solved the problem:

    Browse to "Local Policies" -> "Security Options".  Now look for the entry "Network Security: LAN Manager authentication level" and open it.  Click on the dropdown menu and select "Send LM & NTLM - use NTLMv2 session security if negotiated".  Apply the settings.

    The weird thing is, this computer has been working on the network for a few months and the problem just appeared this morning.

     

     

    Thursday, March 31, 2011 4:45 PM
  • Ok I don’t know if this is the same problem or not but I can see my windows 2000 server and access it or maybe not.  I can’t see the shared folders that are on the server, when I click on the server thru the network it opens up but that’s it….. I don’t get error or anything asking for passwords I just can’t see folders.  Now we are in the same workgroup.

    I also changed the clocks too mine was five minutes off. I even followed the steps "Bubbapcguy" suggested.

    I did change my network security levels on both server and pc too, is there anything I’m missing?

     

    Thursday, April 07, 2011 2:50 PM
  • what computer do i chk local polices on the windows 7 home or the server 2003

     

    Thursday, May 05, 2011 5:40 AM
  • The solution may be simpler then you think. I just spent days banging my head against the wall trying to figure it out and here what I found:

    Make sure the clocks are in sync on Win 7 and Win2K boxes. Thats all it is. My Win2K clock was 2 hours two fast. Once I changed the time I was able to connect with no problems. I actually validated that by changing the clock again I had re-introduced the problem.

    Happy sharing!
    This worked when everything else did not !!!!!!
    Tuesday, May 17, 2011 2:14 PM
  • Everyone: the bubapcguy-suggested steps are not needed.

    I have several workgroup servers (windows 2008 and 2008r2) that I connect to without any problems, from windows 2003, 7, or OS X. This morning I could not connect to the share of the new server, kept getting access denied messages from all client systems (even tho I could connect via remote desktop). When I tried to connect via NET USE command line, got an incredibly useful "System error 5 has occurred." message. Knowledge base on this error gives completely random responses, shooting in the dark. 

    Finally, realized that I forgot to turn off (the laughably useless) "User Account Control;"  as soon as I did that and rebooted, I could connect to shares normally. Comparison with other servers shows that was the only difference that prevented access.

    So, to cut a long story short, turn off UAC if the time sync suggestion doesn't work.

    Hope it helps someone. (if you can't get a mac, which I highly recommend).


    Friday, May 20, 2011 10:03 AM
  • Still not work for my computer. I follow every step above.

    Friday, July 01, 2011 9:18 AM
  • Windows 7 Home Premium does not have secpol.msc or gpedit.msc modules available.  You have to have the Windows 7 Ultimate or Professional versions.  Can you formulate an answer that will help Windows 7 Home Premium users?  I think Microsoft missed the mark when they assumed that home users would not want or should not be able to network with other computers at their homes that are running XP or Vista.  I'm getting this Microsoft is a bully to the home user feeling.
    Saturday, July 23, 2011 5:08 PM
  • Try disabling UAC and check what happens (you need a reboot)

    or explicitely allow acces for the 'admin'-user (not its group but the user-account).

     

    Frits van Drie

    MCT

    Monday, July 25, 2011 12:11 PM
  • does no one here search for answers???
    answered here many times...

    click the start button and type secpol.msc in the search function.

    Browse to "Local Policies" -> "Security Options".  Now look for the entry "Network Security: LAN Manager authentication level" and open it.  Click on the dropdown menu and select "Send LM & NTLM - use NTLMv2 session security if negotiated".  Apply the settings.

    In the Advanced sharing settings page of Network and sharing center, you need to have it set as Work/Home profile.  Try

    -Enable network discovery
    -Turn on  file and print sharing
    -Turn off password protected sharing
    -Use user accounts and passwords to connect to other computers

    The other settings such as encryption I have set as use 128 bit encryption.

    Please check related policies.

    1. Enter “gpedit.msc” in the Start Search box.
    2. Open “Computer Configuration”/Windows Settings/Security Settings/Local Policies/Security Settings.
    3. In the right pane, enable the following policies:

    Network access: Allow anonymous SID/name translation
    Network access: Let Everyone permissions apply to anonymous users

    Also please disable the following policies.

    Network access: Restrict anonymous access to Named Pipes and Shares
    Network access: Do not allow anonymous enumeration of SAM accounts
    Network access: Do not allow anonymous enumeration of SAM accounts and shares


    So what when this doesn't work?

    I have searched and searched for a solution to my problem but no-one seems to have an answer, so let me give you the rundown. I have three computers, one running Windows 7 Professional 64bit, one with XP Home 32bit and one with Vista Home Premium 32bit. They all show on each others Network windows as being there. I can access files and folders in  the Public folder in Windows 7 from XP and Vista, I can even see other files and folders but I can't access them. This would appear to be part of Microsoft's policy to exclude access to Windows 7 files and folders unless they are transferred to the Public folder but that is no problem. I can access files, folders and printers between XP and Vista. In the past, before Windows 7, I had absolutely no problem with networking and in fact was quite a wiz at setting up networks for community centres and friends. Why is it that whatever I try I just cannot get Windows 7 to play ball? I even went overboard recently and purchased a downloadable publication from a guy in America who claimed he had all the answers and would have me up and running in no time. Two weeks later and after much to-ing and fro-ing via emails he gave up and refunded the purchase value of the publication. That says it all and I am still struggling to solve this problem. Ask me a pertinent question and I guess I have tried that, so this just about sums it up ... until Windows 7 appeared on the scene networking was easy-peasy. Why did Microsoft have to mess up something that worked and worked well? This in fact is my only criticism of Windows 7, all else is fine and I love it so why don't Microsoft sort this out and take us back to what really did work. One can tell by the number of forums and feedbacks on this subject that it is a BIG BIG problem and won't go away until someone at Microsoft see how serious it is and do something about it ... pronto!! And Microsoft, please, please don't bring out another version of Windows to justify your actions, just issue a patch that will put things right!!

    PS. I have also run a little free utility by the name of Wireless Network Watcher and all three computers show their relevant IP addresses and MACs, what else can one do?

    PPS. As a challenge I am even willing to put my Windows 7 computer on the line and give access to any Microsoft expert who thinks he/she has the answer, that's how frustrated I am over this. I am now entering my 77th year and would like to spend some of the time enjoying my retirement, not slogging away at something like this.


    Tuesday, August 02, 2011 6:42 PM
  • A year and a half later, and I'm struggling with - no, defeated by - the same problem. Win7 H-P x64 on a Lenovo laptop sees a Vista box on the workgroup, but will not access it, while XP machines have no problem. I get the broken log in error, when both accounts in question have the same login info, and sharing passwords are disabled. Digging down, the error was "this account does not have permission to access...".

    I spent an intense week half a year ago, up against the same problem, trying to share with a Linux install. I finally had to give up.

    I've tried the fixes here, including the clock set. H-P doesn't support changing the method of authorization. So quite simply, I'm out of options.

    Very evidently, MS thinks it is uninportant that the H-P user have a reliable file share function on the LAN. My opinion is that they are carrying the forced upgrade to higher versions WAY too far.

    Wednesday, August 03, 2011 12:40 PM
  • A year and a half later, and I'm struggling with - no, defeated by - the same problem. Win7 H-P x64 on a Lenovo laptop sees a Vista box on the workgroup, but will not access it, while XP machines have no problem. I get the broken log in error, when both accounts in question have the same login info, and sharing passwords are disabled. Digging down, the error was "this account does not have permission to access...".

    I spent an intense week half a year ago, up against the same problem, trying to share with a Linux install. I finally had to give up.

    I've tried the fixes here, including the clock set. H-P doesn't support changing the method of authorization. So quite simply, I'm out of options.

    Very evidently, MS thinks it is uninportant that the H-P user have a reliable file share function on the LAN. My opinion is that they are carrying the forced upgrade to higher versions WAY too far.


    paul1149 raises an interesting point here. I am running an HP Pavilion Slimline, could this have something to do with my problems? I wonder ...  
    • Proposed as answer by oppiman Wednesday, August 31, 2011 2:20 PM
    • Unproposed as answer by oppiman Wednesday, August 31, 2011 2:20 PM
    Thursday, August 04, 2011 11:09 AM
  • Is this is still a problem?
    Here is my answer:

    If you run W7 and try to access a share on an "older" sytem like XP or server 2003/2000,
    and if your W7 is "only" the home edition,
    then try this:

    On your W7 home edition PC copy this text:

    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
    "LmCompatibilityLevel"=dword:00000001
    

    paste it into a new text file and save it as "enable_w7_access_xp_share.reg".
    Double-click on the enable_w7_access_xp_share.reg file and merge it into the registry.
    Now reboot your W7 PC.

    You should now be able to access shares on older windows again.


    Wednesday, August 31, 2011 2:26 PM
  • I have spent many hours with this Windows 7 sharing problem and have followed all the "answers" posted here and nothing have worked. This was until I stumbled across this post at, http://www.sevenforums.com/network-sharing/113133-0x800704cf-error.html

    It seems somehow Windows 7 has created hundreds of hidden network devices and hence has prevented proper file sharing. To check if this is your problem, Go to Device Manager, view show hidden devices. Then browse to > Network Adapters > and see if you have hundreds of "Microsoft 6to4 adaptors". This from what I gather is a bug since October 2010 when MS introduce some miniWifi adaptor update: http://support.microsoft.com/kb/980486

    In short,

    1) delete all of these useless devices, one by one, or follow this link http://www.ryanvictory.com/posts/automating-6to4-adapter-removal-in-windows/ for script file.

    2) go to your actual wifi network adaptor from network connections, right click, then status, then wireless properties, uncheck the "Enable WLAN connection settings" to ensure windows do not go creating more of these 

    3) Ensure you have all the basic network sharing set up correctly (i.e. enabling NetBIOS, same workgroup name, correct share permissions on share folders in each PC, enable file sharing...etc)

    4) I wouldn't adjust all the security policies as per the solution posted here either, it leaves a giant security hole and let everyone have guest (then everyone) access on you computer. (not required and didn't fix squat for me...)

    5) Restart you computer and with luck you can finally browse your network and then access your network share.

    This works for me, it may or may not work for you. I hope this is helpful to someone out there.

     


    • Proposed as answer by Seanixguy Sunday, September 04, 2011 4:33 PM
    • Unproposed as answer by Seanixguy Sunday, September 04, 2011 5:16 PM
    • Proposed as answer by KMN62 Monday, December 26, 2011 2:17 PM
    • Unproposed as answer by KMN62 Monday, December 26, 2011 3:34 PM
    Wednesday, August 31, 2011 11:16 PM
  • This is what worked for me. 

    1)  Go the Vista machine and right click on the folder you want to share and choose share. 

    2)  Under the security tab choose Edit. Then under the Group or user names click Add. 

    3)  In the Enter the object name box type in "everyone" then click OK.  Don't include the quotation marks.

        Then check full control if you desire,  and Apply in the Permissions box.

        It will go through applying the setting and it will state that permission is denied for some folders.  Keep hitting continue       until ti done. 

    Go back to the 7 machine and try to access you share.  Hope it works for you.

     

    Sunday, September 04, 2011 5:21 PM
  • Hello,

    I was having an issue going from my Win7 Pro 64 bit PC which was on a domain to another XP box that was only a member of a workgroup.  I keep getting a message that the user credentials were incorrect.  I tried many of the steps above, with no luck.  Going from my XP box to my Win7 worked fine though, as long as I provided correct user credentials.  Not what I ultimately wanted though.

    I then went to my XP box and opened up secpol.msc.  Under Security Setting->Local Policies->Security Options I went to the "Network Access: Sharing and security model for local accounts".  I switched my drop down to "Classic - local users authenticate as themselves" and rebooted.  I am now able to do a NET USE command from my Win7 box to the C$ on my XP box.

    Not sure if any of the other steps I did, as suggested as above, helped as well.  Perhaps this will help someone else too.

    Wednesday, September 14, 2011 3:22 PM
  • Hello,

    I was having an issue going from my Win7 Pro 64 bit PC which was on a domain to another XP box that was only a member of a workgroup.  I keep getting a message that the user credentials were incorrect.  I tried many of the steps above, with no luck.  Going from my XP box to my Win7 worked fine though, as long as I provided correct user credentials.  Not what I ultimately wanted though.

    I then went to my XP box and opened up secpol.msc.  Under Security Setting->Local Policies->Security Options I went to the "Network Access: Sharing and security model for local accounts".  I switched my drop down to "Classic - local users authenticate as themselves" and rebooted.  I am now able to do a NET USE command from my Win7 box to the C$ on my XP box.

    Not sure if any of the other steps I did, as suggested as above, helped as well.  Perhaps this will help someone else too.

    Wednesday, September 14, 2011 3:23 PM
  • The solution as outlined above does work, but what was Microsoft thinking when they did this?  It's insane to think that any ordinary users will be able to do this.  Essentially, they have disabled a function that many Windows users have come to depend upon without supplying any reasonable way to re-enable it.  In future versions of Windows they should provide a simple way for users to enable sharing to and from other computers, NAS devices, etc.  The current method is likely to be one more thing that drives people to buy Macs.
    • Edited by Lee I-B Sunday, November 27, 2011 8:10 PM
    Sunday, November 27, 2011 8:10 PM
  • Folks,

    I too had a problem not being able to see the home network shared folders and files on my Win7 computer unless a username and password were provided...which I didn't have because I never set up one...

    Out of frustration I've searched and tried all the solutions mentioned in this forum thread...

    • Fix the clocks -- didn't work because ALL my clocks on ALL my computers were synced to the same server and correct time
    • Change Registry Settings for LmCompatibilityLevel -- Couldn't try because I have Win7 Home Premium...
    • Remove "Microsoft 6 to 4 Adapters"  -- Only had one, but uninstalled it anyway....didn't work..

    What worked for me was:

    • CONTROL PANEL > NETWORK AND INTERNET > NETWORK AND SHARING > ADVANCED SHARING SETTINGS
    • Under HOME OR WORK profile, select "Turn OFF Password Protected Sharing"

    Given that it was a new/recently purchased laptop, I must have played with the security setting and selected "Turn ON Password Protected Sharing" unbeknownst of the affect it would have....

    Hope this helps somebody...

    KMN

    Monday, December 26, 2011 2:30 PM
  • I've tried all of the above where applicable with no success.

    I have windows 7 Professional, trying to connect to a computer with Vista Home Premium SP1. Both on Workgroup, Home/Work and Private location respectively.

    Just can't authenticate from Windows 7. Keeps wanting me to connect as \\myWindows7\myname which of course Vista has no knowledge of.  There seems to be no way to tell Vista about this user.

    does no one here search for answers??? 
    answered here many times...

    Yes a great thread to search for answers, but I think there are more solutions than answers.

    Wednesday, December 28, 2011 2:38 AM
  • Ok, I finally got my Windows 7 to work!

    1) I right clicked on the "drive" that I had set as shared, but was not sharing, and clicked "properties".

    2) I clicked on the "security" tab

    3)  Under "group or user names", "Everyone" was not showing up and this was my problem.  So if "Everyone shows up on your system, your problem may be different.

    4) I clicked on "Edit"

    5) I clicked on  "Add"

    6) I clicked on  "Advanced"

    7) I clicked in "Find Now"

    8) I scrolled down to "Everyone" and selected it, and clicked "OK" and then "OK" till I got back to the "Security Tab"

    9) I then clicked "Everyone" and then under "Allow", I ticked off the check boxes.

    10) I then clicked  "OK" and after it went through the files, it allowed me to share.

    I hope this helps someone.

    Wednesday, December 28, 2011 7:43 PM
  • Funny isn't it, when you read what you typed and get a new thought. So I realised that I might do better with Vista Home Premium SP2. After downloading and installing, I tried again with no success.

    However, a new thought popped into my head. Perhaps I should try entering the target computer name into the User Name box of the Network Logon dialogue. I entered myVistaTarget\myVistaName. Suddenly, the Domain-Name showing the name of the Windows 7 machine magically changed to the name "myVistaTarget". 

    With trepidation I clicked OK, and then the shares on Vista magically appeared.

    Problem solved!

    Still can't say exactly what the answer was, because I had previously tried logging on in this way, although not against Vista SP2. 

    So that's my take on it. Thanks all.

    Saturday, December 31, 2011 3:16 AM
  • thank you. the time zone answer solved my connection problem also.

     

    Monday, January 16, 2012 2:34 AM
  • Remember everyone if you ever changed your account name on your machine it will still hold its original name. i.e Matt change his account to Sarah... guess what use Matt for user name if accessing a share on that machine from another odds are it will work along with the password.  Also it should work for new user name and password as well but sometimes it gets funky and you have to use that old name and password.  The Everyone advice should do the trick along with password protected sharing disabled. One thing I'm not to sure of is if changing the the machines name will have same result as the same user name.
    Sunday, January 29, 2012 9:06 AM
  • I can't believe I spent almost an entire day trying to figure this out. Thank you big_nk!
    Monday, February 06, 2012 8:03 PM
  • bubba fix doesnt work for me. Really frustrating, been a network/system admin for 10 yrs, of course I dont have these problems on domains, but these are my personal machines at home, both running windows 7 pro. I have essentially a storage box (or file server) that runs windows 7 pro and used to be able to access it fine from all my other windows 7 pro machines. Originally I was able to figure out how to get windows 7 pro to do file sharing pretty easily without much trouble, fairly straight forward for me being exprienced doing this kind of thing. One day i just tried to connect and couldnt, all of a sudden. Maybe there were a few windows updates, but that its. the killer is, i can still connect to all of the other machines from my storage box, its just the other machines cant connect to this one no matter what i do. Even worse its a fairly new install, i did a wipe and fresh install not to long ago, because of this kind of issue. i figured windows was mucked up and didnt feel like wasting alot of time figuring it out, so i started over from scratch. now a few weeks later, here i am again. Worked fine for a few weeks, all of a sudden i cant access network shares. I tried this even though it worked the way it was....
    • Edited by b1ackhawk Saturday, February 11, 2012 1:43 AM
    Friday, February 10, 2012 10:42 PM
  • I just bought a new Windows 7 desktop last week and have been trying to hook up my network with my have 2 Windows XP laptops.

    My laptops both appear in my network on my windoes 7 computer, and i can access their files.

    The problem is My desktop was showing up on the laptops but I was denied permission to access, I followed the advice given here now my desktop doesn't even show up anymore. I tried reversing the settings but still nothing, but my laptops still appear on my desktop network list.

    What can i do to get this going? I need these networked.

    Is there a way to roll back my settings? would a system restore work?

    Monday, February 13, 2012 1:26 PM
  • I was experiencing this problem and tried the above - worked!  On a different computer with the same problem, no dice!  Therefore in addition to the above steps, I did the following:

    Set a static IP address for the computer:

     - First open command prompt and look up your current IP address (ipconfig /all)

     - Click on "Local Area Connection" then "Properties" then  "adapter settings" choose " Internet Protocol Version 4 IPV4"

     - Choose "Use the following IP address" and populate with what you noted using ipconfig prompt.

    - Now disable and enable the adapter.

    - Then go back through the same steps and choose "Obtain IP address automatically"

    These steps have worked for me on multiple computers.  Good Luck!

    Thursday, March 01, 2012 9:49 PM
  • For me, this turned out to be an issue (by design) with the new UAC (User Account Control) introduced since Vista.  A MS KB is available @ http://support.microsoft.com/kb/951016
    Saturday, March 10, 2012 8:49 AM
  • Glad you asked! Just be prepared to return to this forum because you won't be able to access your shares, on other window machines or servers for that matter on your network, unless you're using a high-end window system (Win 7 Pro and up), which apparently handles (or corrects) the problem, judging from comments here, including my own experience.

    This problem frequently occurs after a fresh windows install when you decide to change the computer name to something more descriptive then then one you selected during the install. You know you're in for a long night if the network ID icon, used to change the domain or workgroup name (which launches a wizard), is grayed-out. I only wish someone could comment on how to ungray it, because I've had several Windows PC retire with the icon still grayed-out. The basic problem I believe goes back to windows 95.

    If you follow the modifications to the Windows Security Police, other have noted here, that should fix the problem, at least that's been my experience. Its far better to create a new user account then to change the one originally created during the install. Microsoft has a article on how to do this, which calls for 3 users accounts. Basically, you transfer account info from the old account to the new account using an intermediate account (but never tried this); otherwise you have remnants of the old account all over the place, creating some unexpected problems or issues you didn't count on. 

    Changing the computer name appears to a far more common issue, but strangely no one seems to mention or talk about it!


    Jerree

    Thursday, March 15, 2012 2:05 AM
  • I have just updated my desktop system to a 64 bit system. The previous system was also Win 7, but 32 bit, and did not have this remote password problem.

    I went through all of the various suggestions given in these posts for username/passwd for a remote mount without success.

    However, your post re: User Name: Domain name\user name led me to experiment with different forms of the username.

    I was using - as I was on my previous system - the user name of my account on the remote system, and this did not work. Neither did adding the domain name as above, from your post.

    However, then it occurred to me that while my account name as I has set it up in the User Account control panel was "xxx", the only user name that showed up in c:/users was the name that the tech used to set up the system, say "yyy'.

    So I tried mounting the remote filesystem using the yyy username in C:/users with the password that I had created when I set up my account (xxx) in Control Panel -> User Accounts

    That worked.

    Why this is an issue on the new 64 bit Win 7 and not on the older 32 bit Win 7, I have no idea.


    • Proposed as answer by wejohnston Tuesday, May 08, 2012 4:07 AM
    • Edited by wejohnston Tuesday, May 08, 2012 4:07 AM
    Tuesday, May 08, 2012 4:07 AM
  • yep, it did for me today... hahahaha, I sync both my windows 7 workstation and 2003 server's time and I was able to connect. 
    Monday, May 28, 2012 4:06 AM
  • I've tried everything suggested here and still when I try and access my Win7 box named X3 from my Win7 box named X4, either in Explorer or by typing \\X3 in the run box, I get the "Windows cannot access \\X3" error.

    If I type \\X3\Downloads (which is a shared folder) I get the username/password box but whichever account I try in that I get the error "Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed".

    If I type \\192.168.1.66 in the run box it connects and opens Explorer showing all the shared folders on X3 just fine though. I've got no firewall on the X3 box (even disabled Windows Firewall) and Comodo Firewall on the X4 box, although I've tried disabling it. I can also connect to other machines from X4 without any problem just clicking on them in Explorer, so it's just the X3 box I'm having trouble with. All machines are in the "Workgroup" group and are using Static IP addresses.

    Hmm, I've just noticed that on X3, if I change the setting to "Turn off Password Protected Sharing" when I go back and check it, it's changed back to to "Turn on", so maybe that's the problem. I don't use Homegroups and in fact have the two Homegroup services disabled.

    Aha, I set a blank password on the Guest account and then Disabled it and now "Turn off Password Protected Sharing" sticks. However, when i go back and check the Guest account is enabled again and if I disable it again "Turn on" gets checked again, so it seems these two settings alter the other one. Anyway, in either state I still have the same problem accessing X3 by name.

    I just tried rebooting X3 in case that was necessary and now it's gone back to "Turn on Password Protected Sharing" and it wouldn't stick to "Turn off" even if I disabled the Guest account until I set a blank password again (I tried setting a non-blank password before rebooting). Still can't access X3 with it set to "Turn off"!

    Monday, May 28, 2012 8:41 PM
  • Big_nk   you are a goooddd , I have  been troubleshooting thiss  for a few  hours  and the solution was  very simple like  you said,   THANK  YOU..

    Thursday, May 31, 2012 4:11 PM
  • did not have to the 6to4 adapter 

    BUT uninstalled all adapters, then rescanned for hardware 

    and yippee !

    all working again 

    Thursday, June 07, 2012 1:53 PM
  • big_nk

    hey man you ROCK

    Thursday, June 21, 2012 10:06 AM
  • and I am still struggling to solve this problem. Ask me a pertinent question and I guess I have tried that, so this just about sums it up ... until Windows 7 appeared on the scene networking was easy-peasy. Why did Microsoft have to mess up something that worked and worked well? This in fact is my only criticism of Windows 7, all else is fine

    I absolutely agree about this networking issue. I've just wasted many hours over the course of several days, simply trying to get two Windows 7 Ultimate systems to share a single folder. I've tried every suggestion in this thread and in several others. No success. This is UTTERLY ABSURD!! This should be a two-click operation. Instead, even an expert Windows users like myself is forced to admit defeat.

    Unfortunately, I can't agree that "all else is fine." I've just spent a week entering one registry hack after another, simply in order to fix things in Win7 that should absolutely never have been broken. Today, I read that Microsoft bought Yammer, for $1.2 billion. That money might have been just about enough to fix all the stupid problems in Windows and Office. But Microsoft continues to chase the phone business, the tablet business, the social networking business... even while it loses all its original competency in the software business. I now look forward to the day when it finally goes out of business, so I can come and dance on the ashes.

    Tuesday, June 26, 2012 1:16 AM
  • Try this:

    Go to the root of your folder... for example the root of the C drive is c:\

    Now right click on the folder select Properties and then select the Security Tab

    Click Advanced and then the Owner Tab. 

    Click Edit.  Click "Other users or Groups"  If you have a locations, click the local which is the same as the name of your machine (you have to be an administrator to do this)

    In the Select User or Group Window, Click Advanced.

    In the Dialogue, click teh "Find Now"

    Slide down to the User called "SYSTEM"  Select SYSTEM  Click OK  Click OK again

    Now you are back in the Advanced Security Settings for Local Disk (C:) (or whatever drive you are fixing permissions on)

    Check the box that says "Replace owner on subcontainers and objects

    Click Apply.

    You will need to nurse the dialog as there will be some objects that explicitly deny (like in the Users folders) but for the most part, you can allow the SYSTEM to have full access to your machine.   This should allow your other logins like Administrator and YourName, etc. to have their default permssions back the way you expect them to be.  Then set your permissions the way you think you need them and remember that this will get you back to ground zero in a jiffy if you need it again.   You may need to repeat the effort on all the boxes you are sharing.  The likelihood that the SIDs are crossed up is one answer and would explain why the denial but the reset to system should help.   If you still have a problem after that, you may want to start looking at Hiren's and think about a reinstall on the box with the messed up SIDs (given that Hiren's wasn't the cause of the problem in the first place).   But the method above has worked for me when other's have failed.  BubbaPCGuy seemed to know right off it was a SID problem and the advice he gave seems best in the list of ideas here.

    Good luck.


    R, J





    • Edited by Crakdkorn Tuesday, June 26, 2012 1:41 AM
    Tuesday, June 26, 2012 1:24 AM
  • Thanks Dave,

    I traveled the same road as you and things turned out well.  I did not have to change anything on the Windows 7 machine.  It took me some time to read through all the post but it was well worth the time.  Thanks again!

    Greg...

    Monday, July 02, 2012 1:02 PM
  • Has anyone got any ideas how to fix the problem with my X3 box shared folders not being accessible by name, only by IP address?
    Monday, July 02, 2012 1:45 PM
  • You are Genuius>> Thank you > Works fine for me.Ohhhhhhhhhhh

    Thanks again

    Tuesday, July 10, 2012 4:35 AM
  • Thanking you sir


    May Allah bestow knowledge upon you,


    thanking you

    Wednesday, July 11, 2012 10:03 AM
  • Hello Filip,

    I was struggling with the problem that I was not able to access my desktop using my laptop. Your comment worked great and the problem was solved.

    I would like to leave here this link:

    http://www.ryanvictory.com/posts/automating-6to4-adapter-removal-in-windows

    In this page, it is possible to download a tool to remove all the 6to4 drives automatically. In my case I had more than 160 drives and each one takes more than 1 minute to be removed. Using this tool the time is almost the same but the batch works by itself and it is possible to leave the computer running during the night.

    Thank you for your comments! save a lot of my time.

    Tuesday, August 28, 2012 10:41 PM
  • The solution may be simpler then you think. I just spent days banging my head against the wall trying to figure it out and here what I found:

    Make sure the clocks are in sync on Win 7 and Win2K boxes. Thats all it is. My Win2K clock was 2 hours two fast. Once I changed the time I was able to connect with no problems. I actually validated that by changing the clock again I had re-introduced the problem.

    Happy sharing!
    It works, wonderful THX a lot
    Thursday, October 04, 2012 7:12 PM
  • Thanks a million.....I've spent hours searching for an answer, then I found this :-)
    Friday, February 08, 2013 11:58 PM
  • Thank you big_nk. 

    The clock on the office Win2K3 Server was 5 seconds behind the clock on my Win 7 laptop/workstation. I advanced the server clock the 5 seconds and voila!  Can't believe I wasted hours and hours on this.  What made me think the internet was always updating the clock on both machines?  Hmmm.  Anyway, I'm now officially operating 5 seconds ahead of current time according to timeanddate.com.  Maybe I can correctly predict stock prices now. :)


    Burton Roberts

    Saturday, March 09, 2013 4:41 PM
  • I searched on tech net but not this site.. thanks of the answer I will let you know how it works...
    Wednesday, May 08, 2013 10:49 AM
  • does no one here search for answers???
    answered here many times...

    click the start button and type secpol.msc in the search function.

    Browse to "Local Policies" -> "Security Options".  Now look for the entry "Network Security: LAN Manager authentication level" and open it.  Click on the dropdown menu and select "Send LM & NTLM - use NTLMv2 session security if negotiated".  Apply the settings.

    In the Advanced sharing settings page of Network and sharing center, you need to have it set as Work/Home profile.  Try

    -Enable network discovery
    -Turn on  file and print sharing
    -Turn off password protected sharing
    -Use user accounts and passwords to connect to other computers

    The other settings such as encryption I have set as use 128 bit encryption.

    Please check related policies.

    1. Enter “gpedit.msc” in the Start Search box.
    2. Open “Computer Configuration”/Windows Settings/Security Settings/Local Policies/Security Settings.
    3. In the right pane, enable the following policies:

    Network access: Allow anonymous SID/name translation
    Network access: Let Everyone permissions apply to anonymous users

    Also please disable the following policies.

    Network access: Restrict anonymous access to Named Pipes and Shares
    Network access: Do not allow anonymous enumeration of SAM accounts
    Network access: Do not allow anonymous enumeration of SAM accounts and shares


    ^ ^ ^ This worked for me! Thank you.
    Monday, May 27, 2013 3:13 AM
  • does no one here search for answers???
    answered here many times...

    click the start button and type secpol.msc in the search function.

    Browse to "Local Policies" -> "Security Options".  Now look for the entry "Network Security: LAN Manager authentication level" and open it.  Click on the dropdown menu and select "Send LM & NTLM - use NTLMv2 session security if negotiated".  Apply the settings.

    In the Advanced sharing settings page of Network and sharing center, you need to have it set as Work/Home profile.  Try

    -Enable network discovery
    -Turn on  file and print sharing
    -Turn off password protected sharing
    -Use user accounts and passwords to connect to other computers

    The other settings such as encryption I have set as use 128 bit encryption.

    Please check related policies.

    1. Enter “gpedit.msc” in the Start Search box.
    2. Open “Computer Configuration”/Windows Settings/Security Settings/Local Policies/Security Settings.
    3. In the right pane, enable the following policies:

    Network access: Allow anonymous SID/name translation
    Network access: Let Everyone permissions apply to anonymous users

    Also please disable the following policies.

    Network access: Restrict anonymous access to Named Pipes and Shares
    Network access: Do not allow anonymous enumeration of SAM accounts
    Network access: Do not allow anonymous enumeration of SAM accounts and shares

    After alot of troubleshooting, i tried this above step, trying to fileshare off and on a homegroup. 

    Disabling firewalls, i found the machine that was causing the issue which was the host machine had 'babylon' and IE10 so after assuring Babylon was completely removed restarting the machine while both machines were still not attached to a home group it still failed, so last effort was to uninstall IE10 and roll it back to version 9.

    Funny enough this resolved the issue after restart, i re installed IE10 and the issue re-occurred. 

    Saturday, June 29, 2013 1:45 AM
  • Mine beats it, I only had a 5 minutes difference... Hail to the Bill (?)
    Thursday, October 17, 2013 1:50 PM
  • Thank you very much for your share.. resolved with your simple solution

    Thursday, December 19, 2013 11:04 AM
  • its so simple .. just match date of your computer with server and done ,, dont try anything...

    Thursday, December 26, 2013 10:58 AM
  • This is the answer that worked for me.  The clock on the computer I was having the problem on was 2 years out of sync.  Updating the date and time did it for me.  
    Wednesday, April 30, 2014 6:14 PM
  • Everyone: the bubapcguy-suggested steps are not needed.

    I have several workgroup servers (windows 2008 and 2008r2) that I connect to without any problems, from windows 2003, 7, or OS X. This morning I could not connect to the share of the new server, kept getting access denied messages from all client systems (even tho I could connect via remote desktop). When I tried to connect via NET USE command line, got an incredibly useful "System error 5 has occurred." message. Knowledge base on this error gives completely random responses, shooting in the dark. 

    Finally, realized that I forgot to turn off (the laughably useless) "User Account Control;"  as soon as I did that and rebooted, I could connect to shares normally. Comparison with other servers shows that was the only difference that prevented access.

    So, to cut a long story short, turn off UAC if the time sync suggestion doesn't work.

    Hope it helps someone. (if you can't get a mac, which I highly recommend).


    Good grief, that did it for me (after doing ALL of the other gpedit changes, the time sync, etc). Geeesh!

    Thank you, Radovan! (and all the others, as well)

    Monday, August 04, 2014 9:40 PM