none
No sync partnership for second user that logs onto Windows 7 SP1 workstation - Offline Files

    Question

  • We have have setup offline files in our network by configuring the appropriate GPO's.

    When a user logs onto a freshly installed windows 7 SP1 workstation the sync partnership is present.

    When that users logs off and then another user logs on, there is no sync partnership present for that other user.

    A gpresult /r run under that other user shows that all the appropriate GPO's have been applied successfully.

    The only solution I've found so far is to do a format of the offline files cache.

    Is this a bug?

     

    Offlines files has been configured so that offlines files is permanent offline in a slow connection mode.

    This is an overview of the Computer GPO:

     

    Configure Background Sync >Enabled  

    Configure background sync: 

     

    Sync Interval (minutes) > 5 

    Sync Variance (minutes) > 2 

    Maximum Allowed Time Without A Sync (minutes) > 7 

    Blockout Start Time (HHMM) > 0 

    HHMM is a value where 

    HH must be between 0 and 24, and 

    MM must be between 0 and 59. 

    Blockout Duration (minutes) > 0 

    Enable Background Sync for shares in user selected "Work Offline" mode > Disabled 

     

    Configure slow-link mode > Enabled  

    UNC Paths: >   

    \\servername\home$ Latency=0 

     

    Default cache size > Enabled  

    Default cache size:>  8000 

     

    Non-default server disconnect actions > Enabled

     

    Specify non-default actions for servers that become unavailable> 

    \\dfspath\Data > 1 (Never go offline. Server's files are unavailable to local computer) 

     

     Turn on economical application of administratively assigned Offline Files > Disabled 

     

     

    This is an overview of the User policy:

     

    Administratively assigned offline files > Enabled  

    Specify network files and folders that are always available offline:> 

    \\servername\home$\%username%  

    Remove 'Make Available Offline' > Enabled 

     

     

     

     


    Thursday, April 07, 2011 2:54 PM

Answers

  • The permissions on both the server as well as the client side are correct. 

    In the mean time i have found a solution for this problem.

    It appears that if the first user logs on and simply sets its homedirectory offline, then logoff and login as another use, that other user cannot get to his/her home directory.

    If you then login as the first user again en simply switch it's homedirectory to online, then logoff and login as the other user the homedirectory of that user can be reached again.

    Apparently offline files works like this: It takes the the whole \\servername\home$ and puts it offline as a whole, including every folder that is underneath the home$ share, which includes every homedirectory of every user.

    This also made me solve the problem. If i simply make the home directory of each user a share and configure offline files to use \\servername\%username%$, there is no problem. Apparently only "\\server\share1" is treated as an independent item that allows it to be switched offline/online without causing another "\\server\share2" path to be switched to offline/online.

    Can you please confirm that my finding are correct?








    Monday, April 18, 2011 9:03 AM

All replies

  • Hi,

     

    Thanks for posting in Microsoft TechNet forums.

     

    Windows does not copy the Access Control List (ACL) of any file during synchronization.  As a result, sometimes access is given, and sometimes not.

     

    Windows will cache permissions for the current user regardless of any other circumstances:

     •User who clicks the file command, “Make Available Offline,” while in online mode.

     •User who accesses a file that is already made available, while in online mode.

     

    When I say “accesses a file”, it can be a variety of actions that cause the permissions to be cached.  Opening the file always seems to work, as does viewing the file’s properties.  For certain types of files, simply highlighting the file’s icon in Explorer can cause the permissions to be cached, and for images it will happen when thumbnails are generated.  Deleting the Thumbs.db file in a folder may be a valid strategy for forcing the offline permissions to update for a small folder of images.  After the permissions are cached for the second user of a file, both users will be able to use that file normally in offline mode.

     

    This workaround is not viable for large file sets or situations where newly created files need to be synchronized automatically.  The file synchronization system is fundamentally flawed because it does not cache the ACLs or even the permissions of the current user.

     

    Best Regards

    Magon Liu

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, April 11, 2011 9:09 AM
  • I don't think ACL is the cause for a sync partnership not to be present for a second or third user that logs on. 

    Only the homedirectory of a user is made offline available , so the users that logon to the workstation do not share any files with eachother.

    Monday, April 11, 2011 9:52 AM
  • Can anyone try to reproduce this problem?
    • Marked as answer by ruudboek Tuesday, April 12, 2011 8:17 AM
    • Unmarked as answer by ruudboek Tuesday, April 12, 2011 8:18 AM
    Monday, April 11, 2011 9:53 AM
  • Ok, i was able to find the cause for this problem.

    It appeared to only occur to home directories that are present on a netapp file server that has an firmware (ontap) version that is not windows 7 tested.

    Also the problem only occurred when the first sync was fully executed for the first logged on user. If you log on as the first user and then quickly logoff before the first sync was finished, you are able to logon as a second user and the sync partnership will then be present for that second user.

    Strange problem though.


    • Marked as answer by ruudboek Tuesday, April 12, 2011 8:18 AM
    • Unmarked as answer by ruudboek Thursday, April 14, 2011 8:52 PM
    Tuesday, April 12, 2011 8:18 AM
  • Ok, i think i made a mistake with my test setup, the computer test policy did not came through. I tested it again and i get the same problem on the windows file server. So it is not limited to the netapp file server.

    I found out that when i remove this policy, the problem does not occur:

    Configure slow-link mode > Enabled  

    UNC Paths: >   

    \\servername\home$ Latency=0 

    However, we need that policy, because the pingtimes on our fileserver fluctuate too much in order for offline files to be able to reliably determin when to go into slow link (offline) mode or not.

    Also, a lot of users work in offices abroad with slow networks, that require their homedrive to be offline at all times (slow link mode) in order to provide sufficient performance for opening files.

    Can someone please help me out here?


    Thursday, April 14, 2011 9:53 AM
  • Hi,

    I think this is server side invoved,please refer to http://support.microsoft.com/kb/842007.

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, April 15, 2011 5:49 AM
  • This problem has nothing to do with that article. Why don't you try to reproduce the problem first?

    Friday, April 15, 2011 7:49 AM
  • The file is locally stored. Users that have correct permission can see the offline files. Please check the permission of the user on both client and server side to check.

    Also go to sync center and check if there is any conflict.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, April 18, 2011 8:13 AM
  • The permissions on both the server as well as the client side are correct. 

    In the mean time i have found a solution for this problem.

    It appears that if the first user logs on and simply sets its homedirectory offline, then logoff and login as another use, that other user cannot get to his/her home directory.

    If you then login as the first user again en simply switch it's homedirectory to online, then logoff and login as the other user the homedirectory of that user can be reached again.

    Apparently offline files works like this: It takes the the whole \\servername\home$ and puts it offline as a whole, including every folder that is underneath the home$ share, which includes every homedirectory of every user.

    This also made me solve the problem. If i simply make the home directory of each user a share and configure offline files to use \\servername\%username%$, there is no problem. Apparently only "\\server\share1" is treated as an independent item that allows it to be switched offline/online without causing another "\\server\share2" path to be switched to offline/online.

    Can you please confirm that my finding are correct?








    Monday, April 18, 2011 9:03 AM
  • Hi,

    Thank you for your updating. Your time and effort is appreciated. It sounds reasonable to me. You can post your comment here for a discussion.

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, April 20, 2011 9:58 AM