none
Your Internet security settings prevented one or more files from being opened

    Question

  • I have Windows 7 64 Bit SP1 Ultimate. I recently started seeing the error message "Your Internet security settings prevented one or more files from being opened" when I closed Internet Explorer. This error now comes up every time I close Internet Explorer. At first I just ignored it, but now I can't install some software that I need. After the initial few steps of the software, Windows stops the process and gives me the above error but about the file I am trying to install.

    I have tried

    • uninstalling my virus scanner (AVG)
    • Put my IE internet settings on the lowest security setting
    • Explicitly, setting the setting "launching applications and unsafe files" to enable everywhere
    • Restored a previous restore point (alas the only one I had was probably after the problem started occurring)

    What can I do? What would cause this?

    Thursday, August 11, 2011 10:31 AM

Answers

  • Hi,

     

    It seems this is just related to the user settings; try to reinstall Internet Explorer to see the result:

     

    Go to Control Panel\Programs and Features\Turn Windows features on or off. Uncheck Internet Explorer 8, click OK and reboot. And then go to Windows features again and check Internet Explorer 8, reboot.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, August 15, 2011 7:44 AM
  • Export the registry( File, select export) to external media before making changes.

    Then you can always recover by importing the previous registry.

    Yeah. too late for that now. But, next time...

    You could try to open an elevated command prompt and run  sfc /scannow. I doubt that would help, but it's worth a try.

    Monday, August 15, 2011 11:41 AM

All replies

  • OK. So, it appears this problem was caused because my user profile was corrupt. I created a new profile and gave it admin priviledges and then I was able to install software.

     

    So, is there a way to repair a user in Windows 7?

    Thursday, August 11, 2011 11:02 AM
  • Try resetting the internet properties. 

    Go to internet Options > Advanced > then at the bottom click Reset...

     

    see if that fixes it

    • Proposed as answer by KroipyBill Wednesday, June 05, 2013 7:04 PM
    Thursday, August 11, 2011 12:52 PM
  • If you're sure that it was your user profile that was corrupt, then this should help:
    http://windows.microsoft.com/en-US/windows7/fix-a-corrupted-user-profile
    Kunal D Mehta - a Windows Server Enthusiast.
    Thursday, August 11, 2011 4:46 PM
  • "Try resetting the internet properties. Go to internet Options > Advanced > then at the bottom click Reset..."

    I've already tried playing with this stuff endlessly. It's nothing to do with IE. It's a corrupt user profile. Actually, I can tell you why.

    AVG (My virus scanner) told me I have a bad registry entry. AVG couldn't remove it. So, I jumped in to regedit and deleted the entry manual. I'm sure this is what @#$^ed my user profile. the only problem is that I idiotically forgot to write down the key that I deleted.

    http://windows.microsoft.com/en-US/windows7/fix-a-corrupted-user-profile

    I've already looked at this link. It's precisely what I DON'T want to do. This link basically just tells you to create a new profile and copy the files across. No. I'm looking for a tool or process to run over my profile and correct registry settings etc.

     

     

     

    Thursday, August 11, 2011 11:59 PM
  • Why does Windows let morons like me @#@# with important $@#$?

     

    Mac never lets me do this #$#$.

    Friday, August 12, 2011 12:00 AM
  • lol they tell you be very careful editing the registry if you don't know what your doing :)
    Friday, August 12, 2011 12:39 PM
  • Hi,

     

    It seems this is just related to the user settings; try to reinstall Internet Explorer to see the result:

     

    Go to Control Panel\Programs and Features\Turn Windows features on or off. Uncheck Internet Explorer 8, click OK and reboot. And then go to Windows features again and check Internet Explorer 8, reboot.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, August 15, 2011 7:44 AM
  • Export the registry( File, select export) to external media before making changes.

    Then you can always recover by importing the previous registry.

    Yeah. too late for that now. But, next time...

    You could try to open an elevated command prompt and run  sfc /scannow. I doubt that would help, but it's worth a try.

    Monday, August 15, 2011 11:41 AM
  • Hi, I'm having the same "Your internet security settings prevented one or more files from being opened" issue, but I can't open "Windows features on or off", a dos prompt, task manager, regedit, and so on. I tried restoring to previous setting from about 2 months ago, it failed, I tried another about 30 days back and it failed also. I have Win7 starter running on a HP Mini CQ10-525DX.
    • Proposed as answer by DrivenOG Friday, September 02, 2011 2:10 PM
    Thursday, September 01, 2011 1:40 PM
  • Hi, I'm having the same "Your internet security settings prevented one or more files from being opened" issue, but I can't open "Windows features on or off", a dos prompt, task manager, regedit, and so on. I tried restoring to previous setting from about 2 months ago, it failed, I tried another about 30 days back and it failed also. I have Win7 starter running on a HP Mini CQ10-525DX.
     After mainking a second account and getting the same error, I uninstalled everything I could, (.NET, Yahoo, Norton, etc.), nothing seemed to help. I gave up and sought outside help, but when they turned it on the second account was free to access programs now, the original was still giving the error. Using the 2nd account I was able to access HP's restore functions and was able to create an "out of the box image" on a flashdrive. Rebooted and the system reformatted the C: drive and reinstalled the softer to the "out of the box" state.
    Friday, September 02, 2011 2:25 PM
  • Just an update for everyone...I ran into the same problem, but it was only occurring with 1 single .exe.  I noticed there was a url name inserted in the name of the .exe (ie program_name_www.website.com.exe).  I fooled around with settings, etc with no luck.  Then I just renamed the .exe file to something simple like abc.exe and Windows allowed it to install without problems.  Just a note to everyone who may be able to avoid some of the more time consuming solutions.  :)
    Tuesday, March 20, 2012 12:57 AM
  • Just an update for everyone...I ran into the same problem, but it was only occurring with 1 single .exe.  I noticed there was a url name inserted in the name of the .exe (ie program_name_www.website.com.exe).  I fooled around with settings, etc with no luck.  Then I just renamed the .exe file to something simple like abc.exe and Windows allowed it to install without problems.  Just a note to everyone who may be able to avoid some of the more time consuming solutions.  :)

    It helped me.... will help u tooooooo
    Sunday, January 19, 2014 6:41 AM
  • You, sir, are a saint. That was easy. Thanks.
    Monday, January 27, 2014 10:12 PM
  • This worked for me!!!!!!!!!!!

    ; I was trying to install an executable from a network share and got the: Your Internet security settings prevented one or more files from being opened

    Tuesday, January 28, 2014 9:45 PM
  • I just had the same problem on my Windows 8.1, this had a really easy fix and wasn't really hard to find.

    Go to your IE Settings, 

    . G oto Security tab turn all the zones to Low.

    . Then go to Privacy Tab turn settings to low.

    . Now go to Advanced Tab then scroll down to the heading where Security is written ( probably after Multimedia )and check (tick) the first three Allow boxes.

    http://i61.tinypic.com/1zg9tdv.png

    Now Restart your computer and try to open the file you were trying to open earlier, it should work now.

    My firewalls, antivirus programs everything was enabled and i didn't mess with any registries. Did the above steps and it worked.

    Later on you can Reset your settings or manually change them back after you've opened/installed whatever you wanted to just to be on the safe side



    • Proposed as answer by Dhamee Thursday, April 24, 2014 10:25 AM
    • Edited by Dhamee Thursday, April 24, 2014 10:33 AM
    Thursday, April 24, 2014 10:24 AM
  • For Windows 7 I corrected the problem using the steps below.  Since Windows 8 is setup for touch screen you will need to find these controls. 

    Corrective Action.  Note that several of these steps require the computer to process the action and may take 20 minutes to complete, depending on the configuration. 

    DELETE INTERNET EXPLORER PERSONAL RECORDS

    (This step may not be necessary)

    Start Windows Operating System (OS) in Safe Mode (Restart windows using F8)

    Select “Start” button

    Select “Control Panel”

    Select “Internet Options”

    Select “Advanced” tab

    Select “Reset” tab for “Reset Internet Explorer settings”

    Select “Delete Personal Records”

    Select “Reset”

    DISABLE INTERNET EXPLORER

    If not in WINDOWS SAFE MODE start Windows OS in Safe Mode (Restart windows using F8) Select “Start” button

    Select “Control Panel”

    Select “Programs and Features”

    Select “Turn Windows Features On or Off” (Left pane)

    Uncheck IE# checkbox (# will be the IE version number)

    Select “OK”

    Reboot the computer

    RE-ENABLE INTERNET EXPLORER

    Windows OS will restart in normal mode, or select normal operation

    Select “Start” button

    Select “Control Panel”

    Select “Programs and Features”

    Select “Turn Windows Features On or Off” (Left pane)

    Check “IE# checkbox” (# will be the IE version number)

    Select “OK”

    Reboot the computer

    RESTORE YOUR DESKTOP

    Select “Start” button

    Select “Control Panel”

    Select “System & Security”

    Select “System”

    Select “System Protection”

    Select “System Restore”

    Select “Chose a different restore point”

    Select a restore point at least 2 weeks ago (Check “Show more restore points” checkbox, if necessary)

    Saturday, May 24, 2014 4:56 PM
  • i resolved this issue by renaming the root folder name . it was more than 58 charecters and i reduced it to 13 and i was able to execute the file.
    Tuesday, June 03, 2014 4:34 AM
  • same thing hit me, I had copied an EXE from my local to the c drive on a server I was remoted into. I copied it from my local TO the server rather than logging into the server and copying it FROM my local.......
    Thursday, June 12, 2014 9:26 PM