none
Nonpresent Devices in Device Manager not functioning in Windows 7

    Question

  • Hi All,

    Just made the jump to Win7.  I used to be able to start a command prompt and then type...

    set devmgr_show_nonpresent_devices=1
    cd\windows\System32
    start devmgmt.msc
    then show hidden devices within device manager

    ...to be able to see Non Present devices.  It appears that I'm no longer able to do so in Windows 7 from the command line.  I actually have to edit the global environemtn variables to successfully see what I need to see.

    Does anyone know why this is and how I can get this to function as before from invoking it from the command prompt (and yes I am running this as an admin account).

    Thanks!

    Sunday, June 13, 2010 7:37 AM

Answers

  • 1. Try running the temporary display as the Administrator, this way:

    Click the Windows Orb (Start) > All Programs > Accessories and right-click Command Prompt, then ‘Run as Administrator’. Type ‘set devmgr_show_nonpresent_devices=1’ (not the quotes but the space) and press Enter. Exit from the command prompt screen.

    Now right-click Computer > Properties > Device Manager (in the left pane), then click View > Show hidden devices.

    2. To permanently display the ‘Phantom‘ devices in DM, right-click Computer > Properties > Advanced System Settings > Advanced Tab > Environment Variables at the bottom. Click New and put devmgr_show_nonpresent_devices in the Variable Name and put 1 in the Variable Value and OK your way out.

    Alternatively, go to the Windows Orb (Start), type regedit, press Enter and in the left pane navigate to HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \Session Manager \Environment and add this key (Edit > New > String Value) DEVMGR_SHOW_NONPRESENT_DEVICES and give it a value of 1.

    If you want ‘Show hidden devices’ to be displayed permanently, add another registry key to HKEY….. above, make it a String Value named DEVMGR_SHOW_DETAILS and give it a value of 1.

    • Edited by BurrWalnut Sunday, June 13, 2010 9:52 AM Re-phrased my reply
    • Proposed as answer by Vivian Xing Friday, June 18, 2010 3:11 AM
    • Marked as answer by Vivian Xing Friday, June 18, 2010 3:11 AM
    Sunday, June 13, 2010 8:02 AM

All replies

  • 1. Try running the temporary display as the Administrator, this way:

    Click the Windows Orb (Start) > All Programs > Accessories and right-click Command Prompt, then ‘Run as Administrator’. Type ‘set devmgr_show_nonpresent_devices=1’ (not the quotes but the space) and press Enter. Exit from the command prompt screen.

    Now right-click Computer > Properties > Device Manager (in the left pane), then click View > Show hidden devices.

    2. To permanently display the ‘Phantom‘ devices in DM, right-click Computer > Properties > Advanced System Settings > Advanced Tab > Environment Variables at the bottom. Click New and put devmgr_show_nonpresent_devices in the Variable Name and put 1 in the Variable Value and OK your way out.

    Alternatively, go to the Windows Orb (Start), type regedit, press Enter and in the left pane navigate to HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \Session Manager \Environment and add this key (Edit > New > String Value) DEVMGR_SHOW_NONPRESENT_DEVICES and give it a value of 1.

    If you want ‘Show hidden devices’ to be displayed permanently, add another registry key to HKEY….. above, make it a String Value named DEVMGR_SHOW_DETAILS and give it a value of 1.

    • Edited by BurrWalnut Sunday, June 13, 2010 9:52 AM Re-phrased my reply
    • Proposed as answer by Vivian Xing Friday, June 18, 2010 3:11 AM
    • Marked as answer by Vivian Xing Friday, June 18, 2010 3:11 AM
    Sunday, June 13, 2010 8:02 AM
  • BurrWalnut,

    Option # 1 worked for me.  Thank you!

    Any idea why I have to right mouse click on the "Command Prompt" application within the accessories group and run as administrator?  The account I'm using is an admin already?  Any easier way to run the command prompt as admin?  I usually type cmd.exe in Run... in order to invoke the command prompt.

     

     

    Monday, June 14, 2010 3:30 AM
  • I'm glad it worked using Run as administrator. I’ve seen a post on how to create an elevated cmd prompt shortcut on the forum here, but didn’t bother to ‘digest it’.

    On the subject of security, it seems to be getting harder and harder to access our own machines. A new security dictionary could be written, including words like; password, administrator, ownership, permissions, user access control, elevation, true administrator, trusted installer and others I can't think of at the moment.

    Monday, June 14, 2010 6:50 AM
  • Hi,

    Requesting an application to run elevated is one of the Key scenarios for User Account Control (UAC). User Account Control (UAC) is a new security component from Windows Vista. UAC enables users to perform common tasks as non-administrators, called standard users, and as administrators without having to switch users, log off, or use Run As. A standard user account is synonymous with a user account in Windows XP. User accounts that are members of the local Administrators group will run most applications as a standard user. By separating user and administrator functions while enabling productivity, UAC is an important enhancement.

    For more information, please refer to: http://technet.microsoft.com/en-us/library/cc709691(WS.10).aspx#BKMK_S1

    Hope it helps.


    Vivian Xing - MSFT
    Friday, June 18, 2010 3:18 AM
  • Hello,

    Having a CMD prompt default to opening with administrator rights.

    Right-click on Command Prompt on the Start Menu and choose properties

    Choose Advanced button from the shortcut tab.

    Check the box that states Run as Administrator.

     


    Thanks, Darrell Gorter This posting is provided "AS IS" with no warranties, and confers no rights. Volume Activation documentation on TechNet http://technet.microsoft.com/en-us/windows/dd197314.aspx http://technet.microsoft.com/en-us/library/dd996588.aspx VAMT - Volume Activation Management Tool - Download link http://www.microsoft.com/downloads/details.aspx?FamilyID=ec7156d2-2864-49ee-bfcb-777b898ad582&displaylang=en
    Friday, June 18, 2010 11:36 PM
  • Darrell

    Thank you for that, I shall remember it now.

    Saturday, June 19, 2010 7:00 AM
  • ... which is good (getting harder and harder). Anything that runs by you inherits your permissions. So it will get muich harder for malicious software to reach system level. The UAC and ACL are the things that lured me to Windows back from 5 years of total GNU/Linux computing.

    These Features exist in all Windows NT derived OSes but in Vista and 7 things got much smarter.

     

    And configuring permissions better makes your system much more practical for multiuser computing (i.e. family members)

     

    PS I can't see the cursor inside the text box. Currently using Firefox 3.6.

    Cheers :)

    Monday, June 06, 2011 11:23 PM
  • 1. Try running the temporary display as the Administrator, this way:

    Click the Windows Orb (Start) > All Programs > Accessories and right-click Command Prompt, then ‘Run as Administrator’. Type ‘set devmgr_show_nonpresent_devices=1’ (not the quotes but the space) and press Enter. Exit from the command prompt screen.

    Now right-click Computer > Properties > Device Manager (in the left pane), then click View > Show hidden devices.

    2. To permanently display the ‘Phantom‘ devices in DM, right-click Computer > Properties > Advanced System Settings > Advanced Tab > Environment Variables at the bottom. Click New and put devmgr_show_nonpresent_devices in the Variable Name and put 1 in the Variable Value and OK your way out.

    Alternatively, go to the Windows Orb (Start), type regedit, press Enter and in the left pane navigate to HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \Session Manager \Environment and add this key (Edit > New > String Value) DEVMGR_SHOW_NONPRESENT_DEVICES and give it a value of 1.

    If you want ‘Show hidden devices’ to be displayed permanently, add another registry key to HKEY….. above, make it a String Value named DEVMGR_SHOW_DETAILS and give it a value of 1.


    l'uso della variabile di ambiente in windows 7 funziona
    Tuesday, July 03, 2012 2:24 PM