none
Prevent Windows 7 group by extensions when sorting in a CD

    Question

  • I have the following files in a CD:

    Document 001.zip
    Document 002.zip
    Document 003.rar
    Document 004.rar
    Document 005.rar
    Document 006.zip

    And that's is how they're sorted alphabetically in WinXP and any common sense will do. But Windows 7, first group them by extension, and then by file name, giving me this on ascent order:

    Document 001.zip
    Document 002.zip
    Document 006.zip
    Document 003.rar
    Document 004.rar
    Document 005.rar

    and this in descent order:

    Document 005.rar
    Document 004.rar
    Document 003.rar
    Document 006.zip
    Document 002.zip
    Document 001.zip

    Which is a quite stupid sorting. The weird thing this only happens on windows explorer while browsing a CD or DVD. So strange, that I can see properly sorted as the first example in a disk folder, burn then into a CD, and when browsing that CD just burned seconds before, I got the weird sorting. It's quite annoying when I have hundreds of files properly named but into different formats (same naming but different extensions like tiff, png, jpg, psd, bmp)

    Thursday, March 15, 2012 5:20 AM

Answers

  • Hi,

    It seems these files are sorted by extensions in Windows XP. However, the files only can be sorted by type in Windows 7 instead.

    As a result, I suggest you trying to cancel sort by extensions in Windows XP and view the result in Windows 7 again.

    Best Regards,

    Kim Zhou


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, March 21, 2012 1:17 AM
    Moderator

All replies

  • Hi,

    Please right click the blank area, choose “Group by”—“(none)”.

    Then, right click the blank area, choose “Sort by”—“Name”.

    Best Regards,

    Kim Zhou


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, March 16, 2012 8:27 AM
    Moderator
  • There is no grouping.

    I do right click on the blank area, "Group by"-"none", and then the grouping "files on disk", "files ready to be burn to disk" dissapear.
    If I do right click and choose "Group by" again, the options "ascendent" "descendent" are disabled.

    Then I try to sort by name the same happens. It sort by group. Same with sort by size or date, first sorts by size all ZIPs and then all RARs.
    Here is a pic, I have my OS in Japanese, but is a language pack, it was in english originally. Trust the first part of filename is exactly the same for all files.
    The context menu is the "group by", already selected "none".

    Friday, March 16, 2012 2:34 PM
  • Hi,

    It seems these files are sorted by extensions in Windows XP. However, the files only can be sorted by type in Windows 7 instead.

    As a result, I suggest you trying to cancel sort by extensions in Windows XP and view the result in Windows 7 again.

    Best Regards,

    Kim Zhou


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, March 21, 2012 1:17 AM
    Moderator
  • Why and how could I do that? This happens on my laptop with Win7. WinXP is on another PC, and I don't know how changing a setting in a different machine could fix this on my Win7. (by the way, the screenshot was from Windows7)

    Also, this happens only when browsing a CD. As I said, having the exact files on hard disk shows them correctly, but on the CD they are grouped by extension/type before sorting. Grouping is disabled too.

    So if I have File1.rar, File2.zip, File3.rar in a CD, with group disabled and sorted alphabetically ascendent I got this:

    File2.zip
    File1.rar
    File3.rar

    I copy&paste those three files on my hard drive, sort exactly the same way, and I got:

    File1.rar
    File2.zip
    File3.rar
    that is the way I expect it to behave. It's strange, so I ask here. Could be just a bug of Windows7?


    • Edited by Anon010101 Wednesday, March 21, 2012 6:55 PM
    Wednesday, March 21, 2012 6:52 PM
  • I am sorry to say it cannot be changed on Windows 7 site. I suggest re-burning a CD in Windows 7.

    Best Regards,

    Kim Zhou


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, March 29, 2012 9:01 AM
    Moderator