none
Cannot enable integration features

    Question

  • When I try to enable integration features I am prompted to log on after I enter my credentials I am re-prompted. I have tried both my domain and local admin accounts both fail. The local admin account is what I setup when creating the VM from scratch. I have Window 7 Enterprise as both my host and guest OS. Both the host and guest computers are joined to my company’s domain.

    Friday, December 17, 2010 9:00 PM

Answers

  • Hello,

    We have had a similar problem in our domain environment using Windows 7 Professional SP1 as both host and guest OS. In our case the problem lied in our strict Group Policy settings. The problematic setting was 

    Computer Configuration/Administrative Templates/Windows Components/Remote Desktop/Remote Desktop Session Host/Security/Always prompt for password upon connection
    

     

    We have had this setting enabled and facing the same problem you described. Disabling this setting in our VM GPO fixed the problem for us. I´m not entirely sure if this is due to preauthentication and VPC architecture being built upon RDP stack, nor I have not found any viable explanation, but you can give it a try. 

    Also you need to add the user account you want to use to connect into VM (Integration services credentials prompt) into Remote Desktop Users group.


    • Marked as answer by Chad Lausier Wednesday, March 30, 2011 1:47 PM
    Wednesday, March 30, 2011 12:48 PM

All replies

  • Hi,

     

    Thanks for posting in Microsoft TechNet forums.

     

    Please refer to this thread http://social.technet.microsoft.com/Forums/en-US/w7itprovirt/thread/7c0b7ba1-b5a1-4168-8c1a-867e9cc63c20 , follow Bob_Bunny’s reply to fix the issue.

     

    Hope it works.

     

    Best Regards,

    Miya Yao

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, December 20, 2010 2:29 AM
  • I have read the other thread and the issue I am having is not the same. I can log in to the VM with no problem. My problem is I am unable to provide an accepted password to enable the integration feature; other than that I can access the vm fine. In the integration features settings I only have audio, clipboard, and printer selected. Enable at startup is also selected.

     

    Monday, December 20, 2010 1:09 PM
  • Did you save the logon credential when you logon the Windows XP mode? Please select the box then check if the issue persists.

     

    What’s the error message you got when you fail to enable the integration features?

     

    If it doesn’t work, I recommend you reinstall the XP mode to check if it works.

     

    Best Regards,

    Miya Yao

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, December 21, 2010 3:29 AM
  • No, I did not save the credentials for XP mode. Whether the credentials are saved or not I am prompted to login, and no credential either domain or local admin are accepted. The error message I received is logon attempt failed, integration feature have been disabled. I have already uninstalled / reinstalled XP mode, created new virtual machines, neither of these have made any difference. I have an XP virtual machine (not XP mode) and it works fine. I was able to enable the integration features once this morning using the local admin account but after rebooting the VM the same credentials do not work again.

    Tuesday, December 21, 2010 5:19 PM
  • Let me clear the issue.

     

    1. You are running the Windows 7 Enterprise as both the host and guest OS. Both of them are domain-joined.

    2. The Windows XP mode should be installed in your host OS.

     

    Now I’m a little confused about which OS are you logon.

     

    If you logon the host OS, I think you can use the Windows XP mode normally.

    If you logon the gust OS, the XP mode cannot be used normally because it’s not supported.

     

    Best Regards,

    Miya Yao

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, December 22, 2010 9:55 AM
  • That is partially correct. My host and guest OS in question is Win 7 enterprise and both are joined to the same domain. I do have XP Mode installed and that VM as well as another XP VM work with no problem. I can log on to all VM’s with no problem, when I try to enable the integration features in the Win 7 Enterprise VM it will not accept my credentials to enable integration, but I can use the VM normally other than that. Doses that help or should I explain further?

     

    Thank you for your continued assistance.

     

    Wednesday, December 22, 2010 1:11 PM
  • Worth checking your firewall settings on the Guest machine.

    The way the firewall behaves before the Guest machine logs-in is critical to integration features.

    This might explain why one VM has a problem and others work, if firewalls have different behaviour.

    (my problem had similar symptom to you

    http://social.technet.microsoft.com/Forums/en-US/w7itprovirt/thread/6d66c40f-8935-44ba-abf4-277bda939f2d/)
    Wednesday, December 22, 2010 4:50 PM
  • I read the other posts and I am unclear what changes need to be made. I am only using windows firewall with default configurations. The remote desktop rules are allowed, I do not see any rules for terminal services.

    Wednesday, December 22, 2010 5:22 PM
  • Hello Chad,

     

    Thanks for your feedback.

     

    From our discussion, the issue occurs on both Windows XP Mode and other virtual machines based on Windows Virtual PC.

     

    I suspect the issue is related to the Virtual PC component, rather than Windows XP mode or other virtual machine files. I recommend you to reinstall the Virtual PC using the following steps:

     

    1.       Set system restore point and make necessary backups.

    2.       Stop virtual machines in running status.

    3.       On the Windows 7 host machine, navigate to Control Panel – Program and Features – View Installed Updates.

    4.       Please find the Windows Virtual PC (KB958559) listed.

    5.       Right-click the update and select Uninstall.

    6.       Finish the process of removing Windows Virtual PC. It may include a reboot.

    7.       Go to the following Website:

    http://www.microsoft.com/windows/virtual-pc/download.aspx

    8.       Click “Don’t need XP Mode and want VPC only? Download Windows Virtual PC without Windows XP Mode.” and select the system version and language.

    9.       Follow the wizard to reinstall the KB958559.

    After these steps, please test if the issue persists.

     

    Thanks.

     

     

    Best Regards,
    Miya


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, December 23, 2010 10:50 AM
  • For clarification, I am able to enable integration features on my XP VM. This issue only occurs on my Win 7 Ent VM. I uninstalled / reinstalled Windows Virtual PC (KB958559) and I am still unable to enable integration features on the Win 7 Ent VM.

    Thursday, December 23, 2010 1:35 PM
  • Hello Chad,

     

    Thanks for your post again.

     

    How did you prepare the Windows 7 Enterprise VHD? Please upgrade the Integration Components on Windows 7-based guest OS, using the following article:

     

    Install or upgrade the Integration Components package

    http://technet.microsoft.com/en-us/library/ee449409(WS.10).aspx

     

    Please recreate a Windows 7 VHD again and check if this issue is caused by the specific VHD.

    Regards,

    Miya Yao


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, December 24, 2010 10:31 AM
  • Remove all 3rd party keyboard and mouse drivers and try to install the integration components again.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Friday, December 24, 2010 3:42 PM
  • Hi Chad,

     

    Did you solve the problem?

     

    Please feel free to give us any update.

     

    Best Regards,

    Miya Yao

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, December 27, 2010 2:07 AM
  • I installed the integration components as instructed and recreated the VHD multiple times, prior to posting the problem. I have many applications installed so I would prefer not to recreate this from scratch again.

     

    I do not have any third party mouse / keyboard drivers installed. I am using the OS drivers for both of these devices.

    Tuesday, December 28, 2010 3:11 PM
  • Inside the temp folder (in the XP) you should find a log file from the Integration mode setup. Can you please upload the log?

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Tuesday, December 28, 2010 8:24 PM
  • Andre, Can you be more specific to the location of the Temp folder? There are no XP systems involved in the problem, both host and Guest are Win 7 Enterprise. 

    Tuesday, December 28, 2010 8:28 PM
  • The temp folder is here:

    C:\Users\<USERNAME>\AppData\Local\Temp

    André


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Wednesday, December 29, 2010 12:35 PM
  • I looked in that directory on the host and the guest, and did not see any files that looked like the appropriate file. I found one text file on the host VPCInstallLog.txt, but this looks like the log file for the install of Virtual PC not the integration features.

    Wednesday, December 29, 2010 2:11 PM
  • Inside the VM, please run Process Monitor [1], try to enbale the Integration components, stop the PM trace and save the Data as a PML file. Zip that file and upload it.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Thursday, December 30, 2010 1:07 PM
  • I ran Process Monitor while trying to enable the integration features. I have the output file zipped, but I do not see how to attach the file to this thread.

    Thursday, December 30, 2010 1:32 PM
  •  but I do not see how to attach the file to this thread.

    upload it to your SkyDrive:

    http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/4fc10639-02db-4665-993a-08d865088d65

    and post a link here.


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Thursday, December 30, 2010 1:58 PM
  • Thank you, I was unaware of the SkyDrive. The file has been uploaded and the link is below. Thank you for your help with this problem, and your patience with me.

    http://cid-9c5557c2c96e4e95.office.live.com/self.aspx/New%20folder/Logfile.zip

    Thursday, December 30, 2010 2:11 PM
  • On an affected Windows 7 Virtual Machine, manually attach vmguest.iso file the cd/dvd drive.
    Access the cd/dvd drive within the virtual machine and execute setup.exe
    Doing this we should be able to install Integration Services.
    Once installed, reboot the virtual machine and check if you are able to make use of Integration Features.
    KetanT | Microsoft
    Thursday, January 27, 2011 10:13 AM
  • Thank you, I was unaware of the SkyDrive. The file has been uploaded and the link is below. Thank you for your help with this problem, and your patience with me.

    http://cid-9c5557c2c96e4e95.office.live.com/self.aspx/New%20folder/Logfile.zip

    I overlooked the topic. Sorry. Does it also happen when you disable Trend Micro OfficeScan Client?

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Thursday, January 27, 2011 2:13 PM
  • I do not have a VMguest.iso file on my system. Where do I get this file or where should it be?

     

    unloading trend after boot and attempting to enable integration serices still prompts for an admin password when the correct password is entered it is still not accepted.

    Thursday, January 27, 2011 3:17 PM
  • I do not have a VMguest.iso file on my system. Where do I get this file or where should it be?

     

    "C:\Program Files\Windows Virtual PC\Integration Components\IntegrationComponents.iso"

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Thursday, January 27, 2011 3:23 PM
  • When I tried to run the setup.exe I received an error that the software is already installed. I removed the old version, rebooted then ran the setup.exe again, then rebooted after install. When I logged back in the integration features still will not enable. The system does not accept the local user ID and password which an administrator.

     

    Thursday, January 27, 2011 4:06 PM
  • To investigate further we need cbs.log file from the affected machine.
    Please follow below steps,

    1. Click Start - Run and type msconfig.
    2. Click Services tab and select 'Hide All Microsoft Services' check box.
    3. Reboot the machine and try installation of Integration Services again.
    4. Reboot the machine and check if we have same issue.
    5. If yes, please upload CBS.log file from C:\Windows\Logs\CBS directory

     

    for uploads email to blrforum-nospam@microsoft.com (remove '-nospam')


    KetanT | Microsoft
    Saturday, January 29, 2011 2:52 AM
  • I completed the requested steps and there was no change in behavior. Here is the link to the log file.

    http://cid-9c5557c2c96e4e95.office.live.com/self.aspx/Integration%20Features/CBS.log

     

    Monday, January 31, 2011 3:55 PM
  • I have the same problem. I setup a VM for window xp and it works perfectly including integration features.  However, I also setup a VM for windows 7 ultimate and it also work perfectly except after I installed the integration features successfully and it ask me to logon and logon failed.  Anyone has answer?
    Wednesday, February 02, 2011 7:37 PM
  • Local user ID?  Do you mean the one from the physical PC?  If so, that wouldn't work in your VM, the two are essentially separate computers with separate OSes, you'd need to use the login for XP Mode.
    Wednesday, February 02, 2011 10:13 PM
  • I tried to login into the VM machine which has window 7 installed (not window xp)
    Wednesday, February 02, 2011 10:55 PM
  •  

    Figure out the solution!!!!

    On the logon Screen, click on "Other User"  and put the following information in the userID and Password field

    UserID:  YourCurrentVMMachineName\YourCurrentVMUserID

    password:YourCurrentVMPassword.

     

    Let me know if it works

     

    • Proposed as answer by Yin-Chun Wednesday, February 02, 2011 11:19 PM
    Wednesday, February 02, 2011 11:10 PM
  • The VM is joined to a corporate domain and neither domain or local (to  the VM) credentials are accepted.

     

    Thursday, February 03, 2011 3:14 PM
  • My VM is joined to my corporate domain so by default it ask me to put in corporateDomain\DomainUserID and DomainPassword and it will not work.  Use your own VM Local Domain which is your MachineName\VmUserID and VM Password will work
    Thursday, February 03, 2011 10:45 PM
  • I had the same problem, followed Bunny's advice and voila! it worked. I have been struggling with this issue for two months and finally discovered this forum.

     

    Thank you so much.

    Friday, February 04, 2011 2:11 AM
  • the local (VM) credentials are not accepted!
    Friday, February 04, 2011 1:01 PM
  • Hey,

    I had the same issue. Although I am using a Virtual PC with Windows 7 without a domain, on a host running Windows 7 in a domain.

    Finally, based on the tips given here, I attached the "C:\Program Files (x86)\Windows Virtual PC\Integration Components\IntegrationComponents.iso" on the machine which resulted in an UNinstall of the integration components.

    Then, I created an additional account local to my virtual machine, with a password (my default account so far had no password) and made that account member of the administrators group on the virtual machine.

    Rebooted the virtual machine, then choose to enable the integration components.

    And when to login appears, I enter the credentials of the virtual machine, so for username: virtualMachineName\newlyCreatedAccountOnVirtualMachine, and it's password.

    And surpisingly it just worked !!

    I'd tried this a thousand times before, but either with credentials of the host, or credentials with the virtual machine, it never worked. Apparantly the credentials of the virtual machine must require a password...

    Wednesday, February 16, 2011 10:30 PM
  • After attaching the ISO and removing the integration components, adding new admin account, reinstalling integration components with that admin account. I was still unable to enable the integration components using the new admin user ID / Password. The user ID / password will allow me to log in to the machine but not enable integration components.

    Thursday, February 17, 2011 4:06 PM
  • Are you creating the admin account inside of the virtual machine?  That was all I had to do ... create a password for the default user inside the virtual machine, then when you enable the integration and it asks for the password, use your virtual machines computers name (under system properties) then a "\" then your virtual machines username and password.
    Tuesday, March 15, 2011 7:51 PM
  • As noted previously I have tried using both a domain account which and admin and a local admin account, neither account will enable the integration features.

    Tuesday, March 15, 2011 8:33 PM
  • Hello,

    We have had a similar problem in our domain environment using Windows 7 Professional SP1 as both host and guest OS. In our case the problem lied in our strict Group Policy settings. The problematic setting was 

    Computer Configuration/Administrative Templates/Windows Components/Remote Desktop/Remote Desktop Session Host/Security/Always prompt for password upon connection
    

     

    We have had this setting enabled and facing the same problem you described. Disabling this setting in our VM GPO fixed the problem for us. I´m not entirely sure if this is due to preauthentication and VPC architecture being built upon RDP stack, nor I have not found any viable explanation, but you can give it a try. 

    Also you need to add the user account you want to use to connect into VM (Integration services credentials prompt) into Remote Desktop Users group.


    • Marked as answer by Chad Lausier Wednesday, March 30, 2011 1:47 PM
    Wednesday, March 30, 2011 12:48 PM
  • Thank you, this resolved my issue.

    Wednesday, March 30, 2011 1:47 PM
  • Hello,

    We have had a similar problem in our domain environment using Windows 7 Professional SP1 as both host and guest OS. In our case the problem lied in our strict Group Policy settings. The problematic setting was 

    Computer Configuration/Administrative Templates/Windows Components/Remote Desktop/Remote Desktop Session Host/Security/Always prompt for password upon connection
    

     

    We have had this setting enabled and facing the same problem you described. Disabling this setting in our VM GPO fixed the problem for us.


    thanks for this helpful post :)

    "A programmer is just a tool which converts caffeine into code"

    I'm going to leave the forum on 31th March 2011 if I don't get a Feedback about the SPAM of 2 MVPs. So if you want an answer, be fast so that I can help you before I leave the Technet forum.
    Wednesday, March 30, 2011 2:19 PM
  • You´re welcome :-)

    However, I´d still like to know, why does it act like that. I´m not very keen on lowering our security standards..

    Thursday, March 31, 2011 6:40 AM
  • I know it is an older thread but I was having the same issue since last week.

    Host and Guest system are W7 Enterprice SP1

    After reading above solution from azarro I was wondering if  any workstation policies  where changed recently and yes :

    Computer Configuration/Policies/Windows Settings/Security Settings/Local Policies/Security Options/UAC:Allow UIAccess applications to prompt for elevation without using the secure desktop was enabled. I set it to Not Defined, rebooted the guest and all integration features where available again. I Enabled the policy again and the issue was back !?, I wonder how things are related.

    I created an new ou for virtual guests. and disabled the setting.


    • Edited by Murdockx Thursday, January 17, 2013 2:00 PM
    Thursday, January 17, 2013 11:32 AM