none
Windows 7 streaming to DLNA TV through routers

    Question

  • I have Samsung DLNA TV and Windows 7 home operating system on my PC. I started the streaming service on Windows 7 media player and the player did detect the Samsung TV. However, my TV cannot detect the DLNA server running on my PC.

    I have two router setup. Router1 is connected to Cable modem. My PC is connected to Router1 and Router2 is also connected to Router1, both on its LAN ports. Now my TV is connected to the Router2 LAN port. If I connect my PC to router2 LAN port, the TV detects the DLNA server. But due to physical location, I cannot have my PC on Router2. It has to be connected to Router1.

    I'm not sure if I need to do any router configurations in order to detect the DLNA server from the TV.

    Appreciate your help.

    Monday, February 28, 2011 12:42 AM

Answers

  • I don't know if you can turn DHCP and NAT off on the WGT624. It is an old router
    and I am not even sure it is compatible with Windows 7. You CAN make this work
    by replacing that second router with a SWITCH.
     
    You should log into the WGT624 and turn off NAT and DHCP if you can and see if
    you can get it to perform as a switch only. Connect to only the LAN ports, not
    the WAN.
     
    This isn't going to work until you either change the WGT624 into a switch or
    replace it with a "real" switch.
     
    Alternatively, there is a (proprietary) wireless N adapter you can buy from
    Samsung.
     
    I actually have the 52 inch version of this particular TV model
     
    Not to confuse the issue, but I found Samsung's DLNA implementation lacking, so
    see
    for what I ended up doing.
     
    On Tue, 1 Mar 2011 04:01:41 +0000, anacharya wrote:
     
    >
    >
    >I have Netgear routers. Route1 is WNR1000 and Router2 is WGT624. I have DHCP turned on for both the routers. The Samsung TV model is LN46B750.
    >
    >Any idea what should I do in order to get the setup working.
     

    Barb Bowman

    http://www.digitalmediaphile.com

    Tuesday, March 01, 2011 9:18 AM

All replies

  • are you trying to use the second router as a switch? did you turn off DHCP in
    router 2? please post more info:
     
    1. brand / model of both routers
    2. what model samsung TV exactly?
     
     
     
    On Mon, 28 Feb 2011 00:42:00 +0000, anacharya wrote:
     
    >
    >
    >I have Samsung DLNA TV and Windows 7 home operating system on my PC. I started the streaming service on Windows 7 media player and the player did detect the Samsung TV. However, my TV cannot detect the DLNA server running on my PC.
    >
    >I have two router setup. Router1 is connected to Cable modem. My PC is connected to Router1 and Router2 is also connected to Router1, both on its LAN ports. Now my TV is connected to the Router2 LAN port. If I connect my PC to router2 LAN port, the TV detects the DLNA server. But due to physical location, I cannot have my PC on Router2. It has to be connected to Router1.
     

    Barb Bowman

    http://www.digitalmediaphile.com

    Monday, February 28, 2011 9:58 AM
  • I have Netgear routers. Route1 is WNR1000 and Router2 is WGT624. I have DHCP turned on for both the routers. The Samsung TV model is LN46B750.

    Any idea what should I do in order to get the setup working.

    Tuesday, March 01, 2011 4:01 AM
  • I don't know if you can turn DHCP and NAT off on the WGT624. It is an old router
    and I am not even sure it is compatible with Windows 7. You CAN make this work
    by replacing that second router with a SWITCH.
     
    You should log into the WGT624 and turn off NAT and DHCP if you can and see if
    you can get it to perform as a switch only. Connect to only the LAN ports, not
    the WAN.
     
    This isn't going to work until you either change the WGT624 into a switch or
    replace it with a "real" switch.
     
    Alternatively, there is a (proprietary) wireless N adapter you can buy from
    Samsung.
     
    I actually have the 52 inch version of this particular TV model
     
    Not to confuse the issue, but I found Samsung's DLNA implementation lacking, so
    see
    for what I ended up doing.
     
    On Tue, 1 Mar 2011 04:01:41 +0000, anacharya wrote:
     
    >
    >
    >I have Netgear routers. Route1 is WNR1000 and Router2 is WGT624. I have DHCP turned on for both the routers. The Samsung TV model is LN46B750.
    >
    >Any idea what should I do in order to get the setup working.
     

    Barb Bowman

    http://www.digitalmediaphile.com

    Tuesday, March 01, 2011 9:18 AM
  • Two way you can do this. 

    1,  Turn off DHCP and UPNP on Router 2.   Patch Router 1 to router 2.  Using the Lan ports on both Router no WAN port!
    Make sure the Router IP are diffecnted from one another.


    2, Other way is to use a loopback cable from Router 2 to router 1.   From Router 1 connect patch cable to Lan port, other end to Router 2 WAN port.

    Use another pitch cable to loop router 2 back to router 1.  From Router 2 connected pitch cable to LAN to Router 1 Lan port.
    Make sure the Router IP are diffecnted from one another.

    Plan and simple.

    Sunday, February 12, 2012 11:33 PM