none
Windows Explorer constantly Not Responding on Windows 7 x64

    Question

  • Whenever I open Windows Media Player, my CPU starts racing. Task Manager shows WMPlayer.exe *32 and explorer.exe *32 to be the culprits. When I click the Task Bar, I get the hourglass pointer and nothing happens. When I right click the Task Bar, I get a Windows Explorer Not Responding Dialog. I tell it to End, then get the 'trying to find a solution or problem' dialog which takes so long so I click the Cancel button. The Task Bar flashes and everything is fine again for a while. Once when I Ended the hanging explorer.exe *32 process in Task Manager, the Task Bar disappeared and I had to restart Windows.

    This also happens even without starting Media Player - usually when I open an explorer and navigate to a folder with media content. I am posting this here because I've spent hours trying to find the answer on the Internet and have been unsuccessful. One posting suggested it was FireFox so I removed it but the problem persists. Another posting said it was a bug with the QuickTime codec that generates thumbnails so I tried to remove QuickTime. But I had to install it again because without it Windows Media Player wouldn't play movies from my camera and I couldn't find alternative codecs anywhere.

    Anyone know how to solve this?  Thanks very much!
    Wednesday, February 03, 2010 4:52 PM

Answers

  • Hi,

    If the issue was caused by Windows Media Player, I would like to confirm if any third party codec is installed. To further troubleshooting, you can try resetting WMP as below:

    1. Open Control Panel/Programs and Features.

    2. Click "Turn Windows features on or off" in the left pane.

    3. Expand "Media Features", uncheck "Windows Media Player". Click "Yes" to continue, and click OK to quit. Then Restart.

     

    Note: If you turn off WMP, Windows Media Center will be turned off either. You may need to re-configure settings for Windows Media Center after re-enabling it.

     

    4. Open "Turn Windows features on or off" again. Turn on the features "Windows Media Player" and "Windows Media Center". Restart.

    5. Launch Windows Media Player, initialize the program.


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Monday, March 08, 2010 3:03 AM
    Thursday, February 25, 2010 3:02 AM

All replies

  • Hi,

     

    This issue can be caused by third party program. I suggest testing it in Clean Boot mode first.

     

    If it persists, try following tool to remove third party extension:

     

    ShellExView:

    http://www.nirsoft.net/utils/shexview.zip

     

    Please also update device drivers and BIOS to latest version.

     

    hope it helps.


    Vivian Xing - MSFT
    Friday, February 05, 2010 3:11 AM
  • Thanks for the suggestion Vivian. Unfortunately it didn't help. I updated my BIOS (which caused me not to be able to start Windows for 2 days!), and also the video drivers. That didn't help so I tried the shexview app and disabled everything that was not part of the Microsoft Windows Operating system. That didn't help either. 

    Now what I wonder? I did notice that I can reliably crash Explorer by just opening Windows Media Player even when Windows Explorer is not open. When I try to click the Task Bar, the pointer changes to the hourglass and nothing happens. I right click on the Task Bar to get the Windows Explorer is not responding dialog.

    Dave
    Tuesday, February 23, 2010 8:52 PM
  • Hi,

    If the issue was caused by Windows Media Player, I would like to confirm if any third party codec is installed. To further troubleshooting, you can try resetting WMP as below:

    1. Open Control Panel/Programs and Features.

    2. Click "Turn Windows features on or off" in the left pane.

    3. Expand "Media Features", uncheck "Windows Media Player". Click "Yes" to continue, and click OK to quit. Then Restart.

     

    Note: If you turn off WMP, Windows Media Center will be turned off either. You may need to re-configure settings for Windows Media Center after re-enabling it.

     

    4. Open "Turn Windows features on or off" again. Turn on the features "Windows Media Player" and "Windows Media Center". Restart.

    5. Launch Windows Media Player, initialize the program.


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Monday, March 08, 2010 3:03 AM
    Thursday, February 25, 2010 3:02 AM
  • Hi Vivian,

    Thanks for the suggestion. I tried it exactly as you stated and unfortunately it still happens after turning Windows Media Player on again (this time I left Media Center off).

    I wish I knew how to fix it because it is sooooo frustrating! I would turn WMP off and just use iTunes but I use the media server to show photos and videos on my Sony Playstation 3 so I guess I can't to that. This is a modern PC with lots of power and everything is up-to-date so I can't believe this issue is unique to me. 

    Is there anything else I can do to resolve this, i.e. like call support and have someone walk through this with me?

    Thanks again for your help.

    Dave
    Tuesday, March 09, 2010 12:28 AM
  • I think I found a fix:

    Quote from http://social.technet.microsoft.com/Forums/en/w7itpromedia/thread/6d5cf1ed-59eb-4bb4-8173-e8100275bc91

    What actually worked for me was this:
    (in regedit)
    Navigate to: HKEY_CLASSES_ROOT\.mpg
    click the entry named shellex
    (make a backup, just in case) on the menu, choose file > export. (this creates an undo file that you can put back by double-clicking the undo file)
    Delete the entry named shellex (right-click, delete)
    * problem fixed *

    Warning: in general, deleting stuff from the registry (especially if you don't know what you are doing) is a simple & quick way of TOTALLY WRECKING your computer. So, go slow. Deleting stuff from the registry usually makes things worse instead of making things better. However, in this situation, it actually helped without trashing my stuff. Please be careful!!!! 

    Wednesday, June 16, 2010 11:25 PM
  • None of the above solutions worked for me.  The problem is that my issue is extremely similar but comes from simply right-clicking on the desktop.  Once I do that - hourglass forever and "Windows Explorer Not responding".  It can never find a solution - no microsoft error message ever finds any viable solution.  The most they ever do is take you to a generic statement about error types.

    This is totally frustrating - brand new HP I5 processor, Win7 Professional, and I can't even show it to my clients for fear that it will crash. 

    This doesn't happen every time either. Sometimes I can go a day or two without the error and then I copy a network file or right click to paste and BOOM - back into the abyss.  Like other people I have searched everywhere for a soultion and have found pages and pages of frustration but no solution.  I will tell you that this NEVER happen on any of my Windows 7 32-bit computers.

     

    Tuesday, July 20, 2010 5:06 PM
  • Hey, i had the same problem :), Simple solution...

    Go to control panel > Folder options > View > and tick mark Always show icon not thumbnails, should be one of the first 3/4.

    If that doesnt really help, run the computer on Safe mode, then ctrl alt del and in new task type ''explorer'', just make a  new account, set it as administrator, and delete the old one, im currently running the new account but having a relapse of sorts, so all ill do is make a new one and transfer my other doc's to the new account. no Biggie, the cause really is unknown, heh, but hope this helps :) since the New Admin account you'll create will have no such problem.

     

    I'm not a tech expert but this is how i got round to doing it, the folder options thing REALLY WORKS. that might explain your Win media dilemma.

    Saturday, August 14, 2010 3:35 PM
  • worked great for me.....tks for your post.
    Sunday, March 06, 2011 4:46 PM