none
Not coming out of sleep mode

    Question

  • Is anyone else having trouble with 7 coming out of sleep mode?  When my system starts back up the screen is there but nothing will respond.  The only thing I can do is hit my power button and it will shut down normally. 
    Sunday, January 25, 2009 1:36 PM

Answers

  • Still having trouble with this ...

    I tried a combo of both solutions listed in this thread. First time, computer went to sleep during the night. I awoke in the middle of the night and hit the "enter" key. System normally came out of sleep mode to the log-in screen. However, when I got up in the morning, the CPU had turned itself off!!

    Second time, went into sleep mode, but now I could not wake it.  Monitor just won't come on - yellow light is on, but it never turns blue. I had to to a hard reboot, which causes my ethernet connection to fail until I do a graceful shutdown and restart.

    What's a Mother to do?

    Er.. Feed the computer some caffiene? (Sorry.. Couldn't resist...) But seriously...In other words - don't let it go to sleep.. Sleep mode has...issues to say the least. The programmers are working on it and will have it fixed before it's released.
    Wednesday, May 27, 2009 11:55 AM

All replies

  • Without more information from the Event Viewer (if there's anything there), the most likely fix is updating your video drivers to the latest version available from the manufacturer of your video chipset (ATI, nVidia, Intel, etc).
    - John
    Sunday, January 25, 2009 2:00 PM
    Answerer
  •  I can come out of sleep mode okay but sometimes my mouse and keyboard won't work, so have to force a shut down. Have sent this in feedback.
    • Proposed as answer by dinkwad Monday, January 26, 2009 12:39 AM
    Sunday, January 25, 2009 2:06 PM
  • I cannot reconnect to my wireless after sleep or hibernation: my NIC becomes disabled and is not possible to reenable.  I submitted a bug report on Microsoft connect.  I have had to reboot 100% of the time to reconnect to the network.  This system responded great with Vista SP1, so I assume this issue will be resolved with the RC release of 7.
    Sunday, January 25, 2009 2:41 PM
  • i am also having the not coming out of sleep mode problem, i have all the sleep/hibernate modes turned off but the monitor still shuts down, not sure of the timing yet. the computer still has activity going by the HDD light but have to reboot from the power button to get a response from the monitor.
    Sunday, January 25, 2009 3:54 PM
  • I have the same problem - it comes out of sleep mode but the mouse and keyboard do not respond. I have this on two different computers - a macbook pro running win7 in boot camp, and a Lenovo T61p. WIth the T61p, if this happens while it's docked, I can fix it by undocking it.
    Sunday, January 25, 2009 9:52 PM
  • Problem Solved. my monitor would stick in sleep mode even though the option to hibernate or sleep was not on. i found this thread from Ronnie Vernon that fixed my problem.

    This is probably due to the Wake Timers. Wake Timers are a component that programmers can use to wake an idle system and peform a routine function.

    Prior to Windows 7, the user had no control over this.

    Windows 7 gives the user the option to disable or enable the sleep timers.

    If you wish to change this setting.

    • Open Control Panel.
    • Select the All Control Panel Items option.
    • Select Power Options.
    • Click Change plan settings in the selected plan.
    • Click Change Advanced Power Settings.
    • Click the + sign next to Sleep.
    • Click the + sign next to Allow Wake Timers.
    • Select the Disable option.
    • Click Apply / OK.

     Hope this helps.

    Monday, January 26, 2009 12:20 AM
  • My wake timers were already disabled.  I am reenabling them now to see if it matters.  
    Monday, January 26, 2009 12:35 AM
  • If tou are useing wireless mouse and keyboard move the receiver plug to another usb port. Windows will reinstall drivers and you wont have to force close
    Monday, January 26, 2009 12:42 AM
  • Here is what I had to do to connect back to the network in Windows 7:

     

    Select my wireless NIC properties and then disable the allow the computer to disable this device to save power.  Now I can sleep in peace so to speak.  The computer wakes correctly and I do not have to reboot the laptop. 

    Monday, January 26, 2009 1:36 AM
  • dinkwad said:

    If tou are useing wireless mouse and keyboard move the receiver plug to another usb port. Windows will reinstall drivers and you wont have to force close



    No they are not wireless they both are USB so cannot use that method to re-connect. Sleep works perfectly everytime, its just this problem on waking (although funnily enough I wake it up by pressing Space on the keyboard which then stops working so go figure! LOL)

    It doesn't always occur, tend to be when the computer has been asleep for some time rather than just for a short while. Will have to monitor this.

    Monday, January 26, 2009 5:59 AM
  • I've been having this problem also...though as soon as mine comes out of sleep it starts doing a memory dump and then rebooting.
    I'm not sure what's causing it as all my drivers are up-to-date.  Anyone having this issue?
    Monday, January 26, 2009 10:26 AM
  • This worked for me and some other folks.  Go into the bios and check your ACPI setting.  There's ususally a choice between S1, S3 and S1 & S3.  Set it to S3.  This solved my problem of locking up keyboard and mouse coming out of sleep.
    Monday, January 26, 2009 5:47 PM
  • DaHound said:

    This worked for me and some other folks.  Go into the bios and check your ACPI setting.  There's ususally a choice between S1, S3 and S1 & S3.  Set it to S3.  This solved my problem of locking up keyboard and mouse coming out of sleep.



    And how do you go into the bios? Don't want to mess up my computer in any way!
    Monday, January 26, 2009 6:01 PM
  • I'm having the problem of just the mouse locking up after auto sleep kicks in. the keyboard works fine. the mouse is a usb mouse.
    Monday, May 11, 2009 1:22 AM
  • Problem Solved. my monitor would stick in sleep mode even though the option to hibernate or sleep was not on. i found this thread from Ronnie Vernon that fixed my problem.

    This is probably due to the Wake Timers. Wake Timers are a component that programmers can use to wake an idle system and peform a routine function.

    Prior to Windows 7, the user had no control over this.

    Windows 7 gives the user the option to disable or enable the sleep timers.

    If you wish to change this setting.

    • Open Control Panel.
    • Select the All Control Panel Items option.
    • Select Power Options.
    • Click Change plan settings in the selected plan.
    • Click Change Advanced Power Settings.
    • Click the + sign next to Sleep.
    • Click the + sign next to Allow Wake Timers.
    • Select the Disable option.
    • Click Apply / OK.

     Hope this helps.


    If I do this, the computer goes to sleep and then IMMEDIATELY reawakes .... ??????
    Thursday, May 14, 2009 11:00 AM
  • I can confirm what sigsaber posted about disabling the Wake Timers.  I also had to add this:

    Control Panel --> System and Security --> System

    OR

    Right click the Computer Desktop ICON.  Select properties.

    Press the Device Manager shield ICON.

    Click Network adapters.

    Double click the listed network adapter.

    Select the Power Management tab.

    Un-Check – Allow the computer to turn off this device to save power.

    Sunday, May 17, 2009 5:29 PM
  • Still having trouble with this ...

    I tried a combo of both solutions listed in this thread. First time, computer went to sleep during the night. I awoke in the middle of the night and hit the "enter" key. System normally came out of sleep mode to the log-in screen. However, when I got up in the morning, the CPU had turned itself off!!

    Second time, went into sleep mode, but now I could not wake it.  Monitor just won't come on - yellow light is on, but it never turns blue. I had to to a hard reboot, which causes my ethernet connection to fail until I do a graceful shutdown and restart.

    What's a Mother to do?
    Wednesday, May 27, 2009 11:24 AM
  • Still having trouble with this ...

    I tried a combo of both solutions listed in this thread. First time, computer went to sleep during the night. I awoke in the middle of the night and hit the "enter" key. System normally came out of sleep mode to the log-in screen. However, when I got up in the morning, the CPU had turned itself off!!

    Second time, went into sleep mode, but now I could not wake it.  Monitor just won't come on - yellow light is on, but it never turns blue. I had to to a hard reboot, which causes my ethernet connection to fail until I do a graceful shutdown and restart.

    What's a Mother to do?

    Er.. Feed the computer some caffiene? (Sorry.. Couldn't resist...) But seriously...In other words - don't let it go to sleep.. Sleep mode has...issues to say the least. The programmers are working on it and will have it fixed before it's released.
    Wednesday, May 27, 2009 11:55 AM
  • Caffeine!!!! Now why didn't I think of that?!? Anyway, good to know Microsoft is on it --- not really a huge issue, but I like to have everything working!!
    Thursday, May 28, 2009 1:05 AM
  • For me, its only my MS Intellimouse that wont respond after waking from Sleep.  Switching between s1, and s3 doesnt matter.  INstalling the MS software/drivers doesnt help either.

    Right now, Im stuck UNPLUGGING my MOUSE and PLUGGING it back in ....

    Im using X58 Express Chipset -based Intel® Desktop Board, and windows 7 64 Bit
    Thursday, August 20, 2009 4:19 PM
  • For me, its only my MS Intellimouse that wont respond after waking from Sleep.  Switching between s1, and s3 doesnt matter.  INstalling the MS software/drivers doesnt help either.

    Right now, Im stuck UNPLUGGING my MOUSE and PLUGGING it back in ....

    Im using X58 Express Chipset -based Intel® Desktop Board, and windows 7 64 Bit

    Control Panel>Hardware and Sound>Power Options click change plan settings > Change advanced power settings

    USB > USB Selective suspend set to disabled

    Ending the USB selective suspend service has completely resolved this issue for me
    Thursday, August 27, 2009 4:50 AM
  • Are these problems happening on the RC build or on the RTM build?

    There were unfortunately some known issues in the RC build with this problem, but we believe the cases are fixed for RTM.
    Want to know if your hardware will work on Windows 7? Check out these links: **Windows 7 Upgrade Advisor ** **Microsoft Logo'd Hardware List**
    Thursday, August 27, 2009 5:04 AM
  • Are these problems happening on the RC build or on the RTM build?

    There were unfortunately some known issues in the RC build with this problem, but we believe the cases are fixed for RTM.
    Want to know if your hardware will work on Windows 7? Check out these links: **Windows 7 Upgrade Advisor ** **Microsoft Logo'd Hardware List**

    I am using the RTM build and have had to disable the usb selective suspend and the wake timers in order to fix my sleep issues.
    Thursday, August 27, 2009 12:22 PM
  • The same thing happens to me if any one knows how to fix this plz tell
    Wednesday, February 03, 2010 11:00 PM

  • Same problem here. A brand new PC.

    I actually had Win7 waking up for about a month, liked this feature too.I actually thought that Win7 is great. But then...

    Then my PC stopped waking up. I hear the HDs spin up, the PS is turns on too, but all USB based stuff and the Display are dead. I did not update any drivers since day 1, so it is not a driver issue, as the only things that changed were MS updates.

     

    MS, seriously, how about you refer this problem, it's all over the bloody internet. Solve the problem, stop bouncing us with "update your drivers, BS".

    Sunday, November 28, 2010 7:41 PM
  • Solved! My wake timers was disabled. I reenabled it and it worked! I am having trouble with getting my laptop to come out of sleep mode. Now I can close the lid to get into sleep mode and tap any keys to wake my laptop up really quick. Cool!

    Thanks!

    Tuesday, August 23, 2011 5:20 PM