none
Windows 7 Homegroup IPv6 connection issues

    Question

  • Hello,

    I am trying to join a Windows 7 Homegroup created by another Windows 7 computer (both computers are on the same network and running Windows 7).  I keep getting the error message that I cannot connect to the Homegroup because IPv6 is not enabled.  However, IPv6 is enabled; I have tried disabling it and re-enabling it, reinstalling my network card drivers, disabling and re-enabling the network card, and I have double-checked that all advanced sharing settings and workgroup names are the same on both computers.  I saw another post here with someone having the same problem but no solution was posted.  Does anybody have an idea what I can do to fix this?  My network card is a Intel(R) Wireless WiFi Link 4965AGN.

    Thanks,
    Cameron
    Monday, September 21, 2009 4:09 AM

Answers

  • Hi,

     

    Based on my research, I would like to explain that IPv6 was depended on by the RNRP service. To troubleshoot the issue, let's refer to the following steps.

     

    1. Temporarily disable Firewall and third party antivirus program on the computer for a test.

     

    2. Verify relevant services

    =========================

    a. Click "Start", type "services.msc" (without quotation marks) in Search Bar and press Enter.

     

    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

     

    b. Right click the "Peer Networking Grouping" service and choose Properties.

    c. Please check if the service is started; if not, please click the Start button and see if it works.

    d. You may also choose Automatic next to Startup type.

    e. Click OK.

    f. Please repeat the above steps with another service: PNRP Machine Name Publication Service.

     

    3. Modify IPv6 registry key to enable IPV6

    ==========================

    a. Click Start, type regedit in Search Bar, and then click regedit in the Programs list.

     

    Note: If you are prompted for an administrator password or confirmation, type your password or click Continue. 

     

    b. Locate and then click the following registry subkey:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters

     

    c. Check whether the "DisabledComponents" registry key exists. If so, let's move on the next steps.

    d. Double click the "DisabledComponents" registry key and modify the value to 0.

     

    (If the key doesn't exist, please create the key above and assign the value 0)

     

    e. Exit Registry Editor, and then restart the computer.

     

    For more information, we can refer to the link below:

     

    How to disable certain Internet Protocol version 6 (IPv6) components in Windows Vista, Windows 7 and Windows Server 2008

     

    Thanks,

    Novak

     

    • Marked as answer by Novak Wu Thursday, September 24, 2009 2:47 AM
    Tuesday, September 22, 2009 3:13 AM

All replies

  • Hi,

     

    Based on my research, I would like to explain that IPv6 was depended on by the RNRP service. To troubleshoot the issue, let's refer to the following steps.

     

    1. Temporarily disable Firewall and third party antivirus program on the computer for a test.

     

    2. Verify relevant services

    =========================

    a. Click "Start", type "services.msc" (without quotation marks) in Search Bar and press Enter.

     

    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

     

    b. Right click the "Peer Networking Grouping" service and choose Properties.

    c. Please check if the service is started; if not, please click the Start button and see if it works.

    d. You may also choose Automatic next to Startup type.

    e. Click OK.

    f. Please repeat the above steps with another service: PNRP Machine Name Publication Service.

     

    3. Modify IPv6 registry key to enable IPV6

    ==========================

    a. Click Start, type regedit in Search Bar, and then click regedit in the Programs list.

     

    Note: If you are prompted for an administrator password or confirmation, type your password or click Continue. 

     

    b. Locate and then click the following registry subkey:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters

     

    c. Check whether the "DisabledComponents" registry key exists. If so, let's move on the next steps.

    d. Double click the "DisabledComponents" registry key and modify the value to 0.

     

    (If the key doesn't exist, please create the key above and assign the value 0)

     

    e. Exit Registry Editor, and then restart the computer.

     

    For more information, we can refer to the link below:

     

    How to disable certain Internet Protocol version 6 (IPv6) components in Windows Vista, Windows 7 and Windows Server 2008

     

    Thanks,

    Novak

     

    • Marked as answer by Novak Wu Thursday, September 24, 2009 2:47 AM
    Tuesday, September 22, 2009 3:13 AM
  • Brilliant; that seems to have done the trick.  Thanks!
    -Cameron
    Friday, September 25, 2009 7:48 PM
  • i had this same problem and this procedure worked! thank you, it is much appreciated :)
    Thursday, April 29, 2010 4:41 AM
  • I am not able to modify the value to 0.  It is currently f.  Could someone give me some more direction please.

    Saturday, June 12, 2010 6:14 AM
  • novak thank you very much for this fix.  i have read many posts on  many threads and none have worked.  yours was totally different from anything i have seen so i was hopeful.  it worked like a charm on the 3 computers i was trying to put on a home group.  thanks again!!!!

     

    Note to RA Modesto:  I know of no reason why you can't change the dword value to 0.  all you should have to do is get the cursor blinking on the "f" and hit backspace to delete it and then type in the number 0.  Good luck.

    Wednesday, August 04, 2010 10:20 PM
  • THANK YOU! Perfect explanation, worked like a charm.
    Monday, September 13, 2010 10:47 PM
  • I am getting extremely frustrated with my homegroup at the moment.

     

    I have win 7 64 bit ultimate on the pc i created my homegroup on. 

    I was able to connect to my homegroup with my netbook (win 7 home premium 32 bit) with no problem.

    I have a laptop with win 7 proffessional 32 bit and keeping getting th dumb error "HomeGroup encountered an error" when I try and connect.

     

    I have tried the above along with 10 other ideas that didn't work and am ready to give-up and go back to workgroups.

    Yes the times are all the same and all have the same timezone!

    Yes I am entering the password correctly!

    I re-created the homegroup - no luck

     

    turned off windows firewall and unistalled my AV software (Avast) - no luck.

     

    really getting angry at this point.

     

    the funniest thing about this is that I am able to share the printer without being on the homegroup. I can access the external hard drive connected to my desktop with no issues but I cannot connect to either of the hard drives inside my desktop "access denied" and these are the drives I want access to so I can create a backup and access ll my dvds and music wirelessly

     

    Anyone have any other suggestions before I give up on homegroups?

    Thursday, September 16, 2010 12:53 AM
  • Dude, this worked perfectly.

    You're a genius!

    Thank you so much!

    Monday, September 27, 2010 1:44 AM
  • DUDE, this doesnt work perfectly!

    No geniuses in sight as the problems gregry20 has experienced are exactly my problems.  Except one minute i can start Homegroup and get a group password and the next the password becomes blank and it says Homegroup is disabled.

    For one fleeting moment my netbook was able to connect on a self created password on my desktop but then after reboot it said Homegroup not available and my desktop when checking the password it was blank again.

    Please put up a better solution tha n restarting IPV6 because it isnt working.

    V/r

    Ken M

    MCP, MCSE NT, SEC+

     


    Been There, Done That
    • Proposed as answer by z2h Thursday, March 17, 2011 1:01 PM
    • Unproposed as answer by z2h Thursday, March 17, 2011 1:01 PM
    Tuesday, October 26, 2010 4:53 PM
  • Worked for me. Thanks
    Friday, October 29, 2010 1:23 PM
  • THIS WAS THE SOLUTION TO MY PROBLEM!!!

    I was having the same issue with IPv6 and HomeGroup for a laptop running Win7 Enterprise x64 that I was trying to get to join to my homegroup (set up with Win7 Professional). I changed the registry setting you mentioned and problem solved.

     

    Thanks!!!

    Saturday, November 06, 2010 9:37 PM
  • I followed the steps and after restart the IPv6 parameter went back to ff. Help
    Friday, January 14, 2011 11:43 PM
  • This worked a charm for me man. Thanks a bundle. However, if it doesnt "seem" to work for you go into your network adapters properties sheet and put the tick back in the box for IPv6. When I could'nt get my homegroup restarted because of the IPv6 error I found myself following the homegroup troubleshooter which pointed me to my network cards property sheet to enable IPv6...but it was already ticked. I followed the steps kindly outlined above, rebooted but alas the issue remained. I went back in to the property sheet and the tick was removed...? Soooo I put the tick back in and voi la I was able to create my homegroup :) I guess the reg fix part of the procedure resets everything such as you have to retick the box to re/enable IPv6. Hope this helps.

    z3r0

    Audio Dropouts - frisky records
    • Proposed as answer by z2h Thursday, March 17, 2011 1:10 PM
    Thursday, March 17, 2011 1:10 PM
  • I saw this and thought I was home free.  My PC can't see the netwok that I am using.  It says I am not connected to any networks.  I can see the router and other computers in network places.  I am trying to set up a homegroup between this PC (win 7 64) and another win 7 32) machine

    Before, when I ran the troubleshooter, it asked me to enable the IPv6. I followed the solution above and now I don't get that response.  It just give up and asks me to call a friend search for a soultion in the help files online or register a call with support services. 

    any thoughts would be appreciated.


    Bowie
    Thursday, March 17, 2011 7:24 PM
  • I am having exactly the same problem as Jim BOB 21 above. This forum needs an solution; please.  I see we have some very experienced techs in this forum. Hopefully this will be solved soon!!!!!!

     

     

     

    A+ N+ CCNA

    Thursday, March 24, 2011 4:07 AM
  • After I set the value of the key "DisabledComponents" to 0 and reboot the value is resetting to the existing non 0 hex figure. I am using Windows 7 Ultimate SP1. How do I prevent this resetting of registry value on reboot. Thanks - Ranabir
    Wednesday, June 01, 2011 1:13 PM
  • I've got the same problem. I managed to create a homegroup using my laptop and I wanted my PC to join the group. However, on the PC the DisabledComponents keeps changing to FF after I restart the system. I have no clue why this is happening - on my laptop there is no such element in the registry and everything works fine.

    Any new ideas?

    Wednesday, June 15, 2011 3:13 PM
  • Make sure that the drives and directories can be shared.

     

    I will now go and try the solutions given by Novak Wu, as I'm having the same problem with making my 64-bits Windows 7 Home Premium pc a member of the same Homegroup as my other 4 Windows 7 pc's. I am getting sick and tired of this IPv6-thing. Bill Gates got rich by not finishing his work properly.

    Wednesday, October 05, 2011 3:00 PM
  • Dit is het dagen aan het prutsen geweest in windows. Maar dit is echt de oplossing . Veel dank
    Thursday, April 19, 2012 9:02 PM
  • BINGO! Thank you, it works....Why do MS have to make it so complicated to do anything? 
    Monday, May 14, 2012 9:40 AM
  • Brilliant .. that fixed it all I am now happily sharing files between my laptop and desktop computers
    Tuesday, July 03, 2012 1:26 AM
  • Novak Wu - Thank you so much. 3-1/2 years later and your solution works like a charm on my Windows 8 systems!
    Wednesday, February 27, 2013 6:40 AM
  • Works like a charm! :)

    Thank you!

    Thursday, March 21, 2013 3:42 PM
  • This procedure effortlessly worked its "magic".  The problem was that the DisabledComponents key was not set to 0.  Both my laptop (Win8) and desktop (Win7) are wireless-connected to the network router.  The printer is plugged into a USB port on my desktop.  With the modification of the DisabledComponents key to value 0, I was able to print a test page from my laptop to the printer on my desktop.

    Thanks, Novak Wu.

    Saturday, April 27, 2013 9:00 PM
  • Beautifully done, Sir. 

    I was going nuts, then frustrated, then depressed trying to hammer it into my PC that IPv6 is [already] enabled, until I found this thread and finally resolved my Homegroup connectivity issue with Novak Wu's answer. Phew!

    Thank you very much!

    Wednesday, May 22, 2013 11:09 AM
  • Thanks for this but and although it was clear there was a problem with

    3. Modify IPv6 registry key to enable IPV6

    c. Check whether the "DisabledComponents" registry key exists. If so, let's move on the next steps.

    A box opened called DWord (32 bit) Value

    d. Double click the "DisabledComponents" registry key and modify the value to 0.

    This showed a VALUE DATA F which under Base the Hexadecimal was highlighted

    What I need clarified is the following: -

    Is the modification an O (alpha) or 0 zero (numeric)

    Under Base Box do I highlight Hexadecimal or Decimal.

     Many thanks
    Wednesday, May 22, 2013 1:28 PM
  • just incase nothing has worked. I tried this:

    http://support.microsoft.com/?scid=kb;en-us;929852&x=11&y=13

    Wednesday, August 14, 2013 7:17 AM
  • worked for me too, thanks for your time.
    Thursday, August 29, 2013 1:56 AM
  • <object height="1" id="plugin0" style=";z-index:1000;" type="application/x-dgnria" width="1"><param name="tabId" value="{39BD7614-0E7C-41A1-97E7-6D16BFDC7291}" /></object>

    I found a solution that worked for me when the above changes, by Novak Wu, did not work.  I made his changes and they may also be essential...but after I did this:

    1. Disable Router Discovery.
    2. Enable Managed Address Configuration (OR enable Other Stateful Configuration.)

    from: the Microsoft support kb 961433


    For both of the above steps, you need to do the following:
    1.  Open an elevated command prompt
    2.   netsh int ipv6 show int
    The output from this command will list your interfaces and their respective index numbers.  You will use this index value in the next command.
    To disable Router Discovery:  netsh int ipv6 set int [index] routerdiscovery=disabled
    You next need to enable either Managed Address or Other Stateful.   Managed Address instructs the client to obtain an address and all options from the DHCP server (the normal behavior for an IPv4 address).   Other Stateful instructs the client to configure its own IPv6 address (or use the statically configured address), but to get all other configuration options from a DHCP server.
    To enable Managed Address: netsh int ipv6 set int [index] managedaddress=enabled
    Note After enabling Managed Address, you may need to run the following commands to delete the existing IP address and renew the DHCP assigned IPv6 address:•netsh int ipv6 delete address [index] <static IPv6 address>
     ipconfig /renew6 [index]
    To enable Other Stateful: netsh int ipv6 set int [index] otherstateful=enabled
    Note After enabling Other Stateful, you may need to run the following commands to release an existing DHCP IPv6 address before assigning a static IPv6 address:•ipconfig /release6 [index]
    •netsh int ipv6 add address [index] <static IPv6 address>
    You can confirm your changes by using the following command to view the existing settings: netsh int ipv6 show int [index]

    Some of these steps were not fully completed due to the state of my system. The key seems to have been in the disabling of the router recovery; the enabling of managed address; and renewing...I rebooted and it link on to the homegroup.

    Thanks, Steve

    Tuesday, September 24, 2013 9:10 PM