none
Cursor Jumping In Windows 7 , outlook 2010 , word 2010

    Question

  • I've been reading around and it appears lots of peopel are experiencing this issue. Has anyone managed to fix this annoying issue of the cursor jumping around in when typing. I'm using a sony vaio laptop , windows 7 ?????

     

     

    Tuesday, April 13, 2010 4:32 PM

Answers

  • Hi jezrp,

     

    Does the issue occur in other applications such as Notepad? If the issue only occurs in Microsoft Office 2010, you can post a thread on Office 2010 Forums.

     

    However, if the issue occurs in other applications as well, please try the following suggestions to see if the issue can be resolved:

     

    If the issue persists after installing the latest drivers which are compatible with Windows 7, the issue can be caused by the factors including third party software, device driver, touchpad settings, virus or spyware infection.

     

    Please see if the following suggestions can resolve the issue:

     

    -    If the issue occurred after installing certain software or hardware, please remove it to check the result. Or, you can perform System Restore to restore to the date before the issue first occurred.

     

    -    Scan your system using anti-spyware and anti-virus software to confirm the system is clean.

     

        Check the touchpad's sensitivity if it is available. You can simply disable the touchpad to test the result. You shall contact the device manufacturer directly to confirm the settings.

     

    -    Use a mouse pad for better mouse performance.

     

    -    Replace the mouse and check the result.

     

    Regards,

    Linda

     

     

     

    • Marked as answer by Linda Yan Wednesday, April 21, 2010 1:33 AM
    Wednesday, April 14, 2010 7:40 AM

All replies

  • Hi jezrp,

     

    Does the issue occur in other applications such as Notepad? If the issue only occurs in Microsoft Office 2010, you can post a thread on Office 2010 Forums.

     

    However, if the issue occurs in other applications as well, please try the following suggestions to see if the issue can be resolved:

     

    If the issue persists after installing the latest drivers which are compatible with Windows 7, the issue can be caused by the factors including third party software, device driver, touchpad settings, virus or spyware infection.

     

    Please see if the following suggestions can resolve the issue:

     

    -    If the issue occurred after installing certain software or hardware, please remove it to check the result. Or, you can perform System Restore to restore to the date before the issue first occurred.

     

    -    Scan your system using anti-spyware and anti-virus software to confirm the system is clean.

     

        Check the touchpad's sensitivity if it is available. You can simply disable the touchpad to test the result. You shall contact the device manufacturer directly to confirm the settings.

     

    -    Use a mouse pad for better mouse performance.

     

    -    Replace the mouse and check the result.

     

    Regards,

    Linda

     

     

     

    • Marked as answer by Linda Yan Wednesday, April 21, 2010 1:33 AM
    Wednesday, April 14, 2010 7:40 AM
  • The system is clean - no viruses

    Has nothing to do with mouse or pointing/touchpad device

    Not sure when the issue happened. I've updated all sony vaio updates & win 7 updates.

    The interent is littered with people having the same issue but there appears to be no fix  ?? Very annoying as it never happedn until i had windows 7 !

    Wednesday, April 14, 2010 10:54 AM
  • Does the issue occur in Notepad and other applications?

    Does the issue occur when using another mouse?

    Does the issue occur after updating the mouse driver?

    Thursday, April 15, 2010 6:20 AM
  • I have the same issue, which is a major problem considering I am writing books on my laptop for a living!

    I have noticed that the problem occurs when I type a 'c'. It doesn't happen every time but is always to do with the 'c' key (with or without shift).

    It only happens in word 2010 and not note pad or when typing on the internet, such as on this forum.

    I have done the virus and spyware checks and that that is all clean. I have a Dell Inspiron 1720, 4mb ram and running win7 ultimate.

    Any ideas anyone?

    Tuesday, June 08, 2010 5:26 PM
  • I've been having the same problem.  I've found two solutions:  the first is to simply shift out of full screen mode.  When you are working in a diminished window, you can place your curser safely outside the window, and it won't jump around in your document.  The other (less reliable) way to eliminate the problem is to turn off your mousepad and use a remote mouse.  The first solution seems to work the best for me.
    Wednesday, August 18, 2010 5:31 PM
  • Linda: has this problem been fixed yet? I have bought a new laptop with Windows 7 and liked it a lot until it started to do this thing about two weeks (apparently after a Windows update...). It has become a real pain. It happens especially in Outlook: when I am doing my mail, the cursor jumps around. Can MSFT fix it?

     

    Wednesday, October 27, 2010 11:41 AM
  • It should be apparent that this is problem has not been caused by a faulty driver, viruses, etc. I am running Windows 7 Ultimate and Office 2010 in a Windows partition on a MacBook Pro. Since there are so many people experiencing the same problem it cannot be anything but a bug in Windows 7 or Office 2010 together with Windows 7.  The CNET Community manager, Lee Koo, took up the jumping cursor issue on August 6 entitled, "Help me cure my jumping coursor while typing on my laptop." Different "workarounds" are suggested. But none address the fundamental problem that there is a bug in the software.
    edlius2
    Sunday, October 31, 2010 6:00 PM
  • Linda -

    I am another person who has a new laptop computer (Sony Vaio) with Windows 7 installed. I hate the fact that the cursor jumps around when I type emails. This did not happen with Windows Vista. Microsoft seems to not be ting it an errorr considerak this seriously oing with Windows 7. I am leaving all the (seemingly "typing") errors in this message because they are NOT typing errors. This is what happens when the darn cursor jumps around. I want you to see how disgusting this is. It makes writng (using this computer) almost impossible. Please --- Microsoft -- stop delaying the repair of ths problem.

    Saturday, January 08, 2011 6:50 PM
  • i am having the same problem.  my cursor continually jumps around in all applications.  it started after a clean install of windows 7 and yes all drivers are up to date.  i am so frustrated that i am about to buy a mac.  please help!!!!!!
    Thursday, January 13, 2011 8:25 PM
  • I agree with all those that have newly installed Windows 7 and Office 2010 on my wife's labtop.  She has an online class and when typing in Word and email the stupid cursers skips all over.  This is rediculus! Microsoft better fix this soon!
    Friday, January 14, 2011 11:54 PM
  • The Microsoft moderator has not made any coments since April 15. Since then, Office 2010 had its official release. It would be useful if Microsoft could provide an update on this problem. Considering how widespread it is, they must also observe the problem in their internal use of these programs.


    edlius2
    Saturday, January 15, 2011 11:57 AM
  • It is January 2011. My wife's laptop is having the same issue. Where is MS's solution? Anyone...anyone...

    Help please, before I get technonagged to death...


    Doogle
    Sunday, January 16, 2011 6:02 PM
  • I too am having the skipping and jumping cursor. I have been trying to solve the issue for months, and can tell you for a fact it is not with my new laptop. I have an ASUS k50 ij, and have been having the trouble since just a month or two after purchasing it in August of last year. I have worked with the ASUS techs over the phone and online with no solution, so they asked me to send it back to them. I did, they attempted to solve the issue, with no solution, so they sent me a new one. After a few days, it ran all of the Windows updates and with no avail, the trouble came back again.

    I know it is with Windows, and am so upset that Windows will not solve the problem. Over time, I have read thousands of messages from people having the exact same issue on a bunch of different computers, so if cant 'be the computer software. It has to be Windows since everyone is having the same issue on so many different machines. I really think Microsoft needs to take a flying leap and we can all switch to Mac! 

    SO WHAT'S UP WINDOWS? WHERE IS OUR ANSWER??????

    Thursday, January 27, 2011 5:41 AM
  • I have a variation on the problem referenced by others.  On XP SP3 with Office 2010, no matter what I am doing, the cursor and control jumps to Outlook.  This began when I installed Outlook 2010.  It is a huge frustration and it can result in unintended changes to be made in Outlook--caused by my keystrokes that I thought were in my browser or some other application altogether!
    gogogord
    Thursday, February 03, 2011 10:19 PM
  • I do have the very same issue now on 2 different laptops: my personal laptop (Lenovo)  after upgraded to Windows 7 (sometimes it shows on  web forums I post) and on my new work laptop (Dell) where I literally cannot use Outlook 2010 because cursor continually jumps out of control. It is not only annoying but very frustrating esp when i need to reply fast.
    I cant believe Windows never responded or addressed this issue!!!
    Monday, February 07, 2011 12:05 AM
  • I am having the same damn problem, be it office, outlook, gmail, hotmail it doesnt matter if I am typing it is jumping. Another frustration is that sometimes if i go back in a sentence to change something, the text following is erased and replaced by the new text. This requires me to go to place in the sentence that needs service hit enter so the following text is advanced so as not to be erased, type the change add a space return the crsor to the beginning of the following text and hit backspace.

    So damn frustrating this needs to be fixed.

    Friday, February 25, 2011 9:37 PM
  • If you have Alps pointing device, try then:

    http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadIndex?cc=us&lc=en&dlc=en&softwareitem=ob-75941-1

    it worked for me...

     

     

    Thursday, March 10, 2011 1:45 AM
  • This new driver installed fine, but when I rebooted the touchpad wasn't working. I don't think these drivers are universal for all laptop brands.

    Has anyone else found a solution? This is ridiculous.

    Saturday, March 12, 2011 5:28 PM
  • I now join the ranks of the frustrated and fed up.  So far in typing this comment, my cursor has jumped around 10 times!!! I have just upgraded my HP Pavillion from Vista to Windows 7.  I never had this problem with Vista.  Please!!!  Can we get some kind of fix for this.  For those that LIVE on our computers a jumpy cursor is worse than a sticky key on a typewriter!! 
    Wednesday, March 16, 2011 4:46 AM
  • Hello ' Have the same issues on a desktop: Mainboard : MSI MS-7181
    Chipset : VIA K8M800 (VT8380)
    Processor : AMD Sempron 3000+ @ 1800MHz
    Physical Memory : 2048MB (2 x 1024 DDR-SDRAM )
     disturb also Babylon, Lingoes, gmail , MS office, AVbowser, Chrome 11, ff4, etc
    hope to find help.
    Sunday, March 20, 2011 8:42 AM
  • I would like to add to g list of disgruntled users. I have deliberately left this message to show how the cursor jumped when I typing this message.a growin
    Wednesday, June 01, 2011 2:24 PM
  • Zuma. after making a change back in a sentance anf then going forward, the letters typed eat the text before them, like a packman,right. Hit "insert" key once. You may have hit it when you were hitting the back space key and then it erases letters going forward with the typing. Sometimes I have to hit it twice to clear the problem.
    Wednesday, June 01, 2011 7:19 PM
  • Oh my God! I have the exact same problem. Brand new Toshiba Satellite, newly installed Windows 7 and JUMPING CURSOR. I'm a novelist mid-way through a new book and this is driving me mad. When the hell is this going to be fixed?

     

    • Proposed as answer by gumsygob Sunday, February 05, 2012 4:06 PM
    • Unproposed as answer by gumsygob Sunday, February 05, 2012 8:16 PM
    Sunday, July 17, 2011 4:23 PM
  • Thank you for posting the touchfreeze link.  I had to use it on my last two laptops and it definitely fixed the jumpy cursor... not only jumped but erased, opened other apps etc... was SO annoying.  I had forgotten the name of this little gem that saved my time and patience!  Everyone with the problem should get touchfreeze!
    Tuesday, August 30, 2011 12:50 PM
  • Anyone with this problem should try to install and use TouchFreeze. I had doubt before I installed that on my Vaio/Win7 because I was pretty sure I didn't touch any part of the mouse-pad while typing. I'm a touch-type programmer for  over ten years, so I know this is not an accidental-touching issue. Nevertheless, just by the fact of having that filter-driver installed somewhere on the filter list, the problem disappears! I wouldn't say it is a fix, but do give it a try. I waited over 3-months before giving up on finding the root causes. I'm so glad now that I'm not going insane at random times when I typed "t" or "r". Cheers.

    PS: Still cross my fingers about this fix and looking for the root causes

    Monday, October 17, 2011 1:13 PM
  • I had the same problems and found a solution...sort of.  I have an Asus laptop and was having the jumping cursor problem.  I went into the control panel and disable the touchpad and voila!  Problem solved.  No more jumping around on the page.  But now I have to use the mouse for all navigation.  No worries!  Pianotony. 

     

    Thursday, October 20, 2011 1:27 AM
  • Thank you for posting the touchfreeze link.  I had to use it on my last two laptops and it definitely fixed the jumpy cursor... not only jumped but erased, opened other apps etc... was SO annoying.  I had forgotten the name of this little gem that saved my time and patience!  Everyone with the problem should get touchfreeze!

    Touchfreeze just solved the problem for me as well! I'm SO relieved!! I had been unbelievably frustrated!
    Tuesday, October 25, 2011 9:09 PM
  • The "Touchfreeze" download solved the problem for me! Thanks so much! What a huge relief!
    Tuesday, October 25, 2011 9:29 PM
  • Just wanted to let you know that when you have any updates to your computer, it seems that you have to download Touchfreeze again.  Not too much of a hardship when you have those annoying cursor jumps.  Also, I have a desktop and this has been happening for months (Dell, Windows 7). My friend's desktop  is acting the same (we bought ours at the same time a year ago next month) so it's not just a laptop issue.  Must be a Windows 7 issue.  Hope an answer is found.

    • Edited by scout123 Saturday, October 29, 2011 7:08 PM
    Saturday, October 29, 2011 7:04 PM
  • Here's to hoping TouchFreeze is the answer. I know for a fact it the problem isn't because I'm touching the touchpad when I type--my hands don't touch anything but the keys. It only happens to me on Microsoft products, like Word and Wordpad.

     

    It's killing me--I have to take notes during a fast-paced lecture for a disabled student, and I miss maybe 1/4 of what the prof says because of this stupid issue. If this doesn't work, I'll just abandon Word and use Notepad :P.

    Tuesday, November 29, 2011 10:22 PM
  • Me, tteeeyping is  atrocious  st o.  Myease...Pl  fix..I h

    ave to find out what is causing this mess.

    Wednesday, December 21, 2011 1:16 AM
  • In your touchpad settings disable "Tap to click"; worked for me.
    • Proposed as answer by petebeall Thursday, December 22, 2011 9:51 PM
    Thursday, December 22, 2011 9:51 PM
  • Since a similar thing happens to me while using my mouse in Mircrosoft Word and Excel for the Mac (Office 2004), I strongly suspect it is a bug in Microsoft's Office software.  If you check various forums, you will see that this "jumping" behavior is a common complaint.  I cannot offer any suggestions as to how you can lessen the effect you are getting when you are typing. In my case, where the jumping is mouse-related, I can lessen the effect my making absolutely sure that the mouse does not move even a millimeter when I click.
    • Proposed as answer by fadjoed Wednesday, January 11, 2012 8:15 PM
    • Unproposed as answer by fadjoed Wednesday, January 11, 2012 8:22 PM
    Friday, January 06, 2012 7:45 PM
  • This is simply a bug in WINDOWS7/Office 2010. I have experienced on different computers even while typing this note. My system is clean of virus and mater of fact it a brand new win7 image. 

    Never experienced it in ubuntu/open office. works like a charm.


    • Edited by fadjoed Wednesday, January 11, 2012 8:25 PM
    Wednesday, January 11, 2012 8:25 PM
  • I was also having this issue.  I read that the optical mouse needs to be kept clean.  I wiped the red sensor light on the mouse with a cotton swab and it corrected the issue.
    Thursday, February 02, 2012 11:38 PM
  • praxilla

    download this driver to fix this i had same problem with toshiba satellite T130-13q

    this solved it the Alps driver is rubbish the synaptics one is a lot better http://www.synaptics.com/resources/drivers

                                              regards Gumsygob

    • Proposed as answer by gumsygob Sunday, February 05, 2012 8:12 PM
    Sunday, February 05, 2012 8:12 PM
  • Not for me. I'm on Win7 64-bit (Compaq Presario CQ56 with Synaptics touchpad). I have the latest Synaptics driver (15.1.6.64), and definitely no viruses. Somtimes all is well, sometimes the cursor jumps around at random when I try to move it. I've fiddled around with the Synaptics driver settings (and there are lots of exciting things that can go wrong in there) and have discovered the following interesting data points:

    1) An external USB mouse works fine at all times.

    2) When it goes wrong, the typical problem is the cursor jumping up the screen as I touch the touchpad, jumping down when I lift my finger, or moving down / jumping up / moving down a bit more / jumping up again as I move my finger down the touchpad.

    3) The problem goes away if I restart, so it's not a hardware or temperature issue IMHO.

    4) All seems to be well until I right-click. It seems that right-clicking is somehow triggering the problem.

    5) The setting page for the Synaptics driver includes "Edge Motion" settings. I have Edge Motion disabled, but one of the subpages has a picture of a touchpad which shows where your finger is. Under normal circumstances it tracks my finger and at the same time the cursor moves normally. When it's misbehaving it tracks my finger but the mouse cursor moves occasionally and erratically, like it the driver isn't delivering mouse interrupts or the interrupts are being swallowed instead of being passed on as mouse movement messages.

    6) Removing the Synaptics driver in favour of the vanilla Microsoft PS-2 driver makes no difference whatsoever, so it doesn't seem to be a driver issue.

    Not the driver, not the hardware... hmm, what's left? Anyone else in this boat? Can anyone else confirm my observations?

    Friday, February 10, 2012 5:30 PM
  • I fixed mine by disabling the touchpad.
    Friday, February 17, 2012 1:47 PM
  • Halve used multiple laptops and the problem is the same.  There has to be a bug with With Win7 and laptop keyboards and not office 2010.  The same issue occurs while typing in this forum.  But Word is my editor so Office I guess is still a possible issue.  Same laptop in a Dock and external keyboard and mouse.. no problem.  Go figure. I'm going to work on setting up hardware profiles to see if this makes a difference.
    Saturday, February 18, 2012 7:53 AM
  • I have just cured the issue on my Word 2010 in Windows 7, the root cause was spoolsrv.exe using cpu process.. I removed and replaced the printer and all is working nicely.
    • Edited by Loochy Wednesday, February 22, 2012 8:35 PM
    Wednesday, February 22, 2012 8:22 PM
  • yes yes yes. the above cures the jumpy cursor for now. I went to task manager and right clicked on spoolsrv.exe and stopped it. Then Word restarted automatically and no jumpy cursor. Thanks Loochy!!
    Friday, February 24, 2012 9:09 PM
  • My issue tracks yours.  Just when I lift my finger from the touchpad, the cursor jumps up or down.  Problem was not there when I took the laptop (Asus i7) out of the box.  Loaded all the updates to the OS, then loaded M$-Office-2010 and the problem started.  I truly hate Microsoft.  The reason I bought a new laptop was because they caused an unrecoverable error in Vista, during an SP update, and their "work-around" was to reformat the hard drive!  I figured I'd start clean and fresh to give myself some longevity with a new system.  I learned my lesson - never, NEVER, N-E-V-E-R trust M$ to make a stable product.
    Monday, February 27, 2012 3:29 AM
  • I have same problem on desktop but am using a minikeyboard with a touchpad it does'nt do it in safe mode,but does with a clean boot which means it's not my app's its one or more of the services conflicting with the driver that win764bit install's when you dont have one you know the one included in windows! If that's not a bug I dont know what is.
    Tuesday, March 20, 2012 3:46 AM
  • ok i bought a dv6 that came with word 2010 but the hard drive died stupid seagate anyway so hp sent me the recovery disk and replaced the hard drive but they sent it out with word 07 and it works fine im running it on windows 7 64bit premium but i dont know if word 2010 worked or not never had a chance to use it anyway my point is my you could try installing word 07 i dont know if you would need to uninstall 2010 or not its an option


    • Edited by jeffd1988 Wednesday, March 21, 2012 9:36 AM
    Wednesday, March 21, 2012 9:35 AM
  • Piling on - this is driving me absolutely nuts. I've used Outlook 2010 on multiple other machines since before it was released (I used to work at Microsoft), and have never had this issue before. It happens on one of my machines - a laptop - and not others. If it's helpful, I've only had this issue with Outlook 2010 on Windows 7 64-bit, and not on Server 2008 64-bit nor Win8 32-bit.
    Tuesday, July 17, 2012 11:03 PM
  • Also, seems totally unrelated to trackpad vs mouse, and also unrelated to whether the window is maximized or not. (Can I say again?: This is super, super annoying!)
    Tuesday, July 17, 2012 11:06 PM
  • I have the same problems.  I read somewhere to go into the control panel and to unclick the "hide pointer while typing" box.  For some reason that actually helped a little, however I still think that the computer is a piece.  If you are in a document try to keep your pointer on the very bottom of the page in what I like to call "the neutral area" so that it's off the page and can't touch anything to make the cursor change
    Monday, August 06, 2012 10:19 PM
  • Exactly! I have had to move from XP this week as my old computer finally died. I borrowed a Windows 7 system to complete a freelancing job and bought a new computer with 7. Note that as I'm typing this, the cursor is jumping! This has never happened on any laptop I've used running XP, or even my old Vista laptop, it's clearly a Windows 7 issue--I am reading two years' worth of complaints but still can't find a good fix. What is Microsoft doing to remedy this? How can it still be happening?
    Saturday, September 22, 2012 8:06 AM
  • I've also done much reading.

    It must be a Win 7 problem.

    It's random and a serious problem when editing in Photoshop, more so than in other programs where it is a royal pain in the neck.

    I die quicker than I need in the various games I use as a diversion.

    Microsoft, fix this manslaughter, please.

    Tuesday, September 25, 2012 1:07 PM
  •  I've been going mad as well!  I've a Dell laptop Win 7 with touchpad plus a Trust wireless mouse (from my old Win XP laptop).  The mouse pointer would not work. Then suddenly 2 days ago it started working! BUT the dreaded pointer-dance started in all programmes.

    After seeing this thread I wondered - should I update the mouse driver?  So: Start > Control panel > View Devices and Printers > USB Input Device > Properties > Hardware > Highlight HID-compliant mouse (Mice and other pointing devices) > Properties > Driver > Update Driver 

    It worked!  When I now go Start > Control panel > View Devices and Printers > USB Input Device > Properties > Hardware > Highlight HID-compliant mouse (Mice and other pointing devices) > Properties > Driver > Update Driver > Driver Details. 

    I see :

    Provider: Microsoft Corporation
    Reversion: 6.1.7600.16385(win7_rtm.090713-1255)
    Copyright: © Microsoft Corporation. All rights reserved.
    Digital Signer: Microsoft Windows

    I'll come back if it starts pointer-dancing again. Until then ... hope this might help someone.


    • Edited by Seejuu Tuesday, November 27, 2012 4:47 PM
    Tuesday, November 27, 2012 4:45 PM
  • <object height="1" id="plugin0" style=";z-index:1000;" type="application/x-dgnria" width="1"><param name="tabId" value="{D883B8D6-035D-453D-B703-E6FCDC7DD191}" /></object>

    Cursor flashing busy in '2010 word office document'

    When I access any '2010 office word doc', I notice that the arrow cursor will momentarily flash the busy icon (the little blue circle)
    about one to two times per second.
    The cursor only does this when it hovers over the doc window and does not do this when I move it anywhere outside the doc window. 

     Interestingly, if I open a folder such as the Pictures or other type of Documents Notepad etc. - no problems;
    but all office docs opened on this desktop Computer not on our notebook - cursor flashing whenever the cursor is over the open doc window.

     This cursor rapidly flashing busy is extremely annoying. Is there any way to fix this flashing? 
    It seems like it's rapidly refreshing/saving doc or something. Need to stop the flashing cursor to use the software.

    Have done a repair and full reinstall of office both failed : Ran Norton 360, Super Anti Spyware, Microsoft security esentials all failed.

     Windows 7 64bit Ultimate
     Office 2010 Home and Student 32bit

    Thanks for any help.


    Borden

    Saturday, October 26, 2013 2:14 AM
  • It has nothing to do with Office, as it happens in any application.

    And Microsoft seems to be absolutely not helpful.

    Brand new Win7 install on laptop, connect with Remote desktop to work...and there it is again.

    Really really sucks.
    And with so many complaints, you'd think the big MS might undertake some action by now...

    Wednesday, January 08, 2014 8:17 AM