none
No Apps or Windows Store work after upgrading to Windows 8.1 Enterprise

    Question

  • Hello,

    Upgraded from Windows 8 Enterprise to Windows 8.1 Enterprise.  Now none of my apps work, cannot even go into the Windows store to repair them.  All of the apps give me an error message of "This App Can't Open" while the PC Settings and Windows Store apps just open to a blank screen.  All Metro apps have a "X" mark on them. What I have already done:

    1.  I already downloaded the app troubleshooter which didn't help.
    2.  No use "contacting the app's publishers" since these are all native Windows apps.
    3.  Tried refreshing, no help.
    4.  System restore, no help.
    5. I don't have a proxy on.
    6. I've updated my graphics card to the most recent version.

    This may sound naive but is there a way to "reinstall" the Windows store?  Can I download it from somewhere?  Please don't tell me to "reinstall or reset" Windows 8.1, that really isn't addressing the problem at all it is simply throwing the entire thing away and starting over.  There has got to be a way to "fix" these sorts of things aside from a clean reinstall, otherwise they shouldn't allow "upgrading" in the first place.
    Sunday, October 20, 2013 2:06 AM

Answers

  • The following finally fixed all issues for me (Store and all apps broken with black X, can't access PC Settings):

    1) Fixing the app store:

      1. Open registry editor typing regedit.exe from a command line.
      2. Browse to the registry key at HKEY_CURRENT_USER\Software\Classes\Local Settings\software\microsoft\windows\currentversion\appmodel\repository\packages.
      3. Right click on the “packages” key and bring up the “Permissions” tab.
      4. Click the “Advanced” button located at the bottom right corner.
      5. Check to see the account name that shows up as the “Owner” (this is the first line of text on the “advanced security settings” dialog for the “packages” key). It should say “SYSTEM”.  (For me this showed the built-in local Administrators group)
      6. If it is any other account, click on the “Change” button next to it.
      7. Type SYSTEM in the “select user” dialog. If “Multiple Names Found” window comes up, select the row for “SYSTEM”.
      8. Click OK to the dialogs and close them all.
      9. Run from admin command prompt:     Powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml

    2) Fixing all modern apps:

    Run from admin PowerShell:

    ((Get-ChildItem "HKLM:SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\InboxApplications") | Get-ItemProperty).Path | Add-AppxPackage -Register -DisableDevelopmentMode

        * When I ran this the black X persisted until after the next step and reboot.  But trying to start an app gives me a new message and a link to the store.

    3) Fixing 3rd party apps:

    Delete the regkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\[UserSid]

    4) Restart.  After a reboot the apps still showed the black X for a minute or so, but it soon cleared up on its own and all apps seemed to be working again.  I was also able to update the apps from the app store once signing in with a Microsoft account.  Finally, I am again able to get into PC Settings.

    • Marked as answer by arthesing Wednesday, November 20, 2013 11:11 PM
    Wednesday, November 20, 2013 1:58 PM

All replies

  • Try all steps from here (App Troubleshooter, Reg permissions):

    What to do if your Windows 8 Modern App fails to start
    http://blogs.technet.com/b/askperf/archive/2013/10/11/what-to-do-if-your-windows-8-modern-app-fails-to-start.aspx


    "A programmer is just a tool which converts caffeine into code"

    Sunday, October 20, 2013 6:23 AM
  • Hello Andre,

    Thanks for your reply.  I went through everything that was listed in that link with no avail.

    For example, the common Windows store event message i'm getting is:

    The app winstore_cw5n1h2txyewy!Windows.Store is not registered for the Windows.Launch contract or is not installed.

    As far as I determine tell nothing on blogs.technet.com is relevant in terms of troubleshooting. I can't even run wsreset.exe (the last resort of the article) because it returns a message of

    "ms-windows-store:PurgeCaches The app didn't start."

    I've spent hours on the internet about this issue and have not found anything however have found other help articles about people having the same issue.  Any other suggestions?

    Sunday, October 20, 2013 5:41 PM
  • Having the same issue (all Metro apps barring Internet Explorer(?), the Windows Store and the Metro Settings menu are broken for me) after upgrading from Win8 Pro + Media Center to Win8.1 Pro + Media Center (and then 'upgrading' to Win8.1 Pro at the suggestion of tech support). Been on the phone with Microsoft tech support over the past week or so, but no luck finding a solution yet.
    Thursday, October 24, 2013 11:35 PM
  • Same problem on my computer ... I am quite disapointed as I didn't find an solution yet and nobody seems to have ... Come on Microsoft !
    Friday, October 25, 2013 8:03 AM
  • I am having the exact same issue after upgrading to Windows 8.1 Enterprise from Windows 8 Enterprise.  I upgraded with our EA Volume Licensed software, which required an install directly from the ISO (as opposed to downloading from the Store, etc).  I have also tried reinstalling from the ISO a second time to no avail.  All of my regular apps are continuing to work normally for the most part.  I'm going to create a support case.
    • Proposed as answer by John RR Monday, July 14, 2014 6:04 PM
    • Unproposed as answer by John RR Monday, July 14, 2014 6:04 PM
    Friday, October 25, 2013 2:48 PM
  • I am having the same issue. Apps do not load and the app store will not load. Is there anyway to reinstall the app store?
    Monday, October 28, 2013 6:52 PM
  • Out of curiosity, do any of the other people experiencing this issue have Avast Antivirus or Malwarebytes Anti-Malware installed? I've heard talk that Avast doesn't agree with the 8.1 upgrade and I'm wondering if having one or both of these programs installed may have contributed to my version of the issue.

    Monday, October 28, 2013 9:03 PM
  • No, not using Avast of Malwarebytes.
    Monday, October 28, 2013 11:35 PM
  • Same problem. At first the apps were fine, but now they're like dead. 
    Tuesday, October 29, 2013 2:02 PM
  • Same problem as yours.

    I just opened my laptop,  using ie11 reading websites(in metro mode), and somehow I wanted to open the Skydrive app in the start screen. I click on the app icon but nothing happened, even the splash screen didn't appear. After that I found that neither do other app if I want to open them. Windows store, Windows Setting, even the Desktop icon in the start screen! whatever in metro is like just all dead. But the weird thing is that the ie11 metro app still runs. Totally no idea what's going around here.

    Hope Microsoft can solve it soon...it's so bothering!!



    • Edited by PACKAGE Wednesday, October 30, 2013 5:40 AM
    Wednesday, October 30, 2013 5:32 AM
  • Same here, come on Microsoft, what the hell?
    Monday, November 04, 2013 10:10 AM
  • Having the same problem.  I setup 2 accounts before upgraded to 8.1.  They are working ok.  

    After upgrading to 8.1, any account I setup is showing all apps with the x mark.  Even the store.  

    Spent 3 hours with HP for support, since it's a new computer.  They tried everything.  Couldn't fix it.  Now they want to to reset and go back to 8.0.  What a waste of time.  

    If 8.1 is not ready yet, why did they release it?  Something basic a Metro apps not installing is just appalling.  

    And this is a new HP laptop.  When I was younger, I had time to fiddle around with this kind of stuff.  Now, I just want stuff to work.  This may force me to go buy the  MAC.  

    Monday, November 04, 2013 1:07 PM
  • Read:

    http://blogs.technet.com/b/ouc1too/archive/2013/10/19/windows-app-store-doesn-t-load-after-8-1-upgrade.aspx

    There you can find a way to make the Store work.
    But I am still having problem with all other apps...

    • Proposed as answer by leifbertil Wednesday, November 06, 2013 1:27 PM
    • Unproposed as answer by arthesing Wednesday, November 06, 2013 1:30 PM
    • Proposed as answer by camatz Thursday, March 06, 2014 6:43 AM
    • Unproposed as answer by camatz Thursday, March 06, 2014 6:43 AM
    Wednesday, November 06, 2013 1:27 PM
  • Unfortunately did not work, received the following error:

    Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF6, Package could
    not be registered.
    error 0x8007064A: Cannot register the request because the following error was
    encountered while initializing the windows.repositoryExtension extension: The
    configuration data for this product is corrupt. Contact your support personnel
    .
    NOTE: For additional information, look for [ActivityId]
    27021ad9-da28-0006-089d-022728dace01 in the Event Log or use the command line
    Get-AppxLog -ActivityID 27021ad9-da28-0006-089d-022728dace01
    At line:1 char:1
    + Add-AppxPackage -DisableDevelopmentMode -Register
    $Env:SystemRoot\WinStore\AppxM ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~~~
        + CategoryInfo          : WriteError: (C:\WINDOWS\WinStore\AppxManifest.xm
       l:String) [Add-AppxPackage], IOException
        + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageMa
       nager.Commands.AddAppxPackageCommand

    Wednesday, November 06, 2013 1:29 PM
  • I have sort of found a way around it, at least so that you can reinstall the win store,  the problem is that with my method, any 2 party apps you have installed will have to be reinstalled.  Start by enabling the built in admin account.  This can be done by hitting your windows key and typing cmd.  when the command prompt is listed right click and select run as administrator.  Then type the following command:

    net user administrator /active:yes

    you should see the words:

    command completed successfully

    then type the following:

    net user administrator password  where password is the password you want for the built in administrator account.

    Then you can sign in as the built in adminstrator, which should give you access to core metro apps such as recovery or reinstall options.  the rest of your metro apps, such as mail, the calendar, etc, will not work.  At that point you can hit the windows key and type refresh my pc, and select the refresh option.  It will delete all 3rd party apps but leave your main apps intact.  

    Friday, November 08, 2013 3:24 PM
  • Unfortunately none of the metro apps are in any better condition when logging in using the built-in administrator accounts.  I have also tried creating new local accounts and new local Microsoft accounts with the same result.
    Saturday, November 09, 2013 5:13 PM
  • Has anyone had any luck yet? I am still down on all fronts. Nothing has worked yet for me.
    Thursday, November 14, 2013 12:08 PM
  • I have this problem also.

    I have tweeted it to @WindowsSupport - they are generally very good, so might be worth doing the same.


    Simon

    Friday, November 15, 2013 9:07 AM
  • Close all applications and the enter this system file checker command into the command prompt (admin):

    sfc /scannow

    When completed restart your computer.

    Wednesday, November 20, 2013 9:15 AM
  • Unfortunately i've tried this many many many times already.
    Wednesday, November 20, 2013 12:22 PM
  • The following finally fixed all issues for me (Store and all apps broken with black X, can't access PC Settings):

    1) Fixing the app store:

      1. Open registry editor typing regedit.exe from a command line.
      2. Browse to the registry key at HKEY_CURRENT_USER\Software\Classes\Local Settings\software\microsoft\windows\currentversion\appmodel\repository\packages.
      3. Right click on the “packages” key and bring up the “Permissions” tab.
      4. Click the “Advanced” button located at the bottom right corner.
      5. Check to see the account name that shows up as the “Owner” (this is the first line of text on the “advanced security settings” dialog for the “packages” key). It should say “SYSTEM”.  (For me this showed the built-in local Administrators group)
      6. If it is any other account, click on the “Change” button next to it.
      7. Type SYSTEM in the “select user” dialog. If “Multiple Names Found” window comes up, select the row for “SYSTEM”.
      8. Click OK to the dialogs and close them all.
      9. Run from admin command prompt:     Powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml

    2) Fixing all modern apps:

    Run from admin PowerShell:

    ((Get-ChildItem "HKLM:SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\InboxApplications") | Get-ItemProperty).Path | Add-AppxPackage -Register -DisableDevelopmentMode

        * When I ran this the black X persisted until after the next step and reboot.  But trying to start an app gives me a new message and a link to the store.

    3) Fixing 3rd party apps:

    Delete the regkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\[UserSid]

    4) Restart.  After a reboot the apps still showed the black X for a minute or so, but it soon cleared up on its own and all apps seemed to be working again.  I was also able to update the apps from the app store once signing in with a Microsoft account.  Finally, I am again able to get into PC Settings.

    • Marked as answer by arthesing Wednesday, November 20, 2013 11:11 PM
    Wednesday, November 20, 2013 1:58 PM
  • Oh my gosh Andy, that did it!  I can't believe it!  I did all of the steps you mentioned, my registry settings were also set to the built-in local Administrators group for the owner of that key.

    All of my metro apps work again as well as my Settings app.

    Thank you very much, i've been frustrated at this for about a month now!

    Andy

    • Proposed as answer by Shafiqah Hadirah Wednesday, December 11, 2013 4:21 PM
    • Unproposed as answer by Launchpad Thursday, December 12, 2013 6:15 PM
    Wednesday, November 20, 2013 11:11 PM
  • YES! That fixed everything for me (though I did need to reinstall my third-party apps from the store to make them reappear on my start menu). Thank you so much for finding and sharing this, I was on the verge of doing yet another 3+ hours repair from the install disk and failing that reinstalling Windows entirely, you have saved me so much stress and time.
    Thursday, November 21, 2013 2:43 AM
  • When I run this...

    ((Get-ChildItem "HKLM:SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\InboxApplications") | Get-ItemProperty).Path | Add-AppxPackage -Register -DisableDevelopmentMode

    It fails with all 'write errors'

    I tried to attach a pic but the forum won't let me. The 1st line said the package couldn't be registered.

    any ideas? I did change the permissions in the reg key and System is listed 1st and as the owner.

    Friday, November 22, 2013 1:12 PM
  • FOLLOW ALL of these steps. 

    Browse to the registry key at HKEY_CURRENT_USER\Software\Classes\Local Settings\software\microsoft\windows\currentversion\appmodel\repository\packages.
    Right click on the “packages” key and bring up the “Permissions” tab.
    Click the “Advanced” button located at the bottom right corner.
    Check to see the account name that shows up as the “Owner” (this is the first line of text on the “advanced security settings” dialog for the “packages” key). It should say “SYSTEM”. 
     If it is any other account, click on the “Change” button next to it and type SYSTEM in the “select user” dialog. If “Multiple Names Found” window comes up, select the row for “SYSTEM”.
    Click OK to the dialogs and close them all.
    Mine was set properly – still  run this from admin command prompt:     Powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml
    Run from admin PowerShell: ((Get-ChildItem "HKLM:SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\InboxApplications") | Get-ItemProperty).Path | Add-AppxPackage -Register –DisableDevelopmentMode
    Delete the regkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\[UserSid]
    Restart.  <o:p></o:p>

    After that my Metro Apps started to load.<o:p></o:p>


    Friday, November 22, 2013 9:15 PM
  • Cant find [UserSid] 

    Please help on the same

    Sunday, November 24, 2013 10:10 AM
  • Hello,

    The cause why appstore does not start is permissions and missing repository registry keys.

    I fixed the problem by doing the following: importing and exporting registry keys / change permissions and reboot the machine.

    login with a local account (must be member of administartor group) not a domain account to your machine. If you do not have, ask a colleague not having the problem with the appstore.

    Ask hem to export the "HKEY_CURRENT_USER\Software\Classes\Local Settings\software\microsoft\windows\currentversion\appmodel" key.

    You need to import this key into the registry using your account.

     Follow this steps:

    Check first the following location to see iof the repository is not empty

    C:\ProgramData\Microsoft\Windows\AppRepository

    1. Open registry editor typing regedit.exe from a command line.
       2. Browse to the registry key at HKEY_CURRENT_USER\Software\Classes\Local Settings\software\microsoft\windows\currentversion\appmodel\repository\packages.
    if the repository is not there, login locally with a different account and export the following registry key:
    HKEY_CURRENT_USER\Software\Classes\Local Settings\software\microsoft\windows\currentversion\appmodel

    - login backup to the account having appstore problem.
    dubbel exported regkey, click yes and confirm overwriting the registry.

       3. Right click on the “packages” key and bring up the “Permissions” tab.
       4. Click the “Advanced” button located at the bottom right corner.
       5. Check to see the account name that shows up as the “Owner” (this is the first line of text on the “advanced security settings” dialog for the “packages” key). (this shows the built-in local Administrators group), it must be “SYSTEM”.    
       6. If it is any other account, click on the “Change” button next to it.
       7. Type SYSTEM in the “select user” dialog. If “Multiple Names Found” window comes up, select the row for “SYSTEM”.
       8. Click OK to the dialogs and close them all.
       9. Run from admin command prompt:    
    Powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml

      10. Reboot your machine.
      11. Start appstore, if you get the error, you have no internet connection.
      12. Close appstore wait a view seconds and start it again.

    This fixed the problem for me.

    Regards, Azzim / System Administrator

    Thursday, November 28, 2013 10:30 AM
  • andy562`s trick worked for me

    I wasn`t able to "Change computer configuration" or open Windows Store

    ((Get-ChildItem "HKLM:SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\InboxApplications") | Get-ItemProperty).Path | Add-AppxPackage -Register -DisableDevelopmentMode

    Thursday, November 28, 2013 4:08 PM
  • When I do step two of andy562's solution I get a message that says ".Path was unexpected at this time" Any idea as to why this is happening for me?
    • Edited by KaitR Monday, December 02, 2013 3:05 PM
    Monday, December 02, 2013 2:38 AM
  • Every time I delete the registry key it comes back. If that's not supposed to happen please explain to me what's going on.
    Tuesday, December 03, 2013 2:14 AM
  • Please execute my steps. Ignore eny error when running the script. Just reboot the system. regards, Azzim95.

    Friday, December 06, 2013 8:11 AM
  • Hello,

    I think this is due to a corrupted profile. Please check within the C:\Users to see if a .tmp profile is created.

    If you are logged with a tmp profile, you need to log in with an administrator acccount and delete the .bak profile in the registry.

    Regards,

    Azzim95

    Friday, December 06, 2013 8:15 AM
  • I had this same issue and none of the options posted on this thread worked.  My issue was that I upgraded using the Enterprise N version, not the regular Enterprise version.  This resulted in an install without Windows Media Player -- and evidently some other critical files.

    I installed the Windows Media Feature Pack, rebooted, and all my apps worked.  I hope this helps someone.

    Thursday, December 26, 2013 2:21 PM
  • Thank you so much!  I have been fighting this machine all day, just got it for my wife, and your fix worked.  The apps stopped working after installing my isp's version of Norton...which was a chore in itself.  Anyways, happy new year and thanks again!  
    Friday, December 27, 2013 3:41 AM
  • Well, at least it fixed the store, the weather app and a few others are still not working.  

    Friday, December 27, 2013 3:42 AM
  • Mine stopped working after successfully installing Norton.

    Friday, December 27, 2013 3:51 AM
  • Hmmm, kind of seems like an easy enough set of programming fixes that COULD have been incorporated by moronic microsoft programmers so that everyone's crap would not have been broken, EH?  Just LAZY TERRIBLE programming practices by Microsoft....and obviously they do not TEST ANYTHING before unleashing the pain onto their customers.
    Monday, December 30, 2013 3:41 PM
  • I spent more time with Microsoft than with my hubby in the last month.

    Nothing helped -and of-course it is windows 8.1.

     but today the tech created another account and lo and behold the apps work in that. Now, if I could only get the apps to work on my main desktop.

    Why give us apps- if they just sit there and do nothing.

    and yes, I have refreshed, even done a repair at Micros request- lost all my software-am still reinstalling that-and you guessed, the tech today literally demanded a repair again-but I said NO.

    Tuesday, December 31, 2013 2:38 AM
  • I so agree
    Tuesday, December 31, 2013 5:26 AM
  • I just wanted to say thank you for this, you fixed my actual issue after trying all the failed articles from MS to resolve this issue. Spent most of this evening after upgrading from Windows 7 SP1 to Windows 8 Pro to Windows 8.1 Pro to finally come across this article after trying dozens of failed resolutions. My final thought if this didn't work was to make one last backup of my data and then wipe the drive and start from scratch and go from there. You saved me from actually having to do that.

    Maybe MS needs to take this fix and make a fixit app to do it...

    Friday, January 17, 2014 4:46 AM
  • The fact that we have to go through all of this is so pathetic.  I am really disgusted with Microsoft.  Windows 8.x go away
    Sunday, January 19, 2014 8:24 PM
  • Hi

    I have solution

    Just open Command Prompt.Copy and paste these lines.

    powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml

    Hit enter

    Now you can run store and other Apps

    Friday, January 24, 2014 10:47 AM
  • I went to the Microsoft website and got technical support.  They fixed the problem for me.  I could not open the Store App, so I was in real trouble.  But the technician fixed it for me.  I would recommend that instead of trying to do it yourself.  I have seen horror stories in my search for answers.
    Sunday, January 26, 2014 8:03 PM
  • Hi!  I could not open the Store App after upgrading to Windows 8.1.  I finally contacted tech support on the Microsoft website and it was fixed.
    Sunday, January 26, 2014 8:06 PM
  • Just to let everyone know I went through the same problem. On Friday Windows 8.1 was installed on a new built custom computer by a Tech while I watched how the build etc. was going. Today, Monday I opened up Start and found my APPS had that dreaded "X" mark in the bottom right hand corner of the App box, didn't matter which App they all had it. When you clicked on the App again doesn't matter which on it said something like the License had expired for the development - something to that effect.

    I was somewhat ticked to say the least and then I decided to look for the phone number to Microsoft to get Tech support - which is located in "System" - tap "Windows key & Pause key" at the same time 0N THE KEYBOARD. Scroll down to where it says Windows is Activated and click on "Read the Microsoft Software License Terms" then scroll down to 'Warranty Procedures". Though, I MAY BE WRONG ABOUT THIS BUT YOU MAY BE ENTITLED TO 3 MONTHS OF FREE TECH SUPPORT FROM Microsoft FROM DATE OF INSTALLATION. Phone: 1-800-Microsoft. Read the warranty. I was on the phone with Microsoft for 2 1/2 hours at no charge to me and the tech I had was very helpful and fixed the problem and made sure the computer had no viruses and it was OK. Microsoft/Tech was very helpful and new what she was doing, I did give her access to the computer and she did download info back to Microsoft. What I got out of this is there is some kind of problem going on with the Apps, why, I don't know and I hope they will find a solution to this problem before the operating system is installed and new discs are mailed out. {Ya, right.) You never know your Hotmail account is linked with registration so it is possible for them to email you, asking if you want new discs with the fix. Remember, Microsoft did mail out to individuals who requested it a Sp1 or 2 disc for XP, I believe because I did get one.

    Tuesday, February 04, 2014 12:10 AM
  • Forgot to mention one thing the Tech did uninstalled the Apps that weren't working and then reinstalled them through the App store. Make a list before you delete and make sure you have access to the App store and the Apps are there. I watched her doing this. Good luck everyone...........
    Tuesday, February 04, 2014 12:15 AM
  • go to Coastalwaters 2448Feb.3, 2014
    Tuesday, February 04, 2014 12:20 AM
  • I have the same problem.  HP and/or Microsoft should immediately set forth a tast force to fix this problem as they know this problem exists when the user upgrades to Windows 8.1.    Techs know it but don't know how to fix it other than go back to Windows 8.  This is not a FIX.   Very disappointed in HP customer support who mostly try to sell you more services.  
    Friday, February 07, 2014 12:23 AM
  • I have Malwares installed with no problems.  I also have Norton but  have found that Norton won't catch malware programs. No problems so far.
    Friday, February 07, 2014 12:26 AM
  • HP should let users know about this and pressure Microsoft.  It is a joint blame game.
    Friday, February 07, 2014 12:28 AM
  • Amen.  I went down that same road and felt totally defeated after spending 3 hours on phone with rep who wanted to go back to 8.0.  What a waste of my time and their resources.  FIX THE PROBLEM!
    Friday, February 07, 2014 12:29 AM
  • SOMEONE NEEDS TO TELL HP TECHS THIS INFO SO THEY AN ASSIST THOSE WITH THIS PROBLEM
    Friday, February 07, 2014 12:33 AM
  • This worked for me, but only for store app.

    To fix this, run the following in a Command Window (CMD) to re-register the Store App:

    powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.XML

    If you get error 0x8007064A after executing this, it means that the registry key "HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages" does not have SYSTEM as the owner.
        Change the owner back to SYSTEM as explained here and try again.

    Hope this helps

    Wednesday, February 12, 2014 10:27 AM
  • thankyou dear sir/madam - microsoft  fouled up and you fixed it thankyou
    Tuesday, February 18, 2014 12:33 PM
  • Similar situation but slightly different - one day all Windows Store apps stopped working. It is a development machine, so I stuck to your item 3) Delete the regkey ... [UserSid]. Everything returned to normal after a reboot.
    Sunday, March 02, 2014 9:20 PM
  • I am having the same problem. I looked on event viewer and unless I am misunderstanding, it looks like the apps that are not working are already downloaded on my computer in a windows 8 folder and cannot be downloaded a second time to my computer since accepting and downloading the free windows 8.1 upgrade. The original app has to be removed before being reinstalled from the store. This is so crazy. I have been trying everything and fear I will do something wrong on this beast and land in worse shape than I am already. There has got to be a simple way of fixing this. Can't Microsoft develop a tool to fix something like this? They have fix it tools for everything else.
    Thursday, March 06, 2014 6:41 AM
  • My store app works but many Microsoft apps don't. Microsoft Mahjong, solitaire, reader, weather channel, etc. All problem apps have one thing in common. They were all downloaded at the time I accepted the free on line upgrade to Windows 8.1 Pro. From what I can see in "Event Viewer", even though I am running Windows 8.1 Pro now, the Windows 8 apps are still on my hard drive and therefore cannot be reinstalled on Windows 8.1 until they are removed. The only other option is to create a new user account which also means another email. Pain in my...you know what. It makes sense to a degree but how do I locate them. I am scared I will mess my computer up big time if I do one thing wrong. It wasn't until after the fact that I discovered a post stating you need to update Windows 8 prior to the upgrade to avoid such issues. So why wasn't the update listed with the upgrade download to insure people wouldn't run into issues like this.  
    Thursday, March 06, 2014 6:51 AM
  • after following all instructions, it seemed to have worked. however, it took a very long time to log in and when it did i was brought to the desktop screen but it was blank and completely black. after a while later, things appeared and i the black x's were disappearing. upon restarting again, the black x's remain but i am able to open the app store now. any solutions to fix?
    Friday, March 14, 2014 10:24 AM
  • Very nice andy562, this worked for me, thank you!
    • Edited by GibbyGrant Saturday, April 05, 2014 8:50 AM
    Saturday, April 05, 2014 8:31 AM
  •  Excuse me, Andy, but I can't find a [UserSid] key in the registry. The app store is fixed ( thanks for that ) but the 3rd party apps are not working. Can you help?


    • Edited by AB1699 Sunday, May 11, 2014 5:29 AM
    Sunday, May 11, 2014 5:28 AM
  • I was unable to find the [UserSid].  Will it actually say this or is it some sort of number?  Also, I noticed that the modern apps are the only ones with the black X on them.  Is it really necessary to fix the 3rd party apps?  Lastly, I completed all the steps but the third party step and nothing happened.  I didn't see any changes.  I think it may be because I was unable to find that UserSid

    Sunday, May 18, 2014 6:23 PM
  • The following finally fixed all issues for me (Store and all apps broken with black X, can't access PC Settings):

    1) Fixing the app store:

      1. Open registry editor typing regedit.exe from a command line.
      2. Browse to the registry key at HKEY_CURRENT_USER\Software\Classes\Local Settings\software\microsoft\windows\currentversion\appmodel\repository\packages.
      3. Right click on the “packages” key and bring up the “Permissions” tab.
      4. Click the “Advanced” button located at the bottom right corner.
      5. Check to see the account name that shows up as the “Owner” (this is the first line of text on the “advanced security settings” dialog for the “packages” key). It should say “SYSTEM”.  (For me this showed the built-in local Administrators group)
      6. If it is any other account, click on the “Change” button next to it.
      7. Type SYSTEM in the “select user” dialog. If “Multiple Names Found” window comes up, select the row for “SYSTEM”.
      8. Click OK to the dialogs and close them all.
      9. Run from admin command prompt:     Powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml

    2) Fixing all modern apps:

    Run from admin PowerShell:

    ((Get-ChildItem "HKLM:SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\InboxApplications") | Get-ItemProperty).Path | Add-AppxPackage -Register -DisableDevelopmentMode

        * When I ran this the black X persisted until after the next step and reboot.  But trying to start an app gives me a new message and a link to the store.

    3) Fixing 3rd party apps:

    Delete the regkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\[UserSid]

    4) Restart.  After a reboot the apps still showed the black X for a minute or so, but it soon cleared up on its own and all apps seemed to be working again.  I was also able to update the apps from the app store once signing in with a Microsoft account.  Finally, I am again able to get into PC Settings.

    Tried this and it worked, a bit long winded but did work, however i still have the black X on all apps including the app store. You would think with all their money they could do an update for this and push it out. C'mon Microsoft.

    Friday, May 23, 2014 1:39 PM
  • I had the same problem as many people here with the exception that I never say a black X on any of my apps.  Just the store would not work and all of my apps would say they could not open.

    I followed the steps in the article with the exception of the part about deleting the [UserSid] key because, like many, I did not have such a key.

    After reboot, my store now works but the other apps still did not work, but I was able to correct that by uninstalling and reinstalling most of them.  However, several of them still refuse to function even after the reinstall, mostly it sees to be the apps that came with Windows (Mail, Calendar, People, Music, and Video).  I say mostly because Games would not work either but after I uninstalled and reinstalled it it started to work again, so it is not all the defaults apps, just some.  The problem is different now though, instead of saying they can't start it is almost like they launch but immediately minimize to the desktop.  You can click their icon on the task bar and they well jump to full screen and then right back to the task bar.Has this been the experience of anyone else and can anyone provide me with guidance on correcting this please?

    Thursday, June 05, 2014 7:42 PM
  • I found the easiest solution to this problem. Don't follow any of these directions. All you need to do is make a new user account, and delete the old one... bada bing, bada boom, bada bam!!! Everything works great! Easiest fix in the world! Basically, there were some files that did not get updated correctly on your currently profile, as was evident by the fact that SkyDrive was still labeled such months after the name switch. You might need to setup an additional Live account because of the stupid manditor web integration (I am completely against software that works diametrically different on different operating systems... its bad practice and users HATE it... ubiquitous user experience my friend. Evolution happens over time, not over night.)

    Additionally, Windows 8.1 Update did not install correctly due to the same but. It falsely report a install fail when it actually just need to do a restart and update. The update fail didn't list a reason, but it was because it needed to restart.

    Wednesday, June 18, 2014 8:25 PM
  • I have exactly the same behavior. I also did not have a registry key with my UserSid. I exported the AppxAllUserStore keys for safe keeping and tried to delete the keys in the folder named S-1-5-21-247....

    as this seemed to be associated with my login based on the applications referenced in there.

    After a reboot,  things took a while to start up.  My Store app didn't work at all (used to) but after some time, it started to work again.  But,  alas, some of the metro apps startup with the splash screen then minimize.

    The registry editor shows the folder S-1-5-21-247.... in the AppxAllUserStore again.  So, it seems this is the registry for my account.

    I really don't want to create a new user account as suggested here because I have had this Microsoft account for several years and my Skype account is tied to it and all the people I interact with on it are relying on it.

    BTW,  this is a brand new Laptop that came preconfigured with 8.1.  It was not an upgrade from 8.0.

    Edit...  I have since learned how to determine my User Sid.  It is not a User ID...  perform this command from Admin command prompt:  wmic useraccount get name,sid

    it will show you a code like I showed above.  This is the registry key to delete being referred to above.  Still,  having done this, it still doesn't work

    • Edited by jkminer Monday, July 07, 2014 3:28 PM
    Monday, July 07, 2014 3:22 PM
  • Just to expand on the above (excellent instructions, by the way).  I am am an Office365 user with a domain connected laptop that was sufferring with the same issues, but without any black x's.  Primarily the Windows Store and PC Settings would not open- no errors , just a quick attempt and a return to the desktop.  SO...

    Step 1 fixed the Windows Store.

    Step 2 has fixed PC Settings

    I won't progress to step 3 at the moment until I have another issue.  Next job is to relay this very clear article to the support desk, who I know have had this on several new computers.

    Please not that these nuances for a domain connected computer may be directly affected by the configuration of our domain policies etc.  Still working on that one.

    Saturday, August 16, 2014 8:09 AM