none
Error in Event Viewer : one or more logs in the Query have errors

    Question

  • I am getting this error when I open the event viewer in Windows 7
    A secondary window opens with the message: One or more logs in the Query have errors

    In the box associated with the error are the following:

    Microsoft Windows-Diagnosis MSDT /debug
    Microsoft Windows-Eventlog Forward Plugin/debug
    Microsoft Windows-Printspooler/Aux-Analytic

    With all of these the comment next to the entry is "the system cannot find the specified file"
    Where are these event log files located and why would they be missing?

    Thanks

    P.S. please move this to the correct forum if I have posted in the wrong location
    Monday, July 13, 2009 6:49 AM

All replies

  • Hi JerryF1,

    The log files should be in %systemroot%\System32\winevt\Logs.  Do you see them there?
    Monday, July 13, 2009 11:38 AM
  • None of the logs referred to in the error exist in that directory. All of the operational logs do, but apparently diagnostic logs need to be activated. I have tried to activate these logs unsucessfully. I do not know if MS has something planned at Windows 7 release, but if this is WAD, there will be alot of inquires about this. I've noticed the same absence of logs in another computer with RC1. Windows 7 has significantly more logs than Vista did, as a third machine still running Vista has no reference to these logs at all.
    Tuesday, July 14, 2009 3:27 AM
  • Does Event Viewer run normally after you acknowledge the message?

    Does the message pop up immediately upon launching the Event Viewer? Or after you navigate in the Event Viewer?

    Did you define any custom views?


    Wednesday, July 15, 2009 12:51 PM