none
Network Vista Laptop + Desktop, Desktop refuses access.

    Question

  • I can't seem to get my vista home laptop wireless to network/file share with my wired desktop. Internet works fine. The desktop can see the laptop (access files) however the laptop can't see the desktop nor can it even ping it (in cmd: ping 192.168.1.100) Here's my setup.

    Linksys WRT150N firmware: 1.51.3
    Wired Vista SP1 Ultimate Desktop (vista firewall disabled)
    Wireless Vista SP1 Home Laptop

    They are on the same submask and workgroup.
    I have WPA turned on and mac filtering but I don't see how that would affect accessing the desktop since all the wireless devices work perfectly fine. I have all the sharing options turned on in the network settings on the desktop.

    Also my PS3 can't discover my desktop but has no problem with the wireless laptop when I use it as a media server. I am thinking it may be something to do with the router since when I disabled the Linksys SPI firewall, my desktop appeared as a possible shared device on the laptop however when I tried to access my desktop through the laptop I got an error saying the computer's name has changed?

    Can someone please help me out?
    Searched the internet for a few hours with no helpful leads.
    Thanks.
    Friday, August 01, 2008 2:08 PM

Answers

  • SUCCESS!

    I messed around with various things before your email and finally figured it out.

    I ran the
    Internet Connectivity Evaluation Tool on my desktop and found that something was blocking the router's upnp functions. This was not a problem on my vista laptop, so clearly windows was causing the issue. I decided to re enable my windows firewall, turn off all the sharing and restart each sharing process one by one. However no matter what I tried I couldn't re enable my firewall it kept on giving me "ERROR 13" in the event viewer. Seems like this is a common error and no one can solve it. After some forum surfing and trying out numerous processes to enable the windows firewall, I noticed my desktop would randomly appear as a shared device on my laptop. After narrowing it down. I got it to work by completely disabling the firewall from the services.msc (windows firewall is set to disabled). My router has a firewall and since its a wired connection with WPA2 and MAC filtering I should be ok without a windows firewall for the time being.

    But if anyone can help me figure out how to turn on the firewall that would be great.
    + tried windows repair install
    + clearing repository
    + disabling / enabling the windows firewall and rebooting several times.

    And consistantly get the ERROR 13.






    Thursday, August 07, 2008 5:09 PM

All replies

  • Please let me know when you find an answer. I've been struggling with this problem for several days and have seen a connection to my desktop (XP) from my laptop (Vista) a couple if times, then it disappears. Also am not able to open my Vista public folder from my desktop. Error message says, "You might not have permission . . . blah blah blah"

    Monday, August 04, 2008 6:06 PM
  • Hi,

     

    Please keep disabling the Linksys SPI firewall, and then try to ping the desktop from the laptop again in order to identify if the firewall blocks the ICMP packets.

     

    If the ping is completed successfully, try accessing the share folder on desktop by using the UNC path. To do so, refer to the following steps:

     

    On the laptop, click Start, type \\ 192.168.1.100\ShareFolder

     

    Hope it helps.

     

    Tuesday, August 05, 2008 6:39 AM
  • Here is what I discovered and I finally got it to work:

    In Vista:

    Make sure Network Discovery is on

    Make sure Password Protected Sharing is off

    Make sure File Sharing is on as well as Media Share and Public Folder Sharing.

    Make sure your network is a private network and that your workgroup matches the XP machine.


    In XP:

    I had to select the network connection I was using and add NetBIOS/IPX/SPX Protocols as well as IPv6

    I also changed my LAN Manager Authentication Level to Send LM & NTLM - Use NTLMv2 session security if negotiated. I ensured that the XP machine matched.


    You can check it by going to Start > Run and type secpol.msc. Go to Local Policies > Security Options & double click Network Security: LAN Manager authentication Level.


    I also ensured that check the Group Policy settings on the XP Pro machine.
    To do so, follow these steps:


    Click Start - Control Panel - Administrative Tools.

    Click to expand Local Policies, then click User Rights Assignments. Click "Access this computer from the network" and make sure that the Everyone group is included. Click "Deny access to this computer from the network" and make sure that the Everyone group is NOT included.


    Overall, it was a bit of a pain in the but, but it works. For me, XP was the major issue.

    Wednesday, August 06, 2008 12:53 AM
  • The problem is VISTA laptop (wireless) to VISTA desktop (wired).
    I have everything enabled you specificied in the post above on my desktop.
    No windows firewall or any other 3rd party firewall, linksys router firewall is turned off as well.
    I am on cable (Rogers) in Toronto if this helps.

    My laptop can see my desktop when I click on the network icon on my window desktop however when I click on the computer icon (for my desktop) I get the following error:

    Windows cannot access \\Computername-PC
    Check spelling of the name. Otherwise, there might be a problem with your network. To try to identify and resolve network problems, click Diagnose.

    I do that and I get this error:

    Cannot communicate with Computername-PC (192.168.1.100).
    Network diagnostics ping the remote host but did not receive a response.


    Thursday, August 07, 2008 12:35 AM
  • Hi,

     

    Based on the current situation, I suggest checking the following:

     

    1.    On the laptop, delete the ARP cache by using the following steps:

    a. Click Start, type cmd in the Start Search box, right-click cmd.exe, and then select Run as Administrator.
    b. In the Command Prompt, type arp –d *, and then press Enter.

    After that, try to ping the desktop computer and check the result.

    2.    Please wired connect the laptop to the Router and check the result.

     

    If the issue persists, please capture the network packets for further research:

     

    1) Download NetMon3.1 from the following website and install it on the Windows Vista machines (both machines):
    http://www.microsoft.com/downloads/details.aspx?FamilyID=18b1d59d-f4d8-4213-8d17-2f6dde7d7aac&DisplayLang=en

    2) Log onto the machines, right-click the Netmon icon and select Run as Administrator to launch NetMon3.1.

    3) In the Microsoft Network Monitor 3.1 window, click
    Create a new capture tab …
     
    4) In the new tab, select all the Network Adapters in the Select Networks window.

    5) After that, press F10 to start NetMon.

    Note: Please start NetMon on both machines.

     

    6) On the laptop, delete the ARP cache again, and then ping the desktop computer.

     

    7) After the ping command complete, go back to the NetMon window and press F11 to stop the NetMon.

     

    8) Press Ctrl+S to save the Netmon file and upload them to the following space:

     

    https://sftasia.one.microsoft.com/choosetransfer.aspx?key=3a99b80c-46a3-4a08-80b2-cce9ac6d665f

    Password: 41Po1u0#j

     

    Thursday, August 07, 2008 2:55 AM
  • SUCCESS!

    I messed around with various things before your email and finally figured it out.

    I ran the
    Internet Connectivity Evaluation Tool on my desktop and found that something was blocking the router's upnp functions. This was not a problem on my vista laptop, so clearly windows was causing the issue. I decided to re enable my windows firewall, turn off all the sharing and restart each sharing process one by one. However no matter what I tried I couldn't re enable my firewall it kept on giving me "ERROR 13" in the event viewer. Seems like this is a common error and no one can solve it. After some forum surfing and trying out numerous processes to enable the windows firewall, I noticed my desktop would randomly appear as a shared device on my laptop. After narrowing it down. I got it to work by completely disabling the firewall from the services.msc (windows firewall is set to disabled). My router has a firewall and since its a wired connection with WPA2 and MAC filtering I should be ok without a windows firewall for the time being.

    But if anyone can help me figure out how to turn on the firewall that would be great.
    + tried windows repair install
    + clearing repository
    + disabling / enabling the windows firewall and rebooting several times.

    And consistantly get the ERROR 13.






    Thursday, August 07, 2008 5:09 PM