none
Windows Media Player security upgrade 2.5.0.1

    Question

  • I am trying to use Overdrive Media to download audiobooks from the local library.  When I try I get a message that says "Unable to acquire a license to play the selected title.  The selected title requires a newer version of the Windows Media Player security upgrade (2.5.0.1) than is currenty installed (2.5.0.0).  Please upgrade the security of your windows Media Player by selecting"Tools>Window Media Player Security Upgrade..." from within OverDrive Media Console." 

    When I try this from the tools menu in overdrive it does nothing.  I have gone to drmlicense.one.microsoft.com to upgrade the security it gives me a message that the component cannot be upgraded.

    Please help.

    Tuesday, November 27, 2012 10:53 PM

Answers

All replies

  • Please make sure that neither WMP or Media Center are running, and then start Internet Explorer as administrator (right-click - Run as administrator). In IE, make sure that Protected Mode is turned off, and go to

    http://drmlicense.one.microsoft.com/Indivsite/en/indivit.asp

    If you click the Upgrade button, does the upgrade succeed now?


    Tim De Baets
    http://www.bm-productions.tk

    Wednesday, November 28, 2012 7:35 PM
  • to upgrade in window 7

    go to you tube I posted the site for windows 7, media player upgrade.

    unable to post web site here but the site ends in 976590

    look for support. microsoft. com. kb 976590

    you know that h  t  t p  : stuff and the forward slaches etc.

    it is there hope this helps?

    Monday, April 15, 2013 10:59 PM
  • I tried your solution and I get another error message:

    Windows Media Player cannot connect to the server.  The server name might not be correct, the server might not be available, or your proxy settings might not be correct.

    I think it is the proxy settings.  What should they be?

    Thursday, July 25, 2013 9:25 PM
  • Rhinemaidens3: which solution are you referring to? When exactly do you get that error?


    Tim De Baets
    http://www.bm-productions.tk

    Friday, July 26, 2013 6:30 PM
  • Yah, I know this is an old thread.

    Just to put my 2.7 cents in...

    I enabled the dev tools, and in the menu bar is a button marked "Browser mode: IE 10".

    I clicked on it and selected "Internet Explorer 10 compability mode".

    The 'update' button worked after that.

    just sayin'

    Friday, September 06, 2013 3:55 AM
  • Thank you! This finally worked!
    Saturday, September 21, 2013 8:12 PM
  • This did work; what a complicated fix. But thank you.  It did upgrade.
    Sunday, February 02, 2014 10:27 PM