none
Windows 8 unexpectedly sleeps after few minutes (less than configured)

    Question

  • I have a problem with Windows 8 sleep on my notebook.

    Windows doesn't "want" to sleep is a common problem people are trying to solve. They use "Power Options", powercfg command etc. but I have exactly opposite problem - sometimes my notebook sleeps every minute or two when idle. I don't how this is possible, I am using "Balanced" plan with default values (sleep after 30 minutes). Usually restarting Windows helps for a while (Windows sleeps correctly after 30 minutes) but later (usually after normal sleep) the problem returns.

    I am experiencing this problem in Enterprise Evaluation (RTM and GA) versions but earlier Release and Consumer Preview versions (all 64-bit) didn't have this problem.

    This problem appears on Dell Latitude E6410 - Intel Core i5 with 8GB memory, latest firmware, default drivers.

    Could anybody help?

    Thanks

    Monday, October 29, 2012 9:28 PM

Answers

  • - Now I think sleep problem could depend on how the computer is waked up (using power button seems ok) but I will test this more. How do you wake up your computer?

    If I wake the laptop with an external keyboard or mouse then it will sleep after 3 minutes of inactivity.  If I wake with the power button on the laptop then it will not sleep!  This is the 3rd OS on this machine and the 2 previous (Vista and W7) did not have this issue.  
    Monday, November 05, 2012 1:45 AM

All replies

  • I have been having the same problem - goes to sleep in a minute or two.  I have tried changing sleep settings and power plans but no help.  Like the original post mine seems to work fine for awhile after a restart, then goes into 'fast sleep' mode again.  I haven't tested but his observation about the problem starting after a normal sleep might be true for me too.  Searched around but can't seem to find an answer that works yet.  I have a Toshiba Satellite laptop.
    Tuesday, October 30, 2012 1:29 PM
  • I have a Toshiba Qosmio and am getting the exact same problem. It's seriously annoying having to log back in every few minutes.
    Tuesday, October 30, 2012 3:56 PM
  • Same issue here. I have a HP 8560W laptop. I have my on battery set to 15 mins sleep and 30 mins for plugged in. Randomly it will sleep after 1-2 mins of idle. The event log shows the sleep was from idle and not a lid close or power button event. Has to be a bug.

    Steve

    Tuesday, October 30, 2012 7:04 PM
  • Most of this kind of issues are caused by the power management model of BIOS. Upgrade the BIOS and see if it helps and if not, I suggest you contact the device manufacturer for more information.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Wednesday, October 31, 2012 7:59 AM
    Moderator
  • I already have latest BIOS version (A13, 30. 7. 2012) on my Dell Latitude E6410.
    Wednesday, October 31, 2012 9:54 AM
  • Same problem in a Toshiba Tecra M11 with win 8 enterprise
    Wednesday, October 31, 2012 10:42 AM
  • I don't see this as a BIOS issue as the event log shows it went into the sleep state due to idle. The sleep time based on idle is controlled by the OS not the BIOS. Also this issue is being seen across multiple vendors so really would be hard pressed to think this is BIOS related.

    Steve

    Wednesday, October 31, 2012 1:14 PM
  • Same problem on my older Gateway laptop.  Anyone else with this problem have Pokki installed, just out of interest?
    Wednesday, October 31, 2012 9:54 PM
  • Same issue, Lenovo Thinkpad T61.  Did not happen with the Release Preview at all.

    Joshua-III, no Pokki installed here.

    Thursday, November 01, 2012 2:24 AM
  • I changed a few settings to try to isolate this and I still cannot prevent this from happening. I disabled all sleep for battery and on plug. I also disabled sleep for power button press, lid close and sleep button press to see if there was a spurious ACPI event or something triggering this. At this point I can't see that as anything then a bug in the OS. The same laptop was running Windows 7 for over a year without a single unexpected sleep event.

    Steve

    Thursday, November 01, 2012 2:32 PM
  • This worked for me: I have created a new power plan and set "never" for all durations. You can access "Create Power Plan" command from Control Panel->Power Settings-> Task Panel.

    Erkal

    Friday, November 02, 2012 3:20 PM
  • I tried the new power plan per Erkal, restarted, put it to sleep, woke it up, 3 minutes later it was sleeping again.
    Friday, November 02, 2012 3:58 PM

  • Getting the same problem after recently upgrading from the Release Preview. Totally disabled all the sleep options but still goes to sleep after a couple minutes. This is on a custom built HTPC. Just trying the custom power plan solution now to see if it resolves it.
    Friday, November 02, 2012 11:35 PM
  • I have the same problem since installing Windows 8 Enterprise Evaluation Version and it's VERY annoying...I never had this problem with Release Preview and I used it for months.

    As the others say if I don't move the mouse or type for 1-2mins, then off it goes to sleep with a loud pop my speakers...looks like I'll have to keep the volume right down until this issue is fixed.

    ...Microsoft might be best to get this sorted quickly as we "were" planning to roll out Win8 but this has put a bit of a dampener on things. It's annoying the hell out of me so I couldn't imagine what our users would think...telling them to restart all the time would not be accepted as they don't need to do this currently.

    Saturday, November 03, 2012 5:01 AM
  • Couple of notes:

    - Usually I use my notebook with closed lid and connected monitor, keyboard and mouse, so I tried to use it with lid open and the problem still occurred.

    - In Event Viewer I can see event from Power-Troubleshooter source that correctly states that wake source is "Power Button" in case I wake up the computer using power button but when I wake up the computer using mouse or keyboard it says that wake source is "Device -ACPI Lid"

    - Now I think sleep problem could depend on how the computer is waked up (using power button seems ok) but I will test this more. How do you wake up your computer?

    Sunday, November 04, 2012 1:08 PM
  • I also have the same problem. After 60 seconds my Win 8 Pro custom built desktop also goes to sleep. This was not an issue for two years before with windows 7. And I agree, unlikely a BIOS issue given that the event viewer triggers sleep due to system idle. In fact, I even tried upgrading the BIOS but no beans. I've made custom power plans with to no avail. I've disabled nearly every startup program without help as well. I've also run system file checker. No solution in all those efforts, or to be found online.

    Going to sleep after a minute of inactivity is extremely frustrating, bordering on unusable. 

    Sunday, November 04, 2012 3:42 PM
  • Had same problem. Laptop went to sleep after a few minutes idle. Did not happen if locked.

    Fixed it by running secpol.msc, setting Local Policies/Security Options/Interactive logon: Machine inactivity limit to 600 seconds. Relog after changing. Now it locks the machine after 10 min idle and sleeps as set in the power profile.

    Edit: I am using an external keyboard/mouse to wake up the laptop.

    • Edited by 10ms Monday, November 05, 2012 9:24 AM
    • Proposed as answer by 10ms Monday, November 05, 2012 9:24 AM
    • Unproposed as answer by 10ms Monday, November 05, 2012 11:14 AM
    • Proposed as answer by KrisM44 Sunday, December 30, 2012 3:59 AM
    • Unproposed as answer by KrisM44 Sunday, December 30, 2012 11:27 PM
    Sunday, November 04, 2012 4:41 PM
  • - Now I think sleep problem could depend on how the computer is waked up (using power button seems ok) but I will test this more. How do you wake up your computer?

    If I wake the laptop with an external keyboard or mouse then it will sleep after 3 minutes of inactivity.  If I wake with the power button on the laptop then it will not sleep!  This is the 3rd OS on this machine and the 2 previous (Vista and W7) did not have this issue.  
    Monday, November 05, 2012 1:45 AM
  • One thing you all should remember, Windows 8 is a relatively new OS as far as commercial release goes.  As they add more and more patches, annoying things like this will be fixed.  Please note, I'm not by any means stating that an OS should do this, just saying the more reports they receive of this issue, the more likely they are to put it in the next hotfix, so please make sure you guys report the issue and continue to discuss any workarounds you find for it!
    Monday, November 05, 2012 1:52 AM
  • Setting "Interactive logon: Machine inactivity limit" to 600 seconds didn't work for me in case waking up computer using external mouse.

    Thanks for your reply

    Monday, November 05, 2012 8:33 PM
  • Morale of this problem :

    1. Always run a full image backup before doing any major change to your PC (like an OS upgrade)

    2. Never install a freshly released Windows OS, it's safer to wait until SP1 is released.


    Sebastian Sajaroff Senior DBA Pharmacies Jean Coutu

    Monday, November 05, 2012 8:45 PM
  • - Now I think sleep problem could depend on how the computer is waked up (using power button seems ok) but I will test this more. How do you wake up your computer?

    If I wake the laptop with an external keyboard or mouse then it will sleep after 3 minutes of inactivity.  If I wake with the power button on the laptop then it will not sleep!  This is the 3rd OS on this machine and the 2 previous (Vista and W7) did not have this issue.  

    I'm running custom made computer desktop that I built, Intel® Desktop Board DP55WG motherboard running i5 CPU 750 @ 2.67GHz, but this whole sleeping has nothing to do with my board or bios, went in there and there is nothing to do with it. I guess I don't mind but every couple minutes that i'm not using it is getting annoying. I understand this is a new OS and all, just isn't there a way to just give an update or a quick fix update. what's the point of windows updates then? just saying, I also brought it back by pressing the power button and well still did it, so technically this isn't resolved!

    Edit: I restarted the OS, and it stopped doing the whole sleeping thing within 2 minutes or how ever long it would go. So I'm assuming maybe if I start to tell it to go to sleep it will start to do that. Which before I would tell it to go to sleep manually. I have not tried it since restart as I am using it at the moment and have no need to sleep it. nor do I care to do testing. just giving heads up, just restart it. if it continues to sleep with out permission... 

    • Edited by sdiaz483 Wednesday, November 07, 2012 12:17 AM
    Tuesday, November 06, 2012 11:51 PM
  • Someone discovered one solution to correct this bug?

    The Workaround is wake with the power button (don't use an external keyboard or mouse)
    Wednesday, November 21, 2012 9:15 AM
  • Same issue with Toshiba Portege 930, latest BIOS applied. I use it with closed lid and wireless mouse.

    Regards

    Saturday, December 01, 2012 10:41 PM
  • I have a problem with Windows 8 sleep on my notebook.

    Windows doesn't "want" to sleep is a common problem people are trying to solve. They use "Power Options", powercfg command etc. but I have exactly opposite problem - sometimes my notebook sleeps every minute or two when idle. I don't how this is possible, I am using "Balanced" plan with default values (sleep after 30 minutes). Usually restarting Windows helps for a while (Windows sleeps correctly after 30 minutes) but later (usually after normal sleep) the problem returns.

    I am experiencing this problem in Enterprise Evaluation (RTM and GA) versions but earlier Release and Consumer Preview versions (all 64-bit) didn't have this problem.

    This problem appears on Dell Latitude E6410 - Intel Core i5 with 8GB memory, latest firmware, default drivers.

    Could anybody help?

    Thanks


    I have the same issue which occasionally happens on my Enterprise Evaluation of Windows 8.
    I do not know what is causing it...
    Saturday, December 01, 2012 11:22 PM
  • Had to travel to the 6th result page from Google to find a similar issue. Same power plan, same settings than OP, computer goes to sleep after little idle time (under 2 minutes).

    Acer Intel Core i5-430m 8GB Kingston. Win 8 upgrade 64 bits. Latest drivers, latest BIOS. Issue didn't happen with Win7. Image integrity checked (sfc -scannow) and OK, nothing relevant at startup, Acer power management (power plan switch if AC plugged/unplugged) uninstalled, clean registry.

    Thursday, December 20, 2012 2:07 PM
  • Same thing with Lenovo V570 laptop.
    Sunday, December 30, 2012 4:02 AM
  • Answer found on - forums mydigitallife info - "Windows-8-entering-sleep-on-its-own"

    Lenovo V570 Laptop with external Logitech mouse on dongle

    uncheck

    Device Manager / Keyboard / HID keyboard device / Allow this device to wake the computer

    Device Manager / Mice and other pointing devices / HID compliant mouse / Allow this device to wake the computer

    Device Manager / Mice and other pointing devices / Logitech HID-compliant mouse / Allow this device to wake the computer

    No more 2 min sleeps, and can wake up with laptop keyboard.


    • Proposed as answer by KrisM44 Sunday, December 30, 2012 11:01 PM
    • Edited by KrisM44 Sunday, December 30, 2012 11:30 PM
    Sunday, December 30, 2012 11:00 PM
  • I like to wake it up with my wireless mouse. I have solved it by hibernating instead of doing standby.

    Regards

    Monday, December 31, 2012 12:48 AM
  • The same annoying issue with Lenovo ThinkPad e420.

    Thursday, January 17, 2013 10:08 AM
  • Umm, HELLO Microsoft?!  This is obviously a huge issue and affecting a lot of people, all with varying hardware.  Why isn't there any official acknowledgement yet by a Microsoft empoloyee on this thread?  It's been nearly THREE months since this post was created, with a steady stream of replies by users reporting the same EXACT issue.  It's easily reproducable by waking your computer up from sleep mode via a USB keyboard/mouse.  After 2 minutes or so, the computer will put itself back to sleep, even if you had disabled sleep mode altogether.

    For a very technical description of what's probably the culprit, check out this post on My Digital Life:

    http://forums.mydigitallife.info/threads/40783-Windows-8-entering-sleep-on-its-own?p=699334&viewfull=1#post699334

    Even if you can't fix the problem, at least acknowledge it so we know you're working on it.

    Thanks!



    • Edited by Farfle1 Thursday, January 17, 2013 12:33 PM
    Thursday, January 17, 2013 12:32 PM
  • I've contacted Microsoft Support.

    They said "It's not a bug." And insist on drivers incompatibility of notebook vendor. Bullshit :(

    Wednesday, January 23, 2013 10:38 AM
  • same issue here, HP Envy 17 and also on a Lenovo Thinkpad, Windows 8 PRO.

    same workaround also: if I press the power button to wake up, the issue is not there.

    a side effect of waking up from mouse or keyboard is that, once resumed, some app that is supposed to resume its state remains offline instead: Skype, Yahoo Messenger, Lync 2013 (this one is stuck at "signing out" and you need to exit-reopen).

    Francesco

    Tuesday, January 29, 2013 10:15 PM
  • I'am experiencing the same problem with my lap Hp probook 6550b. It goes to sleep after 2 minutes and after wake up my lync 2013 is signing out and you need to exit-reopen it to work again.

    I have tried all sugestions but nothing helps.

    Igor

    Thursday, January 31, 2013 1:04 PM
  • Exact same problem here, also HP ProBook 6550b. This is fresh Windows 8 pro installation (less than a week old). 
    Wednesday, February 06, 2013 2:35 PM
  • Same issue here. ASUS G53SW laptop, Windows8 X64. Set to sleep never in Power Options, but goes into sleep after 2 mins if it was waken up by usb kbd or mouse.
    Sunday, February 17, 2013 10:58 AM
  • POSSIBLE SOLUTION

    I had this problem.  If your computer goes back to sleep exactly 2 or 5 minutes after it is woken up by a timer or USB device (not by the sleep button) , this solution may well work for you:

    http://www.sevenforums.com/tutorials/35767-sleep-return-timeout-unattended-wake-up.html

    The solution requires you to add "System unattended sleep timeout" to Advanced Power Settings (step 1).  It beats me why this isn't there by default - if it were, I suspect that most people would have worked out the solution for themselves.

    Good luck.

    • Proposed as answer by Ian Ham Saturday, February 23, 2013 11:07 PM
    Saturday, February 23, 2013 2:14 PM
  • Great post.  I did not have the settings in Option 1, so I tried Option 2.  At step 7 I set both keywords to 0 (zero) and after restarting I am able to wake the laptop with a USB keyboard and it stays awake!!
    Saturday, February 23, 2013 11:57 PM
  • I am glad that this worked for you too - I know how frustrating this is. In the solution above, step 1 of option 1 includes a link which takes you to a page which helps you to add the appropriate settings to Advanced Power Settings. There you can download a .reg file which automatically makes the necessary amendments to the registry.
    • Edited by Ian Ham Sunday, February 24, 2013 7:53 AM
    Sunday, February 24, 2013 7:51 AM
  • Ian, your suggestion fixed the problem for me. Thank you for posting the solution. I downloaded the Add_System_unattended_sleep_timeout.reg file and simply ran that, which gave me that new option in advanced power options. How easy.

    It's nice to be able to keep the lid closed on my laptop and to wake the system with a mouse or keyboard and not have to use the power button. (And not have the system go back to sleep after two minutes!)

    It's bizarre that Microsoft would allow this difficulty to persist because it seems that it is affecting many users and can be resolved so easily.

    Monday, April 01, 2013 2:47 PM
  • External screen was my issue in the end. Try setting to just second screen only if you do the same.
    Monday, August 19, 2013 8:20 PM
  • This fixed my problem of computer going to sleep after only 1-2 minutes of inactivity regardless of settings. In windows 8 though only allowed to change the option of "allow this device to wake the computer" under one device (mouse) but that is all it took. Rebooted immediately and redid the power options to my liking and all is well. Thanks to Kris444
    Thursday, September 12, 2013 5:32 PM
  • Go to: Control Panel\Hardware and Sound\Power Options

    Then, "Change Plan Settings"

    You should see an option that states: "Put the computer to sleep:"

    Choose "Never", then click "Save Changes"

    Worked for me. :)

    Friday, November 08, 2013 2:36 AM
  • Didn't work for me with Windows 8.1.  When I put that in the registry (first by hand, then using the registry setup files) my laptop stopped sleep altogether.  Then when I removed it, my laptop would sleep again.

    However, I'm left with the problem where the laptop goes back to sleep a couple of minutes after I wake it up.  I wouldn't mind that, but it's kind of disturbing to have your computer go to sleep in the middle of reading something.  Kind of ruins your train of thought *smile*.

    Anyways, still researching for a solution to this problem.

    Thursday, November 21, 2013 12:50 AM
  • i dont know whether you have already sorted out the problem. go to control panel and search for power setting. Then look for something along the lines of change display thing for power options. then you can change the duration of the sleep to never. It should be in the power settings option so just have a look through
    • Edited by jamjammjsj Sunday, December 08, 2013 7:50 AM
    Sunday, December 08, 2013 7:49 AM
  • POSSIBLE SOLUTION

    I had this problem.  If your computer goes back to sleep exactly 2 or 5 minutes after it is woken up by a timer or USB device (not by the sleep button) , this solution may well work for you:

    http://www.sevenforums.com/tutorials/35767-sleep-return-timeout-unattended-wake-up.html

    The solution requires you to add "System unattended sleep timeout" to Advanced Power Settings (step 1).  It beats me why this isn't there by default - if it were, I suspect that most people would have worked out the solution for themselves.

    Good luck.

    Nice solution, I have windows 8 and try this, seems work and no unattended sleep.

    Thanks Lan, and everyone should try this.

    Sunday, December 15, 2013 6:18 AM
  • Yes this one works for me.  Very strange that it overrides the other power settings. I have Win8.1 and it appears to have been a recent update that has started to put me computer to sleep as previously my computer would stay on all night.
    Sunday, January 12, 2014 12:55 AM
  • Same problem Windows 8.1
    Friday, January 24, 2014 11:14 PM
  • I'd just add that it happens also while I'm typing, doubly frustrating. Win 8.1. Event log says kernel power event, triggered from the application API. Still none the wiser. Have to do a restart to clear this condition for a while, before it starts happening again -- I think after a regular scheduled inactivity sleep.
    Friday, January 31, 2014 4:40 PM
  • I have the same problem but with a different twist. I have an Asus T100A Notebook. There are two uses on the same machine and we each have the same sleep settings. When I'm logged in, the display falls asleep after one minute. If the other person is logged in, she doesn't have any problems. Asus was no help and wants me to return the machine for them to repair. I assume it has to be some setting that is being missed. 
    Wednesday, February 12, 2014 9:34 PM
  • Greetings from the future! It's Feb 2014 and this issue has not been corrected via patch.
    Wednesday, February 19, 2014 3:38 AM
  • same problem. unexpected sleep when not in use or even when I'm actively using a program.

    windows 8.1 - Lenovo Thinkpad Twist

    Didn't encounter this problem back when my machine was still in windows 8.0. Also, I've noticed that my laptop seems to be always processing (I am hearing a noise from the processor I guess - don't know the technical term). 

    Too bad I failed to save a snapshot before I updated to Windows 8.1

    Monday, February 24, 2014 6:55 PM
  • Thank you so much!!!
    Friday, February 28, 2014 4:09 AM
  • Me too. I'm on a new computer (second one with Windows 8) and I was rather chuffed to find there was an "Enable USB wake option" in the BIOS. The last one didn't have that. So I enabled it and looked forward to being able to wake the computer from sleep with the mouse.

    I had exactly the same experience as Steve KY.  Wake the computer with the mouse, and three minutes later it's gone back to sleep again. It's the problem many parents have trying to get teenagers out of bed! Since then I've disabled the USB wake option.

    So I can confirm this is an issue, but goodness knows what's causing it. I'll bet Microsoft don't either. It's annoying, but not worth losing sleep over. I've resigned myself to the fact that with many Windows operating systems, we should be grateful for anything that works at all.

    Sunday, March 02, 2014 10:48 PM
  • Once again, big company ignores customer.  Time to speak with our wallets again.  It's the only thing they ever listen to.  
    Wednesday, March 05, 2014 7:27 PM
  • Still doing it now after fresh OS install with all updates including 8.1 update 1.



    • Edited by Tronoterry Wednesday, April 09, 2014 11:13 AM
    Wednesday, April 09, 2014 10:48 AM