none
Connecting Two Laptops Via WIFI (Vista Home Premium & Windows 7)

    Question

  • I am quite new to wireless connectivity. Currently have two laptops with WIFI facility however, with Windows 7 & the other with with Windows Vista (Home Premium). Have tried my level best but haven't succeeded till yet. Unidentified network found in one or both the systems' network & sharing centre. Sure would oblige if someone would kindly help me out with a step to step guide in this regard.

    Thanx in advance & Best Regards,

    Faraz!

    Saturday, May 22, 2010 7:44 PM

Answers

  • Hi,

     

    The most convenient method to setup a Wireless network is purchasing a Wireless router and configure relevant settings in router’s web page. However, if there is no Wireless router, I suggest you refer to the following article to create a computer-to-computer (ad hoc) network

     

    Set up a computer-to-computer (ad hoc) network

     

    Thanks,

    Novak

    • Marked as answer by Novak Wu Wednesday, June 02, 2010 3:02 AM
    Tuesday, May 25, 2010 2:44 AM

All replies

  • First thing you need to do is set up the access point properly.  Most access points are configured with an SSID that broadcasts so you can easily find it from your wireless clients. 

    If you are not using an access point and simply want the two laptops to be able to communicate with each other, you'll need to up an ad-hoc wireless network between them.  that can be done on the wireless properties of the NIC.

    You'll have to consider that both laptops may have the windows firewall enabled so you will have to configure them accordingly.


    Visit my blog: anITKB.com, an IT Knowledge Base.
    Saturday, May 22, 2010 11:34 PM
  • Again tried my best by even turning off firewalls on both or setting up them as well but failed. Could u list down the steps? When I create an ad hoc wireless network on laptop 1 with Vista the one with Windows 7 when tries to connect to the same, finding the signals to be Excellent it ends up with an unidentified network. Similarly, on the other hand, if the network is created on laptop 2 with windows 7 the laptop 1 with vista finds the same trouble. Even the workgroup name on both laaptops are same.

    Please c if u can refer to some source of helpful info.

    Thanx again.

    Monday, May 24, 2010 5:01 AM
  • Again tried my best by even turning off firewalls on both or setting up them as well but failed. Could u list down the steps? When I create an ad hoc wireless network on laptop 1 with Vista the one with Windows 7 when tries to connect to the same, finding the signals to be Excellent it ends up with an unidentified network. Similarly, on the other hand, if the network is created on laptop 2 with windows 7 the laptop 1 with vista finds the same trouble. Even the workgroup name on both laaptops are same.

    Please c if u can refer to some source of helpful info.

    Thanx again.


    SAME THING HERE.

    after reading your posts, i planned to tell you how easily it can be done.  just like vista but easier, i was going to say.

    huh.  glad i checked before posting.  i went ahead and setup the win7 adhoc network with a few simple clicks.  oh how nice.  but then i noticed, when you hover over it in the Connect dialog, it says the signal is EXCELLENT.  oh really?  nobody else is broadcasting yet.  how can that be?  and then it won't connect and aborts out !!!  and how can that be?  i mean, somebody's got to go first in an adhoc network.  so how can you possibly not connect?  that makes no sense.  messed up.

    can't blame it on the very recent intel abgn driver either.  well, the other computer has a year old broadcom driver.  but they both acted exactly the same.  and since, like you, i also have vista on both both these computers, both with adhoc networks that definitely talk to eachother, i was able to cross check vista-vista, vista-win7 and win7-win7 configs as a sanity check.  so i'm sure i wasn't goofing up something.  it just wouldn't work with win7.

    then i removed that (adhoc) wireless network (from Manage wireless networks), and set it up again.  and again.  and again.  until finally, for no reason i can explain, it did work. it correctly reports NO SIGNAL when that's correct, and it sees the other computer and folders and everything you'd expect.  i did that on both computers.  oh goody, now it works.  took two hours.  did i say TWO HOURS.  i meant THREE.

    just like vista but easier, i was going to say.  yeah.  just like vista.

    • Proposed as answer by ᅠᅠBanned Friday, June 25, 2010 2:47 PM
    Monday, May 24, 2010 11:53 AM
  • Hi,

     

    The most convenient method to setup a Wireless network is purchasing a Wireless router and configure relevant settings in router’s web page. However, if there is no Wireless router, I suggest you refer to the following article to create a computer-to-computer (ad hoc) network

     

    Set up a computer-to-computer (ad hoc) network

     

    Thanks,

    Novak

    • Marked as answer by Novak Wu Wednesday, June 02, 2010 3:02 AM
    Tuesday, May 25, 2010 2:44 AM
  • Novak, we understand the very simple steps for creating an adhoc network.  just type set up an adhoc in StartMenu, and a wizard takes you thru it.

    after you have set one up, you do not need two computers to connect to it.  what should happen when you connect is it will show you NO SIGNAL and tell you it is Waiting for users to connect.  but instead, it reported EXCELLENT signal, and then aborted trying to connect.

    that's why Faraz was confused.  that's why i'm confirming.  it doesn't work right.

    i spent a few hours repeating those trivially simple setup wizard steps.  i don't know why it finally worked right.  but even so, it is not-quite-right.  right now as i type, while (my other computer) is connected to an adhoc network and Waiting for users, when i hover the mouse over the system tray network icon, the info tooltip says Not connected - connections are available  (which is wrong) and viewing it in Network & Sharing Center states You are currently not connected to any networks (again wrong)and because of that, i cannot click its network icon (it's not present) to change the icon, merge other network locations, or change it from Public to, say, Work or Private.  of course, as soon as a 2nd computer signs onto that adhoc network, Network & Sharing Center will show the network's icon and those options will become available.  that's too late.  i would want to set those things before another computer connects to that adhoc network.  see?  this whole thing is buggy.

    • Proposed as answer by ᅠᅠBanned Friday, June 25, 2010 2:46 PM
    Tuesday, May 25, 2010 4:21 AM
  • anyway, Faraz, i will tell you what i did that maybe maybe was what made it work.  keep trying.  once you get it set up, the adhoc network works great.  you'll really like using it.  it's fun.

    first, like you already explained, i turned off the firewall temporarily.  (i doubt that has anything to do with it).  second, i turned-off IPv6 for the wifi adapter, so only IPv4 remains.  i actually think that's what fixed it.  i'm guessing and embarrassed to admit it.  but this is the step that seemed to make it work for me.  on 2 different computers.

    to turn off IPv6, go to Network & Sharing Center.  click Change adapter settings.   find and right-click your wifi adapter, then click uac Properties.  in the dialog that appears, find the entry  [ ] Internet Protocol Version 6 (TCP/IPv6)  and remove the checkmark.  then ok out of that dialog.

    after you do get it setup and working, log onto your adhoc network and go back into Network & Sharing Center.  click its icon (under View your active networks).  then click the link at the bottom of that dialog where it says Merge or delete network locations.  if you see duplicated adhoc network entries in there, use ctrl-click to highlight them and merge them all together.

    • Proposed as answer by ᅠᅠBanned Friday, June 25, 2010 2:46 PM
    Tuesday, May 25, 2010 5:00 AM
  • i've found it impossible to set up an adhoc network while any other device/member is broadcasting.  they all have to be turned-off first.

    if you can see that network in Connect To, then you cannot create a permanent adhoc network entry at that time.

    • Proposed as answer by ᅠᅠBanned Friday, June 25, 2010 2:46 PM
    Friday, June 25, 2010 2:46 PM
  • hello, a friend and I are having a little trouble with our networking, but nothing we try really seems to work. here's our situation:

    we have two windows laptop computers; one with the windows vista home primium operating system, and the other with windows seven. our main goal was to try and get a classic blizzard game running through a network. starcraft. our first naive efforts consisted of directly connecting the computers together via an ethernet cable. No luck. we the messed around with some settings until we gave up and moved on to a new idea. we had a working linksys router that was not being used, and decided to give it a shot.  again, no luck. tried changing the router settings to that of the blizzard specs and failed again. we searched the internet for some sort of solution, and ended up here.  my newest theory is that the game we are wanting to run through a network is slightly out of date and therefore needs to be patched. any halp on the matter would be most apriciated. i apologize for the unprofessionality of this post. I'm currently at a loss for internet, so i'm having to post with my droid. this webpage is a tad incompatable. 

    Thanks in advance.

     

    Sunday, July 18, 2010 4:40 AM
  • Hello Exticede,

    The original posting already contains a response that has been marked as the answer.  You really should have created a new thread for your question.  In any case, I think you questions may be too vague to get an exact answer to your issue.  I would recommend that even before you attempt to get the game(s) working, you really need to get the two computers networked properly. 

    The simpliest way to do this is by connecting both computers together by using a ethernet cable.  If you connect them directly together the cable that you use must be a "cross-over" cable.   Otherwise, you will need to use a hub or a switch between them.

    Rather than using APIPA for IP addressing, you should configure each interface with its own IP address address.  For instance, on one comptuer you could assign the address of 192.168.100.1 and on the other you could assign 192.168.100.2.  Use a 24 bit subnet mask (255.255.255.0).  No default gateway needed on those interfaces. 

    Once that it set up, validate connectivity between the systems by using the PING command.

    After that has been set up, proceed with the rest of the game configuration.

     


    Visit: anITKB.com, an IT Knowledge Base.
    Sunday, July 18, 2010 7:45 PM
  • Hello grits n gravy,

    If you read through Exticede's posting, to best assist this user, any issues related to basic networking should probably be taken care of before the application issues are resolved.

    While you are correct, we do not know Exticede's knowledge regarding NIC configuration.  The cross-over cable, I think is a much simplier approach for testing purposes in this scenario.  In addition, in regards to APIPA, again, you are correct that there is no reason to change it.  However, again, we do not know Exticede's experience with IP, so setting both NICs to a fixed IP, I think is a good idea for assisting in troubleshooting.  In the advice that I provided, you are taking two unknowns (cabling and IP) and turning them into "knowns".

    If Exticede does have the expertise in this area, I do not beleive that this user would be posting this question.

    Feel free to provide Exticede with some additional advice that could assist in resolving the issue.

     


    Visit: anITKB.com, an IT Knowledge Base.
    Monday, July 19, 2010 1:54 PM
  • Well, its sounds like you have all of the answers.  Why don't you provide "Exticede" with some usefull information then.  It appears that you may not have understood my last posting.  I made no reference to a CAT6 cable.  Exticede's posting makes no reference to a Gigabit Ethernet, so I not sure why you brought that up.  In addition, I was not suggesting to hard code a 169.254.x.x address.  

    Since Exticede has not responded, it appears that these postings have been of little or no value.

     


    Visit: anITKB.com, an IT Knowledge Base.
    Tuesday, July 20, 2010 3:25 PM