none
Remote OK button does not bring up the on screen keyboard

    General discussion

  • WHen prompted for the on screen keyboard it indicates you can double click the mouse or click OK on the remote.
    While the mouse works the OK button does nothing.  Is there a way to fix this so you can drive media center without
    the mouse and just the remote.

    Monday, October 12, 2009 2:47 AM

All replies

  • Hi wef42:
         Please don't laugh at this!  I've had a couple times when the input from the remote didn't produce the expected result and by chance one time I used a different remote and the problems disappeared.  Hmmm........since the remotes were identical I thought I'd replace the batteries and everything worked again.  I only mention this........just in case :)
    Tuesday, October 13, 2009 1:00 AM
  • Good idea.  Unfortunately the remote is new and we build a couple of HTPC's and they all do the same thing
    so I dont think its a battery thing.  Maybe its a problem with this brand of remote.
    Tuesday, October 13, 2009 9:24 AM
  • Hi wef42, does the issue occur on both Windows Vista Media Center and Windows 7 Media Center? If so, we can consider this as a remote issue. 
    Sean Zhu - MSFT
    Wednesday, October 14, 2009 4:15 AM
  • I have not tried it on Vista but will attempt to do so.
    I do know that two different brands of remote exhibit the same behavior.


    Thursday, October 15, 2009 2:10 AM
  • I too have this problem, would like to be able to fully drive Windows Media Center on Windows 7 with my Dell remote that came with my laptop. I think the remote maps straight to keyboard presses, so this could be the problem if Media Center is reading the source of the command and not accepting some sources.
    Tuesday, November 10, 2009 2:54 AM
  • Found it. You need to create and set the following most obscure registry setting.
    It then works.

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Media Center\Settings\MCE.PerUserSettings\showOskOnKeyboardEnter

     

    set it to 1.

    Sunday, December 27, 2009 3:09 AM
  • I set the registry value HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Media Center\Settings\MCE.PerUserSettings\showOskOnKeyboardEnter to 1, restarted the compuer, yet the remote ok button does not work.

     

    OS: Windows 7 64 bit Ultimate

    Remote: VRC-1100, Vista MCE Remote Control

     


    -- With Regards Shailen Sukul Software Architect/Developer/Consultant/Trainer (BSc | Mct | Mcpd | Mcts (Sharepoint, Biztalk, Web, Win, Dist Apps) | Mcsd.NET | Mcsd | Mcad) MSN | Skype | GTalk Id: shailensukul Blog: http://shailen.sukul.org
    Tuesday, July 13, 2010 6:22 PM
  • This worked great for me on Win 7 x64 Home Premium with an Hauppauge remote.
    Thursday, February 03, 2011 4:42 AM
  • Your advice on changing the referenced registry setting to 1 worked perfectly.  Great fix!  How'd you ever find this??

    FYI, running Win7 Home Premium (32 bit) with Vista MCE VRC-1100 remote.  Based on results, it doesn't appear to be an issue with this (or any) remote - a simple change to the registry setting solves it.

    Friday, July 08, 2011 9:51 PM
  • I discovered that the change in the referenced registry setting works great for bringing up the OSK in certain WMC screens, but it does not work in WMC screens for Internet TV searches or NetFlix searches.  Any advice for these?  I looked for other possible registry settings that might be specific for these other WMC screens, but nothing so far.  Thanks for any advice.
    Saturday, July 09, 2011 6:02 PM
  • WMC User in Georgia: it looks like nobody here knows an answer (myself included). I suggest that you repost this at the Windows Entertainment and Connected Home forums, there are some WMC experts there.
    Tim De Baets
    http://www.bm-productions.tk
    Tuesday, July 12, 2011 4:15 PM
  • wef42 - I am raising a beer to you :-)  Perfect sir.

    However, bit of additional info.  I had an issue because my console has no keyboard/mouse and I can only login remotely as as admin user (my 'TV' user does not have remote rights - for security).

     

    So;

    1. Logon remotely as an admin user and launch regedit.exe

    2. In Regedit highlight the HKEY_USERS key and go to File->Load Hive

    3. Browse to the users folder (in my case c:\Users\TV) and select NTUSER.DAT, then click Open.

    4. Enter a 'Key Name' the same as the users name (anything will do actually...) Click OK.

    5. in the HKEY_USERS you will now see a 'folder' (its a 'Hive'), open it and go to Software\Microsoft\Windows\CurrentVersion\Media Center\Settings\MCE.PerUserSettings\showOskOnKeyboardEnter and set it to 1, as described by wef42.

    6. Back in HKEY_USERS, highlight the Key Name that appeared in step 4 and select File->Unload Hive.  Ok, the confirmation.

    Bob's yer uncle - all done.

     

    Note.  If you have hacked the Terminal Services to enable concurrent logins (IE. You remote in while the console is still logged in) then go to Task manager (Right click in taskbar and select task manager).  Then in Processes tab click 'Show processes from all users' and then go to Users tab.  Right click the console user and select Log Off.  THEN do the above.  Otherwise. when you try to load the NTUSERS.DAT hive in step 3 you will get an Access Denied error.

     

    Thanks wef42! :-)

    Wednesday, September 28, 2011 3:35 AM
  • Found it. You need to create and set the following most obscure registry setting.
    It then works.

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Media Center\Settings\MCE.PerUserSettings\showOskOnKeyboardEnter

     

    set it to 1.

    Worked for me using a Firefly remote. Thanks!

    Freakishly weird that WMC indicates you can press 'OK' to bring up the onscreen keyboard, but then doesn't have the registry set to complete that action...

    Saturday, August 04, 2012 2:07 PM
  • Nice one wef42 - spot on thanks...

    Probably says more about MS's test & QA process than freakishly weird :-)

    Tuesday, August 07, 2012 5:01 AM