none
Windows 7 - Two default gateway 0.0.0.0

    Question

  • Hi,

     We have setup a windows 7 machine, it takes IP address properly from DHCP server, but takes two default gateways . First default gateway - 0.0.0.0 & second default Gateway 192.168.1.1 (This is correct one).

    Unless I delete the first default gateway manually my machine does come on the network. Can some one please let me know what could be the issue.

     

    Thanks & Regards

    Vari

    Monday, July 27, 2009 11:18 AM

Answers

All replies

  • you could change it manually in registry at the interfaces set which looks something like this SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{AF7DDF0F-8372-4CB3-8110-E8581F7142F3} so you have to find out which one is the interface you are using and create a REG_Multi_SZ named DefaultGateway and manually type the desired gateway but i dont recomend you doing that cause could cause problems if you dont know what you're doing so wait for other replies and stay tuned...
    Regards,
    RR
    Monday, July 27, 2009 3:10 PM
  • Did you correctly set Default Gateway? If it is set to obtain IP automatically, the issue can be caused by the router. In this case, I suggest that you upgrade the router. If the issue persists, we may need to run "route delete" command to remove the invalid route at startup as a workaround. You may make a batch file and put it in the Startup folder to make it automatically run at startup.
    Arthur Xie - MSFT
    Tuesday, July 28, 2009 10:22 AM
    Moderator
  • This problem with two default gateways seems to be a 'bug'. It was present in Vista and Windows Server 2008 (but they showed access as being 'Local Only'. In Windows 7 the system tray icon shows 'Internet access', but believe me there is no internet access (Ping can resolve a web address, but can't actually ping it).

    It seems that as long as the 0.0.0.0 default gateway is present, it won't work. Doing a ROUTE DELETE 0.0.0.0 works, but it is hardly a solution.

    I don't accept the 'upgrade my router' option either. I have got a business class router that works fine with every other OS.

    Is there a proper fix for this problem?
    • Proposed as answer by mjbmjbmjbmjb Friday, October 11, 2013 11:41 AM
    Wednesday, August 12, 2009 7:07 PM
  • I am facing this annoying problem as well after migrating to the RTM version of Windows 7. I didn't see this problem on the Windows 7 RC nor on the Vista. I didn't change any hardware in the migration. The current network configuration works fine in the last two years.

    I can resolve this problem by disabling my network adapter and then enabling it again. However, this problem may come out again if I recycle my system.

    When this problem happens, I can see an additional 'UnIdentified network' entry in the active networks of network and sharing center.

    ps: In my network, I have a special configuration. I have two routers, one for internet access and another one is used as the wireless access point. I had disabled the wireless router DHCP function and thus the only DHCP server is the internet access router. I am not sure whether this configuration trigger this problem.
    Thursday, August 13, 2009 10:34 PM
  • Just found a solution to my problem. The problem was caused by Adobe CS3 product and Windows 7. The following blog article has a very good explanation of this problem:

    http://heaths.spaces.live.com/blog/cns!9415F61CBB1A8030!1819.entry

    To fix the problem, I have to remove the Bonjour services installed by Adobe CS3 following instruction in this forum thread:

    http://forums.adobe.com/message/1634806#1634806

    Now, everything works fine. :)
    Saturday, August 15, 2009 5:08 PM
  • alanchau, thank you for disseminating this information, I was going nuts. I even bought a new router trying to solve this...

    Saturday, November 21, 2009 4:59 AM
  • Thank you so much alanchau,

    I was pulling my hair out over this... the one thing I didn't notice was it started to happen after I installed CS3, and to be honest who would!!!

    A design applications suite that fecks up your computers ability to use DHCP services on the network, nice one adobe...

    Wednesday, February 03, 2010 5:20 PM
  • I just fixed this one by adding an IRPStackSize=18 entry. Known issue with limited network connections, google it.

    I'm no expert, it was a lucky guess! It may work for others and may be a better solution than disabling bonjou.

     

    Microsoft, come on guys,  the IRPStackSize issue has been around for years and years, I can't believe it has not been addressed properly in Windows 7!

    Saturday, March 20, 2010 11:08 AM
  • Hi Steve,

    when u say 18 u mean in hexadecimal right? please lemme knw coz a few months ago i was trying to find an optimal setting for the irpstacksize....

    thanks in advance,

    RR

    Sunday, March 21, 2010 1:56 AM
  • Thanks so much.

    Adobe Bonjour servicewas the root cause of issue.

    I run the following command:

    "C:\Program Files\Bonjour\mDNSResponder.exe" -remove

    this removed the service and I also restarted the computer and it works fine now!

    Thanks again!

    Cheers.


    Just MCP now...
    • Proposed as answer by Levente Rög Tuesday, April 06, 2010 8:59 PM
    Monday, March 22, 2010 7:25 PM
  • This can also be fixed by installing the latest version of itunes (which will also update Bonjour)

    I suspects it's because of an old version of Bonjour being installed, either because of an old version of itunes which isnt updated or a version of the adobe suite like CS3 which for whatever reason isnt updated either (maybe because it's not a legit copy).

    • Proposed as answer by BillyRubinOCD Friday, January 13, 2012 9:35 AM
    Monday, April 26, 2010 8:27 AM
  • Hi I had the Exact Problem Myself today and (as stated) I can confirm it Was "Bonjour" This Is How I fixed it

    Windows Gets an 0.0.0.0 Gateway

    Pete

    PeteNetLive

     

     


    Tuesday, September 28, 2010 2:04 PM
  • I know this is an old thread now but still valid.

    I had the same problem on a Samsung NC10 Netbook but only with the wired LAN connection, strangely the WLAN internet access worked fine. I checked the DHCP settings on my Windows 2008 server and it all seemed to be OK - other Windows 7 machines on the network were also OK so it had to be something to do with the NC10 config.

    I'd previously installed iTunes but had removed it, as it simply was too slow to use on an Atom machine, but when I checked it had left the Bonjour directory in Program Files. Sure enough, opening a command prompt and typing ""C:\Program Files\Bonjour\mDNSResponder.exe" -remove" did the trick and my default gateway is now back to the proper DHCP settings.

    Many thanks to alanchau and Kashiff for pointing this out, it sure saved me a lot of time!!

    Regards

    Derek.

    Sunday, October 17, 2010 12:35 PM
  • Thank you alanchau! It never fails that this problem occurs when I am trying to resolve a router issue.

     

    Thanks again!

    Wednesday, November 17, 2010 2:00 PM
  • Had this same issue with a Windows Server 2008 Enterprise clean install.  Default gateways were 0.0.0.0 and 192.168.0.1 (correct one). Did the following:

    From command line --> route delete 0.0.0.0

    Then had to re-add my 192.168.0.1 default gateway in the network connections properties.  (I have a static IP)

    It worked, not sure if it is a permanent solution, running updates now which should hopefully solve the issue.

    Sunday, December 26, 2010 6:00 PM
  • The Agilent mDNS Responder also causes a routing table problem, check this in addition to the National Instruments mDNS Responder for older software versions.  Seems like a lot of software implementing the mDNS Responder service is suffering from this problem.  My affected system was Windows 7 32-bit and I just disabled the service to get it to work.
    Tuesday, January 11, 2011 12:09 PM
  • Thanks so much.

    Adobe Bonjour servicewas the root cause of issue.

    I run the following command:

    "C:\Program Files\Bonjour\mDNSResponder.exe" -remove

    this removed the service and I also restarted the computer and it works fine now!

    Thanks again!

    Cheers.


    Just MCP now...

    You just made my day! THANKS!
    Friday, February 04, 2011 2:35 PM
  • Thanks for your solution. It worked fine on Server 2008.
    Thursday, December 08, 2011 4:50 PM
  • This can also be fixed by installing the latest version of itunes (which will also update Bonjour)

    I suspects it's because of an old version of Bonjour being installed, either because of an old version of itunes which isnt updated or a version of the adobe suite like CS3 which for whatever reason isnt updated either (maybe because it's not a legit copy).

    There's really no need to disable or remove the Bonjour service and affect your iTunes, Adobe CS3, ... applications. Get the latest Bonjour service which is compatible with Windows 7 from from http://support.apple.com/kb/DL999.

    Install it and reboot and your problems should go away.

    My problem started after fitting a Netgear FVG318 I was always given a DHCP address and the correct gateway, but also the 0.0.0.0 gateway resulting in healthy connectivity around my network and to the firewall, but no internet access. I have Adobe CS3 and QuickTime, but not iTunes.

    • Proposed as answer by vtr1000xe Friday, August 17, 2012 4:28 AM
    Friday, January 13, 2012 9:44 AM
  • thanks alot

    Tuesday, April 10, 2012 7:53 PM
  • Thank you so much alanchau, kashiff & BillyRubinOCD.

    This had me pulling hair out.

    Got it working yesterday by disabling unneeded things on the NIC, and giving it a static IP and removing it again. However this morning it was back with the same problem.

    This all makes sense now :) Thanks!

    • Proposed as answer by ShieldsHome PC Wednesday, November 28, 2012 10:00 AM
    Wednesday, August 15, 2012 2:57 PM
  • Hi!

    I have a problem similar to, but not on workstations bonjour service. IP addresses assigned DHCP server (2008R2) via a DHCP relay (Juniper SRX router). How to solve the problem?


    cenubit

    • Proposed as answer by rcr203 Friday, January 04, 2013 12:16 AM
    • Unproposed as answer by rcr203 Friday, January 04, 2013 12:16 AM
    Wednesday, November 28, 2012 8:17 AM
  • Amazing, I came across this answer and it worked:

    (which I found here, on another thread; social.technet.microsoft.com/Forums/en-US/itprovistanetworking/thread/1e26fb5b-7d35-47ad-a50d-2025737da6b0/?prof=required

    (note; I rebooted after doing the reset, and I connected right away as soon as I restarted - Windows 7)

    Click "Start"

    Type "cmd" in the search box press "ctrl" + "shift" + "enter"

    at the DOS Prompt type "netsh winsock reset" and hit enter

    once completed after 30 seconds or so my "red X" on the internet connection was gone, I once again had Local and Internet Connection

    Friday, January 04, 2013 12:19 AM
  • I'm using static type ip address.

    I removed Bonjour service, but I could't fix this problem.

    so, I tried below...


    run below on cmd prompt.

    netsh interface ipv4 set address "Your Network Name" static "Your Ip Address" 255.255.255.0 "Your Gateway Address" 1

    for example,

    netsh interface ipv4 set address "local network" static 192.168.0.44 255.255.255.0 192.168.0.1 1

    and test your ip address

    ipconfig

    if your Gateway is modified,

    for example,

    Default Gateway . . . . . . . . . : 192.168.0.1

    Now, your default Gateway is successfully changed.

    If you want to use "dhcp", return to "Obtain an IP address automatically"

    :)


    • Edited by indigo73 Friday, August 30, 2013 3:54 AM
    Friday, August 30, 2013 3:10 AM
  • This worked for me on a Windows 7 reinstall.
    Friday, October 11, 2013 11:43 AM
  • In my case was caused by CS3 after new install of Win7-64. Solved with "Netsh winsock reset" run as administrator from DOS prompt.

    Thank you RCR203

    Sunday, March 02, 2014 6:28 PM