none
Black screen after a windows 7 update

    Question

  • Hi, I have a Toshiba Satellite P200-P100 running Windows 7.
    A few weeks ago, after a Windows 7 Update, my monitor would not show any image, it would light up, but still no image. Not even the BIOS it would load.
    I fixed it by using System Restore using another monitor. The same happened again today, I must have ran the same update, but this time a system restore did not solve it, neither did reinstalling Win 7. Any suggestions?

    Thanks,
    Spre3
    Saturday, December 12, 2009 8:49 PM

All replies

  • Hi Spre3,

    I assume Win7 was reinstalled now, so when will the black screen occur, during booting up, logging on or running certain program? Does all the monitor encounter the black screen? Will they work on other PCs?

    Test it in Safe mode:

    Restart the computer and start pressing the F8 key on the keyboard. On a computer that is configured to boot multiple Operating Systems, press the F8 key when you see the boot menu. When the Windows Advanced Options menu appears, select Safe Mode, and then press Enter. Log onto Windows by using the Administrator account or any user account with Administrator privileges.

    Monday, December 14, 2009 5:36 AM
  • Hello Spre3,

     

    According to your problem description, I suggest you go to Windows Safe mode and then roll back the display adaptor driver.

     

    1)    Detach all unnecessary peripheral devices from your computer, such as printers, scanners and removable storage devices.

    2)    Restart the computer.

    3)    Keep pressing the F8 key until the Windows Startup menu appears.

    4)    Choose Safe Mode, and press Enter.

    5)    If we could log in the system in Safe mode, please go to Device Manager, right click your hardware device in the list and select Properties; then click Driver tab and click Roll Back Driver button.

    Note: In Safe Mode, your system display and Desktop will look and perform differently than in Normal Mode. This is only temporary.

     

    Good luck

    Andy

    Monday, December 14, 2009 6:52 AM
  • The problem occurs as soon as the laptop is switched on, making me believe it's not a software fault, but a hardware fault.
    I can only visualize image with an external monitor

    Thanks,
    Spre3
    Monday, December 14, 2009 9:10 AM
  • Hi,

    Does the external monitor display completely normal? Will the laptop screen work in Safe Mode?

    If the external monitor works fine and the laptop still show black screen in Safe Mode, I would consider sending the laptop to repairshop too. May be the build in display card crashed somehow.
    Wednesday, December 16, 2009 2:33 AM
  • Yeah, the external monitor works perfectly fine. The laptop's monitor won't display any image, not even the Bios when the laptop is turned on. It does show a light, even tho its black and that light gets brighter when we adjust the monitors brightness, pressing FN+F6.
    Repair shop said it was a motherboard's fault.

    Thanks,
    Spre3
    Wednesday, December 16, 2009 9:31 PM
  • Hi,

    As the external monitor works fine, but the build in monitor won't even display the BIOS screen and this issue occurs right after installing Win7 update , pls try reseting\updating your BIOS. If this does not work, the build in monitor may be burned to corrupt somehow.
    Thursday, December 17, 2009 2:57 AM
  • This is quite a while afterd the last message but I've just spent 2 days trying to fix my black screen, Win 7, and today it worked.  I tried "repair computer" and restoring, and using my repair disk and nothing worked.  Finally I booted to safe mode pressing F8.  Went to control panel, device manager, display adaptors, and as there were two, right clicked on them in turn and updated driver, and then uninstalled driver.  Then I rebooted and the computer booted up to normal mode with 600 x 800 resolution, and told me the new driver was being installed.  Then it asked to restart, so when I did, it came back to the black screen.

    I went back to safe mode, then I removed my password in the user account, in case that was doing something to stop booting up properly, then I disabled automatic windows update (had a bit of a mission finding out where) - but I clicked start and typed windows update into the search ..and that didn't help and in the end I think I typed in "services" then went to windows update and right clicked and went to properties and disabled it.  Then I repeated the updating and uninstalling of drivers as above, and this time when it rebooted and went to windows normally, with 600 x 800 resolution, I didn't reboot when it asked me too.  Instead, I changed the screen resolution to as large as it would allow me, (it stretched everything) and went to the HP website, put in my model number of laptop which is an HP Envy, and downloaded the latest graphic amd driver.  That fixed the problem and now my computer is working fine again!

    Sunday, June 17, 2012 6:03 AM