none
CPU Core Parking in Windows 7, Should it be left alone or should users disable it?

    Question

  •  

    I've been reading up on this but an official answer to this issue would be welcomed. What I like to know is what is the benefits of core parking?  And should it be left alone or tweaked as some suggest?  One example is found below:

    http://ultimatecomputers.net/forum/viewtopic.php?f=7&t=3644

     

    The link below suggests that Core Parking is for laptops? I really don't know but this thread was created with Home PC in mind.

    http://forum.cakewalk.com/tm.aspx?high=&m=1852473&mpage=1#1853037.

    Wouldn't changing the power option from Balanced to High Performance do the same thing without having to do a registry tweak?

    Friday, March 25, 2011 10:30 PM

Answers

  • 1) if all cores are used, they don't get parked. They are only parked if the CPU is not busy.

    2) Coreparking only works for Intel i3/i5/i7 CPUs, NO other CPUs. Look at the Resource Monitor (CPU-tab) to see which CPU core is parked:


    André


    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Tuesday, March 29, 2011 7:54 PM

All replies

  • Never turn it off. It helps you to save energy. Unused Cores are parked and not used which results in a lower energy consume. Core Parking is enabled if you use the balanced power plan and only work for Intel i Core CPUs (i5,i7).

    André


    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Saturday, March 26, 2011 12:15 PM
  • Hi,

     

    Did your issue solved by the suggestion of Andre? Please feel free to give me any update.

     

    Thanks.

     

    Regards, 

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, March 29, 2011 2:48 AM
    Moderator
  • More or less.  In a nut shell one should not edit the registry.  After doing some research I found that one can do the exact same thing but the information on how to do it isn't readily available.  So I will try my best to explain it (help me if I'm wrong).

     

    1. If there are any concerns as to the use of the CPU in games, etc one should choose the Performance Power State instead of making registry edits. 

    2.  You can make changes to this plan by going into it's Advance Power Settings, select Processor Power Management and check to see if you have Minimum Processor State and Maximum Processor State.  If you don't see those options it is because you have SpeedStep (Intel), PowerNow (AMD) disabled from the Bios.  Those options must be enabled in order to view those options.  

    3. With a user's dynamic frequency scaling enabled via bios a user can choose a Power Option suited for their needs.  Choosing Performance Power Option should keep both min/max Processor State at 100%.  If one choses Balance it will keep the Minimum Processor State as low as 5% and Maxmium at 100% (power saver should be the same).

     

    This is what I've gathered.

     

     

    Tuesday, March 29, 2011 5:37 PM
  • 1) if all cores are used, they don't get parked. They are only parked if the CPU is not busy.

    2) Coreparking only works for Intel i3/i5/i7 CPUs, NO other CPUs. Look at the Resource Monitor (CPU-tab) to see which CPU core is parked:


    André


    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Tuesday, March 29, 2011 7:54 PM
  • Hi,

     

    Did your issue solved by the suggestion of Andre? Please feel free to give me any update.

     

    Thanks.

     

    Regards, 

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, April 04, 2011 1:04 AM
    Moderator
  • Hi,

     

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios. If the issue still persists, please feel free to  reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

     

    BTW,  we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems. Thanks for your understanding and efforts.

     

    Regards,

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, April 08, 2011 2:17 AM
    Moderator
  • I have found that the answer to this question is normally NO. However, situations do exist where it is desirable to disable CPU Parking.

    I created a freeware tool to disable or enable CPU core Parking in REAL TIME, so you can see the effects of doing so. There HAVE BEEN apparent performance problems and/or considerations, as additional 'hidden' variables were added to the power configuration to tweak CPU Parking further.

    During routine testing, I was surprised to find that the new AMD Bulldozer platform, complete with the latest scheduler Microsoft hotfix, achieved a substantial performance boost after disabling CPU Parking. Of course, this new platform pairs its cores with shared computational units, thus the first scheduler hotfix actually started treating every other core as a logical core.

    Anyway, I noticed extreme problems in system performance on that PC, and disabling CPU Parking *did* seem to make a *real time* difference in performance. YMMV. I encourage you to experiment. I included on the page instructions on how to use powercfg.exe (no need to edit the registry), so you don't have to use the Freeware tool I created, BUT it's there to use if you want it: http://bitsum.com/about_cpu_core_parking.php 

    It is *certainly* possible that under *some* situations the scheduler is too aggressive in its CPU/core parking, and thus could impact performance. Although 'wake up' time is fast, it is not instant, nor is there any 'predictive' measure - and since CPU utilization often occurs in brief bursts, there is definitely the possibility of inferior performance.

    Under MOST situations though, it should be fine. AMD's Bulldozer was a bit ahead of the OS schedulers in development. The software lagged behind the hardware in this case.


    Jeremy Collake
    Bitsum - http://bitsum.com

    Sunday, May 06, 2012 7:34 AM
  • 2646060  An update that selectively disables the Core Parking feature in Windows 7 or in Windows Server 2008 R2 is available

    http://support.microsoft.com/kb/2646060/EN-US

    • Proposed as answer by tmac3931 Thursday, July 26, 2012 9:25 PM
    Thursday, July 26, 2012 9:24 PM
  • Its not just Intel, My AMD FC8320 is also parking cores, also they unpark as soon as they are needed so don't worry about it its saving power and heat for you.
    Friday, August 09, 2013 12:34 PM
  • Really? I turned on 'high performance' and they are still iterating on and off... I"m converting a video and don't know if this is impacting speed or not.  You'd think the CPU's would be at 100%, but the 'overall' is averaging 22%.  So WHY is the processor group not maxed?  Is the process delayed more by the HD? Other?

    My old school single cpu used to max out, as did core duals, so what's different... feel like I'm getting ripped off on power to get the conversion done faster.


    • Edited by rwwwwww Sunday, March 02, 2014 1:31 AM
    Sunday, March 02, 2014 1:30 AM