none
autounattend.xml file not found during Windows 7 setup

    Question

  • Hi, no matter what I've tried, I can't seem to get setup to recognise my answer file. I've followed the instructions correctly and have made several answer files at this stage. Originally I was trying to install Windows 7 Ultimate N SP1 x64 and when it didn't work I thought maybe the SP1 was causing issues. I then configured an answer file and tried to install Windows 7 Ultimate x64 but still the answer file was not detected. I then tried Windows 7 Ultimate x86 but still the same. I have the autounattend.xml file on the root of my USB stick. The drive is recognised by the system and is in the boot menu at startup. When setup loads, the light on the USB stick flickers as if it is being read but still the language option appears every time. I have tried formatting the drive with both NTFS and FAT32 but still the same. Then I thought it might have something to do with my language entry so Ichanged this from 'en-ie' to 'en-IE' - but still the same. What can I be doing wrong? Does the USB stick need to be prepared in any specific way? 
    Thursday, December 01, 2011 9:43 AM

Answers

  • Extra,

      en-IE is not a language pack.  The only english language pack is en-US.

    Thanks

    Sean


    MCTS: Windows 7
    Friday, December 09, 2011 7:19 PM

All replies

  • can you post your answer file here please?

     

    Also first thing i would check is that the architecture used when creating the answer file matches that of the OS that is being applied.

    Thursday, December 01, 2011 12:37 PM
  • Yes architecture always matches. I reverted to using Windows 7 Ultimate x86 as this is the version that all the guides seem to have been written for. Here is my answer file for Windows 7 Ultimate x86. I placed xxxxx-xxxxx-xxxxx-xxxxx-xxxxx here for the product key. When I validate the answer file I get errors about OS Image/InstallFrom and OS Image/InstallTo. I save the file and place it on my USB stick but setup keeps ignoring it.

     

    <?xml version="1.0" encoding="utf-8" ?>
    - <unattend xmlns="urn:schemas-microsoft-com:unattend">
    - <settings pass="windowsPE">
    - <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    - <SetupUILanguage>
      <UILanguage>en-IE</UILanguage>
      </SetupUILanguage>
      <InputLocale />
      <UILanguage>en-IE</UILanguage>
      </component>
    - <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    - <UserData>
    - <ProductKey>
      <Key>xxxxx-xxxxx-xxxxx-xxxxx-xxxxx</Key>
      </ProductKey>
      <AcceptEula>true</AcceptEula>
      </UserData>
    - <ImageInstall>
    - <OSImage>
      <InstallToAvailablePartition>true</InstallToAvailablePartition>
      </OSImage>
      </ImageInstall>
      </component>
      </settings>
      <cpi:offlineImage cpi:source="wim:c:/wims/install.wim#Windows 7 ULTIMATE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
      </unattend>

    Thursday, December 01, 2011 12:57 PM
  • hmm...I changed the UI language in my answerfile  to en-US and setup then recognised it?

    I thought the whole idea of an answer file was that setup could be configured to install the way you wanted?

     

    Friday, December 02, 2011 11:47 AM
  • Hi,

     

    It seems you have found the resolution. Thanks for sharing.

     

    The UILanguage "en-IE" doesn't exist. Available Language Packs:

    http://technet.microsoft.com/en-us/library/dd744369(WS.10).aspx

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, December 05, 2011 8:07 AM
  • Hi Niki,

     

    It's not a reolution.

    How do I configure my new installation to start with UI language en-IE (english-Ireland)? 

    Friday, December 09, 2011 4:08 PM
  • Extra,

      en-IE is not a language pack.  The only english language pack is en-US.

    Thanks

    Sean


    MCTS: Windows 7
    Friday, December 09, 2011 7:19 PM
  • OK...thanks. Yes, I saw it wasn't a language pack but as en-IE is configurable during setup, I thougth I should be able to specify it in my answerfile.
    Saturday, December 10, 2011 6:23 PM
  • Hi,

     

    Since en-IE is not a language pack, that's why your setup cannot recognize the answer file. There is no English-Ireland, if you specify it as you want, it won't work.

     

    Best Regards,

    Niki


    Niki Han

    TechNet Community Support


    Tuesday, December 13, 2011 10:03 AM