none
Unable to Write/Delete data on External USB disk in Windows 7.

    Question

  • Hii,

    I recently bought a new AMD x4 945, MSI 785 chipset system and installed Windows 7 ultimate edition on it. Now when i connect my old External USB WD hdd to it it is successfuly able to connect, it is able to read copy the data but i am not able to delte/write any data to it. I connet the same HDD to my old Windows XP sp2 system and it works fine there. Seems like the HDD got only read only access in windows 7. How will be able to write/delete data from it ?
    Thursday, February 11, 2010 6:42 AM

Answers

  • Hi,

    Regarding the hotfix, I think you can install it directly. The hotfix will replace/update some USB related system files which would be helpful for USB related issues.

    Actually, I have had this type of issue before and format is a quick fix to me (please remember to formant it under Windows 7). Since you do not have other free space, you can consider copy those data to another PC (of your friends or the PC in your office)

    Meanwhile, what would happen when you try to save file to this USB HDD? If you receive error message stating "The disk is write-protected.  Remove the write-protection or use another disk”, please remove write protection from your USB flash drive using the below method:
    ====================
    1. Open start menu, in the search bar type REGEDIT and press enter. This will open the registry editor.
    2. Navigate to the following path:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies

    Note: If the registry key StorageDevicePolicies does not exist, you will need to create it manually.

    3. Highlight StorageDevicePolicies, and then create a New DWORD (32-bit) Value named as WriteProtect.
    4. Double click the key WriteProtect in the right window and set the value to 0 in the Value Data Box and press OK button
    5. Restart your computer and try copying files into your USB drives.

    If the issue persists, you may have to run the following command as a fix:
    ====================
    1. Start > search bar -> CMD and press enter
    2. type< diskpart
    3. type< list disk
    4. type< select disk # (# is the number of the USB HDD you’ve pluged in)
    5. type< attributes disk clear readonly

    Do you still have the same issue after reboot?

    Please post your update info if you have make any progress

    Friday, February 12, 2010 8:26 AM

All replies


  • Hi there,

    First of all, have you install the following hotfix for USB issue? Most USB issue can be fixed by it.
    http://support.microsoft.com/kb/976972

    if the issue persists after installing the hotfix, pls let me know what the exact error you may encountered when you try to delete/write to the old external USB HDD. Meanwhile, do you have the same issue when you use other USB flash disk or external HDD?

    Additional, you can also backup your files on the HDD and format it under Windows 7 as a quick fix, do you still have the same issue now?

    Thursday, February 11, 2010 9:12 AM
  • Thank you for your reply.
    I have not applied the hotfix yet. I do not get any error while delete/write data to the USB disk. The options to create new folder or delete any file/folder are not available for the data in my External USB HDD. Seems like it system is opening it in Read only mode.

    I am not sure if i should apply this hotfix as i am not facing any of the issues mentioned in the kb.
    Currently i switched over to my old system as i needed to do some work with that data on HDD. In next 2 days i will switch back again to my windows 7 system and check if it has "NVIDIA USB EHCI" controller and will apply the hotfix and update you guys on the staus.
    Formatting the USB HDD with Windows 7 will be pain as it's a 1 TB HDD and i do not have any other space available to backup that data.
    Friday, February 12, 2010 7:04 AM
  • Hi,

    Regarding the hotfix, I think you can install it directly. The hotfix will replace/update some USB related system files which would be helpful for USB related issues.

    Actually, I have had this type of issue before and format is a quick fix to me (please remember to formant it under Windows 7). Since you do not have other free space, you can consider copy those data to another PC (of your friends or the PC in your office)

    Meanwhile, what would happen when you try to save file to this USB HDD? If you receive error message stating "The disk is write-protected.  Remove the write-protection or use another disk”, please remove write protection from your USB flash drive using the below method:
    ====================
    1. Open start menu, in the search bar type REGEDIT and press enter. This will open the registry editor.
    2. Navigate to the following path:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies

    Note: If the registry key StorageDevicePolicies does not exist, you will need to create it manually.

    3. Highlight StorageDevicePolicies, and then create a New DWORD (32-bit) Value named as WriteProtect.
    4. Double click the key WriteProtect in the right window and set the value to 0 in the Value Data Box and press OK button
    5. Restart your computer and try copying files into your USB drives.

    If the issue persists, you may have to run the following command as a fix:
    ====================
    1. Start > search bar -> CMD and press enter
    2. type< diskpart
    3. type< list disk
    4. type< select disk # (# is the number of the USB HDD you’ve pluged in)
    5. type< attributes disk clear readonly

    Do you still have the same issue after reboot?

    Please post your update info if you have make any progress

    Friday, February 12, 2010 8:26 AM
  • Addtionally, I would like to suggest you checking the permissions of the disk. If it is read-only, try to take ownership of the disk and edit the permissions to have write/delete privilege.


    How to take ownership of a file or folder

    Edit the permissions:
    =============

    1) Right click the drive.
    2) Hightlight Security tab.
    3) Select the current user.
    4) Click Edit and check the Allow box of Full control.
    5) Click Apply and OK.
     
    Best Regards
    Dale

    Wednesday, February 17, 2010 2:28 AM
  • Can't edit the security and take ownership as the security tab is not showing on the properties page.

    Sunday, February 28, 2010 11:20 AM
  • I installed hotfix as per http://support.microsoft.com/kb/976972 , Performed the "StorageDevicePolicies" registry key but problem still exists.
    Format and Diskpart still needs to be tried. Soon i will arrange for the backup and perform diskpart as well. I do not think disk part will help much as when i saw external hdd status in diskpart it does not shows it as read only. 
    Monday, March 01, 2010 7:24 AM
  • Surprizingly I was able to write/delete data 2 days back. It worked fine for hours. I deleted some of the data fine.  I shut down the pc and again I am not able to write/delete any data from it.  I still can't figure out how it worked and why it is not working now.
    Sunday, March 07, 2010 11:32 AM
  • Still No go with it..DiskPart shows it "Read Only: No" both at disk and volume level. As suggested in the article i still tried "ClearReadonly" but no luck.. Any more suggestions..?
    Thursday, June 17, 2010 1:35 PM
  • I tried many methods on Internet: regedit, diskpart, etc. not work on my HP8GB on Lenovo T410. Co can't get rid of Win7 either. This is for sure a bug.
    Friday, February 04, 2011 7:24 PM
  • Thanks for the info. Of all of the processes I tried, this was the only thing that worked and without deleting any of my files. Very simple too.
    LMCfashions@comcast.net
    Sunday, July 10, 2011 12:14 AM
  • Hi, you wrote:

    "Thanks for the info. Of all of the processes I tried, this was the only thing that worked and without deleting any of my files. "

    But you did not mention what you exactly did...  Can you explain?

    Sunday, July 17, 2011 9:34 AM
  • hi there,

    been there, tried everything..just registered to help you..

    follow this:

    open usb, right click, then Tool, Check now.. that will fix the usb disk

    next reinsert the disk and format it, but using FAT not FAT32. after you finished that your disk won't be write protected anymore and you also will gave Security tab..

     

    i hope this helps..it did to me..

     

    all the best

    Sunday, August 14, 2011 12:48 PM
  • None of this worked I went through all of the motions, creating the director in the registry along with the CMD and everything else.  Are there any other alternatives?
    Tuesday, August 30, 2011 12:39 AM
  • Thanks for your post. I have a generic USB 8G flash drive that is stuck in write-protect mode in WIN7-64 bit. It does not format nor can the properties be changed. I have tried several 'fixes' including a usb utility that didn't find the drive. I checked the registry for the StorageDevicePolicies but didn't find it. This drive does not format on XP, either.

    I had some success with the diskpart on the CMD line.

    attributes disk gives the listing and shows the Current read-only state: Yes. There is another attribute called read-only:No

    Why these attributes do not agree is unknown.

    However, the attributes disk clear readonly command executes OK and did not clear the current read-only state:Yes.

    The readonly state changes to Yes with SET and changes to No with clear. Although the commands seem to work OK, the drive write-protection is not cleared.

    Your suggestions are welcome.

     

     

    Tuesday, September 13, 2011 3:52 AM
  •  

    1. Start > search bar -> CMD and press enter
    2. type< diskpart
    3. type< list disk
    4. type< select disk # (# is the number of the USB HDD you’ve pluged in)
    5. type< attributes disk clear readonly

    Attributes disk clear readonly worked for me, thanks

    Tuesday, October 25, 2011 10:04 AM
  • Hi 

    I have a USB drive that is write-protected.

    I used this procedure;

    If the issue persists, you may have to run the following command as a fix:
    ====================
    1. Start > search bar -> CMD and press enter
    2. type< diskpart
    3. type< list disk
    4. type< select disk # (# is the number of the USB HDD you’ve pluged in)
    5. type< attributes disk clear readonly

     

    It completed OK and there is no change on the write-protecion for this USB dirve.

    I suspect it has a hardware failure.

    Anybody have another idea?
    Thanks 


     


    Wednesday, October 26, 2011 2:51 AM
  • I have the same problem. I tried checkdisk, diskpart, usb recovery manager, tried using the cmd... editing the registry... went through all sorts of french / english boards.

    No Solution.

    It's useless, it always will stay "write protected" I even tried disregarding the protection using ubuntu and the terminal with several tutorial nothing worked !
    this damn key won't get writeable



    • Edited by siriusql Tuesday, November 01, 2011 4:48 PM
    Tuesday, November 01, 2011 4:38 PM
  • HI I TRIED ALL THE THINGS  BUT STILL UNABLE TO REMOVE WRITE PROTECTION IN USB
    Tuesday, December 27, 2011 10:12 AM
  • "RAMABADRAN V" wrote in message news:9b08213c-9c35-4237-8c4e-c041fd810389...
    HI I TRIED ALL THE THINGS  BUT STILL UNABLE TO REMOVE WRITE PROTECTION IN USB
     
    Some USB sticks come with a hardware switch for safety – check yours.
     

    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth
    Tuesday, December 27, 2011 10:21 AM
  • Gordon,

    very useful info it help me very much i tried to remove write protection from my friend flash drive for so many days.

    but the second option running cmd command was help me and no need to restart.you

     

    Thank you

    Saturday, December 31, 2011 5:53 AM
  • SAME HERE.... this is obviously a WINDOWS7 Problem with USB hard drives.... I have a 2 TB drive.... the person how suggest formatting is NOT a true engineers way to fix this..... it's a idiotic way ..... 

     

    I have tried everything suggested here and with my own 30+ years of knowledge.  NOTING WORKS.... FIX THIS ISSUE MICROSOFT.... 

     

    Your issue has made ALL MY USB hard drives USELESS .... This issue has been going on now for over a year that I am aware... WHERE IS THE SUPPORT??. .... or are we too busy fixing the problems in win8 and pulling another 98 second edition rip-off??

     

    FIX THIS ON WINDOWS 7.

     

    DID IT ALL ... DISKPART, REGISTRY EDITED .... Storage parameters do NOT have USB parms that are obvious, where are they??

    I WILL NOT FORMAT JUST BECAUSE MICROSOFT HAS ONCE AGAIN FAILED IN SUPPORT .... AND HAS FAILED TO TRAIN THEIR PAPERED ENGINEERS ! ! ! !  ??

     

    NONE of the moderators, partners OR users solutions here WORK...... they are all a BIG waste of time!!!!!  and some lacking knowledge .... and yes... some are partners.... scary ....

     

    • Edited by Eagle_Quest Saturday, January 28, 2012 2:36 PM
    Saturday, January 28, 2012 2:30 PM
  • Hi,

    I don't know if the problem I experienced is in any way related to yours, but I thought that I would share my experience, and perhaps it will help.

    I use Windows Media Center (WMC) in Windows 7 to record TV programs, and I set WMC to store my files on an external drive. I was watching live TV in WMC when I got the surprising message that my disk had run out of space. I did not think that I was anywhere close to that condition, and in fact I had plenty of room on the drive. I happened to notice in Explorer when I viewed the properties of my Recorded TV folder and its files, that they were all set to the Read-only attribute, and that was strange since I never set my files/folder to Read-only. So I Googled "read only" and found these articles:

    http://itexpertvoice.com/home/fixing-the-windows-7-read-only-folder-blues/

    http://support.microsoft.com/kb/326549

    Apparently Microsoft has changed the attributes for security-related reasons during one of their Windows updates. The articles explain that you cannot use the Properties dialog to change a FOLDER from read only - it has to be done from the DOS prompt. And apparently because my WMC Recorded TV folder was Read-only it thought it was out of space. (Why this would be so I have no idea.) I have unset the Read-only folder attribute, and I am now waiting to see if WMC is happy.

    Perhaps your issue is related.

    Thursday, February 02, 2012 8:32 PM
  • Hey! Try this way! I just find out and it works!

    I am using Win. 7 and I had problem with my USD.

    Try this:

    - Right click and choose "Properties"

    - Find " Sharing" tab

    - Look for " Advance Sharing" click on it.

    - Tick " Share this folder"

    - OK

    Let me know if it works for you...
    You should know what Folder Sharing mean when you want to share.

     

    Friday, February 03, 2012 5:41 PM
  • Hey! Try this way! I just find out and it works!

    I am using Win. 7 and I had problem with my USD.

    Try this:

    - Right click and choose "Properties"

    - Find " Sharing" tab

    -

    Hi! Friends,

    I have tried all this things but not working for me please need help

    Sunday, March 04, 2012 1:30 PM
  • Hi! Friends,

    I have same issue , tried this things but not working for me please need help

    Wednesday, March 21, 2012 12:08 PM
  • friends , My problem solved.

    Try this this post :  How to Remove Read Only Protection From USB Drive

    thanks

    • Proposed as answer by Metro-User Wednesday, March 21, 2012 12:28 PM
    Wednesday, March 21, 2012 12:27 PM
  • friends , My problem solved.

    Try this this post :  How to Remove Read Only Protection From USB Drive

    thanks


    Thank you sir .. last method helped me
    Wednesday, March 21, 2012 12:45 PM
  • follow the steps


    1.Open a new note pad file.

    2.Copy this

    cd\
    reg add “HKLM\System\CurrentControlSet\Control\StorageDevicePolicies” /t Reg_dword /v

    WriteProtect /f /d 0

    3.save it as DISABLEWP.BAT

    4.Then copy it to start up folder.

    When you insert a pendrive it remove write protection.If it becomes.Or simply use any software which fix this kind of problem.You may try long path tool from http://longpathtool.com .It may help you.Thanks.
    Saturday, March 24, 2012 9:23 AM
  • Hi,

    Regarding the hotfix, I think you can install it directly. The hotfix will replace/update some USB related system files which would be helpful for USB related issues.

    Actually, I have had this type of issue before and format is a quick fix to me (please remember to formant it under Windows 7). Since you do not have other free space, you can consider copy those data to another PC (of your friends or the PC in your office)

    Meanwhile, what would happen when you try to save file to this USB HDD? If you receive error message stating "The disk is write-protected.  Remove the write-protection or use another disk”, please remove write protection from your USB flash drive using the below method:
    ====================
    1. Open start menu, in the search bar type REGEDIT and press enter. This will open the registry editor.
    2. Navigate to the following path:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies

    Note: If the registry key StorageDevicePolicies does not exist, you will need to create it manually.

    3. Highlight StorageDevicePolicies, and then create a New DWORD (32-bit) Value named as WriteProtect.
    4. Double click the key WriteProtect in the right window and set the value to 0 in the Value Data Box and press OK button
    5. Restart your computer and try copying files into your USB drives.

    If the issue persists, you may have to run the following command as a fix:
    ====================
    1. Start > search bar -> CMD and press enter
    2. type< diskpart
    3. type< list disk
    4. type< select disk # (# is the number of the USB HDD you’ve pluged in)
    5. type< attributes disk clear readonly

    Do you still have the same issue after reboot?

    Please post your update info if you have make any progress

    If u are using Antivirus program like Quick Heal, it has data theft protection, so please check that and disable it for removable storage devices.

    Tuesday, March 27, 2012 9:33 AM
  • I agree. This is a BUG. I have read all the words from Microsoft about making folders read only but it's the drive that's read only for me. Can't backup, won't allow me to format. Changed the registry to 0 ran CMD clear read only, changed the drive path, made sure of my permissions etc. Best I got was a couple of hours then changes back.

    I don't care what the reason that microsoft has for this but I totally agree with Eaglequest that this is a Windows 7 BUG and needs to be fixed.

    Wednesday, March 28, 2012 3:36 AM
  • I am not sure whether this will cure your problem, my USB was rendered useless and I tried this fix from HP now works a treat and it's totally free.   http://www.softpedia.com/get/System/Hard-Disk-Utils/HP-USB-Disk-Storage-Format-Tool.shtml
    • Edited by aichqu Wednesday, March 28, 2012 10:30 PM
    Wednesday, March 28, 2012 10:29 PM
  • I got the 2TB HDD. I use sony vaio windows 7 professional. The computer/Disk management screen DOES show the Hard Disk as a Disk 1, unknown, 1863.01 GB, Not Initialized with the message of UNALLOCATED. But my computer does NOT display this 2tb HDD in the folder. Therefore, I cant run the attrib commands on my computer.

    I will be greateful if you can help me please...

    Sunday, April 01, 2012 8:27 PM
  • It worth to mention that I have tried EASE Partition Master 8.0.1 Server Edition but my above mentioned problem is still there....
    Sunday, April 01, 2012 8:29 PM
  • I have the same issue.  I am running Windows 7 Professional - 64bit.

    I've tried several USB drives with different format types:  FAT, FAT32 and NTFS.  I am unable to write to the drive.  I am unable to right-click and see the security tab.  Since I am in a domain environment, I tried logging on as a member of the domain administrator group - no luck.  I then tried logging on as THE domain administrator and it works.  I am able to write to the disk.

    I have tried all the suggestions in this thread and nothing works.  I obviously can't have the users logging in as administrator.  They are already local administrators.  I have turned off the UAC.  I am at a loss.  This only happens on the Windows 7 64bit clients.

    Monday, April 16, 2012 5:11 PM
  • Hi Gordon 7,

    Sadly your suggestion does not work for me.

    It is a definately a software issue. I have locked 2 USB memory sticks proving it. The first one was a surprise, the second a planned experiment.

    Our industrial safety PLC program sets the current Read-only State to yes when we archive our programs.

    If this problem can't be solved we are going to use a lot of memory sticks.

    Kind regards,

    Dave_48.

    Tuesday, April 17, 2012 11:17 AM
  • Hello Everyone,

    I was able to resolve my issue.  Here is what I did.

    Firstly, there are a series of options in the Group Policy Object Editor that deal with read/write permissions on hard drives and removable media.  I basically changed their individual settings from "Not configured" to "Disabled".

    Start -> Run... -> gpedit.msc -> OK

    Computer Configuration -> Administrative Templates -> System -> Removable Storage Access

    In here I disabled all of the "Deny read access/write access" options; you may only want to disable the ones relating directly to the type of media that you want to access.

    Here are the ones I changed:

    Removable Disks:  Deny execute access
    Removable Disks:  Deny read access
    Removable Disks:  Deny write access

    Double-click each one and select the 'Disabled' radio button.

    Do the same as above, except the first step is "User Configuration" instead of "Computer Configuration"

    The second thing I did involves the registry.  Backup the registry before continuing.  If you're not sure how, read on.

    Start > Run... > regedit > OK

    Highlight "Computer" and right-click. Select "Export" and save the backup somewhere safe.  Just double-click it if you want to reset the changes you make.

    After backing up, navigate to the following registry location:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\StorageDevicePolicies

    Click on StorageDevicePolicies and on the right-hand side there should be a DWORD value labeled "WriteProtect".  If there isn't one, create it.  Either way, make sure it has a value of 0.  Double-click it to change it.

    Do the same with the following two locations (creating any non-existent keys/values along the way):

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control

    This resolved the issue I was having.  I hope this helps others.

    • Proposed as answer by clange50 Monday, May 14, 2012 6:00 PM
    Tuesday, April 17, 2012 2:47 PM
  • "RAMABADRAN V" wrote in message news:9b08213c-9c35-4237-8c4e-c041fd810389...
    HI I TRIED ALL THE THINGS  BUT STILL UNABLE TO REMOVE WRITE PROTECTION IN USB
    Some USB sticks come with a hardware switch for safety – check yours.

    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    I had a dumb moment, been trying solve this all morning, then realized it was indeed a switch for safety. Thanks Noel. :)

    Teching It Easy: With Windows |ActiveWin | Notebooks | Microsoft MVP

    Sunday, April 29, 2012 1:54 PM
  • "Andre Da Costa" wrote in message news:1c25fe81-0cd2-43ee-a9e6-88b8b8df9102...

    I had a dumb moment, been trying solve this all morning, then realized it was indeed a switch for safety. Thanks Noel. :)

     
     
    BTDT :)

    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth
    Sunday, April 29, 2012 2:47 PM
  • This problem just happened to me yesterday while I was trying to  copy some files from my windows 7 laptop to my 4 GB sandisk cruzer blade flash disk and voila I got the message:

    "Disk is write-protected"

    I was stuck. Could not delete any file or paste one onto it.

    After checking the net I tried different format tools but in vain. I came to realize that this glitch was more common and increasing. Unfortunately there is still no solution!

    Saturday, May 05, 2012 10:40 AM
  • Hello Everyone,

    I was able to resolve my issue.  Here is what I did.

    Firstly, there are a series of options in the Group Policy Object Editor that deal with read/write permissions on hard drives and removable media.  I basically changed their individual settings from "Not configured" to "Disabled".

    Start -> Run... -> gpedit.msc -> OK

    Computer Configuration -> Administrative Templates -> System -> Removable Storage Access

    In here I disabled all of the "Deny read access/write access" options; you may only want to disable the ones relating directly to the type of media that you want to access.

    Here are the ones I changed:

    Removable Disks:  Deny execute access
    Removable Disks:  Deny read access
    Removable Disks:  Deny write access

    Double-click each one and select the 'Disabled' radio button.

    Do the same as above, except the first step is "User Configuration" instead of "Computer Configuration"

    The second thing I did involves the registry.  Backup the registry before continuing.  If you're not sure how, read on.

    Start > Run... > regedit > OK

    Highlight "Computer" and right-click. Select "Export" and save the backup somewhere safe.  Just double-click it if you want to reset the changes you make.

    After backing up, navigate to the following registry location:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\StorageDevicePolicies

    Click on StorageDevicePolicies and on the right-hand side there should be a DWORD value labeled "WriteProtect".  If there isn't one, create it.  Either way, make sure it has a value of 0.  Double-click it to change it.

    Do the same with the following two locations (creating any non-existent keys/values along the way):

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control

    This resolved the issue I was having.  I hope this helps others.

    The first part with gpedit.msc is what finally fixed this for me. Still working after multiple reboots. Thanks!
    • Proposed as answer by WuJi Wednesday, May 23, 2012 3:44 PM
    Monday, May 14, 2012 6:04 PM
  • THE ABOVE WORKED!!!!!! FINALLY!!! I've been dealing with this issue of "Administrator Permission" or "Access Denied" for 5 months now, and the first part of the above answer WORKED!!!! I'm re-pasting it below, if for no other reason than it made my day!

    Start -> Run... -> gpedit.msc -> OK

    Computer Configuration -> Administrative Templates -> System -> Removable Storage Access

    In here I disabled all of the "Deny read access/write access" options; you may only want to disable the ones relating directly to the type of media that you want to access.

    Here are the ones I changed:

    Removable Disks:  Deny execute access
    Removable Disks:  Deny read access
    Removable Disks:  Deny write access

    Double-click each one and select the 'Disabled' radio button.

    Do the same as above, except the first step is "User Configuration" instead of "Computer Configuration"

    Monday, May 21, 2012 7:44 PM
  • I went through the whole thread until I found this solution from clang50 and it works for me.  I am using Window 7 Ultimate 64 bit.  Skip all other BS or link to useless advertising site.  Corrections: the credit should go to jkoons but I follow the steps here.
    • Edited by WuJi Wednesday, May 23, 2012 3:53 PM correction
    Wednesday, May 23, 2012 3:45 PM
  • Sorry, the credit should goes to jkoons but I used clange50's post.
    • Proposed as answer by WuJi Wednesday, May 23, 2012 3:51 PM
    Wednesday, May 23, 2012 3:51 PM
  • Dear Joe,

    I have tried both of the ways but my problem is still there...................please help me with some other way that can remove write protection from my pendrive.

    thanks.

    Muhammad Ali

    Tuesday, July 10, 2012 11:27 PM
  • Hello. I am new to win 7 about 4 days. I have this problem with my usb drives flash and sata. I followed an above instruction to change the registry. Search REGEDIT. Follow the path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies. My registry didn't have StorageDevicePolicies. At Control there was no value entered so I entered a value of 0. It worked. All usb drives are not write porotected, they don't shut off or become  unrecognized by the system. I don't know what future effect this will have on the system but I think not alot. By making this registry change your putting a instruction Zero where no instruction was. GOOD LUCK.
    Sunday, July 15, 2012 5:35 PM
  • for gideonsis;

    where exectly did you put value of 0?  was it in control itself or you created new key in control and if you did what was the name of the key you have created?   I have tried all of the above and none helped me to fix this problem.  Maybe you have a solution but I am not following you 100% so please clarify when you have a minute.

    thanks!

    Monday, July 16, 2012 12:17 PM
  • Hi,

    I have a Dell Latitude E6400 laptop with Intel Core2 Duo CPU (2.80GHz), running Windows 7 Professional (64-bit).

    I started to have this same problem after my RAM upgraded from 4GB to 8GB a few weeks ago (well, also had some Windows updates installed), but never had this issue before.

    I'm a domain user and also a member of the local Administrators group.

    I tried the following ways suggested here (thanks for all the advices!) with different USB drives/portable HDDs/memory cards (that I used before without this issue, none of them has write-protect lock), but NONE of them worked:

    - Hotfix (http://support.microsoft.com/kb/976972)
      When trying to install it, I got a message saying this does not apply to my system and could not continue.

    - Registry key WriteProtect under
        HKLM\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies
        HKLM\SYSTEM\ControlSet001\Control\StorageDevicePolicies
        HKLM\SYSTEM\ControlSet002\Control\StorageDevicePolicies
      They all have value 0.

    - "attributes disk clear readonly" command within the "disk part" tool
      There is no need since "Read-only state" already shows No.

    - Local Group Policy (via gpedit.msc)
      Disabled "Removable Disks:  Deny execute/read/write access"
      Disabled "All Removable Storage Classes:  Deny all access"
     under
      Computer Configuration > Administrative Templates > System > Removable Storage Access
      User Configuration > Administrative Templates > System > Removable Storage Access

    - Control and ownership
      All of my removable device have FAT or FAT32 file system, there is no security tab in the Properties window.
      I formatted one USB drive to NTFS, then checked Properties>Security, I am the owner with full control.

    Every changed above was followed by a reboot. But nothing helped. When I tried to create a folder or copy a file to the USB drive, I got a "Destination Folder Access Denied" message (see screen shot):

    Very oddly, I did the following and don't understand why (in command mode, I'm able to create a folder but unable to delete it):

    So right now I'm totally out of clue what to do... please help! Thank you.

    Friday, July 20, 2012 2:58 PM
  • You know what, people ? :)

    I tried all of the above and been wasting last 2 hours on this problem. Nothing worked. Tried everything on the internet and everything that was included here. I was getting this darn Unable To Write error...

    Then i tried uninstalling everything and solution was that DISK DEFRAGMENTING SOFTWARE ( O&O Defrag Software) was issue and preventing from writing to usb drive.

    I hope this solves somebody's problems!

    Cheers.

    Friday, July 20, 2012 8:13 PM
  • Hi,

    I have gone through the above steps. but i wasn't helpful.

    Made the DWORD value and restarted the machine also still not working.

    And also i had checked with diskpart but while using listdisk command its not showing my external device details.

    Pls help, as i m facing issues since last couple days and its very difficult to work without pendrive and external HDD.

    -Nitesh

    Thursday, August 23, 2012 10:42 AM
  • Hi,

    I am not getting "Removable Storage Access" option. Can you pls help.

    -Nitesh

    Thursday, August 23, 2012 10:45 AM
  • Hi,

    I am not getting "Removable Storage Access" option. Can u pls help.

    Error for your reference.

    Thursday, August 23, 2012 10:51 AM
  • Nitesh Rao

    You would be far better to post your own problem with detaills an a NEW question of your own - this thread has been marked as Answered and it's likelyy that most participants have unsubscribed


    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth

    Thursday, August 23, 2012 3:32 PM
  • Hi, regarding your steps, you said that is there isn't the registry key, I will have to create it manually.

    So how do I create it? I have searched the net and yet I am still unable to create the registry key.

    Sunday, September 30, 2012 2:51 PM
  • Hi sir...

    This is Bhargav. I tried the method you mentioned above.

    But it is not solving my problem.

    Is there any other alternatives i could try?

    Wednesday, October 31, 2012 5:37 AM
  • friends , My problem solved.

    Try this this post :  How to Remove Read Only Protection From USB Drive

    thanks


    Thank you sir .. last method helped me

      Hah!! Here's the last method:

    The only solution is then to through (SIC) out your USB drive and buy a new one..

    We hope this post will help you !

    Wednesday, November 21, 2012 1:53 PM
  • Hello guys; I have the same problem. I tried everything to solve the problem: registry mods, checking the security settings, diskpart read only clear.. none of these worked. (Windows 7 ultimate 64x)

    My problem is very curious. Since I maintain a huge database of engineering technical images and schematics, i have to use 18 WD 2TB usb hard drives drives, which are linked to the computer using 3x 7 port usb2 hubs. When the computer boots up, it loads windows 7, and after, it mounts the drives one by one. I currently have 3 drives that are read only. The curious part of the story, is that the drives that become read only, are not the same, at each reboot. The read only problem, seems to be migrating from one drive, to another, randomly. A week ago, i had two read only drives. The problem is not related to the usb hubs. Even if i plug some of the drives to the front usb port of the omputer, i still get read only randomly, on all of the drives at on point or another. Each of these drive work correctly on win XP/Vista computer, using the same set-up, so it's definitely a Windows 7 related bug. I just ordered Windows 8 professionnal. Hopefully, i wont have the problem with the new OS. If the problem is still present in win 8, i will install winXP.

    Thursday, January 31, 2013 11:13 PM
  • YYEEAAAAAAAAAAAHHHHHHH !!! this what is working !! no other things like format and other sh!t..
    Friday, September 06, 2013 4:00 PM
  • Hi, if this can help,

    All i did was to put the usb key in a mac, format it there then bck to the laptop win7.

    From there i was able to format it again, and everything is fine.

    Good luck

    Saturday, October 05, 2013 6:13 AM
  • Still i can't access....Plz give the Solution.
    Monday, November 18, 2013 7:17 PM
  • Did you got any luck with this? I am in same situation. Exactly same thing is happening with my laptop and couldnt find any luck yet.
    Monday, November 25, 2013 2:35 AM
  • Hi,

    I have a Dell Latitude E6400 laptop with Intel Core2 Duo CPU (2.80GHz), running Windows 7 Professional (64-bit).

    I started to have this same problem after my RAM upgraded from 4GB to 8GB a few weeks ago (well, also had some Windows updates installed), but never had this issue before.

    I'm a domain user and also a member of the local Administrators group.

    I tried the following ways suggested here (thanks for all the advices!) with different USB drives/portable HDDs/memory cards (that I used before without this issue, none of them has write-protect lock), but NONE of them worked:

    - Hotfix (http://support.microsoft.com/kb/976972)
      When trying to install it, I got a message saying this does not apply to my system and could not continue.

    - Registry key WriteProtect under
        HKLM\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies
        HKLM\SYSTEM\ControlSet001\Control\StorageDevicePolicies
        HKLM\SYSTEM\ControlSet002\Control\StorageDevicePolicies
      They all have value 0.

    - "attributes disk clear readonly" command within the "disk part" tool
      There is no need since "Read-only state" already shows No.

    - Local Group Policy (via gpedit.msc)
      Disabled "Removable Disks:  Deny execute/read/write access"
      Disabled "All Removable Storage Classes:  Deny all access"
     under
      Computer Configuration > Administrative Templates > System > Removable Storage Access
      User Configuration > Administrative Templates > System > Removable Storage Access

    - Control and ownership
      All of my removable device have FAT or FAT32 file system, there is no security tab in the Properties window.
      I formatted one USB drive to NTFS, then checked Properties>Security, I am the owner with full control.

    Every changed above was followed by a reboot. But nothing helped. When I tried to create a folder or copy a file to the USB drive, I got a "Destination Folder Access Denied" message (see screen shot):

    Very oddly, I did the following and don't understand why (in command mode, I'm able to create a folder but unable to delete it):

    So right now I'm totally out of clue what to do... please help! Thank you.

    Any resolution to this situation?

    Monday, November 25, 2013 2:36 AM
  • Hello!

    I already done all the steps and requirement but when i'm on the procedure of changing the write protect value to 0, message appeared saying "Cannot edit write protect: Error writing the value's new contents."

    I hoping that you can help me on this matter..

    Sunday, December 15, 2013 11:14 PM
  • I was having this issue and tried all the methods with no result.

    how mine became write protected was using the usb for a bootable windows 8.1 image using rufus.

    what what i tried and worked was.

    use rufus, partition scheme ntfs, quick format checked, with all others unchecked.

    its passed the first 3 tasks and failed. which clears all the boot options, etc.

    windows was not detecting the drive anymore so I took it out and put it back in and windows detected and said to format.

    I ran a quick format and it was then working.

    if everything else fails, try at your own risk.

    Sunday, December 22, 2013 12:30 PM
  • hi dear ,

    i have followed the above u mentioned both way but the issue is not solved ,

    in REGEDIT , aftr going to control (StorageDevicePolicies) this is not present there , what is this problum i cant understand.

    if you have any other solution please post.

    Monday, December 23, 2013 3:57 AM
  • Hi

    I am salman.after roboot the computer again face this problem.My micro sd card not format.if format then again face those things.an error face like unable system error and first you protection off.

    Tuesday, January 28, 2014 7:07 AM
  • Hi friends.

    I had same problem and i tried all methods lyk regedit and command prompt diskpart method. nothing is helpful,... 

    And in my flash drive i found a folder named "USB" and its write protected also. in all blog no one said about this folder. bt i seen somewhere in internet. need to change the read only option in properties of file name "Protected.txt" in usb drive... am not found this type of file bt i found only "USB" folder only..

    Can anybody help me???? :(

    MY FLASH DRIVE is hp 8gb 

    recover my flash drive. i dont want any folder and files.


    Wednesday, January 29, 2014 7:14 AM
  • NO it's not working. I tried it multiple times.
    Wednesday, February 05, 2014 11:51 AM
  • My flash drive is not showing security tab in properties.
    Wednesday, February 05, 2014 11:54 AM
  • Check to see if Bitlocker Drive Encryption is in Control Panel

    if so click Manage BitLocker, and then click Turn On BitLocker, follow the wizard, once it's done you should be able to copy files to your usb drive.

    Thursday, February 13, 2014 3:20 AM
  • I'm in the same exact boat as you.  I tried all these things also with no luck.  I even tried to format a USB thumb drive and got the same error.

    The bad part is that it used to work and I could write to USB drives. Now no USB thumb or hard drive works.  Works great on my old Vista laptop tho.

    Did you find any solutions? I would love to hear them.

    Thursday, April 03, 2014 2:05 AM
  • Tried all these.  What if they didn't work?  Any other ideas?  No USB drive works for some reason.  Thanks!

    Thursday, April 03, 2014 2:16 AM
  • All this is waste of time...

    I used http://www.antspec.com/usbflashinfo/ to detect USB controler type

    In my case it was Phison 2303 (2251-03)

    I used Phison utility Restore-v3.13.0.0.exe to reset my USB drive to factory default setings.

    After that I successfuly formated it.

    You need tool related to your controler type.

    Best regards :)

    Antanas

    Thursday, September 04, 2014 10:00 PM