none
Windows 7 - The System Administrator has set policies to prevent this installation.

    Question

  • I was trying to install a software on my Windows 7 Home basic. Windows Installer keeps me warning 'The system administrator has set policies to
    prevent this installation'. What seems to be the problem, Can anyone please help me on this. Thanks
    Tuesday, March 23, 2010 7:44 AM

Answers

  • Hi,

    Do you mean only MSI file encounter this error? In addition, please let us know if you are in the domain enviroment.

    To further troubleshooting, please refer to the following steps:

    Enable built-in admin account
    ==============
    1. Click Start, click "All Programs", please find and open "Accessories" folder.
    2. Please right-click on "Command Prompt" item and select "Run as administrator".
    3. Please type the following command line in to the coming window.

    net user administrator /active:yes

    Note: There is a space between "Administrator" and "/active:yes".

    4. Log off and log on the Administrator account and then try to install.

    Also try turning off UAC:

    1. Click the Start Button, type "User account control" and press Enter.

    2. When the User account control settings box appears, move the slider to Never notify.

    3. Click OK and then install the program.

    If any security program is installed, please temporarily disable it.

    note: Please turn off the admin account by running net user administrator /active:no and then turn on UAC after troubleshooting.

     


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Thursday, April 01, 2010 9:00 AM
    Thursday, March 25, 2010 3:49 AM

All replies

  • Hi,

    I would like to confirm which software encountered this problem. Is the computer in a domain.

    This can be a permission issue. To troubleshoot it, please try the following steps:

    Install program under compatibility mode & Administrator level
    =================
    1. Right click on the installation file (setup.exe) and click Properties.
    2. Click on the Compatibility tab.
    3. Select “Run this program in compatibility mode for.”
    4. Choose Windows Vista (Service Pack 2) from the drop down list.
    5. Select “Run this program as an administrator” option under the Privilege Level topic.
    6. Click Apply, click OK.
     
    Right click on the setup file and choose Run as administrator to install it again.

    Hope it helps.


    Vivian Xing - MSFT
    Wednesday, March 24, 2010 7:10 AM
  • software: NOD32 and Motorola cellphone driver

     

    OS - Windows 7 not Vista

     

    I am unable to follow your steps since it was an MSI file.

    Thursday, March 25, 2010 3:17 AM
  • Hi,

    Do you mean only MSI file encounter this error? In addition, please let us know if you are in the domain enviroment.

    To further troubleshooting, please refer to the following steps:

    Enable built-in admin account
    ==============
    1. Click Start, click "All Programs", please find and open "Accessories" folder.
    2. Please right-click on "Command Prompt" item and select "Run as administrator".
    3. Please type the following command line in to the coming window.

    net user administrator /active:yes

    Note: There is a space between "Administrator" and "/active:yes".

    4. Log off and log on the Administrator account and then try to install.

    Also try turning off UAC:

    1. Click the Start Button, type "User account control" and press Enter.

    2. When the User account control settings box appears, move the slider to Never notify.

    3. Click OK and then install the program.

    If any security program is installed, please temporarily disable it.

    note: Please turn off the admin account by running net user administrator /active:no and then turn on UAC after troubleshooting.

     


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Thursday, April 01, 2010 9:00 AM
    Thursday, March 25, 2010 3:49 AM
  • hi im having the same problem im trying to install Vu8 xstream but this 

     The System Administrator has set policies to prevent this installation"    keeps pooping out im just trying to run the trial any help would be very good .

    Wednesday, July 28, 2010 5:54 AM
  • I am also getting the same error message on my Windows 7 Premuim system when i try to uninstall a program 
    Monday, May 02, 2011 10:28 PM
  • I tried this for my issue but it had no effect. I still get The system Administrator has set policies to prevent this installation.

    I'm trying to install some drivers for a M-Audio Midi device from the website and the software disc with no progress. I am not part of a domain environment and now I feel I have tried so many things that I can't backtrack.

    Some advice would be appreciated.
    Friday, June 24, 2011 5:48 PM
  • I have tried everything in all the tips about and I still get the same message.  WTF!
    Monday, July 25, 2011 3:52 AM
  • You must run .msi files from a command prompt AS ADMINISTRATOR. 

    With the .msi installer file on your system, click the Start button -> All Programs -> Accessories, then right-click the "Command Prompt" icon and select "Run as administrator" (credentials may or may not be required, depending on your user rights).  Then execute the .msi file from the command line.

    
    Friday, June 21, 2013 6:41 PM