locked
I found out what to do with the Windows 7 Slow Internet Connection problem!!

    General discussion

  • I've been having the issue with a Lenovo laptop I upgraded to Win7 for a long time. I got a wired connection and a wireless connection to a same router. The performance of the wired connection is very poor, that is, buffering and downloading is terriblly slow, while the wireless connection seems to be quite normal.

     

    Now I finnally got away from the annoying problem. What you should do is to go to your net-card properties and change the speed from 100 Mbps Full Duplex to Auto Negotiate, or do the opposite, that is, you have to change the speed from Auto Negotiate to 100 Mbps Full Duplex if your situation is that the oringinal is Auto Negotiate. Now press confirm. Bang!!

     

    I have been inspired by the following thread "Windows 7 Slow Internet Connection"

    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/b201eadd-dcf2-4ec1-8d91-c242e5d1b0dd

    Please go to the bottom line to check it out. The guy named katrash said,

    "For those with this problem, I would like to add my experience switching to Windows 7.

     

    Recently I went from XP to Win7 but my net speed was so slow and frustrating. I tried many of the things menttioned above but nothing helped. I even thought of going back to XP (the same computer worked very fine then) besides my other 2 computers which are connected to the same router has no problem with connecting to the internet.

     

    Today, I went to net-card properties and changed the speed from Auto Negotiate to 100 Mbps Full Duplex. Like magic ... I have full speed now - even better than with XP.

     

    Steps: Control Panel --> Network and Sharing Center --> Change Adapter Settings --> right click the conection and select properties --> select Configure button --> goto Advanced tab --> look for Link Speed and Duplex --> change Auto Negotiate to 100 Mbps Full Duplex.

     

    Note: the speed might depend on the routed and network card you use. My configuration is "Linksys WRT54G" router and "Intel(R) PRO/1000 MT Network Connection" net card."

     

    My situation is that it was 100 Mbps Full Duplex before I did anything, so I did the opposite way and it worked. It seems useless for you to turn off QoS or do the “netsh int tcp set global autotuninglevel=disable”stuff. Hopefully this can help you. This is my first thread here and my first post written in English (I'm Chinese). Please take my appology if there are problems in my writing. I will really appreciate it if you would be so kind as to tell me if there's anything wrong in my writing.

     

    Any questions please contact me at smartfeir@qq.com. And~I love China but to h*ll with GFW in China!!

    Saturday, July 03, 2010 7:49 PM

All replies